<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_a94ef89159982350f062c8aaac4b1146.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c8ede1184c0ba74d10d7f190bacfec01.css" rel="stylesheet" /><title>5 Points to Ponder: Great NASCAR Finishes Abound After Indy</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="5 Points to Ponder: Great NASCAR Finishes Abound After Indy - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="ONE: Massive Win for Kahne I have a good friend who is a huge Kasey Kahne fan. He’s from the same ho"/><meta property="og:url" content="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP-660x425.jpg" /><meta name="description" content="ONE: Massive Win for Kahne I have a good friend who is a huge Kasey Kahne fan. He’s from the same home town --Enumclaw, WA -- as the 14-year, 488-race Hend"/><link rel="canonical" href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="5 Points to Ponder: Great NASCAR Finishes Abound After Indy" /><meta property="og:description" content="ONE: Massive Win for Kahne I have a good friend who is a huge Kasey Kahne fan. He’s from the same home town --Enumclaw, WA -- as the 14-year, 488-race Hend" /><meta property="og:url" content="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:tag" content="Dale Earnhardt Jr." /><meta property="article:tag" content="Kasey Kahne" /><meta property="article:tag" content="Matt DiBenedetto" /><meta property="article:tag" content="Timmy Hill" /><meta property="article:section" content="5 Points To Ponder" /><meta property="article:published_time" content="2017-07-25T01:37:36-04:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP.jpg" /><meta property="og:image:width" content="700" /><meta property="og:image:height" content="466" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="ONE: Massive Win for Kahne I have a good friend who is a huge Kasey Kahne fan. He’s from the same home town --Enumclaw, WA -- as the 14-year, 488-race Hend" /><meta name="twitter:title" content="5 Points to Ponder: Great NASCAR Finishes Abound After Indy" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP.jpg" /><meta name="twitter:creator" content="@dannypeters" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; 5 Points to Ponder: Great NASCAR Finishes Abound After Indy Comments Feed" href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/feed/" /> <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script type="text/javascript" data-cfasync="false">/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-34668381-1';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.7.5" /><meta name="generator" content="Seriously Simple Podcasting 1.16.4" /><link rel='shortlink' href='https://www.frontstretch.com/?p=141141' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F07%2F25%2F5-points-to-ponder-great-nascar-finishes-abound%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F07%2F25%2F5-points-to-ponder-great-nascar-finishes-abound%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.5.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="text/javascript">var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-141141 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="search-mobile"><form method="get" id="searchform-mobile" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a href="https://www.frontstretch.com/newsletter/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/newsletter/', 'Newsletter');" target="_blank">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-136612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136612"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast-powered-by-draftkings/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="search-block"><form method="get" id="searchform-header" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div></div></div><div class="header-content"><a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo" style=" margin-top:15px; margin-bottom:15px;"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/', '');" class="mega-menu-link"  title="5 Points to Ponder: Great NASCAR Finishes Abound After Indy"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP-660x425.jpg" width="660" height="330" alt="5 Points to Ponder: Great NASCAR Finishes Abound After Indy" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/', '5 Points to Ponder: Great NASCAR Finishes Abound After Indy');" class="mega-menu-link"  title="5 Points to Ponder: Great NASCAR Finishes Abound After Indy">5 Points to Ponder: Great NASCAR Finishes Abound After Indy</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/', '');" class="mega-menu-link"  title="Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Fontana-CUP-Kasey-Kahne-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/', 'Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition');" class="mega-menu-link"  title="Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition">Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/', '');" class="mega-menu-link"  title="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Dale-Earnhardt-Jr-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/', 'Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC');" class="mega-menu-link"  title="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC">Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/', '');" class="mega-menu-link"  title="Beside The Rising Tide: 1313 Turkey Court"><img src="https://www.frontstretch.com/wp-content/uploads/2014/08/2014-Atlanta-NNS-fans-II-CIA-55x55.jpg" width="110" height="75" alt="Beside The Rising Tide: 1313 Turkey Court" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/', 'Beside The Rising Tide: 1313 Turkey Court');" class="mega-menu-link"  title="Beside The Rising Tide: 1313 Turkey Court">Beside The Rising Tide: 1313 Turkey Court</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/', '');" class="mega-menu-link"  title="The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Matt-DiBenedetto-car-Matthew-T-Thacker-110x75.jpg" width="110" height="75" alt="The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/', 'The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy');" class="mega-menu-link"  title="The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy">The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 24, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/24/dale-earnhardt-jr-taking-talents-to-nbc-after-season/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/24/dale-earnhardt-jr-taking-talents-to-nbc-after-season/', '');" class="mega-menu-link"  title="Dale Earnhardt Jr. taking Talents to NBC After Season"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/dalej-110x75.jpg" width="110" height="75" alt="Dale Earnhardt Jr. taking Talents to NBC After Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/24/dale-earnhardt-jr-taking-talents-to-nbc-after-season/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/24/dale-earnhardt-jr-taking-talents-to-nbc-after-season/', 'Dale Earnhardt Jr. taking Talents to NBC After Season');" class="mega-menu-link"  title="Dale Earnhardt Jr. taking Talents to NBC After Season">Dale Earnhardt Jr. taking Talents to NBC After Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 24, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', '');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-NXS-William-Byron-burnout-Matthew-T-Thacker-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', 'Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness">Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', '');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-NXS-William-Byron-burnout-Matthew-T-Thacker-NKP-660x425.jpg" width="660" height="330" alt="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', 'Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness">Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/23/xfinity-breakdown-william-byron-wins-in-first-attempt-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/xfinity-breakdown-william-byron-wins-in-first-attempt-at-indianapolis/', '');" class="mega-menu-link"  title="XFINITY Breakdown: William Byron Wins First Indianapolis Attempt"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/William-Byron-Indy-110x75.jpg" width="110" height="75" alt="XFINITY Breakdown: William Byron Wins First Indianapolis Attempt" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/23/xfinity-breakdown-william-byron-wins-in-first-attempt-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/xfinity-breakdown-william-byron-wins-in-first-attempt-at-indianapolis/', 'XFINITY Breakdown: William Byron Wins First Indianapolis Attempt');" class="mega-menu-link"  title="XFINITY Breakdown: William Byron Wins First Indianapolis Attempt">XFINITY Breakdown: William Byron Wins First Indianapolis Attempt</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/22/justin-allgaier-i-screwed-myself-there/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/justin-allgaier-i-screwed-myself-there/', '');" class="mega-menu-link"  title="Justin Allgaier: &#8216;I Screwed Myself There&#8217;"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/allglalal-110x75.jpg" width="110" height="75" alt="Justin Allgaier: &#8216;I Screwed Myself There&#8217;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/22/justin-allgaier-i-screwed-myself-there/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/justin-allgaier-i-screwed-myself-there/', 'Justin Allgaier: &#8216;I Screwed Myself There&#8217;');" class="mega-menu-link"  title="Justin Allgaier: &#8216;I Screwed Myself There&#8217;">Justin Allgaier: &#8216;I Screwed Myself There&#8217;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 22, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/22/william-byron-keeps-paul-menard-at-bay-for-indianapolis-win/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/william-byron-keeps-paul-menard-at-bay-for-indianapolis-win/', '');" class="mega-menu-link"  title="William Byron Keeps Paul Menard at Bay for Indianapolis Win"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/4d6f20d7f7de54e3f369c73898d489cd-11-110x75.jpg" width="110" height="75" alt="William Byron Keeps Paul Menard at Bay for Indianapolis Win" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/22/william-byron-keeps-paul-menard-at-bay-for-indianapolis-win/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/william-byron-keeps-paul-menard-at-bay-for-indianapolis-win/', 'William Byron Keeps Paul Menard at Bay for Indianapolis Win');" class="mega-menu-link"  title="William Byron Keeps Paul Menard at Bay for Indianapolis Win">William Byron Keeps Paul Menard at Bay for Indianapolis Win</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 22, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/22/elliott-sadler-wins-xfinity-pole-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/elliott-sadler-wins-xfinity-pole-at-indianapolis/', '');" class="mega-menu-link"  title="Elliott Sadler Wins XFINITY Pole at Indianapolis"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/398a8e8df9404d2275bb67824ec0eb04-11-110x75.jpg" width="110" height="75" alt="Elliott Sadler Wins XFINITY Pole at Indianapolis" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/22/elliott-sadler-wins-xfinity-pole-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/22/elliott-sadler-wins-xfinity-pole-at-indianapolis/', 'Elliott Sadler Wins XFINITY Pole at Indianapolis');" class="mega-menu-link"  title="Elliott Sadler Wins XFINITY Pole at Indianapolis">Elliott Sadler Wins XFINITY Pole at Indianapolis</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 22, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/20/4-burning-questions-will-restrictor-plates-work-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/4-burning-questions-will-restrictor-plates-work-at-indianapolis/', '');" class="mega-menu-link"  title="4 Burning Questions: Will Restrictor Plates Work at Indianapolis?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Kyle-Busch-Donuts-Indianapolis-XFINITY-2016-Yvonne-Leonard-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Will Restrictor Plates Work at Indianapolis?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/20/4-burning-questions-will-restrictor-plates-work-at-indianapolis/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/4-burning-questions-will-restrictor-plates-work-at-indianapolis/', '4 Burning Questions: Will Restrictor Plates Work at Indianapolis?');" class="mega-menu-link"  title="4 Burning Questions: Will Restrictor Plates Work at Indianapolis?">4 Burning Questions: Will Restrictor Plates Work at Indianapolis?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 20, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/20/friday-faceoff-is-less-really-more-in-nascar/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/friday-faceoff-is-less-really-more-in-nascar/', '');" class="mega-menu-link"  title="Friday Faceoff: Is Less Really More in NASCAR?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/admenard-110x75.jpg" width="110" height="75" alt="Friday Faceoff: Is Less Really More in NASCAR?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/20/friday-faceoff-is-less-really-more-in-nascar/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/friday-faceoff-is-less-really-more-in-nascar/', 'Friday Faceoff: Is Less Really More in NASCAR?');" class="mega-menu-link"  title="Friday Faceoff: Is Less Really More in NASCAR?">Friday Faceoff: Is Less Really More in NASCAR?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 20, 2017</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://www.frontstretch.com/cwts-schedule/"><i class="fa fa-arrow-right"></i>2017 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/news/truck-series-news/"><i class="fa fa-arrow-right"></i>News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/"><i class="fa fa-arrow-right"></i>Commentary</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/"><i class="fa fa-arrow-right"></i>Race Report</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/', '');" class="mega-menu-link"  title="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Dale-Earnhardt-Jr-pack-racing-Russell-LaBounty-NKP-660x425.jpg" width="660" height="330" alt="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/', 'Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC');" class="mega-menu-link"  title="Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC">Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', '');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-NXS-William-Byron-burnout-Matthew-T-Thacker-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', 'Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness">Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/20/tracking-the-trucks-matt-crafton-slays-dirt-racing-at-eldora/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/tracking-the-trucks-matt-crafton-slays-dirt-racing-at-eldora/', '');" class="mega-menu-link"  title="Tracking the Trucks: Matt Crafton Slays Dirt Racing at Eldora"><img src="https://www.frontstretch.com/wp-content/uploads/2017/02/2017-Daytona-I-CWTS-Matt-Crafton-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="Tracking the Trucks: Matt Crafton Slays Dirt Racing at Eldora" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/20/tracking-the-trucks-matt-crafton-slays-dirt-racing-at-eldora/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/tracking-the-trucks-matt-crafton-slays-dirt-racing-at-eldora/', 'Tracking the Trucks: Matt Crafton Slays Dirt Racing at Eldora');" class="mega-menu-link"  title="Tracking the Trucks: Matt Crafton Slays Dirt Racing at Eldora">Tracking the Trucks: Matt Crafton Slays Dirt Racing at Eldora</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 20, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/19/nascar-mailbox-is-it-bobby-pierces-time-to-shine-at-eldora/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/19/nascar-mailbox-is-it-bobby-pierces-time-to-shine-at-eldora/', '');" class="mega-menu-link"  title="NASCAR Mailbox: Is it Bobby Pierce&#8217;s Time to Shine at Eldora?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/07/ELD_072016_02-110x75.jpg" width="110" height="75" alt="NASCAR Mailbox: Is it Bobby Pierce&#8217;s Time to Shine at Eldora?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/19/nascar-mailbox-is-it-bobby-pierces-time-to-shine-at-eldora/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/19/nascar-mailbox-is-it-bobby-pierces-time-to-shine-at-eldora/', 'NASCAR Mailbox: Is it Bobby Pierce&#8217;s Time to Shine at Eldora?');" class="mega-menu-link"  title="NASCAR Mailbox: Is it Bobby Pierce&#8217;s Time to Shine at Eldora?">NASCAR Mailbox: Is it Bobby Pierce&#8217;s Time to Shine at Eldora?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 19, 2017</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', '');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-NXS-William-Byron-burnout-Matthew-T-Thacker-NKP-660x425.jpg" width="660" height="330" alt="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/', 'Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness');" class="mega-menu-link"  title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness">Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/20/nitro-shots-crunch-time/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/nitro-shots-crunch-time/', '');" class="mega-menu-link"  title="Nitro Shots: Crunch Time"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Chicago-Ron-Capps-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: Crunch Time" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/20/nitro-shots-crunch-time/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/20/nitro-shots-crunch-time/', 'Nitro Shots: Crunch Time');" class="mega-menu-link"  title="Nitro Shots: Crunch Time">Nitro Shots: Crunch Time</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 20, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/13/nitro-shots-why-is-drag-racing-such-a-hard-sell/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/13/nitro-shots-why-is-drag-racing-such-a-hard-sell/', '');" class="mega-menu-link"  title="Nitro Shots: Why Is Drag Racing Such a Hard Sell?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Chicago-Steve-Torrence-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: Why Is Drag Racing Such a Hard Sell?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/13/nitro-shots-why-is-drag-racing-such-a-hard-sell/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/13/nitro-shots-why-is-drag-racing-such-a-hard-sell/', 'Nitro Shots: Why Is Drag Racing Such a Hard Sell?');" class="mega-menu-link"  title="Nitro Shots: Why Is Drag Racing Such a Hard Sell?">Nitro Shots: Why Is Drag Racing Such a Hard Sell?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 13, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/06/nitro-shots-godspeed-good-lady/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/nitro-shots-godspeed-good-lady/', '');" class="mega-menu-link"  title="Nitro Shots: Godspeed, Good Lady"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Terry-Chandler-and-Beckman-team-courtesy-DSR-110x75.jpg" width="110" height="75" alt="Nitro Shots: Godspeed, Good Lady" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/06/nitro-shots-godspeed-good-lady/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/nitro-shots-godspeed-good-lady/', 'Nitro Shots: Godspeed, Good Lady');" class="mega-menu-link"  title="Nitro Shots: Godspeed, Good Lady">Nitro Shots: Godspeed, Good Lady</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 6, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/06/29/nitro-shots-the-magic-number-shall-be-what/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/29/nitro-shots-the-magic-number-shall-be-what/', '');" class="mega-menu-link"  title="Nitro Shots: The Magic Number Shall Be What?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/NHRA-2017-Norwalk-Bo-Butner-car-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: The Magic Number Shall Be What?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/06/29/nitro-shots-the-magic-number-shall-be-what/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/29/nitro-shots-the-magic-number-shall-be-what/', 'Nitro Shots: The Magic Number Shall Be What?');" class="mega-menu-link"  title="Nitro Shots: The Magic Number Shall Be What?">Nitro Shots: The Magic Number Shall Be What?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 29, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/', '');" class="mega-menu-link"  title="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/william-byron-christopher-bell-iowa-110x75.jpg" width="110" height="75" alt="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/', 'Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big');" class="mega-menu-link"  title="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big">Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 25, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/06/22/nitro-shots-fathers-sons/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/22/nitro-shots-fathers-sons/', '');" class="mega-menu-link"  title="Nitro Shots: Fathers &#038; Sons"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/NHRA-2017-Bristol-Clay-Millican-with-Wally-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: Fathers &#038; Sons" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/06/22/nitro-shots-fathers-sons/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/22/nitro-shots-fathers-sons/', 'Nitro Shots: Fathers &#038; Sons');" class="mega-menu-link"  title="Nitro Shots: Fathers &#038; Sons">Nitro Shots: Fathers &#038; Sons</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 22, 2017</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/16/pace-laps-a-massive-weekend-at-new-hampshire-for-jgr-and-josef-newgardens-big-indycar-win/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/16/pace-laps-a-massive-weekend-at-new-hampshire-for-jgr-and-josef-newgardens-big-indycar-win/', '');" class="mega-menu-link"  title="Pace Laps: A Massive Weekend at New Hampshire for JGR and Josef Newgarden&#8217;s Big IndyCar Win"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/toyota-1-nhms-640x425.jpg" width="660" height="330" alt="Pace Laps: A Massive Weekend at New Hampshire for JGR and Josef Newgarden&#8217;s Big IndyCar Win" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/16/pace-laps-a-massive-weekend-at-new-hampshire-for-jgr-and-josef-newgardens-big-indycar-win/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/16/pace-laps-a-massive-weekend-at-new-hampshire-for-jgr-and-josef-newgardens-big-indycar-win/', 'Pace Laps: A Massive Weekend at New Hampshire for JGR and Josef Newgarden&#8217;s Big IndyCar Win');" class="mega-menu-link"  title="Pace Laps: A Massive Weekend at New Hampshire for JGR and Josef Newgarden&#8217;s Big IndyCar Win">Pace Laps: A Massive Weekend at New Hampshire for JGR and Josef Newgarden&#8217;s Big IndyCar Win</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 16, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/13/if-helio-castroneves-wants-indycar-title-he-needs-to-win-it-this-year/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/13/if-helio-castroneves-wants-indycar-title-he-needs-to-win-it-this-year/', '');" class="mega-menu-link"  title="If Hélio Castroneves Wants IndyCar Title, He Needs to Win it This Year"><img src="https://www.frontstretch.com/wp-content/uploads/2016/08/16C_5783-1-110x75.jpg" width="110" height="75" alt="If Hélio Castroneves Wants IndyCar Title, He Needs to Win it This Year" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/13/if-helio-castroneves-wants-indycar-title-he-needs-to-win-it-this-year/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/13/if-helio-castroneves-wants-indycar-title-he-needs-to-win-it-this-year/', 'If Hélio Castroneves Wants IndyCar Title, He Needs to Win it This Year');" class="mega-menu-link"  title="If Hélio Castroneves Wants IndyCar Title, He Needs to Win it This Year">If Hélio Castroneves Wants IndyCar Title, He Needs to Win it This Year</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 13, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/11/the-frontstretch-5-motorsports-memories-moments-that-blew-our-minds/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/11/the-frontstretch-5-motorsports-memories-moments-that-blew-our-minds/', '');" class="mega-menu-link"  title="The Frontstretch 5: Motorsports Memories &#038; Moments That Blew Our Minds"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/2017-Charlotte-All-Star-CUP-DEnny-Hamlin-tire-rub-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Motorsports Memories &#038; Moments That Blew Our Minds" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/11/the-frontstretch-5-motorsports-memories-moments-that-blew-our-minds/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/11/the-frontstretch-5-motorsports-memories-moments-that-blew-our-minds/', 'The Frontstretch 5: Motorsports Memories &#038; Moments That Blew Our Minds');" class="mega-menu-link"  title="The Frontstretch 5: Motorsports Memories &#038; Moments That Blew Our Minds">The Frontstretch 5: Motorsports Memories &#038; Moments That Blew Our Minds</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 11, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/06/4-burning-questions-chase-elliott-ryan-blaney-whos-ahead-at-the-halfway-point/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/4-burning-questions-chase-elliott-ryan-blaney-whos-ahead-at-the-halfway-point/', '');" class="mega-menu-link"  title="4 Burning Questions: Chase Elliott &#038; Ryan Blaney, Who&#8217;s Ahead at the Halfway Point?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/39b408d18c0112a3c31d90feade1fd7a-11-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Chase Elliott &#038; Ryan Blaney, Who&#8217;s Ahead at the Halfway Point?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/06/4-burning-questions-chase-elliott-ryan-blaney-whos-ahead-at-the-halfway-point/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/4-burning-questions-chase-elliott-ryan-blaney-whos-ahead-at-the-halfway-point/', '4 Burning Questions: Chase Elliott &#038; Ryan Blaney, Who&#8217;s Ahead at the Halfway Point?');" class="mega-menu-link"  title="4 Burning Questions: Chase Elliott &#038; Ryan Blaney, Who&#8217;s Ahead at the Halfway Point?">4 Burning Questions: Chase Elliott &#038; Ryan Blaney, Who&#8217;s Ahead at the Halfway Point?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 6, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/07/06/happiness-is-the-nascar-world-we-live-in/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/happiness-is-the-nascar-world-we-live-in/', '');" class="mega-menu-link"  title="Happiness Is: The NASCAR World We Live In"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/stenhouse-dis-win-2-110x75.jpg" width="110" height="75" alt="Happiness Is: The NASCAR World We Live In" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/07/06/happiness-is-the-nascar-world-we-live-in/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/07/06/happiness-is-the-nascar-world-we-live-in/', 'Happiness Is: The NASCAR World We Live In');" class="mega-menu-link"  title="Happiness Is: The NASCAR World We Live In">Happiness Is: The NASCAR World We Live In</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 6, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/', '');" class="mega-menu-link"  title="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/william-byron-christopher-bell-iowa-110x75.jpg" width="110" height="75" alt="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/25/pace-laps-happy-days-at-sonoma-underdog-takeover-at-iowa-scott-dixon-wins-big/', 'Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big');" class="mega-menu-link"  title="Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big">Pace Laps: Happy Days at Sonoma, Underdog Takeover at Iowa &#038; Scott Dixon Wins Big</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 25, 2017</span></li><li><div class="post-thumbnail"><a href="https://www.frontstretch.com/2017/06/22/happiness-is-silliness-inevitability-overload/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/22/happiness-is-silliness-inevitability-overload/', '');" class="mega-menu-link"  title="Happiness Is: Silliness, Inevitability &#038; Overload"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/2017-Dover-I-CUP-Jimmie-Johnson-happy-Logan-Whitton-NKP-110x75.jpg" width="110" height="75" alt="Happiness Is: Silliness, Inevitability &#038; Overload" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a href="https://www.frontstretch.com/2017/06/22/happiness-is-silliness-inevitability-overload/" onclick="__gaTracker('send', 'event', 'outbound-menu', 'https://www.frontstretch.com/2017/06/22/happiness-is-silliness-inevitability-overload/', 'Happiness Is: Silliness, Inevitability &#038; Overload');" class="mega-menu-link"  title="Happiness Is: Silliness, Inevitability &#038; Overload">Happiness Is: Silliness, Inevitability &#038; Overload</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 22, 2017</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://www.frontstretch.com/sports-cars/">Sports Cars</a><ul class="sub-menu menu-sub-content"><li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://www.frontstretch.com/category/imsa/">IMSA</a></li></ul></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.draftkings.com/gateway?s=696638929" title="Draft Kings - Free Fantasy Racing" > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/draft-kings-728x90.png" alt="Draft Kings - Free Fantasy Racing" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/points-to-ponder/">5 Points To Ponder</a></span> <span class="delimiter">/</span> <span class="current">5 Points to Ponder: Great NASCAR Finishes Abound After Indy</span></div><article class="post-listing post-141141 post type-post status-publish format-standard has-post-thumbnail  category-points-to-ponder category-cup-series category-danny-peters category-featured-content tag-dale-earnhardt-jr tag-kasey-kahne tag-matt-dibenedetto tag-timmy-hill" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Russell LaBounty/NKP)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">5 Points to Ponder: Great NASCAR Finishes Abound After Indy</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dannyp/" title="">Danny Peters </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/points-to-ponder/" rel="category tag">5 Points To Ponder</a>, <a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/danny-peters/" rel="category tag">Danny Peters</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/#comments">1 Comment</a></span></p><div class="clear"></div><div class="entry"><h3><strong>ONE: Massive Win for Kahne</strong></h3><p>I have a good friend who is a huge <a href="/tag/kasey-kahne/">Kasey Kahne</a> fan. He’s from the same home town &#8211;Enumclaw, WA &#8212; as the 14-year, 488-race Hendrick Motorsports veteran, and he’s followed Kahne’s career from the very start. He is, if you will, the definition of a die-hard fan. This past week, when I sent him my column, he wrote back saying he had been scared to read in the past few weeks because he was worried I would be writing negatively about Kahne’s longer term prognosis in the Cup Series. I told him I wouldn’t do that in his honor but truthfully didn’t believe a word of what I wrote. I figured that particular “point” was coming sooner rather than later.</p><p>Then, as I watched the waning laps on Sunday evening, my wife seeing Kahne at the front of the field started asking me about how long it had been since he last won. I told her not to worry as it wasn’t going to happen. Little did I know.</p><p>“I think a win like today can give myself confidence and momentum, our whole team a boost, which is something that we need,” said Kahne in the post-race media conference. “We work hard, too. But the guys that are winning and running up front, their momentum, their confidence is tough to keep up with when it&#8217;s been a couple years.”</p><p>Now the truth is Kahne’s future at HMS is cloudy at best (sorry, Jason!), but this win could be just the tonic he needs to finish up 2017 in the best possible fashion.</p><figure id="attachment_134523" style="width: 300px" class="wp-caption alignright"><img class="size-medium wp-image-134523" src="https://www.frontstretch.com/wp-content/uploads/2017/04/dalenaoth-300x196.jpg" alt="" width="300" height="196" srcset="https://www.frontstretch.com/wp-content/uploads/2017/04/dalenaoth-300x196.jpg 300w, https://www.frontstretch.com/wp-content/uploads/2017/04/dalenaoth-150x98.jpg 150w, https://www.frontstretch.com/wp-content/uploads/2017/04/dalenaoth-660x430.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/04/dalenaoth.jpg 914w" sizes="(max-width: 300px) 100vw, 300px" /><figcaption class="wp-caption-text">Fans will be seeing more of Dale Earnhardt, Jr. in a tie after he joints NBC broadcast team in 2018. (Photo: Zach Catanzareti)</figcaption></figure><h3><strong>TWO: Junior to the NBC Broadcast Booth</strong></h3><p>In what cannot be construed as a surprising announcement, news reaches us that <a href="/tag/dale-earnhardt-jr/">Dale Earnhardt, Jr.</a> will be joining the NBC broadcast team next season.</p><p>&#8220;It is a tremendous honor not only to join NBC Sports next year but to begin a new career alongside people who love NASCAR as much as I do,&#8221; said Earnhardt in a media release.</p><p>And you can’t help but feel Junior will fit in well alongside Rick Allen, Jeff Burton and former crew chief and good buddy, Steve Letarte.</p><p>&#8220;I will devote my heart and soul to this broadcast team and pledge my very best to the millions who watch it,” noted Junior of his future career and you can bet your bottom dollar that this will indeed be the case.</p><p>When I wrote about Junior moving to the broadcasting side of things a few weeks back, there was a mixed reaction in the comments which did, to some degree, surprise me. I am firmly in the positive camp with this news and I expect Junior to take to the mic with great dexterity following in the footsteps of his former teammate Jeff Gordon. Junior is about as much a NASCAR lifer as you can possibly get and I for one am delighted to see him take the next steps in his post-driving career. My money is on him being a great success.</p><h3><strong>THREE: Top 10 for Matt DiBenedetto</strong></h3><p>This column has always been – and will always be – about celebrating the unexpected great results for the drivers in, shall we say, less than top echelon equipment. So, with that in mind, this week my shout out goes to <a href="/tag/matt-dibenedetto/">Matt DiBenedetto</a>, who picked up his third ever top 10 at Indianapolis Motor Speedway. DiBenedetto, who drives full time for the Go Fas Racing team, finished eighth for his second top 10 of the year; the other came in the Daytona 500 when he finished ninth. Go check the Go Fas Racing Twitter feed if you want to revel in the joy of what this finish means. For example:</p><blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">We&#39;re not used to this. So cool for a small team. <a href="https://t.co/2KXAufeRoK">pic.twitter.com/2KXAufeRoK</a></p><p>&mdash; Go Fas Racing (@GoFasRacing32) <a href="https://twitter.com/GoFasRacing32/status/889290742388199424">July 24, 2017</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>Too often in NASCAR we’re caught up with who won and where the big boys finished that we fail to celebrate the results like this that, to all intents and purposes, are as good as a win especially at a non-restrictor plate track (or should that just be a regular track?) So well done, Mr. DiBenedetto, here’s to more success for you and the team before the season is done.</p><h3><strong>FOUR: Next Up, Pocono Part Two</strong></h3><p>Next up, we head back to Pocono Raceway for the second and final time in the 2017 Cup season. This will be Cup race number 80 at the two-and-a-half mile, three turn flat track, a streak that runs all the way back to 1974 and a race won by the King himself – Richard Petty. When we last raced at the circuit in mid-June, the race was won by <a href="/tag/ryan-blaney/">Ryan Blaney</a> for his first (and to date only) top echelon victory, holding off a charging <a href="/tag/kevin-harvick/">Kevin Harvick</a> in the final laps.</p><p>One big piece of recent Pocono-related news has happened away from the track with Brandon Igdalsky resigning his position at President and CEO to take up an opportunity with NASCAR as the Managing Director of Event Marketing and Promotion. Nick Igdalsky will take over as CEO while Ben May will assume the role of President.</p><p>“I am very grateful and excited,” noted Igdalsky. “I have observed every aspect of the operation here at Pocono Raceway, starting as a 13 year old, and look forward to working with our incredible team. Our goals remain the same: to create exciting and lifelong experiences at a beautiful and sustainable facility and that will remain our focus.”</p><p>Best of luck to the new leadership team and here’s hoping for a great race this weekend.</p><h3><strong>FIVE: And finally&#8230;.</strong></h3><p>And finally this week, a quick shout out to <a href="/tag/timmy-hill/">Timmy Hill</a> who picked up a career best 14th-place finish amidst all the late race carnage this past weekend. Driving for journeyman racer <a href="/tag/carl-long/">Carl Long</a> in his third race of the year (and 200th in total across all three series), Hill has an average finish of 35.4 and a previous high of 27th (twice in 2013 at Charlotte and Pocono). Hill expressed his excitement, where else but on Twitter.</p><p><a href="https://twitter.com/TimmyHillRacer/status/889303514744311809/">https://twitter.com/TimmyHillRacer/status/889303514744311809/</a></p><p><a href="https://www.frontstretch.com/2017/07/23/timmy-hill-scores-best-cup-finish-in-200th-nascar-start/">He also took the time to speak to us here</a> at <em>Frontstretch,</em> noting: “I just want to keep working away….I embrace what I do. We don’t have all the funding and resources but I certainly embrace what we do. Hopefully, one day, I can get that opportunity.”</p><p>Let’s hope that is the case for Timmy but in the meanwhile, well done, sir. Well done.</p></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=141141" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=5+Points+to+Ponder%3A+Great+NASCAR+Finishes+Abound+After+Indy&url=https://www.frontstretch.com/?p=141141" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=141141&amp;name=5+Points+to+Ponder%3A+Great+NASCAR+Finishes+Abound+After+Indy" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=141141&title=5+Points+to+Ponder%3A+Great+NASCAR+Finishes+Abound+After+Indy" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=141141&title=5+Points+to+Ponder%3A+Great+NASCAR+Finishes+Abound+After+Indy" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=141141&amp;description=5+Points+to+Ponder%3A+Great+NASCAR+Finishes+Abound+After+Indy&amp;media=https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kasey-Kahne-Rick-Hendrick-celebrate-Russell-LaBounty-NKP-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">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</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/dale-earnhardt-jr/" rel="tag">Dale Earnhardt Jr.</a> <a href="https://www.frontstretch.com/tag/kasey-kahne/" rel="tag">Kasey Kahne</a> <a href="https://www.frontstretch.com/tag/matt-dibenedetto/" rel="tag">Matt DiBenedetto</a> <a href="https://www.frontstretch.com/tag/timmy-hill/" rel="tag">Timmy Hill</a></p><section id="author-box"><div class="block-head"><h3>About Danny Peters</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2014/05/Danny-Peters-150x150.jpg" width="90" height="90" alt="Danny Peters" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Danny starts his 10th year with the Frontstretch in 2016, writing the Tuesday signature column Five Points To Ponder. An English transplant living in San Francisco, by way of New York City, he’s had an award-winning marketing career with some of the biggest companies sponsoring sports. Working with racers all over the country, his freelance writing has even reached outside the world of racing to include movie screenplays.</div><div class="author-social flat-social"> <a class="social-twitter" target="_blank" href="http://twitter.com/dannypeters"><i class="fa fa-twitter"></i><span> @dannypeters</span></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/" rel="prev"><span>Previous</span> Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition</a></div><div class="post-next"></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Fontana-CUP-Kasey-Kahne-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/07/25/whos-hot-whos-not-in-nascar-darkness-on-the-edge-edition/" rel="bookmark">Who’s Hot &#038; Who’s Not In NASCAR: Darkness On The Edge Edition</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Dale-Earnhardt-Jr-pack-racing-Russell-LaBounty-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/07/25/couch-potato-tuesday-dale-earnhardt-jr-chooses-nascar-on-nbc/" rel="bookmark">Couch Potato Tuesday: Dale Earnhardt Jr. Chooses NASCAR On NBC</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/"> <img width="272" height="125" src="https://www.frontstretch.com/wp-content/uploads/2014/08/2014-Atlanta-NNS-fans-II-CIA-272x125.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/07/25/beside-the-rising-tide-1313-turkey-court/" rel="bookmark">Beside The Rising Tide: 1313 Turkey Court</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 25, 2017</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Matt-DiBenedetto-car-Matthew-T-Thacker-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2017/07/24/the-underdog-house-nascars-small-teams-make-it-work-at-indy/" rel="bookmark">The Underdog House: NASCAR&#8217;s Small Teams Make It Work At Indy</a></h2><p>Think Small Indianapolis Motor Speedway isn’t exactly a track known for being kind to underfunded &hellip;</p></div></section><div id="comments"><div id="comments-box"><div class="block-head"><h3 id="comments-title">One comment</h3><div class="stripe-line"></div></div><div class="post-listing"><ol class="commentlist"><li id="comment-28388"><div  class="comment even thread-even depth-1 comment-wrap" ><div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/ec56cf0dfddcc887d11fc6b3c0f8cf36?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div><div class="comment-content"><div class="author-comment"> <cite class="fn">kb</cite><div class="comment-meta commentmetadata"><a href="https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/#comment-28388"> July 25, 2017 at 3:00 am</a></div><div class="clear"></div></div><p>Yeah, the Junior entitled snarkiness will continue..well because he is Junior and it is his world and we just live in it. His booth bias will be strong, he will stutter, he will not articulate a complete sentence, or if he does, it will take till the next commercial break. Booth bias is a disease that just got worse! THE CDC has no cure! His ego does not allow him to go home and shut up! &#8220;Concussion&#8221; my okele, party boy did not want to do it anymore, and it would have crushed the ones that still believe he is DALE SR! And that would not be good for NASCAR&#8230;I&#8217;m thinking Rick and Brian thought! Gotta keep the T SHIRT SALES STRONG! MO!</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.frontstretch.com/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/?replytocom=28388#respond' onclick='return addComment.moveForm( "comment-28388", "28388", "respond", "141141" )' aria-label='Reply to kb'>Reply</a></div></div></li></ol></div></div><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/25/5-points-to-ponder-great-nascar-finishes-abound/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='141141' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e3f6cd3940" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="206"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1931074544731095"
data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a><br /><br /><a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-2" class="widget widget_text enhanced-text-widget"><div class="widget-top"><h4>Promo Code NASCAR5 Earns 5% Off ($150 Minimum) on TicketLiquidator!</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget widget-text"><script type="text/javascript" src="https://tickettransaction2.com/Brokers/01504-011/WidgetJS/scriptsretail-stringutils.js"></script><script type="text/javascript">var widgetCSS = document.createElement("link");widgetCSS.setAttribute("rel", "stylesheet");widgetCSS.setAttribute("type", "text/css");widgetCSS.setAttribute("href", "https://tickettransaction2.com/Brokers/01504-011/WidgetCSS/Style.css");document.getElementsByTagName("head")[0].appendChild(widgetCSS);</script><div id="TL_Search_Widget" style="width: 200px; border: 1px solid rgb(218, 212, 200);"><div id="tlsw_header"><img src="//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/findtickets.png"><input id="tlsw_searchTxt" value="Search by Track or Event" onblur="if(this.value=='') this.value=this.defaultValue;" onfocus="if(this.value==this.defaultValue) this.value='';" type="text"><div id="tlsw_searchBtn" style="background-image: url(&quot;//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/blue_btn.png&quot;);" onclick="tn_SubmitSearch()"><script type="text/javascript">function tn_KeyDownHandler(e) {if (e == null) e = window.event;if (e.keyCode == 13) tn_SubmitSearch();}document.getElementById('tlsw_searchTxt').onkeypress = tn_KeyDownHandler;</script></div></div><ul id="tlsw_content" class="suggestionsArea"><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-sprint-cup-series-tickets.aspx"><span class="tlsw_linktext">Sprint Cup</span></a></li><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-xfinity-series-tickets.aspx"><span class="tlsw_linktext">Xfinity Series</span></a></li><li class="tlsw_suggestion" onmouseover="this.style.backgroundPosition='bottom right';" onmouseout="this.style.backgroundPosition='top right';" style="background-image:url(https://s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/red-bg.png);"><a target="_blank" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/tix/nascar-camping-world-truck-series-tickets.aspx"><span class="tlsw_linktext">Camping World Truck Series</span></a></li></ul><div id="tlsw_scripts"><script type="text/javascript">function tn_SubmitSearch() {var SearchPhrase = document.getElementById('tlsw_searchTxt').value.trim().replace(/\s/g, '-');window.open('//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=' + 'http://www.ticketliquidator.com/tix/' + SearchPhrase + '-tickets.aspx');}</script></div><div id="tlsw_footer"><a id="tlsw_footer_link" href="//www.jdoqocy.com/click-7929989-10858765?sid=&amp;url=http://www.ticketliquidator.com/default.aspx" target="_blank"><img src="//s3.amazonaws.com/ticketliquidator/affiliates/widgetMaker/SearchWidget/logo.png"></a></div></div></div></div></div><div id="text-34" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a> <br> <A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/FV-2017-Banner-Ad.jpg" alt="" /> </a></div></div><div id="text-5" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2017, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://www.frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_d288726ecde47d718c7033869962203d.js"></script></body></html>