<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c57c0ec0af7b5d33f3cbfe9538b780aa.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c8ede1184c0ba74d10d7f190bacfec01.css" rel="stylesheet" /><title>The 10: The Biggest &quot;Should Have Won&quot; Races of the Past 25 Years</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="The 10: The Biggest &#8220;Should Have Won&#8221; Races of the Past 25 Years - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="This week, the teams of the Monster Energy NASCAR Cup Series enjoyed their final weekend off until t"/><meta property="og:url" content="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP-660x425.jpg" /><meta name="description" content="This week, the teams of the Monster Energy NASCAR Cup Series enjoyed their final weekend off until the season ends. Whether it was traveling the world or r"/><link rel="canonical" href="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The 10: The Biggest &quot;Should Have Won&quot; Races of the Past 25 Years" /><meta property="og:description" content="This week, the teams of the Monster Energy NASCAR Cup Series enjoyed their final weekend off until the season ends. Whether it was traveling the world or r" /><meta property="og:url" content="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:section" content="Featured Content" /><meta property="article:published_time" content="2017-08-30T05:46:52-04:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP.jpg" /><meta property="og:image:width" content="700" /><meta property="og:image:height" content="466" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="This week, the teams of the Monster Energy NASCAR Cup Series enjoyed their final weekend off until the season ends. Whether it was traveling the world or r" /><meta name="twitter:title" content="The 10: The Biggest &quot;Should Have Won&quot; Races of the Past 25 Years" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP.jpg" /><meta name="twitter:creator" content="@Frontstretch" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.frontstretch.com\/","name":"Frontstretch","alternateName":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.frontstretch.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.frontstretch.com\/2017\/08\/30\/the-10-the-biggest-should-have-won-races-of-the-past-25-years\/","sameAs":["https:\/\/www.facebook.com\/Frontstretch","https:\/\/instagram.com\/frontstretchdotcom\/","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/twitter.com\/Frontstretch"],"@id":"#organization","name":"Frontstretch","logo":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/04\/favicon-196x196.png"}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; The 10: The Biggest &#8220;Should Have Won&#8221; Races of the Past 25 Years Comments Feed" href="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/feed/" />  <script type="text/javascript" data-cfasync="false">var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.7.5" /><meta name="generator" content="Seriously Simple Podcasting 1.17.3" /><link rel='shortlink' href='https://www.frontstretch.com/?p=143598' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F08%2F30%2Fthe-10-the-biggest-should-have-won-races-of-the-past-25-years%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F08%2F30%2Fthe-10-the-biggest-should-have-won-races-of-the-past-25-years%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.5.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="text/javascript">var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-143598 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="search-mobile"><form method="get" id="searchform-mobile" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-136612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136612"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast-powered-by-draftkings/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="search-block"><form method="get" id="searchform-header" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div></div></div><div class="header-content"><a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo" style=" margin-top:15px; margin-bottom:15px;"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/nascar-mailbox-why-are-nascar-throwback-paint-schemes-a-big-deal/" title="NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/rut-660x330.jpg" width="660" height="330" alt="NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/nascar-mailbox-why-are-nascar-throwback-paint-schemes-a-big-deal/" title="NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?">NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Unlikely Underdog Overachievers" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers">The Frontstretch 5: Unlikely Underdog Overachievers</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/beside-the-rising-tide-darlington-1979/" title="Beside the Rising Tide: Darlington 1979"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/darlingtonf-110x75.jpg" width="110" height="75" alt="Beside the Rising Tide: Darlington 1979" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/beside-the-rising-tide-darlington-1979/" title="Beside the Rising Tide: Darlington 1979">Beside the Rising Tide: Darlington 1979</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/entry-list-bojangles-southern-500-3/" title="Entry List: Bojangles Southern 500"><img src="https://www.frontstretch.com/wp-content/uploads/2016/01/Darlington-Raceway-55x55.jpg" width="110" height="75" alt="Entry List: Bojangles Southern 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/entry-list-bojangles-southern-500-3/" title="Entry List: Bojangles Southern 500">Entry List: Bojangles Southern 500</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/adventure-of-a-lifetime-a-look-at-a-childs-first-nascar-race/" title="Adventure of a Lifetime: A Look At A Child&#8217;s First NASCAR Race"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/IMG_3196-110x75.jpg" width="110" height="75" alt="Adventure of a Lifetime: A Look At A Child&#8217;s First NASCAR Race" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/adventure-of-a-lifetime-a-look-at-a-childs-first-nascar-race/" title="Adventure of a Lifetime: A Look At A Child&#8217;s First NASCAR Race">Adventure of a Lifetime: A Look At A Child&#8217;s First NASCAR Race</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kyle-Busch-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season">5 Points to Ponder: The Sharp End of the 2017 NASCAR Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/up-to-speed-rumors-fly-for-richard-petty-motorsports/" title="Up to Speed: Rumors Fly for Richard Petty Motorsports"><img src="https://www.frontstretch.com/wp-content/uploads/2016/02/2016-Daytona-Unlimited-CUP-Aric-Almirola-Richard-Petty-NKP-55x55.jpg" width="110" height="75" alt="Up to Speed: Rumors Fly for Richard Petty Motorsports" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/up-to-speed-rumors-fly-for-richard-petty-motorsports/" title="Up to Speed: Rumors Fly for Richard Petty Motorsports">Up to Speed: Rumors Fly for Richard Petty Motorsports</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 27, 2017</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/couch-potato-tuesday-nbc-decides-to-cheap-out-on-road-america/" title="Couch Potato Tuesday: NBC Decides to Cheap Out on Road America"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-William-Byron-Scott-LAgasse-Jr-racing-Brett-Moist-NKP-660x425.jpg" width="660" height="330" alt="Couch Potato Tuesday: NBC Decides to Cheap Out on Road America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/couch-potato-tuesday-nbc-decides-to-cheap-out-on-road-america/" title="Couch Potato Tuesday: NBC Decides to Cheap Out on Road America">Couch Potato Tuesday: NBC Decides to Cheap Out on Road America</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kyle-Busch-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season">5 Points to Ponder: The Sharp End of the 2017 NASCAR Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/the-underdog-house-clements-wrote-the-feel-good-story-nascar-needed/" title="The Underdog House: Jeremy Clements Wrote The Feel-Good Story NASCAR Needed"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-burnout-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="The Underdog House: Jeremy Clements Wrote The Feel-Good Story NASCAR Needed" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/the-underdog-house-clements-wrote-the-feel-good-story-nascar-needed/" title="The Underdog House: Jeremy Clements Wrote The Feel-Good Story NASCAR Needed">The Underdog House: Jeremy Clements Wrote The Feel-Good Story NASCAR Needed</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/xfinity-breakdown-spin-and-win-for-jeremy-clements/" title="XFINITY Breakdown: Spin And Win For Jeremy Clements"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-checkered-flag-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="XFINITY Breakdown: Spin And Win For Jeremy Clements" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/xfinity-breakdown-spin-and-win-for-jeremy-clements/" title="XFINITY Breakdown: Spin And Win For Jeremy Clements">XFINITY Breakdown: Spin And Win For Jeremy Clements</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/jeremy-clements-gets-long-awaited-victory-josef-newgarden-extends-points-lead/" title="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/jeremy-clements-gets-long-awaited-victory-josef-newgarden-extends-points-lead/" title="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead">Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/26/james-davison-paces-final-xfinity-practice-session/" title="James Davison Paces Final Xfinity Practice Session"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/d90027ee7ad3d66d60e747ba4c0a4b74-11-110x75.jpg" width="110" height="75" alt="James Davison Paces Final Xfinity Practice Session" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/26/james-davison-paces-final-xfinity-practice-session/" title="James Davison Paces Final Xfinity Practice Session">James Davison Paces Final Xfinity Practice Session</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 26, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/james-davison-hopes-road-america-is-springboard-to-full-time-nascar-career/" title="James Davison Hopes Road America Is Springboard to Full-Time NASCAR Career"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/d90027ee7ad3d66d60e747ba4c0a4b74-11-110x75.jpg" width="110" height="75" alt="James Davison Hopes Road America Is Springboard to Full-Time NASCAR Career" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/james-davison-hopes-road-america-is-springboard-to-full-time-nascar-career/" title="James Davison Hopes Road America Is Springboard to Full-Time NASCAR Career">James Davison Hopes Road America Is Springboard to Full-Time NASCAR Career</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 24, 2017</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://www.frontstretch.com/cwts-schedule/"><i class="fa fa-arrow-right"></i>2017 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/news/truck-series-news/"><i class="fa fa-arrow-right"></i>News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/"><i class="fa fa-arrow-right"></i>Commentary</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/"><i class="fa fa-arrow-right"></i>Race Report</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-jordan-anderson-trying-to-be-the-peoples-driver/" title="Beyond the Cockpit: Jordan Anderson Trying to Be the People&#8217;s Driver"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/jordan-anderson-640x425.jpg" width="660" height="330" alt="Beyond the Cockpit: Jordan Anderson Trying to Be the People&#8217;s Driver" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-jordan-anderson-trying-to-be-the-peoples-driver/" title="Beyond the Cockpit: Jordan Anderson Trying to Be the People&#8217;s Driver">Beyond the Cockpit: Jordan Anderson Trying to Be the People&#8217;s Driver</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Unlikely Underdog Overachievers" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers">The Frontstretch 5: Unlikely Underdog Overachievers</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/truckin-thursdays-brad-keselowski-racing-becomes-latest-casualty-in-the-truck-series/" title="Truckin&#8217; Thursdays: Brad Keselowski Racing Becomes Latest Casualty in the Truck Series"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Iowa-CWTS-Chase-Briscoe-truck-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="Truckin&#8217; Thursdays: Brad Keselowski Racing Becomes Latest Casualty in the Truck Series" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/truckin-thursdays-brad-keselowski-racing-becomes-latest-casualty-in-the-truck-series/" title="Truckin&#8217; Thursdays: Brad Keselowski Racing Becomes Latest Casualty in the Truck Series">Truckin&#8217; Thursdays: Brad Keselowski Racing Becomes Latest Casualty in the Truck Series</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 24, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/23/daniel-suarezs-crew-chief-issued-lug-nut-penalty-after-bristol-cup-race/" title="Daniel Suarez&#8217;s Crew Chief Issued Lug Nut Penalty After Bristol Cup Race"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Daniel-Suarez-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="Daniel Suarez&#8217;s Crew Chief Issued Lug Nut Penalty After Bristol Cup Race" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/23/daniel-suarezs-crew-chief-issued-lug-nut-penalty-after-bristol-cup-race/" title="Daniel Suarez&#8217;s Crew Chief Issued Lug Nut Penalty After Bristol Cup Race">Daniel Suarez&#8217;s Crew Chief Issued Lug Nut Penalty After Bristol Cup Race</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 23, 2017</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/nitro-shots-the-big-event/" title="Nitro Shots: The Big Event"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/NHRA-2017-Brainerd-Alexis-Dejoria-versus-Cruz-Pedregon-courtesy-NHRA-660x425.jpg" width="660" height="330" alt="Nitro Shots: The Big Event" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/nitro-shots-the-big-event/" title="Nitro Shots: The Big Event">Nitro Shots: The Big Event</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 24, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/17/nitro-shots-a-necessary-distraction/" title="Nitro Shots: A Necessary Distraction"><img src="https://www.frontstretch.com/wp-content/uploads/2017/04/NHRA-2017-Las-Vegas-Tommy-Johnson-Jr.-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: A Necessary Distraction" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/17/nitro-shots-a-necessary-distraction/" title="Nitro Shots: A Necessary Distraction">Nitro Shots: A Necessary Distraction</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 17, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/09/nitro-shots-nhra-does-some-things-right-some-things-wrong/" title="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Brittany-Force-car-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/09/nitro-shots-nhra-does-some-things-right-some-things-wrong/" title="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong">Nitro Shots: NHRA Does Some Things Right, Some Things Wrong</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 9, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/06/pace-laps-daniel-suarez-impresses-and-cup-drivers-dominate-xfinity-series-at-the-glen/" title="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/kybspark-110x75.jpg" width="110" height="75" alt="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/06/pace-laps-daniel-suarez-impresses-and-cup-drivers-dominate-xfinity-series-at-the-glen/" title="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen">Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/02/nitro-shots-a-little-like-can-go-a-long-way/" title="Nitro Shots: A Little Like Can Go a Long Way"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/NHRA-2017-Sonoma-J.R.-Todd-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: A Little Like Can Go a Long Way" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/02/nitro-shots-a-little-like-can-go-a-long-way/" title="Nitro Shots: A Little Like Can Go a Long Way">Nitro Shots: A Little Like Can Go a Long Way</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/27/nitro-shots-calling-corporate-america/" title="Nitro Shots: Calling Corporate America"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/024-LeahPritchettPhoenix-110x75.jpg" width="110" height="75" alt="Nitro Shots: Calling Corporate America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/27/nitro-shots-calling-corporate-america/" title="Nitro Shots: Calling Corporate America">Nitro Shots: Calling Corporate America</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-NXS-William-Byron-burnout-Matthew-T-Thacker-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/23/major-weekend-indianapolis-hendrick-motorsports-eldora-madness/" title="Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness">Pace Laps: A Major Weekend at Indianapolis for Hendrick Motorsports &#038; Eldora Madness</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 23, 2017</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-660x425.jpg" width="660" height="330" alt="The Frontstretch 5: Unlikely Underdog Overachievers" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers">The Frontstretch 5: Unlikely Underdog Overachievers</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kyle-Busch-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season">5 Points to Ponder: The Sharp End of the 2017 NASCAR Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/jeremy-clements-gets-long-awaited-victory-josef-newgarden-extends-points-lead/" title="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/27/jeremy-clements-gets-long-awaited-victory-josef-newgarden-extends-points-lead/" title="Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead">Pace Laps: Jeremy Clements Gets Long Awaited Victory, Josef Newgarden Extends Points Lead</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/pace-laps-kyle-busch-takes-the-broom-at-bristol-bad-news-for-brad-keselowski-racing/" title="Pace Laps: Kyle Busch Takes the Broom at Bristol &#038; Bad News for Brad Keselowski Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/Kyle-Busch-Bringing-out-the-Broom-Bristol-110x75.jpg" width="110" height="75" alt="Pace Laps: Kyle Busch Takes the Broom at Bristol &#038; Bad News for Brad Keselowski Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/pace-laps-kyle-busch-takes-the-broom-at-bristol-bad-news-for-brad-keselowski-racing/" title="Pace Laps: Kyle Busch Takes the Broom at Bristol &#038; Bad News for Brad Keselowski Racing">Pace Laps: Kyle Busch Takes the Broom at Bristol &#038; Bad News for Brad Keselowski Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/alexander-rossi-continues-to-impress-on-the-2-5-mile-ovals/" title="Alexander Rossi Continues to Impress on the 2.5-Mile Ovals"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/rossi-110x75.jpg" width="110" height="75" alt="Alexander Rossi Continues to Impress on the 2.5-Mile Ovals" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/alexander-rossi-continues-to-impress-on-the-2-5-mile-ovals/" title="Alexander Rossi Continues to Impress on the 2.5-Mile Ovals">Alexander Rossi Continues to Impress on the 2.5-Mile Ovals</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/will-power-maneuvers-his-way-to-2nd-straight-pocono-win/" title="Will Power Maneuvers His Way to 2nd Straight Pocono Win"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/pwoerpoer-110x75.jpg" width="110" height="75" alt="Will Power Maneuvers His Way to 2nd Straight Pocono Win" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/will-power-maneuvers-his-way-to-2nd-straight-pocono-win/" title="Will Power Maneuvers His Way to 2nd Straight Pocono Win">Will Power Maneuvers His Way to 2nd Straight Pocono Win</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/tony-kanaan-pocono-is-becoming-my-indianapolis/" title="Tony Kanaan: Pocono Is Becoming My Indianapolis"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/kana-110x75.jpg" width="110" height="75" alt="Tony Kanaan: Pocono Is Becoming My Indianapolis" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/20/tony-kanaan-pocono-is-becoming-my-indianapolis/" title="Tony Kanaan: Pocono Is Becoming My Indianapolis">Tony Kanaan: Pocono Is Becoming My Indianapolis</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 20, 2017</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://www.frontstretch.com/sports-cars/">Sports Cars</a><ul class="sub-menu menu-sub-content"><li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://www.frontstretch.com/category/imsa/">IMSA</a></li></ul></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.draftkings.com/gateway?s=696638929" title="Draft Kings - Free Fantasy Racing" > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/draft-kings-728x90.png" alt="Draft Kings - Free Fantasy Racing" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/featured-content/">Featured Content</a></span> <span class="delimiter">/</span> <span class="current">The 10: The Biggest &#8220;Should Have Won&#8221; Races of the Past 25 Years</span></div><article class="post-listing post-143598 post type-post status-publish format-standard has-post-thumbnail  category-featured-content category-frank-velat category-power-rankings" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Logano Whitton / NKP)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">The 10: The Biggest &#8220;Should Have Won&#8221; Races of the Past 25 Years</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/fvelat/" title="">Frank Velat </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/frank-velat/" rel="category tag">Frank Velat</a>, <a href="https://www.frontstretch.com/category/power-rankings/" rel="category tag">Power Rankings</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/#comments">2 Comments</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>This week, the teams of the Monster Energy NASCAR Cup Series enjoyed their final weekend off until the season ends. Whether it was traveling the world or relaxing at home, the competitors did whatever they felt would recharge their batteries. So I decided to give our contributors a chance to clear their minds as well. Which group needed the break more? I suppose that&#8217;s all a matter of perspective.</p><p>Regardless, this week we present to you something that sports fans in general are all too familiar with: the dreaded near miss. Not winning is always tough but when a sure win is exchanged for bitter defeat, it can almost chip away at one&#8217;s soul. NASCAR is chock full of examples of this indiscriminate gut punch. But what are the worst?</p><p>Due to the abundance of such occurrences throughout the sport&#8217;s history, I&#8217;ll limit this to the past 25 years. Otherwise, the list would have probably taken a year to put together. So here are ten times that I thought a driver &#8220;shoulda had that one&#8221; in a Cup race. What are yours?</p><p><strong>How the Rankings Are Calculated:</strong> Ordinarily, <em>Frontstretch</em> does our power rankings similar to how the Associated Press does them for basketball or football. Our expert stable of NASCAR writers, both on staff and from other major publications, will vote for the top 10 on a 10-9-8-7&#8230; 3-2-1 basis, giving 10 points to their first-place driver, nine for second and so on. In the end, Frank Velat calculates the points, adds some funny one-liners and&#8230; there you go! But this week, he kicked everyone out and took the whole thing over. Anyways, have a look.</p><table id="rankings" style="height: 3550px;" width="896"><tbody><tr align="left" bgcolor="#ff0000"><td style="color: #fff;"><pre>Rank</pre></td><td style="color: #fff;"><pre>Change</pre></td><td style="color: #fff;"><pre>Name</pre></td><td style="color: #fff;"><pre>Total Votes</pre></td></tr><tr><td><h3>1</h3></td><td bgcolor="#cccccc"></td><td><img class="alignleft size-medium wp-image-78840" src="https://www.frontstretch.com/wp-content/uploads/2014/06/2014-IndyCar-Juan-Pablo-Montoya-199x300.jpg" alt="" width="199" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2014/06/2014-IndyCar-Juan-Pablo-Montoya-199x300.jpg 199w, https://www.frontstretch.com/wp-content/uploads/2014/06/2014-IndyCar-Juan-Pablo-Montoya.jpg 660w" sizes="(max-width: 199px) 100vw, 199px" /></p><h4>Juan Pablo Montoya: 2009 at Indianapolis</h4><div>Montoya was without question the best car at Indy that weekend. It wasn&#8217;t just that he led 116 of the first 124 laps. He would shoot out to huge leads and just keep getting further away. Then he was busted for speeding on pit road and had to serve his penalty. Montoya nearly became the only driver to win at Indianapolis in both IndyCar and NASCAR.</div><h5></h5></td><td bgcolor="#cccccc"></td></tr><tr><td><h3>2</h3></td><td bgcolor="#cccccc"><strong> </strong></td><td><img class="alignleft size-medium wp-image-131102" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Brad-Keselowski-Headshot-196x300.jpg" alt="" width="196" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Brad-Keselowski-Headshot-196x300.jpg 196w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Brad-Keselowski-Headshot-98x150.jpg 98w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Brad-Keselowski-Headshot-660x1013.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Brad-Keselowski-Headshot.jpg 760w" sizes="(max-width: 196px) 100vw, 196px" /></p><h4><a href="/tag/brad-keselowski">Brad Keselowski</a>: 2010 at Texas</h4><p>There were 334 laps in this race. Keselowski led 312 of them. It&#8217;s almost ludicrous to think he wouldn&#8217;t win, but a debris caution with 18 to go brought the field close and Jimmie Johnson tracked him down and got by with four to go. <em><br /> </em></td><td bgcolor="#cccccc"></td></tr><tr><td><h3>3</h3><p>&nbsp;</td><td bgcolor="#cccccc"></td><td><figure id="attachment_131118" style="width: 223px" class="wp-caption alignleft"><img class="size-medium wp-image-131118" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kyle-Busch-Headshot-223x300.jpg" alt="" width="223" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kyle-Busch-Headshot-223x300.jpg 223w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kyle-Busch-Headshot-111x150.jpg 111w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kyle-Busch-Headshot-660x889.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kyle-Busch-Headshot.jpg 760w" sizes="(max-width: 223px) 100vw, 223px" /><figcaption class="wp-caption-text">(Photo: NASCAR)</figcaption></figure><h4><a href="/tag/kyle-busch">Kyle Busch</a> : 2009 at Daytona</h4><p>Busch was on his way to a Daytona 500 triumph when things got a little too aggressive on the backstretch. Maybe you feel he blocked <a href="/tag/dale-earnhardt-jr">Dale Earnhardt Jr</a> or you think Earnhardt turned Busch. Either way, the 88 laps Busch led meant nothing when his car sat wrecked in the Turn 3 infield.</p><h5></h5></td><td bgcolor="#cccccc"></td></tr><tr><td><h3>4</h3><p><strong> </strong></td><td bgcolor="#cccccc"></td><td><figure id="attachment_131117" style="width: 210px" class="wp-caption alignleft"><img class="size-medium wp-image-131117" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kurt-Busch-Headshot-210x300.jpg" alt="" width="210" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kurt-Busch-Headshot-210x300.jpg 210w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kurt-Busch-Headshot-105x150.jpg 105w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kurt-Busch-Headshot-660x941.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Kurt-Busch-Headshot.jpg 760w" sizes="(max-width: 210px) 100vw, 210px" /><figcaption class="wp-caption-text">(Photo: NASCAR)</figcaption></figure><h4>Tony Stewart &amp; <a href="/tag/kurt-busch">Kurt Busch</a>: 2007 Daytona 500<a href="http://old.frontstretch.com/tag/dale-earnhardt-jr"><br /> </a></h4><p>The only two cars that could touch each other during the first three-quarters of the race ended up doing just that. Contact left both in the Turn 4 wall and added to the Daytona 500 frustration for both. Busch exorcised his demons this year but Stewart retired having never won the big race.</p><p><i><br /> </i></p><h5></h5></td><td bgcolor="#cccccc"></td></tr><tr><td><h3>5</h3></td><td bgcolor="#cccccc"><strong> </strong></td><td><img class="alignleft size-medium wp-image-68483" src="https://www.frontstretch.com/wp-content/uploads/2014/02/Ambrose-200x300.jpg" alt="" width="200" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2014/02/Ambrose-200x300.jpg 200w, https://www.frontstretch.com/wp-content/uploads/2014/02/Ambrose-682x1024.jpg 682w" sizes="(max-width: 200px) 100vw, 200px" /></p><h4><a href="/tag/marcos-ambrose">Marcos Ambrose</a>: 2010 At Sonoma</h4><p>Trying to save fuel a little too aggressively ended up costing the Aussie a shot at his first career win. While leading under yellow, Ambrose turned off the engine and wasn&#8217;t able to cut it back on until after five cars, including eventual race winner <a href="/tag/jimmie-johnson">Jimmie Johnson</a>, had passed him by.<em><br /> </em></p><p>&nbsp;</td><td bgcolor="#cccccc"></td></tr><tr><td><h3>6</h3></td><td bgcolor="#cccccc"><h3><strong> </strong></h3></td><td style="text-align: left;"><img class="size-medium wp-image-143618 alignleft" src="https://www.frontstretch.com/wp-content/uploads/2017/08/2005-Rusty-Wallace-NASCAR-via-Getty-Images-201x300.jpg" alt="" width="201" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/08/2005-Rusty-Wallace-NASCAR-via-Getty-Images-201x300.jpg 201w, https://www.frontstretch.com/wp-content/uploads/2017/08/2005-Rusty-Wallace-NASCAR-via-Getty-Images-100x150.jpg 100w, https://www.frontstretch.com/wp-content/uploads/2017/08/2005-Rusty-Wallace-NASCAR-via-Getty-Images-660x986.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/08/2005-Rusty-Wallace-NASCAR-via-Getty-Images.jpg 1024w" sizes="(max-width: 201px) 100vw, 201px" /></p><h4>Rusty Wallace: 1999 Daytona 500</h4><p>Like Stewart, Wallace finished out his career without a Daytona 500 trophy. This race was no doubt his best shot, as he led 107 of the 200 laps. But a banzai move by Jeff Gordon with 10 laps to go switched Wallace&#8217;s fate with that of Gordon, who would pick up his second 500 victory.<em><br /> </em></td><td bgcolor="#cccccc"><h3><strong> </strong></h3></td></tr><tr><td><h3>7</h3></td><td bgcolor="#cccccc"><strong> </strong></td><td><img class="alignleft size-medium wp-image-143619" src="https://www.frontstretch.com/wp-content/uploads/2017/08/056-3-darlington-gordon-090196-227x300.jpg" alt="" width="227" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/08/056-3-darlington-gordon-090196-227x300.jpg 227w, https://www.frontstretch.com/wp-content/uploads/2017/08/056-3-darlington-gordon-090196-113x150.jpg 113w, https://www.frontstretch.com/wp-content/uploads/2017/08/056-3-darlington-gordon-090196-660x874.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/08/056-3-darlington-gordon-090196.jpg 1024w" sizes="(max-width: 227px) 100vw, 227px" /></p><h4>Hut Stricklin: 1996 at Darlington</h4><p>While Stricklin wasn&#8217;t as dominant as some on this list, he did lead the most laps. The heartbreak in his run at Darlington Raceway was in the fact that he never even came close to winning after this race. The runner up finish to Jeff Gordon was the last top-five finish of his career.</td><td bgcolor="#cccccc"></td></tr><tr><td><h3>8</h3></td><td bgcolor="#cccccc"><strong> </strong></td><td><img class="alignleft size-medium wp-image-143620" src="https://www.frontstretch.com/wp-content/uploads/2017/08/2011-nscs-bill-elliott-waist-up-200x300.jpg" alt="" width="200" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/08/2011-nscs-bill-elliott-waist-up-200x300.jpg 200w, https://www.frontstretch.com/wp-content/uploads/2017/08/2011-nscs-bill-elliott-waist-up-100x150.jpg 100w, https://www.frontstretch.com/wp-content/uploads/2017/08/2011-nscs-bill-elliott-waist-up-660x990.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/08/2011-nscs-bill-elliott-waist-up.jpg 1024w" sizes="(max-width: 200px) 100vw, 200px" /></p><h4>Bill Elliott: 2003 at Homestead</h4><p>2001 winner Elliott led 189 of the 267 laps and appeared to have his 44th career in hand. Until he cut a tire on the last lap. Elliott never won another Cup race.<em><br /> </em></p><p>&nbsp;</td><td bgcolor="#cccccc"></td></tr><tr><td><h3>9</h3></td><td bgcolor="#cccccc"><h3><strong> </strong></h3></td><td><figure id="attachment_131121" style="width: 226px" class="wp-caption alignleft"><img class="size-medium wp-image-131121" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Martin-Truex-Jr-Headshot-226x300.jpg" alt="" width="226" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Martin-Truex-Jr-Headshot-226x300.jpg 226w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Martin-Truex-Jr-Headshot-113x150.jpg 113w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Martin-Truex-Jr-Headshot-660x878.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Martin-Truex-Jr-Headshot.jpg 760w" sizes="(max-width: 226px) 100vw, 226px" /><figcaption class="wp-caption-text">(Photo: NASCAR)</figcaption></figure><h4><a href="/tag/martin-truex-jr">Martin Truex Jr</a>: 2015 at Dover</h4><p>For the second week in a row, Truex led 191 laps. For the second week in a row, he didn&#8217;t win. Don&#8217;t feel too bad though. He wound up in Victory Lane the following race at Pocono.<em><br /> </em></td><td bgcolor="#cccccc"></td></tr><tr><td><h3>10</h3></td><td bgcolor="#cccccc"><h3><strong> </strong></h3><h3></h3></td><td><img class="alignleft size-medium wp-image-131122" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Matt-Kenseth-Headshot-236x300.jpg" alt="" width="236" height="300" srcset="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Matt-Kenseth-Headshot-236x300.jpg 236w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Matt-Kenseth-Headshot-118x150.jpg 118w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Matt-Kenseth-Headshot-660x838.jpg 660w, https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Cup-Matt-Kenseth-Headshot.jpg 760w" sizes="(max-width: 236px) 100vw, 236px" /></p><h4><a href="/tag/matt-kenseth">Matt Kenseth</a>: 2013 at Martinsville</h4><p>Kenseth had a great shot to win at what has statistically been his worst track. Leading 202 laps wasn&#8217;t enough though, as Jeff Gordon chased him down and got past with 20 to go, relegating Kenseth to second.<em><br /> </em></p><p>&nbsp;</td><td bgcolor="#cccccc"><h3><strong> </strong></h3></td></tr></tbody></table><p><strong>Who Voted: Frank Velat</strong>, <em>Frontstretch</em></p></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=143598" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=The+10%3A+The+Biggest+%E2%80%9CShould+Have+Won%E2%80%9D+Races+of+the+Past+25+Years&url=https://www.frontstretch.com/?p=143598" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=143598&amp;name=The+10%3A+The+Biggest+%E2%80%9CShould+Have+Won%E2%80%9D+Races+of+the+Past+25+Years" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=143598&title=The+10%3A+The+Biggest+%E2%80%9CShould+Have+Won%E2%80%9D+Races+of+the+Past+25+Years" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=143598&title=The+10%3A+The+Biggest+%E2%80%9CShould+Have+Won%E2%80%9D+Races+of+the+Past+25+Years" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=143598&amp;description=The+10%3A+The+Biggest+%E2%80%9CShould+Have+Won%E2%80%9D+Races+of+the+Past+25+Years&amp;media=https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Brad-Keselowski-racing-Logan-Whitton-NKP-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">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</script> </article><section id="author-box"><div class="block-head"><h3>About Frank Velat</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://secure.gravatar.com/avatar/24760c4307ca307de3e7abb35fd4797a?s=90&#038;d=mm&#038;r=g" width="90" height="90" alt="" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 photo avatar-default" /></div><div class="author-description"> Frank Velat has been an avid follower of NASCAR and other motorsports for over 20 years. He brings a blend of passionate fan and objective author to his work. Frank offers unique perspectives that everyone can relate to, remembering the sport's past all the while embracing its future. Follow along with @FrankVelat on Twitter.</div><div class="author-social flat-social"> <a class="social-site" target="_blank" href="http://Frontstretch.com"><i class="fa fa-home"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2017/08/30/nascar-mailbox-why-are-nascar-throwback-paint-schemes-a-big-deal/" rel="prev"><span>Previous</span> NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?</a></div><div class="post-next"><a href="https://www.frontstretch.com/2017/08/30/chase-elliott-william-byron-to-change-car-numbers-for-2018/" rel="next"><span>Next</span> Chase Elliott, William Byron to Change Car Numbers for 2018</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/08/30/nascar-mailbox-why-are-nascar-throwback-paint-schemes-a-big-deal/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2016/09/rut-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/08/30/nascar-mailbox-why-are-nascar-throwback-paint-schemes-a-big-deal/" rel="bookmark">NASCAR Mailbox: Why Are NASCAR Throwback Paint Schemes a Big Deal?</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-ronnie-bassett-jr-learning-patience-consistency-in-2017-kn-season/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/08/basss-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-ronnie-bassett-jr-learning-patience-consistency-in-2017-kn-season/" rel="bookmark">Beyond the Cockpit: Ronnie Bassett Jr. Learning Patience, Consistency in 2017 K&#038;N Season</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-jordan-anderson-trying-to-be-the-peoples-driver/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/08/jordan-anderson-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/08/30/beyond-the-cockpit-jordan-anderson-trying-to-be-the-peoples-driver/" rel="bookmark">Beyond the Cockpit: Jordan Anderson Trying to Be the People&#8217;s Driver</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" rel="bookmark">The Frontstretch 5: Unlikely Underdog Overachievers</a></h2><p>Jeremy Clements nabbed the win for his family-owned team in Sunday&#8217;s XFINITY Series race from Road &hellip;</p></div></section><div id="comments"><div id="comments-box"><div class="block-head"><h3 id="comments-title">2 comments</h3><div class="stripe-line"></div></div><div class="post-listing"><ol class="commentlist"><li id="comment-29650"><div  class="comment even thread-even depth-1 comment-wrap" ><div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/d54be2016894209f461b337a27cd8b35?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div><div class="comment-content"><div class="author-comment"> <cite class="fn">Upstate24fan</cite><div class="comment-meta commentmetadata"><a href="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/#comment-29650"> August 30, 2017 at 12:46 pm</a></div><div class="clear"></div></div><p>I think there is a typo on number 2.  That Texas race Brad dominated was 2015.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/?replytocom=29650#respond' onclick='return addComment.moveForm( "comment-29650", "29650", "respond", "143598" )' aria-label='Reply to Upstate24fan'>Reply</a></div></div></li><li id="comment-29645"><div  class="comment odd alt thread-odd thread-alt depth-1 comment-wrap" ><div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/4c07ff417debb64ce8878a2dae641934?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div><div class="comment-content"><div class="author-comment"> <cite class="fn">DoninAjax</cite><div class="comment-meta commentmetadata"><a href="https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/#comment-29645"> August 30, 2017 at 10:49 am</a></div><div class="clear"></div></div><p>The &#8220;banzai move by Jeff Gordon&#8221; brought the double yellow line into existence. I call it the Jeff Gordon rule.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.frontstretch.com/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/?replytocom=29645#respond' onclick='return addComment.moveForm( "comment-29645", "29645", "respond", "143598" )' aria-label='Reply to DoninAjax'>Reply</a></div></div></li></ol></div></div><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/08/30/the-10-the-biggest-should-have-won-races-of-the-past-25-years/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='143598' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4e13b77831" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="69"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1931074544731095"
data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a><br /><br /><a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="text-34" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a> <br> <A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/FV-2017-Banner-Ad.jpg" alt="" /> </a></div></div><div id="text-5" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2017, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://www.frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_374d59183f846257b14c86b49fcfee31.js"></script></body></html>