<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c57c0ec0af7b5d33f3cbfe9538b780aa.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_123f5b4887ec2c0a1a4f748610ba7051.css" rel="stylesheet" /><title>NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience? - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="Technology is always changing, for better or for worse. In auto racing, technological advances have"/><meta property="og:url" content="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone-660x425.jpg" /><meta name="description" content="Technology is always changing, for better or for worse. In auto racing, technological advances have made vehicles not only faster, but more durable. Howeve"/><link rel="canonical" href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?" /><meta property="og:description" content="Technology is always changing, for better or for worse. In auto racing, technological advances have made vehicles not only faster, but more durable. Howeve" /><meta property="og:url" content="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:tag" content="Ty Dillon" /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2017-09-06T06:10:58-04:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone.jpg" /><meta property="og:image:width" content="1536" /><meta property="og:image:height" content="1024" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Technology is always changing, for better or for worse. In auto racing, technological advances have made vehicles not only faster, but more durable. Howeve" /><meta name="twitter:title" content="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone.jpg" /><meta name="twitter:creator" content="@Frontstretch" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.frontstretch.com\/","name":"Frontstretch","alternateName":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.frontstretch.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.frontstretch.com\/2017\/09\/06\/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience\/","sameAs":["https:\/\/www.facebook.com\/Frontstretch","https:\/\/instagram.com\/frontstretchdotcom\/","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/twitter.com\/Frontstretch"],"@id":"#organization","name":"Frontstretch","logo":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/04\/favicon-196x196.png"}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience? Comments Feed" href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/feed/" />  <script type="text/javascript" data-cfasync="false">var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.7.5" /><meta name="generator" content="Seriously Simple Podcasting 1.17.3" /><link rel='shortlink' href='https://www.frontstretch.com/?p=144110' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F09%2F06%2Fnascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F09%2F06%2Fnascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.5.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="text/javascript">var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-144110 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="search-mobile"><form method="get" id="searchform-mobile" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-136612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136612"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast-powered-by-draftkings/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="search-block"><form method="get" id="searchform-header" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div></div></div><div class="header-content"><a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/did-you-notice-the-fine-line-of-nascar-drivers-personal-lives-where-it-all-went-wrong/" title="Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong"><img src="https://www.frontstretch.com/wp-content/uploads/2014/10/Jeremy-Mayfield-Credit-LAT-PHOTOGRAPHIC.jpg" width="660" height="330" alt="Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/did-you-notice-the-fine-line-of-nascar-drivers-personal-lives-where-it-all-went-wrong/" title="Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong">Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/" title="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone-110x75.jpg" width="110" height="75" alt="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/" title="NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?">NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/the-frontstretch-5-things-that-dont-sit-right/" title="The Frontstretch 5: Things That Don&#8217;t Sit Right"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Daniel-Suarez-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Things That Don&#8217;t Sit Right" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/the-frontstretch-5-things-that-dont-sit-right/" title="The Frontstretch 5: Things That Don&#8217;t Sit Right">The Frontstretch 5: Things That Don&#8217;t Sit Right</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/" title="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/3d57ee60417e630de83dda9fef8ca983-11-110x75.jpg" width="110" height="75" alt="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/" title="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership">Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/the-10-nascar-cup-series-power-rankings-after-darlington/" title="The 10: NASCAR Cup Series Power Rankings After Darlington"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Darlington-Cup-2017-Denny-Hamlin-Yvonne-Leonard-110x75.jpg" width="110" height="75" alt="The 10: NASCAR Cup Series Power Rankings After Darlington" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/the-10-nascar-cup-series-power-rankings-after-darlington/" title="The 10: NASCAR Cup Series Power Rankings After Darlington">The 10: NASCAR Cup Series Power Rankings After Darlington</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/5-points-to-ponder-dont-sleep-on-denny-hamlin/" title="5 Points to Ponder: Don&#8217;t Sleep On&#8230; Denny Hamlin?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/haml-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: Don&#8217;t Sleep On&#8230; Denny Hamlin?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/5-points-to-ponder-dont-sleep-on-denny-hamlin/" title="5 Points to Ponder: Don&#8217;t Sleep On&#8230; Denny Hamlin?">5 Points to Ponder: Don&#8217;t Sleep On&#8230; Denny Hamlin?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/beside-the-rising-tide-with-autumn-closing-in/" title="Beside The Rising Tide: With Autumn Closing In"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Darlington-Cup-2017-Aric-Almirola-2-Throwback-Mike-Neff-110x75.jpg" width="110" height="75" alt="Beside The Rising Tide: With Autumn Closing In" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/beside-the-rising-tide-with-autumn-closing-in/" title="Beside The Rising Tide: With Autumn Closing In">Beside The Rising Tide: With Autumn Closing In</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 5, 2017</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/" title="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/3d57ee60417e630de83dda9fef8ca983-11-640x425.jpg" width="660" height="330" alt="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/" title="Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership">Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/hamlin-darlington-nxs-110x75.jpg" width="110" height="75" alt="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens">Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/xfiinty-breakdown-denny-hamlin-makes-darlington-personal-playground/" title="XFINITY Breakdown: Denny Hamlin Makes Darlington Personal Playground"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Denny-Hamlin-Darlington-Celebration-110x75.jpg" width="110" height="75" alt="XFINITY Breakdown: Denny Hamlin Makes Darlington Personal Playground" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/xfiinty-breakdown-denny-hamlin-makes-darlington-personal-playground/" title="XFINITY Breakdown: Denny Hamlin Makes Darlington Personal Playground">XFINITY Breakdown: Denny Hamlin Makes Darlington Personal Playground</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/02/ryan-sieg-finds-light-in-struggling-darlington-weekend/" title="Ryan Sieg Finds Light in Struggling Darlington Weekend"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/a62bd321d96a8ba7899aad4ba4852745-11-110x75.jpg" width="110" height="75" alt="Ryan Sieg Finds Light in Struggling Darlington Weekend" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/02/ryan-sieg-finds-light-in-struggling-darlington-weekend/" title="Ryan Sieg Finds Light in Struggling Darlington Weekend">Ryan Sieg Finds Light in Struggling Darlington Weekend</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/02/denny-hamlin-perfects-crossover-maneuver-for-darlington-xfinity-win/" title="Denny Hamlin Perfects Crossover Maneuver for Darlington XFINITY Win"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/328d8b1286f69667aa2872182d92b280-11-110x75.jpg" width="110" height="75" alt="Denny Hamlin Perfects Crossover Maneuver for Darlington XFINITY Win" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/02/denny-hamlin-perfects-crossover-maneuver-for-darlington-xfinity-win/" title="Denny Hamlin Perfects Crossover Maneuver for Darlington XFINITY Win">Denny Hamlin Perfects Crossover Maneuver for Darlington XFINITY Win</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/01/cup-series-throwback-paint-schemes-for-2017/" title="Cup Series Throwback Paint Schemes for 2017"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Darlington-Cup-2017-Jeffrey-Earnhardt-Throwback-Mike-Neff-110x75.jpg" width="110" height="75" alt="Cup Series Throwback Paint Schemes for 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/01/cup-series-throwback-paint-schemes-for-2017/" title="Cup Series Throwback Paint Schemes for 2017">Cup Series Throwback Paint Schemes for 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 1, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/01/the-throwback-schemes-of-the-xfinity-series-for-2017/" title="The Throwback Schemes of the XFINITY Series for 2017"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Darlington-XFINITY-Throwback-2017-Austin-Dillon-Mike-Neff-110x75.jpg" width="110" height="75" alt="The Throwback Schemes of the XFINITY Series for 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/01/the-throwback-schemes-of-the-xfinity-series-for-2017/" title="The Throwback Schemes of the XFINITY Series for 2017">The Throwback Schemes of the XFINITY Series for 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 1, 2017</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://www.frontstretch.com/cwts-schedule/"><i class="fa fa-arrow-right"></i>2017 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/news/truck-series-news/"><i class="fa fa-arrow-right"></i>News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/"><i class="fa fa-arrow-right"></i>Commentary</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/"><i class="fa fa-arrow-right"></i>Race Report</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/couch-potato-tuesday-nbcsn-has-fun-in-darlington-forgets-stuff/" title="Couch Potato Tuesday: NBCSN Has Fun in Darlington, Forgets Stuff"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/c2d8d02e30afb263e7584e1d7387a8f2-11-640x425.jpg" width="660" height="330" alt="Couch Potato Tuesday: NBCSN Has Fun in Darlington, Forgets Stuff" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/05/couch-potato-tuesday-nbcsn-has-fun-in-darlington-forgets-stuff/" title="Couch Potato Tuesday: NBCSN Has Fun in Darlington, Forgets Stuff">Couch Potato Tuesday: NBCSN Has Fun in Darlington, Forgets Stuff</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>September 5, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/tracking-trucks-austin-cindric-uses-dump-run-win-canada/" title="Tracking the Trucks: Austin Cindric Uses Dump &#038; Run to Win in Canada"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/Austin-cindric-ctmp-110x75.jpg" width="110" height="75" alt="Tracking the Trucks: Austin Cindric Uses Dump &#038; Run to Win in Canada" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/tracking-trucks-austin-cindric-uses-dump-run-win-canada/" title="Tracking the Trucks: Austin Cindric Uses Dump &#038; Run to Win in Canada">Tracking the Trucks: Austin Cindric Uses Dump &#038; Run to Win in Canada</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/hamlin-darlington-nxs-110x75.jpg" width="110" height="75" alt="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens">Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/4-burning-questions-who-will-channel-their-throwback-legend-at-darlington/" title="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/darlington-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/4-burning-questions-who-will-channel-their-throwback-legend-at-darlington/" title="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?">4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 31, 2017</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/nitro-shots-troy-coughlin-jr-out-richie-crampton-in/" title="Nitro Shots: Troy Coughlin Jr. Out, Richie Crampton In"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/Crampton-660x425.jpg" width="660" height="330" alt="Nitro Shots: Troy Coughlin Jr. Out, Richie Crampton In" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/nitro-shots-troy-coughlin-jr-out-richie-crampton-in/" title="Nitro Shots: Troy Coughlin Jr. Out, Richie Crampton In">Nitro Shots: Troy Coughlin Jr. Out, Richie Crampton In</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/nitro-shots-the-big-event/" title="Nitro Shots: The Big Event"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/NHRA-2017-Brainerd-Alexis-Dejoria-versus-Cruz-Pedregon-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: The Big Event" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/24/nitro-shots-the-big-event/" title="Nitro Shots: The Big Event">Nitro Shots: The Big Event</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 24, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/17/nitro-shots-a-necessary-distraction/" title="Nitro Shots: A Necessary Distraction"><img src="https://www.frontstretch.com/wp-content/uploads/2017/04/NHRA-2017-Las-Vegas-Tommy-Johnson-Jr.-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: A Necessary Distraction" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/17/nitro-shots-a-necessary-distraction/" title="Nitro Shots: A Necessary Distraction">Nitro Shots: A Necessary Distraction</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 17, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/09/nitro-shots-nhra-does-some-things-right-some-things-wrong/" title="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Brittany-Force-car-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/09/nitro-shots-nhra-does-some-things-right-some-things-wrong/" title="Nitro Shots: NHRA Does Some Things Right, Some Things Wrong">Nitro Shots: NHRA Does Some Things Right, Some Things Wrong</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 9, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/06/pace-laps-daniel-suarez-impresses-and-cup-drivers-dominate-xfinity-series-at-the-glen/" title="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/kybspark-110x75.jpg" width="110" height="75" alt="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/06/pace-laps-daniel-suarez-impresses-and-cup-drivers-dominate-xfinity-series-at-the-glen/" title="Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen">Pace Laps: Daniel Suarez Impresses &#038; Cup Drivers Dominate XFINITY Series at The Glen</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 6, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/02/nitro-shots-a-little-like-can-go-a-long-way/" title="Nitro Shots: A Little Like Can Go a Long Way"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/NHRA-2017-Sonoma-J.R.-Todd-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: A Little Like Can Go a Long Way" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/02/nitro-shots-a-little-like-can-go-a-long-way/" title="Nitro Shots: A Little Like Can Go a Long Way">Nitro Shots: A Little Like Can Go a Long Way</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/27/nitro-shots-calling-corporate-america/" title="Nitro Shots: Calling Corporate America"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/024-LeahPritchettPhoenix-110x75.jpg" width="110" height="75" alt="Nitro Shots: Calling Corporate America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/07/27/nitro-shots-calling-corporate-america/" title="Nitro Shots: Calling Corporate America">Nitro Shots: Calling Corporate America</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 27, 2017</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/04/despite-watkins-glen-trouble-josef-newgarden-still-has-points-advantage-but/" title="Despite Watkins Glen Trouble, Josef Newgarden Still Has Points Advantage, But .…"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/JGS_1027-1-660x425.jpg" width="660" height="330" alt="Despite Watkins Glen Trouble, Josef Newgarden Still Has Points Advantage, But .…" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/04/despite-watkins-glen-trouble-josef-newgarden-still-has-points-advantage-but/" title="Despite Watkins Glen Trouble, Josef Newgarden Still Has Points Advantage, But .…">Despite Watkins Glen Trouble, Josef Newgarden Still Has Points Advantage, But .…</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>September 4, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/hamlin-darlington-nxs-110x75.jpg" width="110" height="75" alt="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/pace-laps-denny-hamlin-dominates-darlington-indycar-series-title-battle-tightens/" title="Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens">Pace Laps: Denny Hamlin Dominates Darlington, IndyCar Series Title Battle Tightens</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/kyle-kaiser-clinches-indy-lights-title-and-entry-into-102nd-indy-500/" title="Kyle Kaiser Wins Indy Lights Title, Clinches Entry into 102nd Indy 500"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/kyle-kaiser-e1504463207764-110x75.jpg" width="110" height="75" alt="Kyle Kaiser Wins Indy Lights Title, Clinches Entry into 102nd Indy 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/03/kyle-kaiser-clinches-indy-lights-title-and-entry-into-102nd-indy-500/" title="Kyle Kaiser Wins Indy Lights Title, Clinches Entry into 102nd Indy 500">Kyle Kaiser Wins Indy Lights Title, Clinches Entry into 102nd Indy 500</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 3, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/4-burning-questions-who-will-channel-their-throwback-legend-at-darlington/" title="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/darlington-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/4-burning-questions-who-will-channel-their-throwback-legend-at-darlington/" title="4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?">4 Burning Questions: Who Will Channel Their Throwback Legend at Darlington?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 31, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/this-may-be-only-the-beginning-for-josef-newgarden/" title="This May Be Only The Beginning For Josef Newgarden"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/16C_3762-1-110x75.jpg" width="110" height="75" alt="This May Be Only The Beginning For Josef Newgarden" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/31/this-may-be-only-the-beginning-for-josef-newgarden/" title="This May Be Only The Beginning For Josef Newgarden">This May Be Only The Beginning For Josef Newgarden</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 31, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Road-America-NXS-Jeremy-Clements-woohoo-Brett-Moist-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Unlikely Underdog Overachievers" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/30/the-frontstretch-5-unlikely-underdog-overachievers/" title="The Frontstretch 5: Unlikely Underdog Overachievers">The Frontstretch 5: Unlikely Underdog Overachievers</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 30, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2017-Indianapolis-CUP-Kyle-Busch-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/08/28/5-points-to-ponder-the-sharp-end-of-the-season/" title="5 Points to Ponder: The Sharp End of the 2017 NASCAR Season">5 Points to Ponder: The Sharp End of the 2017 NASCAR Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2017</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://www.frontstretch.com/sports-cars/">Sports Cars</a><ul class="sub-menu menu-sub-content"><li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://www.frontstretch.com/category/imsa/">IMSA</a></li></ul></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.draftkings.com/gateway?s=696638929" title="Draft Kings - Free Fantasy Racing" > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/draft-kings-728x90.png" alt="Draft Kings - Free Fantasy Racing" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?</span></div><article class="post-listing post-144110 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-featured-content category-joseph-wolkin category-nascar-mailbox tag-ty-dillon" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: NASCAR via Getty Images)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">NASCAR Mailbox: What Crucial Element is Still Missing from the At-Track Experience?</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/jwolkin/" title="">Joseph Wolkin </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/joseph-wolkin/" rel="category tag">Joseph Wolkin</a>, <a href="https://www.frontstretch.com/category/nascar-mailbox/" rel="category tag">NASCAR Mailbox</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/#comments">2 Comments</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>Technology is always changing, for better or for worse.</p><p>In auto racing, technological advances have made vehicles not only faster, but more durable. However, the experience at American racetracks is far behind the 21st century.</p><p>What is WiFi? Well, according to some tracks, no one knows what in the world it is, and that&#8217;s a major problem considering it&#8217;s 2017. When a problem erupts, the first thing people do is jump to their smartphones. At this point, it&#8217;s natural instinct.</p><p>But when you&#8217;re at a racetrack in the middle of nowhere USA, cell reception barely exists. Once again, it&#8217;s 2017, folks.</p><p>Track operators need to get on this immediately. NASCAR helped a few tracks modernize their technology quite a bit last year, with the leaders being Daytona International Speedway and Dover International Speedway. But for the rest of the tracks, you need a hope and a prayer when posting a picture or video to social media.</p><p>On the bright side, another NASCAR team has announced it not only extended the contract of its driver, but the sponsor as well. Germain Racing will have <a href="/tag/ty-dillon/">Ty Dillon</a> and GEICO on its No. 13 machine in a new multi-year deal, giving the organization a sign of stability and growth in a time when funding drives success.</p><p><em>Have a question for NASCAR Mailbox? Tweet me at <a href="http://twitter.com/josephnasar">@JosephNASCAR</a> or shoot me an email at Joseph.Wolkin@gmail.com! </em></p><p><strong>Q: Is it time for NASCAR tracks to get WiFi? <em>&#8211; Jason R., Philadelphia</em></strong></p><p><strong>A:</strong> Considering NASCAR&#8217;s push at its youth movement with programs such as NASCAR Next, it&#8217;s shocking that the sport hasn&#8217;t forced tracks to get with the times.</p><p>Fans want to post pictures and videos on social media during race weekends, and after Sprint&#8217;s departure, cell service is clearly lacking. A not-so-easy but needed fix is adding WiFi capability at all 23 tracks. Obviously, it&#8217;s expensive to find a WiFi provider for tens of thousands of people at one given moment, but it is certainly doable.</p><p>Think about it: All of the major sports have WiFi in their facilities. Citi Field in New York even has a special area for fans to charge their phones. Heck, Verizon even brings portable charging stations to IndyCar Series events as part of its activation, and it&#8217;s incredibly useful.</p><p>At this point, it&#8217;s a necessity to have WiFi at the racetrack. Why make fans stress over not being able to send a picture to someone when there are only 24 hours in a day?</p><p>Cisco, a leader in stadium WiFi across America, is one option for tracks. Another is ARRIS, a firm that is already a NASCAR partner and helped provide the technology to power phones through the Daytona 500 weekend.</p><p>With the addition of WiFi, fans won&#8217;t have to worry about the airwaves overflowing on their 3G and 4G networks, enabling them to send content with ease.</p><p>It&#8217;s ironic that a sport known for speed and technology is slowly integrating this enhancement. A handful of tracks have gotten on board with the idea of having WiFi, but it needs to be done on a larger scale and soon.</p><p>Some tracks offer certain areas for WiFi, and while that&#8217;s fine and dandy, it&#8217;s not enough. Why should people wait two hours to upload a photo to Twitter, a key part of NASCAR&#8217;s marketing campaign?</p><p>It&#8217;s 2017. Let&#8217;s get with the times.</p><p><strong>Q: What does Ty Dillon mean for Germain Racing&#8217;s future? <em>&#8211; Casey E., Richmond</em></strong></p><p><strong>A: </strong>For the first time, Germain has a stable driver and more importantly, a long-standing alliance with Richard Childress Racing.</p><blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">We’ve been w/ <a href="https://twitter.com/GEICORacing">@GEICORacing</a> for ten years and we’ll be with them for more to come! <a href="https://twitter.com/tydillon">@tydillon</a> we’re excited to have you as part of it! <a href="https://twitter.com/hashtag/GOTyme?src=hash">#GOTyme</a> <a href="https://t.co/BeP6QS8wqP">pic.twitter.com/BeP6QS8wqP</a></p><p>&mdash; Germain Racing (@GermainRacing) <a href="https://twitter.com/GermainRacing/status/905106019336036353">September 5, 2017</a></p></blockquote><p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>Dillon was as consistent as it gets in his three full XFINITY Series seasons with RCR, with no average finish for a season worse than 10.5. He was never outstanding besides his triumph at Indianapolis Motor Speedway, but his ability behind the wheel in a time when RCR as a whole was re-shaping proved to be worthy of three straight top-five finishes in the standings.</p><p>Now that he&#8217;s at the Cup level, Germain is the perfect fit for him. The grandson of Richard Childress has a chance to do something different from his brother, <a href="/tag/austin-dillon/">Austin Dillon</a>, and that&#8217;s to make a name for himself outside of the family.</p><p>The younger Dillon brother can separate himself, building his own brand with a different team, even though he&#8217;s still getting some support from his family&#8217;s operation. It&#8217;s an important move as he looks to further his career, and it means Childress himself believes in what Germain is doing.</p><p>Germain can now focus on growing its brand with Dillon as the centerpiece, a much more powerful thing to do with a younger, unproven driver.</p><p>Though Dillon is only in the midst of his first Cup season, the potential to improve is there. He&#8217;s on track to earn the team&#8217;s best average finish since it moved from the Truck and XFINITY series in 2009, and consistency is the key.</p><p>When Dillon led 40 laps at Dover, he seemed like an ace, and that&#8217;s even without a bunch of funding. Figure if RCR boosts its alliance with Germain even more than it did entering this year, Dillon has the potential to have runs like Dover week-in and week-out.</p><p>Germain now has the stability to run well for several years to come, and RCR&#8217;s investment in the organization is going to be a key part of its future.</p></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=144110" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=NASCAR+Mailbox%3A+What+Crucial+Element+is+Still+Missing+from+the+At-Track+Experience%3F&url=https://www.frontstretch.com/?p=144110" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=144110&amp;name=NASCAR+Mailbox%3A+What+Crucial+Element+is+Still+Missing+from+the+At-Track+Experience%3F" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=144110&title=NASCAR+Mailbox%3A+What+Crucial+Element+is+Still+Missing+from+the+At-Track+Experience%3F" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=144110&title=NASCAR+Mailbox%3A+What+Crucial+Element+is+Still+Missing+from+the+At-Track+Experience%3F" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=144110&amp;description=NASCAR+Mailbox%3A+What+Crucial+Element+is+Still+Missing+from+the+At-Track+Experience%3F&amp;media=https://www.frontstretch.com/wp-content/uploads/2017/09/brad-keselowski-phone-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">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</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/ty-dillon/" rel="tag">Ty Dillon</a></p><section id="author-box"><div class="block-head"><h3>About Joseph Wolkin</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://secure.gravatar.com/avatar/e2060b88d44f0777870dbc5f6dd20121?s=90&#038;d=mm&#038;r=g" width="90" height="90" alt="" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 photo avatar-default" /></div><div class="author-description"> Joseph started with Fronstretch in Aug. 2014 and worked his way up to become an editor in less than a year. A native of Whitestone, New York, Joseph writes for NASCAR Pole Position magazine as a weekly contributor, along with being a former intern at Newsday and the Times Beacon Record Newspapers, each on Long Island. With a focus on NASCAR, he runs our social media pages and writes the NASCAR Mailbox column, along with other features for the site.</div><div class="author-social flat-social"> <a class="social-site" target="_blank" href="http://bookstore.archwaypublishing.com/Products/SKU-000953886/Grandma.aspx"><i class="fa fa-home"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2017/09/06/the-frontstretch-5-things-that-dont-sit-right/" rel="prev"><span>Previous</span> The Frontstretch 5: Things That Don&#8217;t Sit Right</a></div><div class="post-next"><a href="https://www.frontstretch.com/2017/09/06/did-you-notice-the-fine-line-of-nascar-drivers-personal-lives-where-it-all-went-wrong/" rel="next"><span>Next</span> Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/09/06/did-you-notice-the-fine-line-of-nascar-drivers-personal-lives-where-it-all-went-wrong/"> <img width="272" height="125" src="https://www.frontstretch.com/wp-content/uploads/2014/10/Jeremy-Mayfield-Credit-LAT-PHOTOGRAPHIC-272x125.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/09/06/did-you-notice-the-fine-line-of-nascar-drivers-personal-lives-where-it-all-went-wrong/" rel="bookmark">Did You Notice?: The Fine Line Of NASCAR Drivers&#8217; Personal Lives &#038; Where It All Went Wrong</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/09/06/the-frontstretch-5-things-that-dont-sit-right/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Michigan-II-CUP-Daniel-Suarez-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/09/06/the-frontstretch-5-things-that-dont-sit-right/" rel="bookmark">The Frontstretch 5: Things That Don&#8217;t Sit Right</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/09/3d57ee60417e630de83dda9fef8ca983-11-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/09/06/beyond-the-cockpit-carl-long-balancing-risk-reward-in-nascar-ownership/" rel="bookmark">Beyond the Cockpit: Carl Long Balancing Risk &#038; Reward in NASCAR Ownership</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>September 6, 2017</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/09/06/the-10-nascar-cup-series-power-rankings-after-darlington/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/09/Darlington-Cup-2017-Denny-Hamlin-Yvonne-Leonard-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2017/09/06/the-10-nascar-cup-series-power-rankings-after-darlington/" rel="bookmark">The 10: NASCAR Cup Series Power Rankings After Darlington</a></h2><p>The stars of the Monster Energy NASCAR Cup Series were kicking it old school this &hellip;</p></div></section><div id="comments"><div id="comments-box"><div class="block-head"><h3 id="comments-title">2 comments</h3><div class="stripe-line"></div></div><div class="post-listing"><ol class="commentlist"><li id="comment-29842"><div  class="comment even thread-even depth-1 comment-wrap" ><div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/8604c9df95d687d0c1a0f0d88d9daada?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div><div class="comment-content"><div class="author-comment"> <cite class="fn">salb</cite><div class="comment-meta commentmetadata"><a href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/#comment-29842"> September 6, 2017 at 12:32 pm</a></div><div class="clear"></div></div><p>WiFi at the track.  You will have a few fans in the stands, glued to their phones, no eyes on the track.  Wonderful.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/?replytocom=29842#respond' onclick='return addComment.moveForm( "comment-29842", "29842", "respond", "144110" )' aria-label='Reply to salb'>Reply</a></div></div></li><li id="comment-29830"><div  class="comment odd alt thread-odd thread-alt depth-1 comment-wrap" ><div class="comment-avatar"><img src="https://secure.gravatar.com/avatar/d443769a71f138a11e46c588805b4703?s=65&#038;d=mm&#038;r=g" width="65" height="65" alt="" class="avatar avatar-65wp-user-avatar wp-user-avatar-65 alignnone photo avatar-default" /></div><div class="comment-content"><div class="author-comment"> <cite class="fn">Glen H.</cite><div class="comment-meta commentmetadata"><a href="https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/#comment-29830"> September 6, 2017 at 10:35 am</a></div><div class="clear"></div></div><p>NA$CAR known for technology?  That&#8217;s a good one.</p><p>They using push rod V8s with throttle body fuel injection, technology that was abandoned by most auto manufactures last century.  They use a chassis design that hasn&#8217;t changed since the much since the 70s with a rear suspension based on something found in old pickup trucks.</p><p>NA$CAR might have some technology but it sure isn&#8217;t in the cars.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.frontstretch.com/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/?replytocom=29830#respond' onclick='return addComment.moveForm( "comment-29830", "29830", "respond", "144110" )' aria-label='Reply to Glen H.'>Reply</a></div></div></li></ol></div></div><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/09/06/nascar-mailbox-what-crucial-element-is-still-missing-from-the-at-track-experience/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='144110' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c400f94350" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="23"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1931074544731095"
data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a><br /><br /><a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="text-34" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a> <br> <A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/FV-2017-Banner-Ad.jpg" alt="" /> </a></div></div><div id="text-5" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2017, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://www.frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_374d59183f846257b14c86b49fcfee31.js"></script></body></html>