<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_4403879c53ce5546a5804e966bc2a4db.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c8ede1184c0ba74d10d7f190bacfec01.css" rel="stylesheet" /><title>2017 Frontstretch Cup: First Data 500 Predictions</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="2017 Frontstretch Cup: First Data 500 Predictions - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="Welcome to our 10th year of staff predictions! Each week, our experts attempt to tell you who the wi"/><meta property="og:url" content="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger-660x330.jpg" /><meta name="description" content="Welcome to our 10th year of staff predictions! Each week, our experts attempt to tell you who the winner of each Cup race will be. Take a look to see who y"/><link rel="canonical" href="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="2017 Frontstretch Cup: First Data 500 Predictions" /><meta property="og:description" content="Welcome to our 10th year of staff predictions! Each week, our experts attempt to tell you who the winner of each Cup race will be. Take a look to see who y" /><meta property="og:url" content="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Frontstretch" /><meta property="article:section" content="2017 Staff Predictions" /><meta property="article:published_time" content="2017-10-28T20:42:54-04:00" /><meta property="article:modified_time" content="2017-10-29T05:17:43-04:00" /><meta property="og:updated_time" content="2017-10-29T05:17:43-04:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger.jpg" /><meta property="og:image:width" content="899" /><meta property="og:image:height" content="668" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Welcome to our 10th year of staff predictions! Each week, our experts attempt to tell you who the winner of each Cup race will be. Take a look to see who y" /><meta name="twitter:title" content="2017 Frontstretch Cup: First Data 500 Predictions" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger.jpg" /><meta name="twitter:creator" content="@Frontstretch" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.frontstretch.com\/","name":"Frontstretch","alternateName":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.frontstretch.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.frontstretch.com\/2017\/10\/28\/2017-frontstretch-cup-first-data-500-predictions\/","sameAs":["https:\/\/www.facebook.com\/Frontstretch","https:\/\/instagram.com\/frontstretchdotcom\/","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/twitter.com\/Frontstretch"],"@id":"#organization","name":"Frontstretch","logo":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/04\/favicon-196x196.png"}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; 2017 Frontstretch Cup: First Data 500 Predictions Comments Feed" href="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/feed/" />  <script type="text/javascript" data-cfasync="false">var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.8.2" /><meta name="generator" content="Seriously Simple Podcasting 1.18.1" /><link rel='shortlink' href='https://www.frontstretch.com/?p=147827' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F10%2F28%2F2017-frontstretch-cup-first-data-500-predictions%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F10%2F28%2F2017-frontstretch-cup-first-data-500-predictions%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.5.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="text/javascript">var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-147827 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="search-mobile"><form method="get" id="searchform-mobile" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-136612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136612"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast-powered-by-draftkings/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="search-block"><form method="get" id="searchform-header" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div></div></div><div class="header-content"><a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo" style=" margin-top:15px; margin-bottom:15px;"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/" title="2017 Frontstretch Cup: First Data 500 Predictions"><img src="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger-660x330.jpg" width="660" height="330" alt="2017 Frontstretch Cup: First Data 500 Predictions" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/" title="2017 Frontstretch Cup: First Data 500 Predictions">2017 Frontstretch Cup: First Data 500 Predictions</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/denny-hamlin-leads-opening-cup-practice-from-martinsville/" title="Denny Hamlin Leads Opening Cup Practice from Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-CUP-Denny-Hamlin-Barry-Cantrell-NKP-110x75.jpg" width="110" height="75" alt="Denny Hamlin Leads Opening Cup Practice from Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/denny-hamlin-leads-opening-cup-practice-from-martinsville/" title="Denny Hamlin Leads Opening Cup Practice from Martinsville">Denny Hamlin Leads Opening Cup Practice from Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/hermie-sadler-back-at-home-with-cup-start-at-martinsville/" title="Hermie Sadler Back at Home with Cup Start at Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/eb3d19afd57413536109a962be961a39-11-110x75.jpg" width="110" height="75" alt="Hermie Sadler Back at Home with Cup Start at Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/hermie-sadler-back-at-home-with-cup-start-at-martinsville/" title="Hermie Sadler Back at Home with Cup Start at Martinsville">Hermie Sadler Back at Home with Cup Start at Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/tech-talk-ambient-temperatures-drive-off-plenty-of-tire-talk-with-justin-alexander/" title="Tech Talk: Ambient Temperatures, Drive Off &#038; Plenty of Tire Talk with Justin Alexander"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/Justin-Alexander-Cup-2017-Charlotte-Mike-Neff-110x75.jpg" width="110" height="75" alt="Tech Talk: Ambient Temperatures, Drive Off &#038; Plenty of Tire Talk with Justin Alexander" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/tech-talk-ambient-temperatures-drive-off-plenty-of-tire-talk-with-justin-alexander/" title="Tech Talk: Ambient Temperatures, Drive Off &#038; Plenty of Tire Talk with Justin Alexander">Tech Talk: Ambient Temperatures, Drive Off &#038; Plenty of Tire Talk with Justin Alexander</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/4-burning-questions-will-martin-truex-jr-grab-first-short-track-win-in-martinsville/" title="4 Burning Questions: Will Martin Truex Jr. Grab First Short Track Win in Martinsville?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/74126709f67ee020ce140c13accd168d-11-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Will Martin Truex Jr. Grab First Short Track Win in Martinsville?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/4-burning-questions-will-martin-truex-jr-grab-first-short-track-win-in-martinsville/" title="4 Burning Questions: Will Martin Truex Jr. Grab First Short Track Win in Martinsville?">4 Burning Questions: Will Martin Truex Jr. Grab First Short Track Win in Martinsville?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/nascar-101-hows-nascars-drive-for-diversity-program-done-so-far/" title="NASCAR 101: How&#8217;s NASCAR&#8217;s Drive for Diversity Program Done So Far?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/84f41d510de97aa029c72e409240c45b-11-110x75.jpg" width="110" height="75" alt="NASCAR 101: How&#8217;s NASCAR&#8217;s Drive for Diversity Program Done So Far?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/nascar-101-hows-nascars-drive-for-diversity-program-done-so-far/" title="NASCAR 101: How&#8217;s NASCAR&#8217;s Drive for Diversity Program Done So Far?">NASCAR 101: How&#8217;s NASCAR&#8217;s Drive for Diversity Program Done So Far?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 27, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/friday-faceoff-did-nascar-go-too-far-with-penalties/" title="Friday Faceoff: Did NASCAR Go Too Far with Penalties?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/293b8120e721ea44df41c2ba84e8db97-11-110x75.jpg" width="110" height="75" alt="Friday Faceoff: Did NASCAR Go Too Far with Penalties?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/27/friday-faceoff-did-nascar-go-too-far-with-penalties/" title="Friday Faceoff: Did NASCAR Go Too Far with Penalties?">Friday Faceoff: Did NASCAR Go Too Far with Penalties?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 27, 2017</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/26/2017-frontstretch-podcast-powered-by-draftkings-episode-33-clockin-out/" title="2017 Frontstretch Podcast Powered by DraftKings – Episode 33: Clockin&#8217; Out"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/d97c28cb09acc0432b66c7fe0e1fb7f2-11-640x425.jpg" width="660" height="330" alt="2017 Frontstretch Podcast Powered by DraftKings – Episode 33: Clockin&#8217; Out" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/26/2017-frontstretch-podcast-powered-by-draftkings-episode-33-clockin-out/" title="2017 Frontstretch Podcast Powered by DraftKings – Episode 33: Clockin&#8217; Out">2017 Frontstretch Podcast Powered by DraftKings – Episode 33: Clockin&#8217; Out</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 26, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/eyes-on-xfinity-christopher-bells-kansas-victory-showcases-why-hes-moving-up-next-year/" title="Eyes on XFINITY: Christopher Bell&#8217;s Kansas Victory Showcases Why He&#8217;s Moving Up Next Year"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-NXS-Christopher-Bell-woohoo-John-K-Harrelson-NKP-110x75.jpg" width="110" height="75" alt="Eyes on XFINITY: Christopher Bell&#8217;s Kansas Victory Showcases Why He&#8217;s Moving Up Next Year" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/eyes-on-xfinity-christopher-bells-kansas-victory-showcases-why-hes-moving-up-next-year/" title="Eyes on XFINITY: Christopher Bell&#8217;s Kansas Victory Showcases Why He&#8217;s Moving Up Next Year">Eyes on XFINITY: Christopher Bell&#8217;s Kansas Victory Showcases Why He&#8217;s Moving Up Next Year</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 25, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/2-headed-monster-was-christopher-bells-move-the-right-one-to-make/" title="2-Headed Monster: Was Christopher Bell&#8217;s Move the Right One to Make?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-NXS-Erik-Jones-Christopher-Bell-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Was Christopher Bell&#8217;s Move the Right One to Make?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/2-headed-monster-was-christopher-bells-move-the-right-one-to-make/" title="2-Headed Monster: Was Christopher Bell&#8217;s Move the Right One to Make?">2-Headed Monster: Was Christopher Bell&#8217;s Move the Right One to Make?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 25, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/23/couch-potato-tuesday-nbc-goes-all-or-nothing-on-nascar-playoffs-at-kansas/" title="Couch Potato Tuesday: NBC Goes All or Nothing on NASCAR Playoffs at Kansas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-NXS-pack-racing-Matthew-T-Thacker-NKP-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: NBC Goes All or Nothing on NASCAR Playoffs at Kansas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/23/couch-potato-tuesday-nbc-goes-all-or-nothing-on-nascar-playoffs-at-kansas/" title="Couch Potato Tuesday: NBC Goes All or Nothing on NASCAR Playoffs at Kansas">Couch Potato Tuesday: NBC Goes All or Nothing on NASCAR Playoffs at Kansas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 23, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/pace-laps-ryan-blaney-beats-3-cup-champions-to-advance-christopher-bell-sparks-controversy/" title="Pace Laps: Ryan Blaney Beats 3 Cup Champions to Advance &#038; Christopher Bell Sparks Controversy"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/Christopher-Bell-Kansas-Victory-XFINITY-110x75.jpg" width="110" height="75" alt="Pace Laps: Ryan Blaney Beats 3 Cup Champions to Advance &#038; Christopher Bell Sparks Controversy" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/pace-laps-ryan-blaney-beats-3-cup-champions-to-advance-christopher-bell-sparks-controversy/" title="Pace Laps: Ryan Blaney Beats 3 Cup Champions to Advance &#038; Christopher Bell Sparks Controversy">Pace Laps: Ryan Blaney Beats 3 Cup Champions to Advance &#038; Christopher Bell Sparks Controversy</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 22, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/xfinity-breakdown-joe-gibbs-racing-teammates-collide-late-christopher-bell-wins-at-kansas/" title="XFINITY Breakdown: Joe Gibbs Racing Teammates Collide Late, Christopher Bell Wins at Kansas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/Christopher-Bell-Kansas-Victory-XFINITY-110x75.jpg" width="110" height="75" alt="XFINITY Breakdown: Joe Gibbs Racing Teammates Collide Late, Christopher Bell Wins at Kansas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/xfinity-breakdown-joe-gibbs-racing-teammates-collide-late-christopher-bell-wins-at-kansas/" title="XFINITY Breakdown: Joe Gibbs Racing Teammates Collide Late, Christopher Bell Wins at Kansas">XFINITY Breakdown: Joe Gibbs Racing Teammates Collide Late, Christopher Bell Wins at Kansas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 22, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/erik-jones-suffers-stinging-defeat-in-xfinity-race-at-kansas-speedway/" title="Erik Jones Suffers Stinging Defeat in XFINITY Race at Kansas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/2017-Talladega-I-NXS-Erik-Jones-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="Erik Jones Suffers Stinging Defeat in XFINITY Race at Kansas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/22/erik-jones-suffers-stinging-defeat-in-xfinity-race-at-kansas-speedway/" title="Erik Jones Suffers Stinging Defeat in XFINITY Race at Kansas">Erik Jones Suffers Stinging Defeat in XFINITY Race at Kansas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 22, 2017</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://www.frontstretch.com/cwts-schedule/"><i class="fa fa-arrow-right"></i>2017 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/news/truck-series-news/"><i class="fa fa-arrow-right"></i>News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/"><i class="fa fa-arrow-right"></i>Commentary</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/"><i class="fa fa-arrow-right"></i>Race Report</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/tracking-the-trucks-noah-gragson-scores-1st-career-victory-at-martinsville/" title="Tracking the Trucks: Noah Gragson Scores 1st Career Victory at Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-CWTS-Martinsville-Noah-Gragson-Matt-Crafton-Kyle-Busch-Grandfather-Clock-NASCAR-via-Getty-Images-660x425.jpg" width="660" height="330" alt="Tracking the Trucks: Noah Gragson Scores 1st Career Victory at Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/tracking-the-trucks-noah-gragson-scores-1st-career-victory-at-martinsville/" title="Tracking the Trucks: Noah Gragson Scores 1st Career Victory at Martinsville">Tracking the Trucks: Noah Gragson Scores 1st Career Victory at Martinsville</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 29, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/the-big-6-questions-answered-after-the-2017-texas-roadhouse-200/" title="The Big 6: Questions Answered After the 2017 Texas Roadhouse 200"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Atlanta-CWTS-Noah-Gragson-truck-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Big 6: Questions Answered After the 2017 Texas Roadhouse 200" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/the-big-6-questions-answered-after-the-2017-texas-roadhouse-200/" title="The Big 6: Questions Answered After the 2017 Texas Roadhouse 200">The Big 6: Questions Answered After the 2017 Texas Roadhouse 200</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 29, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/john-hunter-nemecheks-title-hopes-take-a-crash-early-at-martinsville/" title="John Hunter Nemechek&#8217;s Title Hopes Take a Crash Early at Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/jhnjhn-110x75.jpg" width="110" height="75" alt="John Hunter Nemechek&#8217;s Title Hopes Take a Crash Early at Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/john-hunter-nemecheks-title-hopes-take-a-crash-early-at-martinsville/" title="John Hunter Nemechek&#8217;s Title Hopes Take a Crash Early at Martinsville">John Hunter Nemechek&#8217;s Title Hopes Take a Crash Early at Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/dirt-racer-jeffrey-abbey-tackling-asphalt-at-martinsville/" title="Dirt Racer Jeffrey Abbey Tackling Asphalt at Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/4aa720819007ed2d7b17c60949cf600e-11-110x75.jpg" width="110" height="75" alt="Dirt Racer Jeffrey Abbey Tackling Asphalt at Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/28/dirt-racer-jeffrey-abbey-tackling-asphalt-at-martinsville/" title="Dirt Racer Jeffrey Abbey Tackling Asphalt at Martinsville">Dirt Racer Jeffrey Abbey Tackling Asphalt at Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/nitro-shots-viva-pro-mod-in-las-vegas/" title="Nitro Shots: Viva Pro Mod in Las Vegas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/NHRA-2017-Gainesville-Troy-Coughlin-Pro-Mod-courtesy-Geiger-Media-660x425.jpg" width="660" height="330" alt="Nitro Shots: Viva Pro Mod in Las Vegas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/nitro-shots-viva-pro-mod-in-las-vegas/" title="Nitro Shots: Viva Pro Mod in Las Vegas">Nitro Shots: Viva Pro Mod in Las Vegas</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 25, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/19/nitro-shots-to-backup-or-not-to-backup/" title="Nitro Shots: To Backup or Not to Backup"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Chicago-Steve-Torrence-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: To Backup or Not to Backup" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/19/nitro-shots-to-backup-or-not-to-backup/" title="Nitro Shots: To Backup or Not to Backup">Nitro Shots: To Backup or Not to Backup</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 19, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/12/nitro-shots-purposely-short-fields-family-life/" title="Nitro Shots: Purposely Short Fields &#038; Family Life"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/NHRA-2017-Norwalk-Bo-Butner-car-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: Purposely Short Fields &#038; Family Life" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/12/nitro-shots-purposely-short-fields-family-life/" title="Nitro Shots: Purposely Short Fields &#038; Family Life">Nitro Shots: Purposely Short Fields &#038; Family Life</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 12, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/05/nitro-shots-and-now-for-the-news/" title="Nitro Shots: And Now for the News"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/1642-11110-110x75.jpg" width="110" height="75" alt="Nitro Shots: And Now for the News" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/05/nitro-shots-and-now-for-the-news/" title="Nitro Shots: And Now for the News">Nitro Shots: And Now for the News</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/01/pace-laps-a-flurry-of-nascar-playoff-activity/" title="Pace Laps: A Flurry of NASCAR Playoff Activity"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/blaney-dover-110x75.jpg" width="110" height="75" alt="Pace Laps: A Flurry of NASCAR Playoff Activity" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/01/pace-laps-a-flurry-of-nascar-playoff-activity/" title="Pace Laps: A Flurry of NASCAR Playoff Activity">Pace Laps: A Flurry of NASCAR Playoff Activity</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 1, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/28/nitro-shots-spending-a-day-as-a-fan/" title="Nitro Shots: Spending a Day as a Fan"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Brittany-Force-car-courtesy-NHRA-110x75.jpg" width="110" height="75" alt="Nitro Shots: Spending a Day as a Fan" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/28/nitro-shots-spending-a-day-as-a-fan/" title="Nitro Shots: Spending a Day as a Fan">Nitro Shots: Spending a Day as a Fan</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 28, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/25/pace-laps-nascar-playoff-stress-tyler-reddicks-triumph-timothy-peters-impressive-return/" title="Pace Laps: NASCAR Playoff Stress, Tyler Reddick&#8217;s Triumph &#038; Timothy Peters&#8217; Impressive Return"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Chicago-NXS-Justin-Allgaier-celebrates-Logan-Whitton-NKP-110x75.jpg" width="110" height="75" alt="Pace Laps: NASCAR Playoff Stress, Tyler Reddick&#8217;s Triumph &#038; Timothy Peters&#8217; Impressive Return" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/25/pace-laps-nascar-playoff-stress-tyler-reddicks-triumph-timothy-peters-impressive-return/" title="Pace Laps: NASCAR Playoff Stress, Tyler Reddick&#8217;s Triumph &#038; Timothy Peters&#8217; Impressive Return">Pace Laps: NASCAR Playoff Stress, Tyler Reddick&#8217;s Triumph &#038; Timothy Peters&#8217; Impressive Return</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 25, 2017</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/20/verizon-departing-as-indycar-entitlement-sponsor-after-2018/" title="Verizon Departing as IndyCar Entitlement Sponsor After 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/verizon-660x425.jpg" width="660" height="330" alt="Verizon Departing as IndyCar Entitlement Sponsor After 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/20/verizon-departing-as-indycar-entitlement-sponsor-after-2018/" title="Verizon Departing as IndyCar Entitlement Sponsor After 2018">Verizon Departing as IndyCar Entitlement Sponsor After 2018</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 20, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/07/whos-where-a-2018-verizon-indycar-series-team-chart/" title="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/kana-110x75.jpg" width="110" height="75" alt="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/07/whos-where-a-2018-verizon-indycar-series-team-chart/" title="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart">Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 7, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/happiness-is-the-drivers-edition/" title="Happiness Is: The Drivers Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/gordon-1-110x75.jpg" width="110" height="75" alt="Happiness Is: The Drivers Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/happiness-is-the-drivers-edition/" title="Happiness Is: The Drivers Edition">Happiness Is: The Drivers Edition</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/rahals-team-grows-while-ganassis-shrinks-for-2018/" title="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/04CJ1848A-110x75.jpg" width="110" height="75" alt="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/rahals-team-grows-while-ganassis-shrinks-for-2018/" title="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018">Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/18/simon-pagenaud-wins-indycar-at-sonoma-josef-newgarden-takes-series-championship/" title="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship"><img src="https://www.frontstretch.com/wp-content/uploads/2017/04/2017-Long-Beach-IndyCar-Simon-Pagenaud-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/18/simon-pagenaud-wins-indycar-at-sonoma-josef-newgarden-takes-series-championship/" title="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship">Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 18, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/17/pace-laps-championship-favorites-reign-at-chicago-josef-newgarden-wins-indycar-title/" title="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/281e4b089bc15482eb1fb53b2b8ec951-11-110x75.jpg" width="110" height="75" alt="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/17/pace-laps-championship-favorites-reign-at-chicago-josef-newgarden-wins-indycar-title/" title="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title">Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 17, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/13/zach-veach-spencer-pigot-secure-full-time-rides-for-2018/" title="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/veah2-110x75.jpg" width="110" height="75" alt="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/13/zach-veach-spencer-pigot-secure-full-time-rides-for-2018/" title="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018">Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 13, 2017</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://www.frontstretch.com/sports-cars/">Sports Cars</a><ul class="sub-menu menu-sub-content"><li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://www.frontstretch.com/category/imsa/">IMSA</a></li></ul></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.draftkings.com/gateway?s=696638929" title="Draft Kings - Free Fantasy Racing" > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/draft-kings-728x90.png" alt="Draft Kings - Free Fantasy Racing" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/2017-staff-predictions/">2017 Staff Predictions</a></span> <span class="delimiter">/</span> <span class="current">2017 Frontstretch Cup: First Data 500 Predictions</span></div><article class="post-listing post-147827 post type-post status-publish format-standard has-post-thumbnail  category-2017-staff-predictions category-cup-series category-featured-content" id="the-post"><div class="single-post-thumb"> <img width="660" height="330" src="https://www.frontstretch.com/wp-content/uploads/2016/10/dinger-660x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Zach Catanzareti)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">2017 Frontstretch Cup: First Data 500 Predictions</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/staff/" title="">Frontstretch Staff </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/2017-staff-predictions/" rel="category tag">2017 Staff Predictions</a>, <a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>Welcome to our 10th year of staff predictions! Each week, our experts attempt to tell you who the winner of each Cup race will be. Take a look to see who your favorite writers think will win it all (or at least score some points) this week!<br /> Think you can out-prognosticate our staff?  Leave your picks in the comments and see how they stack up!</p><p><strong>How we roll:</strong></p><p>Each writer picks the drivers they think will win the first two stages and the overall race.  We can’t pick the same driver two weeks in a row or more than four times in a season. The first two stages pay one bonus point, with three bonus points if someone can get all three winners correct.  Overall race points remain the same:</p><p><strong>Prediction Scoring</strong><br /> +5 – Win<br /> +3 – 2<sup>nd</sup>-5<sup>th</sup><br /> +1 – 6<sup>th</sup>-10th<br /> 0 – 11th-20th<br /> -1 – 21st-30th<br /> -2 – 31st-36th<br /> -3 – 37<sup>th</sup>-40<sup>th</sup></p><p><strong>This week&#8217;s predictions: First Data 500</strong></p><table width="99%"><tbody><tr><td width="25%"><strong>Writer</strong></td><td width="25%"><strong>Stage 1</strong></td><td width="25%"><strong>Stage 2</strong></td><td width="25%"><strong>Race Winner</strong></td></tr><tr><td width="25%"><span style="color: #00ccff;"><strong>Amy Henderson</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Denny Hamlin</td><td width="25%">Jimmie Johnson</td></tr><tr><td width="25%"><span style="color: #ff9900;"><strong>Corey Brewer</strong></span></td><td width="25%">Martin Truex Jr.</td><td width="25%">Martin Truex Jr.</td><td width="25%">Denny Hamlin</td></tr><tr><td width="25%"><span style="color: #808000;"><strong>Mark Howell</strong></span></td><td width="25%">Kyle Larson</td><td width="25%">Dale Earnhardt Jr.</td><td width="25%">Dale Earnhardt Jr.</td></tr><tr><td width="25%"><span style="color: #99ccff;"><strong>Dustin Albino</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Brad Keselowski</td><td width="25%">Jimmie Johnson</td></tr><tr><td width="25%"><span style="color: #999999;"><strong>Dan Greene</strong></span></td><td width="25%">Chase Elliott</td><td width="25%">Kyle Larson</td><td width="25%">Denny Hamlin</td></tr><tr><td width="25%"><span style="color: #ffcc99;"><strong>Davey Segal</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Kyle Larson</td><td width="25%">Kyle Larson</td></tr><tr><td width="25%"><span style="color: #993366;"><strong>Bryan Gable</strong></span></td><td width="25%">Denny Hamlin</td><td width="25%">Kyle Busch</td><td width="25%">Jimmie Johnson</td></tr><tr><td width="25%"><span style="color: #cc99ff;"><strong>Michael Massie</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Denny Hamlin</td><td width="25%">Chase Elliott</td></tr><tr><td width="25%"><span style="color: #008080;"><strong>Christian Koelle</strong></span></td><td width="25%">Martin Truex Jr.</td><td width="25%">Brad Keselowski</td><td width="25%">Brad Keselowski</td></tr><tr><td width="25%"><span style="color: #339966;"><strong>Jeff Wolfe</strong></span></td><td width="25%">Kyle Larson</td><td width="25%">Chase Elliott</td><td width="25%">Jimmie Johnson</td></tr><tr><td width="25%"><span style="color: #333300;"><strong>Frank Velat</strong></span></td><td width="25%">Brad Keselowski</td><td width="25%">Kyle Busch</td><td width="25%">Chase Elliott</td></tr><tr><td width="25%"><span style="color: #003300;"><strong>Clayton Caldwell</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Martin Truex Jr.</td><td width="25%">Jimmie Johnson</td></tr><tr><td width="25%"><span style="color: #008000;"><strong>Huston Ladner</strong></span></td><td width="25%">Kyle Busch</td><td width="25%">Matt Kenseth</td><td width="25%">Jimmie Johnson</td></tr></tbody></table><p><strong>Results: Hollywood Casino 400</strong></p><table style="height: 1287px;" width="901"><tbody><tr><td width="74"><strong>Writer</strong></td><td width="72"><strong>Stage 1</strong></td><td width="74"><strong>Stage 2</strong></td><td width="86"><strong>Race Winner</strong></td><td width="81"><strong>Winner Pick Finish</strong></td><td width="63"><strong>Total Points</strong></td></tr><tr><td width="74"><span style="color: #00ccff;"><strong>Amy Henderson</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Kyle Larson</td><td width="86"><strong>Martin Truex Jr.</strong></td><td width="81"><strong>1<sup>st</sup></strong></td><td width="63"><strong>5</strong></td></tr><tr><td width="74"><span style="color: #ff9900;"><strong>Corey Brewer</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Martin Truex Jr.</td><td width="86"><strong>Martin Truex Jr.</strong></td><td width="81"><strong>1<sup>st</sup></strong></td><td width="63"><strong>5</strong></td></tr><tr><td width="74"><span style="color: #808000;"><strong>Mark Howell</strong></span></td><td width="72">Kevin Harvick</td><td width="74">Ryan Blaney</td><td width="86">Jimmie Johnson</td><td width="81">11<sup>th</sup></td><td width="63">0</td></tr><tr><td width="74"><span style="color: #99ccff;"><strong>Dustin Albino</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Kevin Harvick</td><td width="86"><strong>Martin Truex Jr.</strong></td><td width="81"><strong>1<sup>st</sup></strong></td><td width="63"><strong>5</strong></td></tr><tr><td width="74"><span style="color: #999999;"><strong>Dan Greene</strong></span></td><td width="72">Kevin Harvick</td><td width="74">Ryan Blaney</td><td width="86">Ryan Blaney</td><td width="81">3rd</td><td width="63">3</td></tr><tr><td width="74"><span style="color: #ffcc99;"><strong>Davey Segal</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Kyle Busch</td><td width="86">Kyle Busch</td><td width="81">10<sup>th</sup></td><td width="63">1</td></tr><tr><td width="74"><span style="color: #993366;"><strong>Bryan Gable</strong></span></td><td width="72">Kevin Harvick</td><td width="74">Martin Truex Jr.</td><td width="86"><strong>Martin Truex Jr.</strong></td><td width="81"><strong>1<sup>st</sup></strong></td><td width="63"><strong>5</strong></td></tr><tr><td width="74"><span style="color: #cc99ff;"><strong>Michael Massie</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Kyle Busch</td><td width="86"><strong>Martin Truex Jr.</strong></td><td width="81"><strong>1<sup>st</sup></strong></td><td width="63"><strong>5</strong></td></tr><tr><td width="74"><span style="color: #008080;"><strong>Christian Koelle</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Martin Truex Jr.</td><td width="86">Kyle Larson</td><td width="81">39<sup>th</sup></td><td width="63">-3</td></tr><tr><td width="74"><span style="color: #339966;"><strong>Jeff Wolfe</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Ryan Blaney</td><td width="86">Kyle Busch</td><td width="81">10<sup>th</sup></td><td width="63">1</td></tr><tr><td width="74"><span style="color: #333300;"><strong>Frank Velat</strong></span></td><td width="72">Martin Truex Jr.</td><td width="74">Martin Truex Jr.</td><td width="86">Ryan Blaney</td><td width="81">3<sup>rd</sup></td><td width="63">3</td></tr></tbody></table><p><strong>Standings</strong></p><table style="height: 1974px;" width="917"><tbody><tr><td width="108"> <strong>Writer</strong></td><td width="59"><strong>Points</strong></td><td width="63"><strong>Behind</strong></td><td width="58"><strong>Starts</strong></td><td width="59"><strong>Wins</strong></td><td width="54"><strong>Top 5</strong></td><td width="67"><strong>Top 10</strong></td></tr><tr><td width="108"><span style="color: #ff9900;"><strong>Corey Brewer</strong></span></td><td width="59"><strong>70</strong></td><td width="63">&#8212;</td><td width="58"><strong>32</strong></td><td width="59">5</td><td width="54">14</td><td width="67">21</td></tr><tr><td width="108"><span style="color: #00ccff;"><strong>Amy Henderson</strong></span></td><td width="59">68</td><td width="63">-2</td><td width="58"><strong>32</strong></td><td width="59">5</td><td width="54"><strong>16</strong></td><td width="67"><strong>23</strong></td></tr><tr><td width="108"><span style="color: #ffcc99;"><strong>Davey Segal</strong></span></td><td width="59">64</td><td width="63">-6</td><td width="58"><strong>32</strong></td><td width="59"><strong>7</strong></td><td width="54">14</td><td width="67">21</td></tr><tr><td width="108"><span style="color: #993366;"><strong>Bryan Gable</strong></span></td><td width="59">57</td><td width="63">-13</td><td width="58">29</td><td width="59">6</td><td width="54">11</td><td width="67">19</td></tr><tr><td width="108"><span style="color: #99ccff;"><strong>Dustin Albino</strong></span></td><td width="59">56</td><td width="63">-14</td><td width="58"><strong>32</strong></td><td width="59">4</td><td width="54">15</td><td width="67">19</td></tr><tr><td width="108"><span style="color: #cc99ff;"><strong>Michael Massie</strong></span></td><td width="59">52</td><td width="63">-18</td><td width="58">30</td><td width="59">6</td><td width="54">10</td><td width="67">15</td></tr><tr><td width="108"><span style="color: #808000;"><strong>Mark Howell</strong></span></td><td width="59">48</td><td width="63">-22</td><td width="58"><strong>32</strong></td><td width="59">0</td><td width="54">13</td><td width="67">20</td></tr><tr><td width="108"><span style="color: #999999;"><strong>Dan Greene</strong></span></td><td width="59">47</td><td width="63">-23</td><td width="58">26</td><td width="59">2</td><td width="54">13</td><td width="67">17</td></tr><tr><td width="108"><span style="color: #003300;"><strong>Clayton Caldwell</strong></span></td><td width="59">46</td><td width="63">-24</td><td width="58">31</td><td width="59">2</td><td width="54">11</td><td width="67">17</td></tr><tr><td width="108"><span style="color: #008000;"><strong>Huston Ladner</strong></span></td><td width="59">41</td><td width="63">-29</td><td width="58">28</td><td width="59">2</td><td width="54">10</td><td width="67">12</td></tr><tr><td width="108"><span style="color: #339966;"><strong>Jeff Wolfe</strong></span></td><td width="59">40</td><td width="63">-30</td><td width="58">29</td><td width="59">4</td><td width="54">9</td><td width="67">15</td></tr><tr><td width="108"><span style="color: #99cc00;"><strong>Vito Pugliese</strong></span></td><td width="59">35</td><td width="63">-35</td><td width="58">20</td><td width="59">4</td><td width="54">6</td><td width="67">11</td></tr><tr><td width="108"><span style="color: #333399;"><strong>Joseph Wolkin</strong></span></td><td width="59">33</td><td width="63">-37</td><td width="58">21</td><td width="59">1</td><td width="54">9</td><td width="67">13</td></tr><tr><td width="108"><span style="color: #333300;"><strong>Frank Velat</strong></span></td><td width="59">28</td><td width="63">-42</td><td width="58">21</td><td width="59">2</td><td width="54">8</td><td width="67">10</td></tr><tr><td width="108"><span style="color: #ff99cc;"><strong>John Haverlin</strong></span></td><td width="59">18</td><td width="63">-52</td><td width="58">6</td><td width="59">1</td><td width="54">4</td><td width="67">5</td></tr><tr><td width="108"><span style="color: #800000;"><strong>John Douglas</strong></span></td><td width="59">17</td><td width="63">-53</td><td width="58">7</td><td width="59">0</td><td width="54">5</td><td width="67">5</td></tr><tr><td width="108"><span style="color: #993300;"><strong>Samarth Kanal</strong></span></td><td width="59">13</td><td width="63">-57</td><td width="58">10</td><td width="59">2</td><td width="54">2</td><td width="67">4</td></tr><tr><td width="108"><span style="color: #993300;"><strong>Matteo Marcheschi</strong></span></td><td width="59">12</td><td width="63">-58</td><td width="58">4</td><td width="59">2</td><td width="54">2</td><td width="67">2</td></tr><tr><td width="108"><span style="color: #3366ff;"><strong>Greg Davis</strong></span></td><td width="59">10</td><td width="63">-60</td><td width="58">12</td><td width="59">0</td><td width="54">4</td><td width="67">7</td></tr><tr><td width="108"><span style="color: #000080;"><strong>Michael Finley</strong></span></td><td width="59">3</td><td width="63">-67</td><td width="58">3</td><td width="59">0</td><td width="54">1</td><td width="67">1</td></tr><tr><td width="108"><span style="color: #008080;"><strong>Christian Koelle</strong></span></td><td width="59">1</td><td width="63">-69</td><td width="58">8</td><td width="59">0</td><td width="54">2</td><td width="67">3</td></tr><tr><td width="108"><strong>Phil Allaway</strong></td><td width="59">0</td><td width="63">-70</td><td width="58">1</td><td width="59">0</td><td width="54">0</td><td width="67">0</td></tr><tr><td width="108"><strong>Zach Catanzareti</strong></td><td width="59">-1</td><td width="63">-71</td><td width="58">2</td><td width="59">0</td><td width="54">0</td><td width="67">0</td></tr><tr><td width="108"><strong>Tom Bowles</strong></td><td width="59">-2</td><td width="63">-72</td><td width="58">2</td><td width="59">0</td><td width="54">0</td><td width="67">0</td></tr><tr><td width="108"><strong>Danny Peters</strong></td><td width="59">-3</td><td width="63">-73</td><td width="58">1</td><td width="59">0</td><td width="54">0</td><td width="67">0</td></tr></tbody></table><p>&nbsp;</p><p>&nbsp;</p></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=147827" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=2017+Frontstretch+Cup%3A+First+Data+500+Predictions&url=https://www.frontstretch.com/?p=147827" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=147827&amp;name=2017+Frontstretch+Cup%3A+First+Data+500+Predictions" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=147827&title=2017+Frontstretch+Cup%3A+First+Data+500+Predictions" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=147827&title=2017+Frontstretch+Cup%3A+First+Data+500+Predictions" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=147827&amp;description=2017+Frontstretch+Cup%3A+First+Data+500+Predictions&amp;media=https://www.frontstretch.com/wp-content/uploads/2016/10/dinger-660x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">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</script> </article><section id="author-box"><div class="block-head"><h3>About Frontstretch Staff</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2015/06/frontstretch-sq-logo-150x150.png" width="90" height="90" alt="Frontstretch Staff" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> The Frontstretch Staff is made up of a group of talented men and women spread out all over the United States and Canada. Residing in 15 states throughout the country, plus Ontario, and widely ranging in age, the staff showcases a wide variety of diverse opinions that will keep you coming back for more week in and week out.</div><div class="author-social flat-social"> <a class="social-site" target="_blank" href="https://frontstretch.com"><i class="fa fa-home"></i></a> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Frontstretch"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/Frontstretch"><i class="fa fa-twitter"></i><span> @Frontstretch</span></a> <a class="social-youtube" target="_blank" href="https://www.youtube.com/user/Frontstretch"><i class="fa fa-youtube"></i></a> <a class="social-pinterest" target="_blank" href="https://www.pinterest.com/frontstretch/"><i class="fa fa-pinterest"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/frontstretchdotcom/"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2017/10/28/joey-logano-fastest-in-first-data-500-final-practice/" rel="prev"><span>Previous</span> Joey Logano Fastest in First Data 500 Final Practice</a></div><div class="post-next"><a href="https://www.frontstretch.com/2017/10/29/the-big-6-questions-answered-after-the-2017-texas-roadhouse-200/" rel="next"><span>Next</span> The Big 6: Questions Answered After the 2017 Texas Roadhouse 200</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/10/29/tracking-the-trucks-noah-gragson-scores-1st-career-victory-at-martinsville/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-CWTS-Martinsville-Noah-Gragson-Matt-Crafton-Kyle-Busch-Grandfather-Clock-NASCAR-via-Getty-Images-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/10/29/tracking-the-trucks-noah-gragson-scores-1st-career-victory-at-martinsville/" rel="bookmark">Tracking the Trucks: Noah Gragson Scores 1st Career Victory at Martinsville</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>October 29, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/10/29/the-big-6-questions-answered-after-the-2017-texas-roadhouse-200/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Atlanta-CWTS-Noah-Gragson-truck-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/10/29/the-big-6-questions-answered-after-the-2017-texas-roadhouse-200/" rel="bookmark">The Big 6: Questions Answered After the 2017 Texas Roadhouse 200</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>October 29, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/10/28/denny-hamlin-leads-opening-cup-practice-from-martinsville/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-CUP-Denny-Hamlin-Barry-Cantrell-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/10/28/denny-hamlin-leads-opening-cup-practice-from-martinsville/" rel="bookmark">Denny Hamlin Leads Opening Cup Practice from Martinsville</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2017</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/10/28/f1-slipstream-saturday-bienvenidos-mexican-grand-prix-more/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/10/lewis_hamilton_wins_in_the_japanese_grand_prix_as_sebastian_vettel_retires_h7727_22547-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2017/10/28/f1-slipstream-saturday-bienvenidos-mexican-grand-prix-more/" rel="bookmark">F1 Slipstream Saturday: Bienvenidos, Mexican Grand Prix &#038; More</a></h2><p>The story of the race is, no surprise, Lewis Hamilton.  Should Hamilton finish fifth or &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/10/28/2017-frontstretch-cup-first-data-500-predictions/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='147827' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b25ab9b531" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="176"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1931074544731095"
data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a><br /><br /><a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="text-34" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a> <br> <A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/FV-2017-Banner-Ad.jpg" alt="" /> </a></div></div><div id="text-5" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2017, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://www.frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_374d59183f846257b14c86b49fcfee31.js"></script></body></html>