<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_4403879c53ce5546a5804e966bc2a4db.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_c8ede1184c0ba74d10d7f190bacfec01.css" rel="stylesheet" /><title>NASCAR Camping World Truck Series Entry List: Lucas Oil 150</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="NASCAR Camping World Truck Series Entry List: Lucas Oil 150 - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="One race remains in the NASCAR Camping World Truck Series Round of 6 to decide who will race for the"/><meta property="og:url" content="https://www.frontstretch.com/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway-660x425.jpg" /><meta name="description" content="30 trucks are on the preliminary entry list for the NASCAR Camping World Truck Series Lucas Oil 150 race at Phoenix Raceway."/><link rel="canonical" href="https://www.frontstretch.com/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="NASCAR Camping World Truck Series Entry List: Lucas Oil 150" /><meta property="og:description" content="30 trucks are on the preliminary entry list for the NASCAR Camping World Truck Series Lucas Oil 150 race at Phoenix Raceway." /><meta property="og:url" content="https://www.frontstretch.com/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:tag" content="Daniel Suarez" /><meta property="article:tag" content="Jason Hathaway" /><meta property="article:tag" content="Jennifer Jo Cobb" /><meta property="article:tag" content="Jesse Little" /><meta property="article:tag" content="jj yeley" /><meta property="article:tag" content="mike harmon" /><meta property="article:tag" content="Ray Ciccarelli" /><meta property="article:tag" content="Robby Lyons" /><meta property="article:tag" content="TJ Bell" /><meta property="article:tag" content="Todd Gilliland" /><meta property="article:tag" content="Todd Peck" /><meta property="article:section" content="Davey Segal" /><meta property="article:published_time" content="2017-11-07T00:42:11-05:00" /><meta property="article:modified_time" content="2017-11-07T00:52:04-05:00" /><meta property="og:updated_time" content="2017-11-07T00:52:04-05:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway.jpg" /><meta property="og:image:width" content="720" /><meta property="og:image:height" content="480" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="30 trucks are on the preliminary entry list for the NASCAR Camping World Truck Series Lucas Oil 150 race at Phoenix Raceway." /><meta name="twitter:title" content="NASCAR Camping World Truck Series Entry List: Lucas Oil 150" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway.jpg" /><meta name="twitter:creator" content="@Frontstretch" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.frontstretch.com\/","name":"Frontstretch","alternateName":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.frontstretch.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.frontstretch.com\/2017\/11\/07\/nascar-camping-world-truck-series-entry-list-lucas-150\/","sameAs":["https:\/\/www.facebook.com\/Frontstretch","https:\/\/instagram.com\/frontstretchdotcom\/","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/twitter.com\/Frontstretch"],"@id":"#organization","name":"Frontstretch","logo":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/04\/favicon-196x196.png"}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; NASCAR Camping World Truck Series Entry List: Lucas Oil 150 Comments Feed" href="https://www.frontstretch.com/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/feed/" />  <script type="text/javascript" data-cfasync="false">var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-34668381-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.8.3" /><meta name="generator" content="Seriously Simple Podcasting 1.18.1" /><link rel='shortlink' href='https://www.frontstretch.com/?p=148329' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F11%2F07%2Fnascar-camping-world-truck-series-entry-list-lucas-150%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2017%2F11%2F07%2Fnascar-camping-world-truck-series-entry-list-lucas-150%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.5.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="text/javascript">var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.frontstretch.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-148329 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="search-mobile"><form method="get" id="searchform-mobile" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-136612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136612"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast-powered-by-draftkings/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="search-block"><form method="get" id="searchform-header" action="https://www.frontstretch.com/"> <button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button> <input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  /></form></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div></div></div><div class="header-content"><a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo" style=" margin-top:15px; margin-bottom:15px;"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/" title="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Texas-II-NXS-green-flag-Brian-Lawdermilk-getty-images-for-texas-motor-speedway-660x425.jpg" width="660" height="330" alt="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/" title="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage">Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/the-underdog-house-racing-for-future-stability-at-texas/" title="The Underdog House: Racing for Future Stability at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/2017-Kansas-I-CUP-AJ-Allmendinger-Aric-Almirola-pack-racing-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Underdog House: Racing for Future Stability at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/the-underdog-house-racing-for-future-stability-at-texas/" title="The Underdog House: Racing for Future Stability at Texas">The Underdog House: Racing for Future Stability at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/whos-hot-whos-not-in-nascar-the-closer-returns-edition/" title="Who&#8217;s Hot &#038; Who&#8217;s Not in NASCAR: The Closer Returns Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/c22f8826bc4fb3cbd2b64e93e986ff24-11-110x75.jpg" width="110" height="75" alt="Who&#8217;s Hot &#038; Who&#8217;s Not in NASCAR: The Closer Returns Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/whos-hot-whos-not-in-nascar-the-closer-returns-edition/" title="Who&#8217;s Hot &#038; Who&#8217;s Not in NASCAR: The Closer Returns Edition">Who&#8217;s Hot &#038; Who&#8217;s Not in NASCAR: The Closer Returns Edition</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/thinkin-out-loud-kevin-harvick-breaks-script-and-wins-an-intermediate-race-in-2017/" title="Thinkin&#8217; Out Loud: Kevin Harvick Breaks Script and Wins an Intermediate Race in 2017"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Texas-II-CUP-Kevin-Harvick-woohoo-Jonathan-Ferrey-getty-images-for-texas-motor-speedway-110x75.jpg" width="110" height="75" alt="Thinkin&#8217; Out Loud: Kevin Harvick Breaks Script and Wins an Intermediate Race in 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/thinkin-out-loud-kevin-harvick-breaks-script-and-wins-an-intermediate-race-in-2017/" title="Thinkin&#8217; Out Loud: Kevin Harvick Breaks Script and Wins an Intermediate Race in 2017">Thinkin&#8217; Out Loud: Kevin Harvick Breaks Script and Wins an Intermediate Race in 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/Erik-Jones-Texas-BUrnout-110x75.jpg" width="110" height="75" alt="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change">Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/the-big-6-questions-answered-after-the-2017-aaa-texas-500/" title="The Big 6: Questions Answered After the 2017 AAA Texas 500"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/Kevin-Harvick-Texas-Burnout-110x75.jpg" width="110" height="75" alt="The Big 6: Questions Answered After the 2017 AAA Texas 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/the-big-6-questions-answered-after-the-2017-aaa-texas-500/" title="The Big 6: Questions Answered After the 2017 AAA Texas 500">The Big 6: Questions Answered After the 2017 AAA Texas 500</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/up-to-speed-this-time-it-really-is-about-winning/" title="Up to Speed: This Time, It Really is About Winning"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/a4061857ee50e740c651d228c161a610-11-110x75.jpg" width="110" height="75" alt="Up to Speed: This Time, It Really is About Winning" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/up-to-speed-this-time-it-really-is-about-winning/" title="Up to Speed: This Time, It Really is About Winning">Up to Speed: This Time, It Really is About Winning</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/" title="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Texas-II-NXS-green-flag-Brian-Lawdermilk-getty-images-for-texas-motor-speedway-660x425.jpg" width="660" height="330" alt="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/" title="Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage">Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/Erik-Jones-Texas-BUrnout-110x75.jpg" width="110" height="75" alt="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change">Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/xfinity-breakdown-erik-jones-sweeps-the-night-season-at-texas/" title="XFINITY Breakdown: Erik Jones Sweeps the Night &#038; Season at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/Erik-Jones-Texas-BUrnout-110x75.jpg" width="110" height="75" alt="XFINITY Breakdown: Erik Jones Sweeps the Night &#038; Season at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/xfinity-breakdown-erik-jones-sweeps-the-night-season-at-texas/" title="XFINITY Breakdown: Erik Jones Sweeps the Night &#038; Season at Texas">XFINITY Breakdown: Erik Jones Sweeps the Night &#038; Season at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/blake-koch-kyle-larson-pace-xfinity-practices-at-texas/" title="Blake Koch, Kyle Larson Pace XFINITY Practices at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/783b8553a5132555a357a88fe6c44b20-11-110x75.jpg" width="110" height="75" alt="Blake Koch, Kyle Larson Pace XFINITY Practices at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/blake-koch-kyle-larson-pace-xfinity-practices-at-texas/" title="Blake Koch, Kyle Larson Pace XFINITY Practices at Texas">Blake Koch, Kyle Larson Pace XFINITY Practices at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/4-burning-questions-will-chase-elliott-still-advance-after-martinsville-loss/" title="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/6f52292ff7bd716febbdad4ece43c5f1-11-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/4-burning-questions-will-chase-elliott-still-advance-after-martinsville-loss/" title="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?">4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/2017-frontstretch-podcast-powered-by-draftkings-episode-34-big-doings-in-texas/" title="2017 Frontstretch Podcast Powered by DraftKings – Episode 34: Big Doings in Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/01e33811c82065a0bb9bcaa3dc8d3a15-11-110x75.jpg" width="110" height="75" alt="2017 Frontstretch Podcast Powered by DraftKings – Episode 34: Big Doings in Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/2017-frontstretch-podcast-powered-by-draftkings-episode-34-big-doings-in-texas/" title="2017 Frontstretch Podcast Powered by DraftKings – Episode 34: Big Doings in Texas">2017 Frontstretch Podcast Powered by DraftKings – Episode 34: Big Doings in Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/eyes-on-xfinity-richard-childress-racing-yet-to-win-in-2017/" title="Eyes on XFINITY: Richard Childress Racing Yet to Win in 2017"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/2017-Dover-I-NXS-Daniel-Hemric-car-NIgel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="Eyes on XFINITY: Richard Childress Racing Yet to Win in 2017" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/eyes-on-xfinity-richard-childress-racing-yet-to-win-in-2017/" title="Eyes on XFINITY: Richard Childress Racing Yet to Win in 2017">Eyes on XFINITY: Richard Childress Racing Yet to Win in 2017</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 2, 2017</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-114644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114644"><a href="https://www.frontstretch.com/cwts-schedule/"><i class="fa fa-arrow-right"></i>2017 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114645"><a href="https://www.frontstretch.com/category/news/truck-series-news/"><i class="fa fa-arrow-right"></i>News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/"><i class="fa fa-arrow-right"></i>Commentary</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/"><i class="fa fa-arrow-right"></i>Race Report</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/Erik-Jones-Texas-BUrnout-640x425.jpg" width="660" height="330" alt="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/05/pace-laps-erik-jones-johnny-sauter-tackle-texas-gt-challenge-faces-major-change/" title="Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change">Pace Laps: Erik Jones, Johnny Sauter Tackle Texas &#038; GT Challenge Faces Major Change</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/tracking-the-trucks-johnny-sauter-punches-championship-ticket-at-texas/" title="Tracking the Trucks: Johnny Sauter Punches Championship Ticket at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Texas-CWTS-Johnny-Sauter-Checkered-Flag-John-K-Harrelson-NKP-110x75.jpg" width="110" height="75" alt="Tracking the Trucks: Johnny Sauter Punches Championship Ticket at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/tracking-the-trucks-johnny-sauter-punches-championship-ticket-at-texas/" title="Tracking the Trucks: Johnny Sauter Punches Championship Ticket at Texas">Tracking the Trucks: Johnny Sauter Punches Championship Ticket at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/johnny-sauter-punches-ticket-to-homestead-with-victory-at-texas/" title="Johnny Sauter Punches Ticket to Homestead with Victory at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/8d253f522a3e84e9c2ad123d5ba1f08c-11-110x75.jpg" width="110" height="75" alt="Johnny Sauter Punches Ticket to Homestead with Victory at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/04/johnny-sauter-punches-ticket-to-homestead-with-victory-at-texas/" title="Johnny Sauter Punches Ticket to Homestead with Victory at Texas">Johnny Sauter Punches Ticket to Homestead with Victory at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/4-burning-questions-will-chase-elliott-still-advance-after-martinsville-loss/" title="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/6f52292ff7bd716febbdad4ece43c5f1-11-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/4-burning-questions-will-chase-elliott-still-advance-after-martinsville-loss/" title="4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?">4 Burning Questions: Will Chase Elliott Still Advance After Martinsville Loss?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 2, 2017</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/nitro-shots-the-penultimate-edition/" title="Nitro Shots: The Penultimate Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/NHRA-2017-Topeka-Pro-Mod-winner-Stevie-Fast-Jackson-courtesy-NHRA-Media-660x425.jpg" width="660" height="330" alt="Nitro Shots: The Penultimate Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/11/02/nitro-shots-the-penultimate-edition/" title="Nitro Shots: The Penultimate Edition">Nitro Shots: The Penultimate Edition</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 2, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/pace-laps-lights-at-martinsville-lewis-hamilton-crowned-champion-imsa-changes-for-2018/" title="Pace Laps: Lights at Martinsville, Lewis Hamilton Crowned Champion &#038; IMSA Changes for 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/Cup-Action-Kyle-Busch-Leading-Way-110x75.jpg" width="110" height="75" alt="Pace Laps: Lights at Martinsville, Lewis Hamilton Crowned Champion &#038; IMSA Changes for 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/29/pace-laps-lights-at-martinsville-lewis-hamilton-crowned-champion-imsa-changes-for-2018/" title="Pace Laps: Lights at Martinsville, Lewis Hamilton Crowned Champion &#038; IMSA Changes for 2018">Pace Laps: Lights at Martinsville, Lewis Hamilton Crowned Champion &#038; IMSA Changes for 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 29, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/nitro-shots-viva-pro-mod-in-las-vegas/" title="Nitro Shots: Viva Pro Mod in Las Vegas"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/NHRA-2017-Gainesville-Troy-Coughlin-Pro-Mod-courtesy-Geiger-Media-110x75.jpg" width="110" height="75" alt="Nitro Shots: Viva Pro Mod in Las Vegas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/25/nitro-shots-viva-pro-mod-in-las-vegas/" title="Nitro Shots: Viva Pro Mod in Las Vegas">Nitro Shots: Viva Pro Mod in Las Vegas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 25, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/19/nitro-shots-to-backup-or-not-to-backup/" title="Nitro Shots: To Backup or Not to Backup"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/NHRA-2017-Chicago-Steve-Torrence-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: To Backup or Not to Backup" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/19/nitro-shots-to-backup-or-not-to-backup/" title="Nitro Shots: To Backup or Not to Backup">Nitro Shots: To Backup or Not to Backup</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 19, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/12/nitro-shots-purposely-short-fields-family-life/" title="Nitro Shots: Purposely Short Fields &#038; Family Life"><img src="https://www.frontstretch.com/wp-content/uploads/2017/06/NHRA-2017-Norwalk-Bo-Butner-car-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: Purposely Short Fields &#038; Family Life" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/12/nitro-shots-purposely-short-fields-family-life/" title="Nitro Shots: Purposely Short Fields &#038; Family Life">Nitro Shots: Purposely Short Fields &#038; Family Life</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 12, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/05/nitro-shots-and-now-for-the-news/" title="Nitro Shots: And Now for the News"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/1642-11110-110x75.jpg" width="110" height="75" alt="Nitro Shots: And Now for the News" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/05/nitro-shots-and-now-for-the-news/" title="Nitro Shots: And Now for the News">Nitro Shots: And Now for the News</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/01/pace-laps-a-flurry-of-nascar-playoff-activity/" title="Pace Laps: A Flurry of NASCAR Playoff Activity"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/blaney-dover-110x75.jpg" width="110" height="75" alt="Pace Laps: A Flurry of NASCAR Playoff Activity" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/01/pace-laps-a-flurry-of-nascar-playoff-activity/" title="Pace Laps: A Flurry of NASCAR Playoff Activity">Pace Laps: A Flurry of NASCAR Playoff Activity</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 1, 2017</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/20/verizon-departing-as-indycar-entitlement-sponsor-after-2018/" title="Verizon Departing as IndyCar Entitlement Sponsor After 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/verizon-660x425.jpg" width="660" height="330" alt="Verizon Departing as IndyCar Entitlement Sponsor After 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/20/verizon-departing-as-indycar-entitlement-sponsor-after-2018/" title="Verizon Departing as IndyCar Entitlement Sponsor After 2018">Verizon Departing as IndyCar Entitlement Sponsor After 2018</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>October 20, 2017</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/07/whos-where-a-2018-verizon-indycar-series-team-chart/" title="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/kana-110x75.jpg" width="110" height="75" alt="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/10/07/whos-where-a-2018-verizon-indycar-series-team-chart/" title="Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart">Who&#8217;s Where? A 2018 Verizon IndyCar Series Team Chart</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 7, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/happiness-is-the-drivers-edition/" title="Happiness Is: The Drivers Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2016/09/gordon-1-110x75.jpg" width="110" height="75" alt="Happiness Is: The Drivers Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/happiness-is-the-drivers-edition/" title="Happiness Is: The Drivers Edition">Happiness Is: The Drivers Edition</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/rahals-team-grows-while-ganassis-shrinks-for-2018/" title="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/04CJ1848A-110x75.jpg" width="110" height="75" alt="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/20/rahals-team-grows-while-ganassis-shrinks-for-2018/" title="Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018">Rahal&#8217;s Team Grows While Ganassi&#8217;s Shrinks For 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 20, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/18/simon-pagenaud-wins-indycar-at-sonoma-josef-newgarden-takes-series-championship/" title="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship"><img src="https://www.frontstretch.com/wp-content/uploads/2017/04/2017-Long-Beach-IndyCar-Simon-Pagenaud-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/18/simon-pagenaud-wins-indycar-at-sonoma-josef-newgarden-takes-series-championship/" title="Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship">Simon Pagenaud Wins IndyCar at Sonoma, Josef Newgarden Takes Series Championship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 18, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/17/pace-laps-championship-favorites-reign-at-chicago-josef-newgarden-wins-indycar-title/" title="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title"><img src="https://www.frontstretch.com/wp-content/uploads/2017/09/281e4b089bc15482eb1fb53b2b8ec951-11-110x75.jpg" width="110" height="75" alt="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/17/pace-laps-championship-favorites-reign-at-chicago-josef-newgarden-wins-indycar-title/" title="Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title">Pace Laps: Championship Favorites Reign at Chicago, Josef Newgarden Wins IndyCar Title</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 17, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/13/zach-veach-spencer-pigot-secure-full-time-rides-for-2018/" title="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2017/05/veah2-110x75.jpg" width="110" height="75" alt="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2017/09/13/zach-veach-spencer-pigot-secure-full-time-rides-for-2018/" title="Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018">Zach Veach, Spencer Pigot Secure Full-Time Rides For 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 13, 2017</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-114556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-114556"><a href="https://www.frontstretch.com/sports-cars/">Sports Cars</a><ul class="sub-menu menu-sub-content"><li id="menu-item-114558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114558"><a href="https://www.frontstretch.com/category/imsa/">IMSA</a></li></ul></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.draftkings.com/gateway?s=696638929" title="Draft Kings - Free Fantasy Racing" > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/draft-kings-728x90.png" alt="Draft Kings - Free Fantasy Racing" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/davey-segal/">Davey Segal</a></span> <span class="delimiter">/</span> <span class="current">NASCAR Camping World Truck Series Entry List: Lucas Oil 150</span></div><article class="post-listing post-148329 post type-post status-publish format-standard has-post-thumbnail  category-davey-segal category-featured-content category-truck-series-news tag-daniel-suarez tag-jason-hathaway tag-jennifer-jo-cobb tag-jesse-little tag-jj-yeley tag-mike-harmon tag-ray-ciccarelli tag-robby-lyons tag-tj-bell tag-todd-gilliland tag-todd-peck" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Phil Allaway)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">NASCAR Camping World Truck Series Entry List: Lucas Oil 150</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dsegal/" title="">Davey Segal </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/davey-segal/" rel="category tag">Davey Segal</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/news/truck-series-news/" rel="category tag">Truck Series News</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>One race remains in the NASCAR Camping World Truck Series Round of 6 to decide who will race for the title at Homestead-Miami Speedway. That elimination race sends the series west to Phoenix International Raceway for the 23rd annual Lucas Oil 150.</p><p>There are 30 trucks on the penultimate preliminary entry list. That includes no Monster Energy NASCAR Cup Series regulars and just one from the XFINITY Series, <a href="/tag/mike-harmon/">Mike Harmon</a>.</p><p>The entries include a number of drivers trying to make a name for themselves. There&#8217;s <a href="/tag/ray-ciccarelli/">Ray Ciccarelli</a> in the No. 0, running a second entry for <a href="/tag/jennifer-jo-cobb">Jennifer Jo Cobb</a>; <a href="/tag/jason-hathaway/">Jason Hathaway</a> in the No. 15 for Premium Motorsports; and <a href="/tag/robby-lyons/">Robby Lyons</a> in the No. 49, that team&#8217;s second Truck.</p><p>A number of veterans are also back in the series this weekend. <a href="/tag/tj-bell/">TJ Bell</a> returns to the No. 45 for Niece Motorsports; <a href="/tag/jj-yeley/">JJ Yeley</a> slots into truck No. 63 owned by the Mittler Brothers; and <a href="/tag/todd-peck/">Todd Peck</a> is in the No. 83 owned by DJ Copp.</p><p>There&#8217;s also a newly-crowned titleholder moving up. <a href="/tag/todd-gilliland/">Todd Gilliland</a>, fresh off his second consecutive NASCAR K&amp;N Pro Series West championship, will pilot the No. 51 Pedigree Toyota for Kyle Busch Motorsports. Young <a href="/tag/jesse-little/">Jesse Little</a> is in the No. 97, prepping for 2018 plans while the No. 99 MDM Motorsports entry currently has no driver listed.</p><p>The green flag for the Lucas Oil 150 is scheduled to fly Friday at approximately 8:49 p.m. ET with television coverage on Fox Sports 1. <a href="/tag/daniel-suarez/">Daniel Suarez</a> is the defending winner of the event.</p><p><span style="text-decoration: underline;"><em><strong>Check below for the full entry list</strong></em></span></p><table id="tablepress-1553" class="tablepress tablepress-id-1553"><thead><tr class="row-1 odd"><th class="column-1">Entry</th><th class="column-2">Car Number</th><th class="column-3">Driver</th><th class="column-4">Sponsor</th><th class="column-5">Manu</th><th class="column-6">Owner</th></tr></thead><tbody class="row-hover"><tr class="row-2 even"><td class="column-1">1</td><td class="column-2">0</td><td class="column-3">Ray Ciccarelli</td><td class="column-4">Star Sales</td><td class="column-5">Chevrolet</td><td class="column-6">Jennifer Jo Cobb</td></tr><tr class="row-3 odd"><td class="column-1">2</td><td class="column-2">2</td><td class="column-3">Austin Hill</td><td class="column-4">United Rentals</td><td class="column-5">Chevrolet</td><td class="column-6">Randy Young</td></tr><tr class="row-4 even"><td class="column-1">3</td><td class="column-2">4</td><td class="column-3">Christopher Bell</td><td class="column-4">Toyota</td><td class="column-5">Toyota</td><td class="column-6">Kyle Busch</td></tr><tr class="row-5 odd"><td class="column-1">4</td><td class="column-2">6</td><td class="column-3">Norm Benning</td><td class="column-4">H&amp;H Transportation</td><td class="column-5">Chevrolet</td><td class="column-6">Norm Benning</td></tr><tr class="row-6 even"><td class="column-1">5</td><td class="column-2">8</td><td class="column-3">John Hunter Nemechek</td><td class="column-4">Fire Alarm Services, Inc.</td><td class="column-5">Chevrolet</td><td class="column-6">Joe Nemechek</td></tr><tr class="row-7 odd"><td class="column-1">6</td><td class="column-2">10</td><td class="column-3">Jennifer Jo Cobb</td><td class="column-4">Driven2Honor.org</td><td class="column-5">Chevrolet</td><td class="column-6">Jennifer Jo Cobb</td></tr><tr class="row-8 even"><td class="column-1">7</td><td class="column-2">13</td><td class="column-3">Cody Coughlin</td><td class="column-4">Ride TV/JEGS</td><td class="column-5">Toyota</td><td class="column-6">Duke Thorson</td></tr><tr class="row-9 odd"><td class="column-1">8</td><td class="column-2">15</td><td class="column-3">Jason Hathaway</td><td class="column-4">Kubota / Choco Authentics</td><td class="column-5">Chevrolet</td><td class="column-6">Jay Robinson</td></tr><tr class="row-10 even"><td class="column-1">9</td><td class="column-2">16</td><td class="column-3">Ryan Truex</td><td class="column-4">Kobe Toyopet</td><td class="column-5">Toyota</td><td class="column-6">Shigeaki Hattori</td></tr><tr class="row-11 odd"><td class="column-1">10</td><td class="column-2">18</td><td class="column-3">Noah Gragson</td><td class="column-4">Switch</td><td class="column-5">Toyota</td><td class="column-6">Kyle Busch</td></tr><tr class="row-12 even"><td class="column-1">11</td><td class="column-2">19</td><td class="column-3">Austin Cindric</td><td class="column-4">Draw-Tite/Reese Brands</td><td class="column-5">Ford</td><td class="column-6">Brad Keselowski</td></tr><tr class="row-13 odd"><td class="column-1">12</td><td class="column-2">21</td><td class="column-3">Johnny Sauter</td><td class="column-4">ISM Connect</td><td class="column-5">Chevrolet</td><td class="column-6">Maurice Gallagher Jr.</td></tr><tr class="row-14 even"><td class="column-1">13</td><td class="column-2">24</td><td class="column-3">Justin Haley</td><td class="column-4">Fraternal Order of Eagles</td><td class="column-5">Chevrolet</td><td class="column-6">Maurice Gallagher Jr.</td></tr><tr class="row-15 odd"><td class="column-1">14</td><td class="column-2">27</td><td class="column-3">Ben Rhodes</td><td class="column-4">Safelite Auto Glass</td><td class="column-5">Toyota</td><td class="column-6">Duke Thorson</td></tr><tr class="row-16 even"><td class="column-1">15</td><td class="column-2">29</td><td class="column-3">Chase Briscoe</td><td class="column-4">Brad Keselowski's Checkered Flag Foundation/Fisher House Foundation</td><td class="column-5">Ford</td><td class="column-6">Brad Keselowski</td></tr><tr class="row-17 odd"><td class="column-1">16</td><td class="column-2">33</td><td class="column-3">Kaz Grala</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">Maurice Gallagher Jr.</td></tr><tr class="row-18 even"><td class="column-1">17</td><td class="column-2">44</td><td class="column-3">Austin Self</td><td class="column-4">AM Technical Solutions</td><td class="column-5">Chevrolet</td><td class="column-6">Shane Lamb</td></tr><tr class="row-19 odd"><td class="column-1">18</td><td class="column-2">45</td><td class="column-3">TJ Bell</td><td class="column-4">Niece Equipment</td><td class="column-5">Chevrolet</td><td class="column-6">Al Niece</td></tr><tr class="row-20 even"><td class="column-1">19</td><td class="column-2">49</td><td class="column-3">Robby Lyons (i)</td><td class="column-4">Sunwest Construction</td><td class="column-5">Chevrolet</td><td class="column-6">Jay Robinson</td></tr><tr class="row-21 odd"><td class="column-1">20</td><td class="column-2">51</td><td class="column-3">Todd Gilliland</td><td class="column-4">Pedigree</td><td class="column-5">Toyota</td><td class="column-6">Kyle Busch</td></tr><tr class="row-22 even"><td class="column-1">21</td><td class="column-2">52</td><td class="column-3">Stewart Friesen</td><td class="column-4">Halmar International</td><td class="column-5">Chevrolet</td><td class="column-6">Chris Larsen</td></tr><tr class="row-23 odd"><td class="column-1">22</td><td class="column-2">57</td><td class="column-3">Mike Senica</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">Norm Benning</td></tr><tr class="row-24 even"><td class="column-1">23</td><td class="column-2">63</td><td class="column-3">JJ Yeley (i)</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">Mike Mittler</td></tr><tr class="row-25 odd"><td class="column-1">24</td><td class="column-2">74</td><td class="column-3">Mike Harmon (i)</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">Mike Harmon</td></tr><tr class="row-26 even"><td class="column-1">25</td><td class="column-2">83</td><td class="column-3">Todd Peck</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">DJ Copp</td></tr><tr class="row-27 odd"><td class="column-1">26</td><td class="column-2">87</td><td class="column-3">Joe Nemechek</td><td class="column-4">D.A.B. Constructors Inc.</td><td class="column-5">Chevrolet</td><td class="column-6">Andrea Nemechek</td></tr><tr class="row-28 even"><td class="column-1">27</td><td class="column-2">88</td><td class="column-3">Matt Crafton</td><td class="column-4">Ideal Door/Menards</td><td class="column-5">Toyota</td><td class="column-6">Rhonda Thorson</td></tr><tr class="row-29 odd"><td class="column-1">28</td><td class="column-2">97</td><td class="column-3">Jesse Little</td><td class="column-4">JJL Motorsports</td><td class="column-5">Toyota</td><td class="column-6">Jason Little</td></tr><tr class="row-30 even"><td class="column-1">29</td><td class="column-2">98</td><td class="column-3">Grant Enfinger</td><td class="column-4">Jive</td><td class="column-5">Toyota</td><td class="column-6">Mike Curb</td></tr><tr class="row-31 odd"><td class="column-1">30</td><td class="column-2">99</td><td class="column-3">TBA</td><td class="column-4">TBD</td><td class="column-5">Chevrolet</td><td class="column-6">Matthew Miller</td></tr></tbody></table></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=148329" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=NASCAR+Camping+World+Truck+Series+Entry+List%3A+Lucas+Oil+150&url=https://www.frontstretch.com/?p=148329" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=148329&amp;name=NASCAR+Camping+World+Truck+Series+Entry+List%3A+Lucas+Oil+150" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=148329&title=NASCAR+Camping+World+Truck+Series+Entry+List%3A+Lucas+Oil+150" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=148329&title=NASCAR+Camping+World+Truck+Series+Entry+List%3A+Lucas+Oil+150" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=148329&amp;description=NASCAR+Camping+World+Truck+Series+Entry+List%3A+Lucas+Oil+150&amp;media=https://www.frontstretch.com/wp-content/uploads/2017/09/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2017-11-07T00:42:11+00:00","datePublished":"2017-11-07T00:42:11+00:00","dateModified":"2017-11-07T00:52:04+00:00","headline":"NASCAR Camping World Truck Series Entry List: Lucas Oil 150","name":"NASCAR Camping World Truck Series Entry List: Lucas Oil 150","keywords":"Daniel Suarez,Jason Hathaway,Jennifer Jo Cobb,Jesse Little,jj yeley,mike harmon,Ray Ciccarelli,Robby Lyons,TJ Bell,Todd Gilliland,Todd Peck","url":"https:\/\/www.frontstretch.com\/2017\/11\/07\/nascar-camping-world-truck-series-entry-list-lucas-150\/","description":"One race remains in the NASCAR Camping World Truck Series Round of 6 to decide who will race for the title at Homestead-Miami Speedway. That elimination race sends the series west to Phoenix Internati","copyrightYear":"2017","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2017\/11\/07\/nascar-camping-world-truck-series-entry-list-lucas-150\/"},"author":{"@type":"Person","name":"Davey Segal","url":"https:\/\/www.frontstretch.com\/author\/dsegal\/"},"articleSection":"Davey Segal,Featured Content,Truck Series News","articleBody":"One race remains in the NASCAR Camping World Truck Series Round of 6 to decide who will race for the title at Homestead-Miami Speedway. That elimination race sends the series west to Phoenix International Raceway for the 23rd annual Lucas Oil 150.\r\n\r\nThere are 30 trucks on the penultimate preliminary entry list. That includes no Monster Energy NASCAR Cup Series regulars and just one from the XFINITY Series, Mike Harmon.\r\n\r\nThe entries include a number of drivers trying to make a name for themselves. There's\u00a0Ray Ciccarelli in the No. 0, running a second entry for Jennifer Jo Cobb;\u00a0Jason Hathaway in the No. 15 for Premium Motorsports; and\u00a0Robby Lyons in the No. 49, that team's second Truck.\r\n\r\nA number of veterans are also back in the series this weekend.\u00a0TJ Bell\u00a0returns to the No. 45 for Niece Motorsports; JJ Yeley\u00a0slots into truck No. 63 owned by the Mittler Brothers; and\u00a0Todd Peck is in the No. 83 owned by DJ Copp.\r\n\r\nThere's also a newly-crowned titleholder moving up. Todd Gilliland, fresh off his second consecutive NASCAR K&amp;N Pro Series West championship, will pilot the No. 51 Pedigree Toyota for Kyle Busch Motorsports.\u00a0Young\u00a0Jesse Little is in the No. 97, prepping for 2018 plans while the No. 99 MDM Motorsports entry currently has no driver listed.\r\n\r\nThe green flag for the Lucas Oil 150 is scheduled to fly Friday at approximately 8:49 p.m. ET with television coverage on Fox Sports 1. Daniel Suarez is the defending winner of the event.\r\n\r\nCheck below for the full entry list\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2017\/09\/2017-Loudon-CWTS-Todd-Gilliland-Truck-Phil-Allaway.jpg","width":720,"height":480}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/daniel-suarez/" rel="tag">Daniel Suarez</a> <a href="https://www.frontstretch.com/tag/jason-hathaway/" rel="tag">Jason Hathaway</a> <a href="https://www.frontstretch.com/tag/jennifer-jo-cobb/" rel="tag">Jennifer Jo Cobb</a> <a href="https://www.frontstretch.com/tag/jesse-little/" rel="tag">Jesse Little</a> <a href="https://www.frontstretch.com/tag/jj-yeley/" rel="tag">jj yeley</a> <a href="https://www.frontstretch.com/tag/mike-harmon/" rel="tag">mike harmon</a> <a href="https://www.frontstretch.com/tag/ray-ciccarelli/" rel="tag">Ray Ciccarelli</a> <a href="https://www.frontstretch.com/tag/robby-lyons/" rel="tag">Robby Lyons</a> <a href="https://www.frontstretch.com/tag/tj-bell/" rel="tag">TJ Bell</a> <a href="https://www.frontstretch.com/tag/todd-gilliland/" rel="tag">Todd Gilliland</a> <a href="https://www.frontstretch.com/tag/todd-peck/" rel="tag">Todd Peck</a></p><section id="author-box"><div class="block-head"><h3>About Davey Segal</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://secure.gravatar.com/avatar/c64140ca479d16f073beb3b16b7d1308?s=90&#038;d=mm&#038;r=g" width="90" height="90" alt="" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 photo avatar-default" /></div><div class="author-description"> Davey serves as the Monday news writer and crafts 2-Headed Monster, along with some other various duties at Fronstretch. He is a senior sports journalism student at Michigan State University and is originally from Rockville, Md. He has an extreme passion for sports and has been following the sport of NASCAR since 2002, when he attended his first race at Dover. He also is a contributing writer for other motorsports websites and produces a weekly NASCAR podcast for WDBM 88.9 Sports called "Victory Lane" featuring interviews, discussion, news and more.</div><div class="author-social flat-social"></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2017/11/05/thinkin-out-loud-kevin-harvick-breaks-script-and-wins-an-intermediate-race-in-2017/" rel="prev"><span>Previous</span> Thinkin&#8217; Out Loud: Kevin Harvick Breaks Script and Wins an Intermediate Race in 2017</a></div><div class="post-next"><a href="https://www.frontstretch.com/2017/11/07/ticket-galaxy-200-entry-list/" rel="next"><span>Next</span> NASCAR XFINITY Series Entry List: Ticket Galaxy 200</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Texas-II-NXS-green-flag-Brian-Lawdermilk-getty-images-for-texas-motor-speedway-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/11/07/couch-potato-tuesday-nascar-on-nbc-turns-to-what-if-coverage/" rel="bookmark">Couch Potato Tuesday: NASCAR On NBC Turns To &#8216;What-If?&#8217; Coverage</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/11/07/the-underdog-house-racing-for-future-stability-at-texas/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/05/2017-Kansas-I-CUP-AJ-Allmendinger-Aric-Almirola-pack-racing-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/11/07/the-underdog-house-racing-for-future-stability-at-texas/" rel="bookmark">The Underdog House: Racing for Future Stability at Texas</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/11/07/whos-hot-whos-not-in-nascar-the-closer-returns-edition/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/09/c22f8826bc4fb3cbd2b64e93e986ff24-11-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2017/11/07/whos-hot-whos-not-in-nascar-the-closer-returns-edition/" rel="bookmark">Who&#8217;s Hot &#038; Who&#8217;s Not in NASCAR: The Closer Returns Edition</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2017</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2017/11/07/can-am-500-entry-list/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-CUP-Kyle-Busch-John-K-Harrelson-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2017/11/07/can-am-500-entry-list/" rel="bookmark">Monster Energy NASCAR Cup Series Entry List: Can-Am 500</a></h2><p>The Monster Energy NASCAR Cup Series heads west this weekend to Phoenix International Raceway for &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/07/nascar-camping-world-truck-series-entry-list-lucas-150/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='148329' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1a5e6a59d4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="84"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1931074544731095"
data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a><br /><br /><a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a><a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="text-34" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a> <br> <A HREF=" https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</A></center></div></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2017/03/FV-2017-Banner-Ad.jpg" alt="" /> </a></div></div><div id="text-5" class="widget widget_text"><div class="widget-top"><h4></h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2017, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script language="javascript" type="text/javascript">var kpg_cell="N";var kpg_nrci_image="https://www.frontstretch.com/wp-content/plugins/no-right-click-images-plugin/not.gif";var kpg_nrci_extra="N";var kpg_nrci_drag="Y";</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type="text/javascript">jQuery(document).ready(function($){
$('#tablepress-1553').dataTable({"order":[],"orderClasses":false,"stripeClasses":["even","odd"],"pagingType":"simple","lengthMenu":[10,25,31,50,100],"pageLength":31});
});</script><script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_f6daab6e3a5501a30dfe2b71d939745d.js"></script></body></html>