<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_fbd416820fcd344c14b2c3adba368bd7.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_a48c92220421d7e1af5d55978d39e7cf.css" rel="stylesheet" /><title>Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In this week’s Frontstretch Podcast Justin Allgaier calls in to help Dustin Albino and Mike Neff bre"/><meta property="og:url" content="https://www.frontstretch.com/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-640x425.jpg" /><meta name="description" content="In this week’s Frontstretch Podcast Justin Allgaier calls in to help Dustin Albino and Mike Neff break down a crazy weekend of racing at Texas Motor"/><link rel="canonical" href="https://www.frontstretch.com/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix" /><meta property="og:description" content="In this week’s Frontstretch Podcast Justin Allgaier calls in to help Dustin Albino and Mike Neff break down a crazy weekend of racing at Texas Motor" /><meta property="og:url" content="https://www.frontstretch.com/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" /><meta property="article:tag" content="Aric Almirola" /><meta property="article:tag" content="Cole Custer" /><meta property="article:tag" content="Jimmie Johnson" /><meta property="article:tag" content="Joey Logano" /><meta property="article:tag" content="Justin Allgaier" /><meta property="article:tag" content="Kevin Harvick" /><meta property="article:tag" content="Tyler Reddick" /><meta property="article:section" content="Dustin Albino" /><meta property="article:published_time" content="2018-11-08T00:43:08+00:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas.jpg" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="425" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In this week’s Frontstretch Podcast Justin Allgaier calls in to help Dustin Albino and Mike Neff break down a crazy weekend of racing at Texas Motor" /><meta name="twitter:title" content="Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas.jpg" /><meta name="twitter:creator" content="@DustinAlbino" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix Comments Feed" href="https://www.frontstretch.com/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.3.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.8" /><meta name="generator" content="Seriously Simple Podcasting 1.19.14" /><link rel='shortlink' href='https://www.frontstretch.com/?p=174480' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2018%2F11%2F07%2Ffrontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2018%2F11%2F07%2Ffrontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /></head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-174480 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo" style=" margin-top:15px; margin-bottom:15px;"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt="Frontstretch"  /><strong>Frontstretch Best seat at the track, best view on the web!</strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/leadership-of-nascar-penalizes-kevin-harvick-along-with-penalizing-itself/" title="Leadership of NASCAR Penalizes Kevin Harvick Along With Penalizing Itself"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/5afa05228915ab83e5282e66ceb81d96-11-640x425.jpg" width="660" height="330" alt="Leadership of NASCAR Penalizes Kevin Harvick Along With Penalizing Itself" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/leadership-of-nascar-penalizes-kevin-harvick-along-with-penalizing-itself/" title="Leadership of NASCAR Penalizes Kevin Harvick Along With Penalizing Itself">Leadership of NASCAR Penalizes Kevin Harvick Along With Penalizing Itself</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/daily-fantasy-nascar-fanduel-forecast-can-am-500/" title="Daily Fantasy NASCAR FanDuel Forecast: Can-Am 500"><img src="https://www.frontstretch.com/wp-content/uploads/2018/07/chasl-110x75.jpg" width="110" height="75" alt="Daily Fantasy NASCAR FanDuel Forecast: Can-Am 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/daily-fantasy-nascar-fanduel-forecast-can-am-500/" title="Daily Fantasy NASCAR FanDuel Forecast: Can-Am 500">Daily Fantasy NASCAR FanDuel Forecast: Can-Am 500</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/2-headed-monster-does-joey-logano-deserve-the-hate/" title="2-Headed Monster: Does Joey Logano Deserve The Hate?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/logano-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Does Joey Logano Deserve The Hate?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/2-headed-monster-does-joey-logano-deserve-the-hate/" title="2-Headed Monster: Does Joey Logano Deserve The Hate?">2-Headed Monster: Does Joey Logano Deserve The Hate?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/martin-truex-jr-cole-pearn-sign-with-joe-gibbs-racings-no-19-team/" title="Martin Truex Jr. &#038; Cole Pearn Sign with Joe Gibbs Racing&#8217;s No. 19 Team"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/TRUEX-110x75.jpg" width="110" height="75" alt="Martin Truex Jr. &#038; Cole Pearn Sign with Joe Gibbs Racing&#8217;s No. 19 Team" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/martin-truex-jr-cole-pearn-sign-with-joe-gibbs-racings-no-19-team/" title="Martin Truex Jr. &#038; Cole Pearn Sign with Joe Gibbs Racing&#8217;s No. 19 Team">Martin Truex Jr. &#038; Cole Pearn Sign with Joe Gibbs Racing&#8217;s No. 19 Team</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/kevin-harvick-no-longer-locked-into-championship-4-after-texas-penalty/" title="Kevin Harvick No Longer Locked Into Championship 4 After Texas Penalty"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/1291f176f00d4db5ec92e57bd88e2495-11-110x75.jpg" width="110" height="75" alt="Kevin Harvick No Longer Locked Into Championship 4 After Texas Penalty" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/kevin-harvick-no-longer-locked-into-championship-4-after-texas-penalty/" title="Kevin Harvick No Longer Locked Into Championship 4 After Texas Penalty">Kevin Harvick No Longer Locked Into Championship 4 After Texas Penalty</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/the-frontstretch-5-title-contenders-their-chances/" title="The Frontstretch 5: Title Contenders &#038; Their Chances"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Las-Vegas-CUP-Joey-Logano-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Title Contenders &#038; Their Chances" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/the-frontstretch-5-title-contenders-their-chances/" title="The Frontstretch 5: Title Contenders &#038; Their Chances">The Frontstretch 5: Title Contenders &#038; Their Chances</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/the-10-nascar-cup-series-power-rankings-after-texas-ii/" title="The 10: NASCAR Cup Series Power Rankings After Texas II"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/279b07a869a6227c57cc956432afdd83-11-110x75.jpg" width="110" height="75" alt="The 10: NASCAR Cup Series Power Rankings After Texas II" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/the-10-nascar-cup-series-power-rankings-after-texas-ii/" title="The 10: NASCAR Cup Series Power Rankings After Texas II">The 10: NASCAR Cup Series Power Rankings After Texas II</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2018</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2018/02/2018-XFINITY-Series-Schedule.pdf">2018 Schedule</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on XFINITY</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">XFINITY Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/eyes-on-xfinity-silly-season-update/" title="Eyes on XFINITY: Silly Season Update"><img src="https://www.frontstretch.com/wp-content/uploads/2018/03/2018-Las-Vegas-I-CWTS-Noah-Gragson-Nigel-Kinrade-NKP-660x425.jpg" width="660" height="330" alt="Eyes on XFINITY: Silly Season Update" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/eyes-on-xfinity-silly-season-update/" title="Eyes on XFINITY: Silly Season Update">Eyes on XFINITY: Silly Season Update</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/entry-list-whelen-trusted-to-perform-200/" title="Entry List: Whelen Trusted to Perform 200"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Phoenix-II-NXS-Justin-Algaier-Christopher-Bell-pack-racing-Russell-LaBounty-NKP-110x75.jpg" width="110" height="75" alt="Entry List: Whelen Trusted to Perform 200" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/entry-list-whelen-trusted-to-perform-200/" title="Entry List: Whelen Trusted to Perform 200">Entry List: Whelen Trusted to Perform 200</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/05/couch-potato-tuesday-nbcsn-forced-to-deal-with-lack-of-nascar-texas-action/" title="Couch Potato Tuesday: NBCSN Forced to Deal With Lack of NASCAR Texas Action"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/f2259412babc8e623d0b7458cb1ff706-11-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: NBCSN Forced to Deal With Lack of NASCAR Texas Action" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/05/couch-potato-tuesday-nbcsn-forced-to-deal-with-lack-of-nascar-texas-action/" title="Couch Potato Tuesday: NBCSN Forced to Deal With Lack of NASCAR Texas Action">Couch Potato Tuesday: NBCSN Forced to Deal With Lack of NASCAR Texas Action</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/0459f96329cf95ee9314329fa57e860d-11-110x75.jpg" width="110" height="75" alt="Pace Laps: 1 More Race to Set the NASCAR Championship Fields" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields">Pace Laps: 1 More Race to Set the NASCAR Championship Fields</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2018</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/2018-camping-world-truck-series-schedule-2/">2018 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/truckin-thursdays-championship-4-clinch-scenarios-for-phoenix/" title="Truckin&#8217; Thursdays: Championship 4 Clinch Scenarios for Phoenix"><img src="https://www.frontstretch.com/wp-content/uploads/2018/03/2018-Las-Vegas-I-CWTS-Brett-Moffitt-Nigel-Kinrade-NKP-660x425.jpg" width="660" height="330" alt="Truckin&#8217; Thursdays: Championship 4 Clinch Scenarios for Phoenix" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/truckin-thursdays-championship-4-clinch-scenarios-for-phoenix/" title="Truckin&#8217; Thursdays: Championship 4 Clinch Scenarios for Phoenix">Truckin&#8217; Thursdays: Championship 4 Clinch Scenarios for Phoenix</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/stewart-friesen-grows-with-each-race-at-halmar-friesen-racing/" title="Stewart Friesen Grows with Each Race at Halmar Friesen Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2018/06/2018-CWTS-Texas-Stewart-Friesen-Rick-Lunkenheimer-110x75.jpg" width="110" height="75" alt="Stewart Friesen Grows with Each Race at Halmar Friesen Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/stewart-friesen-grows-with-each-race-at-halmar-friesen-racing/" title="Stewart Friesen Grows with Each Race at Halmar Friesen Racing">Stewart Friesen Grows with Each Race at Halmar Friesen Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/entry-list-lucas-oil-150-2/" title="Entry List: Lucas Oil 150"><img src="https://www.frontstretch.com/wp-content/uploads/2017/11/2017-Phoenix-II-CWTS-Matt-Crafton-pack-racing-Logan-Whitton-NKP-110x75.jpg" width="110" height="75" alt="Entry List: Lucas Oil 150" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/06/entry-list-lucas-oil-150-2/" title="Entry List: Lucas Oil 150">Entry List: Lucas Oil 150</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/0459f96329cf95ee9314329fa57e860d-11-110x75.jpg" width="110" height="75" alt="Pace Laps: 1 More Race to Set the NASCAR Championship Fields" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields">Pace Laps: 1 More Race to Set the NASCAR Championship Fields</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2018</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/" title="Nitro Shots: For Your Viewing Pleasure"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/NHRA-2018-Cruz-Pedregon-car-courtesy-NHRA-Media-660x425.jpg" width="660" height="330" alt="Nitro Shots: For Your Viewing Pleasure" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/" title="Nitro Shots: For Your Viewing Pleasure">Nitro Shots: For Your Viewing Pleasure</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/nitro-shots-how-do-you-make-championships-exciting/" title="Nitro Shots: How Do You Make Championships Exciting?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Las-Vegas-Steve-Torrence-championship-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: How Do You Make Championships Exciting?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/nitro-shots-how-do-you-make-championships-exciting/" title="Nitro Shots: How Do You Make Championships Exciting?">Nitro Shots: How Do You Make Championships Exciting?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/logno-110x75.jpg" width="110" height="75" alt="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville">Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/nitro-shots-all-things-big-small/" title="Nitro Shots: All Things Big &#038; Small"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Charlotte-Fall-Steve-Torrence-pits-credit-Toni-Montgomery-110x75.jpg" width="110" height="75" alt="Nitro Shots: All Things Big &#038; Small" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/nitro-shots-all-things-big-small/" title="Nitro Shots: All Things Big &#038; Small">Nitro Shots: All Things Big &#038; Small</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 17, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/14/pace-laps-a-tame-talladega/" title="Pace Laps: A Tame Talladega?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/f73c9f63beb9a32fa6ca8e0b4d53a1a8-11-110x75.jpg" width="110" height="75" alt="Pace Laps: A Tame Talladega?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/14/pace-laps-a-tame-talladega/" title="Pace Laps: A Tame Talladega?">Pace Laps: A Tame Talladega?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 14, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/13/carolina-nationals-qualifying-is-in-the-books/" title="Carolina Nationals Qualifying Is In The Books"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Charlotte-Fall-Brittany-Force-top-qualifier-credit-Toni-Montgomery-110x75.jpg" width="110" height="75" alt="Carolina Nationals Qualifying Is In The Books" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/13/carolina-nationals-qualifying-is-in-the-books/" title="Carolina Nationals Qualifying Is In The Books">Carolina Nationals Qualifying Is In The Books</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 13, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/10/nitro-shots-the-tough-guy-award/" title="Nitro Shots: The Tough Guy Award"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Texas-Robert-Hight-winning-car-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: The Tough Guy Award" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/10/nitro-shots-the-tough-guy-award/" title="Nitro Shots: The Tough Guy Award">Nitro Shots: The Tough Guy Award</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 10, 2018</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/log2-660x425.jpg" width="660" height="330" alt="4 Burning Questions: Can Joey Logano Steal a Championship?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?">4 Burning Questions: Can Joey Logano Steal a Championship?</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/BATTLE-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Closest Finishes Ever" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever">The Frontstretch 5: Closest Finishes Ever</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2042-1-110x75.jpg" width="110" height="75" alt="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign">Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 30, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/26/robert-wickens-left-paralyzed-from-waist-down-after-pocono-accident/" title="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident"><img src="https://www.frontstretch.com/wp-content/uploads/2018/08/wickn-110x75.jpg" width="110" height="75" alt="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/26/robert-wickens-left-paralyzed-from-waist-down-after-pocono-accident/" title="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident">Robert Wickens Left Paralyzed from Waist Down After Pocono Accident</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 26, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/19/mclaren-will-not-field-full-time-entry-in-indycar-series-in-2019/" title="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2588-1-110x75.jpg" width="110" height="75" alt="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/19/mclaren-will-not-field-full-time-entry-in-indycar-series-in-2019/" title="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019">McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 19, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/ed-jones-set-for-road-courses-indianapolis-500-in-2019-with-ed-carpenter-racing/" title="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/JGS_2018-MIDOHIO-167087-1-110x75.jpg" width="110" height="75" alt="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/ed-jones-set-for-road-courses-indianapolis-500-in-2019-with-ed-carpenter-racing/" title="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing">Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 17, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/09/28/felix-rosenqvist-will-pilot-no-10-entry-for-chip-ganassi-racing-in-2019/" title="Felix Rosenqvist Will Pilot No. 10 Entry for Chip Ganassi Racing in 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/16C_0565-1-110x75.jpg" width="110" height="75" alt="Felix Rosenqvist Will Pilot No. 10 Entry for Chip Ganassi Racing in 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/09/28/felix-rosenqvist-will-pilot-no-10-entry-for-chip-ganassi-racing-in-2019/" title="Felix Rosenqvist Will Pilot No. 10 Entry for Chip Ganassi Racing in 2019">Felix Rosenqvist Will Pilot No. 10 Entry for Chip Ganassi Racing in 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 28, 2018</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/0459f96329cf95ee9314329fa57e860d-11-640x425.jpg" width="660" height="330" alt="Pace Laps: 1 More Race to Set the NASCAR Championship Fields" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/04/pace-laps-1-more-race-to-set-the-nascar-championship-fields/" title="Pace Laps: 1 More Race to Set the NASCAR Championship Fields">Pace Laps: 1 More Race to Set the NASCAR Championship Fields</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/aim-vasser-sullivan-hires-jack-hawksworth-as-lead-driver/" title="AIM VASSER SULLIVAN Hires Jack Hawksworth As Lead Driver"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/2018-Watkins-Glen-IWSC-Jack-Hawksworth-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="AIM VASSER SULLIVAN Hires Jack Hawksworth As Lead Driver" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/aim-vasser-sullivan-hires-jack-hawksworth-as-lead-driver/" title="AIM VASSER SULLIVAN Hires Jack Hawksworth As Lead Driver">AIM VASSER SULLIVAN Hires Jack Hawksworth As Lead Driver</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 30, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/logno-110x75.jpg" width="110" height="75" alt="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville">Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/ligiers-revenge-united-autosports-leads-ligier-podium-sweep-at-portimao/" title="Ligier&#8217;s Revenge: United Autosports Leads Ligier Podium Sweep at Portimão"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/2018-Portimao-ELMS-Filipe-Albuquerque-Will-Stevens-Checkered-Flag-Jakob-Ebrey-Photography-110x75.jpg" width="110" height="75" alt="Ligier&#8217;s Revenge: United Autosports Leads Ligier Podium Sweep at Portimão" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/ligiers-revenge-united-autosports-leads-ligier-podium-sweep-at-portimao/" title="Ligier&#8217;s Revenge: United Autosports Leads Ligier Podium Sweep at Portimão">Ligier&#8217;s Revenge: United Autosports Leads Ligier Podium Sweep at Portimão</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2018</span></li></ul></div></div></div></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="http://fanduel.com/frontstretch" title="FanDuel - Play Now!" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/04/fd-nascar-generic-728x90.jpg" alt="FanDuel - Play Now!" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/dustin-albino/">Dustin Albino</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix</span></div><article class="post-listing post-174480 post type-post status-publish format-standard has-post-thumbnail  category-dustin-albino category-featured-content category-mike-neff category-podcast tag-aric-almirola tag-cole-custer tag-jimmie-johnson tag-joey-logano tag-justin-allgaier tag-kevin-harvick tag-tyler-reddick" id="the-post"><div class="single-post-thumb"> <img width="640" height="425" src="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-640x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas.jpg 640w, https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-150x100.jpg 150w, https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-300x199.jpg 300w, https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-310x205.jpg 310w" sizes="(max-width: 640px) 100vw, 640px" /></div><div class="single-post-caption">(Photo: Nigel Kinrade Photography)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/mike-neff/" rel="category tag">Mike Neff</a>, <a href="https://www.frontstretch.com/category/podcast/" rel="category tag">Podcast</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In this week’s <em>Frontstretch</em> Podcast <a href="/tag/justin-allgaier">Justin Allgaier</a> calls in to help <a href="https://twitter.com/DustinAlbino">Dustin Albino</a> and <a href="https://twitter.com/MNeffShortTrack">Mike Neff</a> break down a crazy weekend of racing at Texas Motor Speedway.</p><p>Allgaier discusses what it&#8217;s like racing for a win while having to save fuel near the end of a NASCAR XFINITY Series race. Despite believing crew chief Jason Burdett made the right call bringing the No. 7 to pit road during a late caution, Allgaier finished fifth.</p><p>Instead of being locked into the championship race at Homestead-Miami Speedway, Allgaier mentions that being 12 points behind the cut-line is a lot of points to make up. However, ISM Raceway is one his best racetracks on the circuit, and he is confident that with his dream-like season, the No. 7 can get to Victory Lane in the desert.</p><p>Staying with the XFINITY theme, the duo discusses the significance of <a href="/tag/cole-custer">Cole Custer</a> making it to Homestead with a shot at the championship after dominating the same race last year. Also, <a href="/tag/tyler-reddick">Tyler Reddick</a> is on a bit of a hot streak.</p><p>Is <a href="/tag/kevin-harvick">Kevin Harvick</a> the championship favorite? He proved that on Sunday (Nov. 4) at Texas, cruising to the victory. But what are <a href="/tag/joey-logano">Joey Logano</a>&#8216;s chances moving forward?</p><p>Finally, both Albino and Neff give hot takes on why drivers need to stop complaining about their competitors racing them hard and an embarrassing miscommunication between NASCAR and <a href="/tag/jimmie-johnson">Jimmie Johnson</a>.</p><p><em>Disclosure: the body of this podcast was recorded prior to NASCAR announcing on Wednesday (Nov. 7) that Harvick&#8217;s victory was encumbered. However, there are still a lot of interesting topics discussed. </em></p><p><em>Make sure to leave us a rating and review and subscribe to the Frontstretch Podcast:<a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p><p><i>Music. Thanks to Big Rock Kevin MacLeod (<a href="http://incompetech.com/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://incompetech.com&amp;source=gmail&amp;ust=1529623483308000&amp;usg=AFQjCNEYiPAsxhsXiokRatbNZRGiEs_xxA">incompetech.com</a>)</i></p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-174480-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2018/11/ISM-RACEWAY-FS-PODCAST.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2018/11/ISM-RACEWAY-FS-PODCAST.mp3">https://www.frontstretch.com/wp-content/uploads/2018/11/ISM-RACEWAY-FS-PODCAST.mp3</a></audio></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=174480" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Justin+Allgaier+Talks+Tricky+Texas%2C+Confidence+Heading+to+Phoenix&url=https://www.frontstretch.com/?p=174480" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=174480&amp;name=Frontstretch+Podcast%3A+Justin+Allgaier+Talks+Tricky+Texas%2C+Confidence+Heading+to+Phoenix" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=174480&title=Frontstretch+Podcast%3A+Justin+Allgaier+Talks+Tricky+Texas%2C+Confidence+Heading+to+Phoenix" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=174480&title=Frontstretch+Podcast%3A+Justin+Allgaier+Talks+Tricky+Texas%2C+Confidence+Heading+to+Phoenix" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=174480&amp;description=Frontstretch+Podcast%3A+Justin+Allgaier+Talks+Tricky+Texas%2C+Confidence+Heading+to+Phoenix&amp;media=https://www.frontstretch.com/wp-content/uploads/2018/11/Justin-Allgaier-Texas-640x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2018-11-07T19:43:08+00:00","datePublished":"2018-11-07T19:43:08+00:00","dateModified":"2018-11-07T19:43:08+00:00","headline":"Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix","name":"Frontstretch Podcast: Justin Allgaier Talks Tricky Texas, Confidence Heading to Phoenix","keywords":"Aric Almirola,Cole Custer,Jimmie Johnson,Joey Logano,Justin Allgaier,Kevin Harvick,Tyler Reddick","url":"https:\/\/www.frontstretch.com\/2018\/11\/07\/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix\/","description":"In this week\u2019s\u00a0Frontstretch\u00a0Podcast Justin Allgaier calls in to help\u00a0Dustin Albino\u00a0and\u00a0Mike Neff\u00a0break down a crazy weekend of racing at Texas Motor Speedway. Allgaier discusses what it's like racing","copyrightYear":"2018","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2018\/11\/07\/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix\/"},"author":{"@type":"Person","name":"Dustin Albino","url":"https:\/\/www.frontstretch.com\/author\/dustin-albino\/"},"articleSection":"Dustin Albino,Featured Content,Mike Neff,Podcast","articleBody":"In this week\u2019s\u00a0Frontstretch\u00a0Podcast Justin Allgaier calls in to help\u00a0Dustin Albino\u00a0and\u00a0Mike Neff\u00a0break down a crazy weekend of racing at Texas Motor Speedway.\r\n\r\nAllgaier discusses what it's like racing for a win while having to save fuel near the end of a NASCAR XFINITY Series race. Despite believing crew chief Jason Burdett made the right call bringing the No. 7 to pit road during a late caution, Allgaier finished fifth.\r\n\r\nInstead of being locked into the championship race at Homestead-Miami Speedway, Allgaier mentions that being 12 points behind the cut-line is a lot of points to make up. However, ISM Raceway is one his best racetracks on the circuit, and he is confident that with his dream-like season, the No. 7 can get to Victory Lane in the desert.\r\n\r\nStaying with the XFINITY theme, the duo discusses the significance of Cole Custer making it to Homestead with a shot at the championship after dominating the same race last year. Also, Tyler Reddick is on a bit of a hot streak.\r\n\r\nIs Kevin Harvick the championship favorite? He proved that on Sunday (Nov. 4) at Texas, cruising to the victory. But what are Joey Logano's chances moving forward?\r\n\r\nFinally, both Albino and Neff give hot takes on why drivers need to stop complaining about their competitors racing them hard and an embarrassing miscommunication between NASCAR and Jimmie Johnson.\r\n\r\nDisclosure: the body of this podcast was recorded prior to NASCAR announcing on Wednesday (Nov. 7) that Harvick's victory was encumbered. However, there are still a lot of interesting topics discussed.\u00a0\r\n\r\nMake sure to leave us a rating and review and subscribe to the Frontstretch Podcast:iTunes\r\n\r\nMusic. Thanks to\u00a0Big Rock Kevin MacLeod (incompetech.com)\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2018\/11\/Justin-Allgaier-Texas.jpg","width":696,"height":425}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/aric-almirola/" rel="tag">Aric Almirola</a> <a href="https://www.frontstretch.com/tag/cole-custer/" rel="tag">Cole Custer</a> <a href="https://www.frontstretch.com/tag/jimmie-johnson/" rel="tag">Jimmie Johnson</a> <a href="https://www.frontstretch.com/tag/joey-logano/" rel="tag">Joey Logano</a> <a href="https://www.frontstretch.com/tag/justin-allgaier/" rel="tag">Justin Allgaier</a> <a href="https://www.frontstretch.com/tag/kevin-harvick/" rel="tag">Kevin Harvick</a> <a href="https://www.frontstretch.com/tag/tyler-reddick/" rel="tag">Tyler Reddick</a></p><div class="e3lan e3lan-post"> <a href="https://patreon.com/frontstretch"><img class="alignleft size-full wp-image-170196" src="https://www.frontstretch.com/wp-content/uploads/2018/10/become_a_patron_button.png" alt="Become A Patron" width="217" height="51" /></a></div><section id="author-box"><div class="block-head"><h3>About Dustin Albino</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361-150x138.jpg" width="90" height="83" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.</div><div class="author-social flat-social"> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a> <a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2018/11/07/2-headed-monster-does-joey-logano-deserve-the-hate/" rel="prev"><span>Previous</span> 2-Headed Monster: Does Joey Logano Deserve The Hate?</a></div><div class="post-next"><a href="https://www.frontstretch.com/2018/11/07/eyes-on-xfinity-silly-season-update/" rel="next"><span>Next</span> Eyes on XFINITY: Silly Season Update</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/11/07/leadership-of-nascar-penalizes-kevin-harvick-along-with-penalizing-itself/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/09/5afa05228915ab83e5282e66ceb81d96-11-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/11/07/leadership-of-nascar-penalizes-kevin-harvick-along-with-penalizing-itself/" rel="bookmark">Leadership of NASCAR Penalizes Kevin Harvick Along With Penalizing Itself</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/11/NHRA-2018-Cruz-Pedregon-car-courtesy-NHRA-Media-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/" rel="bookmark">Nitro Shots: For Your Viewing Pleasure</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/11/07/truckin-thursdays-championship-4-clinch-scenarios-for-phoenix/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/03/2018-Las-Vegas-I-CWTS-Brett-Moffitt-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/11/07/truckin-thursdays-championship-4-clinch-scenarios-for-phoenix/" rel="bookmark">Truckin&#8217; Thursdays: Championship 4 Clinch Scenarios for Phoenix</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/11/07/daily-fantasy-nascar-fanduel-forecast-can-am-500/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/07/chasl-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2018/11/07/daily-fantasy-nascar-fanduel-forecast-can-am-500/" rel="bookmark">Daily Fantasy NASCAR FanDuel Forecast: Can-Am 500</a></h2><p>The final race of the Round of 8 for the Monster Energy NASCAR Cup Series&#8217; &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/11/07/frontstretch-podcast-justin-allgaier-talks-tricky-texas-confidence-heading-to-phoenix/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='174480' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e27b1683d1" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="149"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="http://www.americanmuscle.com"  target="_blank"  > <img src="https://frontstretch.com/wp-content/uploads/2014/06/American-Muscle-250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-10" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.fanduel.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/04/fd-nascar-generic-300x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/02/300x250-re-2018.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-2" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><p align="center"><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a></p><p align="center"><a href="https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</a></p></div></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2018, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_4bbc267081ecf22084da11ffbe432147.js"></script></body></html>