<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_baf70cf80921cf727eb2b12f897f6540.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_440e8ba8883b372add179f73477f3009.css" rel="stylesheet" /><title>Frontstretch Podcast: Best of 2018</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="Frontstretch Podcast: Best of 2018 - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In a special offseason episode of the Frontstretch Podcast, Dustin Albino, Mike Neff and Zach Catanz"/><meta property="og:url" content="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/logano-660x425.jpg" /><meta name="description" content="In a special offseason episode of the Frontstretch Podcast, Dustin Albino, Mike Neff and Zach Catanzareti discuss the best of 2018. The gang kicks it off"/><link rel="canonical" href="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Best of 2018" /><meta property="og:description" content="In a special offseason episode of the Frontstretch Podcast, Dustin Albino, Mike Neff and Zach Catanzareti discuss the best of 2018. The gang kicks it off" /><meta property="og:url" content="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" /><meta property="article:tag" content="Aric Almirola" /><meta property="article:tag" content="Chase Elliott" /><meta property="article:tag" content="Joey Logano" /><meta property="article:tag" content="Kevin Harvick" /><meta property="article:tag" content="Kyle Busch" /><meta property="article:tag" content="Martin Truex Jr." /><meta property="article:tag" content="Ross Chastain" /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2018-12-27T16:56:36+00:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/logano.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2018/11/logano.jpg" /><meta property="og:image:width" content="974" /><meta property="og:image:height" content="658" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In a special offseason episode of the Frontstretch Podcast, Dustin Albino, Mike Neff and Zach Catanzareti discuss the best of 2018. The gang kicks it off" /><meta name="twitter:title" content="Frontstretch Podcast: Best of 2018" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2018/11/logano.jpg" /><meta name="twitter:creator" content="@DustinAlbino" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Best of 2018 Comments Feed" href="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.3.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.frontstretch.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.0.2" /><meta name="generator" content="Seriously Simple Podcasting 1.19.15" /><link rel='shortlink' href='https://www.frontstretch.com/?p=176649' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2018%2F12%2F27%2Ffrontstretch-podcast-best-of-2018%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2018%2F12%2F27%2Ffrontstretch-podcast-best-of-2018%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://www.frontstretch.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /></head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-176649 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/" title="Frontstretch Podcast: Best of 2018"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/logano-660x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Best of 2018" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/" title="Frontstretch Podcast: Best of 2018">Frontstretch Podcast: Best of 2018</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/2018-nascar-driver-reviews-david-ragan/" title="2018 NASCAR Driver Reviews: David Ragan"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/David-Ragan-38-110x75.jpg" width="110" height="75" alt="2018 NASCAR Driver Reviews: David Ragan" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/2018-nascar-driver-reviews-david-ragan/" title="2018 NASCAR Driver Reviews: David Ragan">2018 NASCAR Driver Reviews: David Ragan</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/21/2018-nascar-driver-reviews-jamie-mcmurray/" title="2018 NASCAR Driver Reviews: Jamie McMurray"><img src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Fontana-CUP-Jamie-McMurray-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="2018 NASCAR Driver Reviews: Jamie McMurray" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/21/2018-nascar-driver-reviews-jamie-mcmurray/" title="2018 NASCAR Driver Reviews: Jamie McMurray">2018 NASCAR Driver Reviews: Jamie McMurray</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 21, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/2018-nascar-driver-reviews-paul-menard/" title="2018 NASCAR Driver Reviews: Paul Menard"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/men-bla-110x75.jpg" width="110" height="75" alt="2018 NASCAR Driver Reviews: Paul Menard" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/2018-nascar-driver-reviews-paul-menard/" title="2018 NASCAR Driver Reviews: Paul Menard">2018 NASCAR Driver Reviews: Paul Menard</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 20, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/corey-lajoie-signs-with-go-fas-racing-for-full-2019-season/" title="Corey LaJoie Signs with Go Fas Racing for Full 2019 Season"><img src="https://www.frontstretch.com/wp-content/uploads/2018/05/corey-lajoie-110x75.jpg" width="110" height="75" alt="Corey LaJoie Signs with Go Fas Racing for Full 2019 Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/corey-lajoie-signs-with-go-fas-racing-for-full-2019-season/" title="Corey LaJoie Signs with Go Fas Racing for Full 2019 Season">Corey LaJoie Signs with Go Fas Racing for Full 2019 Season</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 20, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-nascar-top-storylines-how-did-each-of-the-big-three-fall-apart/" title="2018 NASCAR Top Storylines: How Did Each of the Big 3 Fall Apart?"><img src="https://www.frontstretch.com/wp-content/uploads/2016/07/2016-Daytona-II-CUP-Martin-Truex-Jr-Kyle-Busch-Nigel-Kinrade-NKP-110x75.jpg" width="110" height="75" alt="2018 NASCAR Top Storylines: How Did Each of the Big 3 Fall Apart?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-nascar-top-storylines-how-did-each-of-the-big-three-fall-apart/" title="2018 NASCAR Top Storylines: How Did Each of the Big 3 Fall Apart?">2018 NASCAR Top Storylines: How Did Each of the Big 3 Fall Apart?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 19, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-nascar-driver-reviews-joey-logano/" title="2018 NASCAR Driver Reviews: Joey Logano"><img src="https://www.frontstretch.com/wp-content/uploads/2018/04/11ebd385883ec594198583b87694288b-11-110x75.jpg" width="110" height="75" alt="2018 NASCAR Driver Reviews: Joey Logano" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-nascar-driver-reviews-joey-logano/" title="2018 NASCAR Driver Reviews: Joey Logano">2018 NASCAR Driver Reviews: Joey Logano</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 19, 2018</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">XFINITY</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2018/02/2018-XFINITY-Series-Schedule.pdf">2018 Schedule</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on XFINITY</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">XFINITY Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/2018-xfinity-series-review-best-of-the-rest/" title="2018 Xfinity Series Review: Best of the Rest"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/Race_FE300-660x425.jpg" width="660" height="330" alt="2018 Xfinity Series Review: Best of the Rest" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/27/2018-xfinity-series-review-best-of-the-rest/" title="2018 Xfinity Series Review: Best of the Rest">2018 Xfinity Series Review: Best of the Rest</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/2018-xfinity-series-review-midpack-teams/" title="2018 Xfinity Series Review: Midpack Teams"><img src="https://www.frontstretch.com/wp-content/uploads/2018/06/clemnt-110x75.jpg" width="110" height="75" alt="2018 Xfinity Series Review: Midpack Teams" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/2018-xfinity-series-review-midpack-teams/" title="2018 Xfinity Series Review: Midpack Teams">2018 Xfinity Series Review: Midpack Teams</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 20, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-xfinity-series-review-playoff-teams/" title="2018 Xfinity Series Review: Playoff Teams"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/Tyler-Reddick-XFINITY-CHAMPIONSHIP-110x75.jpg" width="110" height="75" alt="2018 Xfinity Series Review: Playoff Teams" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/2018-xfinity-series-review-playoff-teams/" title="2018 Xfinity Series Review: Playoff Teams">2018 Xfinity Series Review: Playoff Teams</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 19, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/13/frontstretch-podcast-talking-off-season-news/" title="Frontstretch Podcast: Talking Offseason News, Plethora of Changes"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-CUP-Kurt-Busch-Barry-Cantrell-NKP-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Talking Offseason News, Plethora of Changes" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/13/frontstretch-podcast-talking-off-season-news/" title="Frontstretch Podcast: Talking Offseason News, Plethora of Changes">Frontstretch Podcast: Talking Offseason News, Plethora of Changes</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 13, 2018</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/2018-camping-world-truck-series-schedule-2/">2018 Schedule</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/13/frontstretch-podcast-talking-off-season-news/" title="Frontstretch Podcast: Talking Offseason News, Plethora of Changes"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/2017-Kansas-II-CUP-Kurt-Busch-Barry-Cantrell-NKP-660x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Talking Offseason News, Plethora of Changes" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/13/frontstretch-podcast-talking-off-season-news/" title="Frontstretch Podcast: Talking Offseason News, Plethora of Changes">Frontstretch Podcast: Talking Offseason News, Plethora of Changes</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>December 13, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/09/brett-moffitt-and-tyler-reddick-championships-celebrated-in-charlotte/" title="Brett Moffitt and Tyler Reddick Championships Celebrated in Charlotte"><img src="https://www.frontstretch.com/wp-content/uploads/2018/12/NASCAR-Awards-2018-110x75.jpg" width="110" height="75" alt="Brett Moffitt and Tyler Reddick Championships Celebrated in Charlotte" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/09/brett-moffitt-and-tyler-reddick-championships-celebrated-in-charlotte/" title="Brett Moffitt and Tyler Reddick Championships Celebrated in Charlotte">Brett Moffitt and Tyler Reddick Championships Celebrated in Charlotte</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 9, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/01/natalie-decker-joining-dgr-crosley-for-2019/" title="Natalie Decker Joining DGR-Crosley for 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2017/07/2016-NCWTS-Natalie-Decker-martinsville-speedway-photo-credit-NASCAR-via-getty-images-110x75.jpg" width="110" height="75" alt="Natalie Decker Joining DGR-Crosley for 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/01/natalie-decker-joining-dgr-crosley-for-2019/" title="Natalie Decker Joining DGR-Crosley for 2019">Natalie Decker Joining DGR-Crosley for 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 1, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/22/frontstretch-podcast-wrapping-up-homestead/" title="Frontstretch Podcast: Wrapping Up Homestead"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/Joey_Logano_FE4002-1-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Wrapping Up Homestead" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/22/frontstretch-podcast-wrapping-up-homestead/" title="Frontstretch Podcast: Wrapping Up Homestead">Frontstretch Podcast: Wrapping Up Homestead</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 22, 2018</span></li></ul></div></div></div></li><li id="menu-item-114549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114549 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/nhra/">NHRA</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/14/nitro-shots-goodbye-farewell-see-you-at-the-strip/" title="Nitro Shots: Goodbye, Farewell, &#038; See You At The Strip"><img src="https://www.frontstretch.com/wp-content/uploads/2018/06/NHRA-2018-Richmond-Steve-Torrence-burnout-courtesy-NHRA-Media-660x425.jpg" width="660" height="330" alt="Nitro Shots: Goodbye, Farewell, &#038; See You At The Strip" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/14/nitro-shots-goodbye-farewell-see-you-at-the-strip/" title="Nitro Shots: Goodbye, Farewell, &#038; See You At The Strip">Nitro Shots: Goodbye, Farewell, &#038; See You At The Strip</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 14, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/" title="Nitro Shots: For Your Viewing Pleasure"><img src="https://www.frontstretch.com/wp-content/uploads/2018/11/NHRA-2018-Cruz-Pedregon-car-courtesy-NHRA-Media-110x75.jpg" width="110" height="75" alt="Nitro Shots: For Your Viewing Pleasure" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/07/nitro-shots-for-your-viewing-pleasure/" title="Nitro Shots: For Your Viewing Pleasure">Nitro Shots: For Your Viewing Pleasure</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 7, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/nitro-shots-how-do-you-make-championships-exciting/" title="Nitro Shots: How Do You Make Championships Exciting?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Las-Vegas-Steve-Torrence-championship-courtesy-NHRA-media-110x75.jpg" width="110" height="75" alt="Nitro Shots: How Do You Make Championships Exciting?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/nitro-shots-how-do-you-make-championships-exciting/" title="Nitro Shots: How Do You Make Championships Exciting?">Nitro Shots: How Do You Make Championships Exciting?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/logno-110x75.jpg" width="110" height="75" alt="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/28/pace-laps-nascars-championship-4-a-little-clearer-following-martinsville/" title="Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville">Pace Laps: NASCAR&#8217;s Championship 4 a Little Clearer Following Martinsville</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 28, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/nitro-shots-all-things-big-small/" title="Nitro Shots: All Things Big &#038; Small"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Charlotte-Fall-Steve-Torrence-pits-credit-Toni-Montgomery-110x75.jpg" width="110" height="75" alt="Nitro Shots: All Things Big &#038; Small" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/nitro-shots-all-things-big-small/" title="Nitro Shots: All Things Big &#038; Small">Nitro Shots: All Things Big &#038; Small</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 17, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/14/pace-laps-a-tame-talladega/" title="Pace Laps: A Tame Talladega?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/f73c9f63beb9a32fa6ca8e0b4d53a1a8-11-110x75.jpg" width="110" height="75" alt="Pace Laps: A Tame Talladega?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/14/pace-laps-a-tame-talladega/" title="Pace Laps: A Tame Talladega?">Pace Laps: A Tame Talladega?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 14, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/13/carolina-nationals-qualifying-is-in-the-books/" title="Carolina Nationals Qualifying Is In The Books"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/NHRA-2018-Charlotte-Fall-Brittany-Force-top-qualifier-credit-Toni-Montgomery-110x75.jpg" width="110" height="75" alt="Carolina Nationals Qualifying Is In The Books" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/13/carolina-nationals-qualifying-is-in-the-books/" title="Carolina Nationals Qualifying Is In The Books">Carolina Nationals Qualifying Is In The Books</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 13, 2018</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/10/fernando-alonso-to-race-in-the-103rd-indianapolis-500-with-mclaren/" title="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2588-1-640x425.jpg" width="660" height="330" alt="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/10/fernando-alonso-to-race-in-the-103rd-indianapolis-500-with-mclaren/" title="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren">Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 10, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/log2-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Can Joey Logano Steal a Championship?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?">4 Burning Questions: Can Joey Logano Steal a Championship?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/BATTLE-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Closest Finishes Ever" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever">The Frontstretch 5: Closest Finishes Ever</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2042-1-110x75.jpg" width="110" height="75" alt="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign">Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 30, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/26/robert-wickens-left-paralyzed-from-waist-down-after-pocono-accident/" title="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident"><img src="https://www.frontstretch.com/wp-content/uploads/2018/08/wickn-110x75.jpg" width="110" height="75" alt="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/26/robert-wickens-left-paralyzed-from-waist-down-after-pocono-accident/" title="Robert Wickens Left Paralyzed from Waist Down After Pocono Accident">Robert Wickens Left Paralyzed from Waist Down After Pocono Accident</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 26, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/19/mclaren-will-not-field-full-time-entry-in-indycar-series-in-2019/" title="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2588-1-110x75.jpg" width="110" height="75" alt="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/19/mclaren-will-not-field-full-time-entry-in-indycar-series-in-2019/" title="McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019">McLaren Will Not Field Full-Time Entry in IndyCar Series in 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 19, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/ed-jones-set-for-road-courses-indianapolis-500-in-2019-with-ed-carpenter-racing/" title="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/JGS_2018-MIDOHIO-167087-1-110x75.jpg" width="110" height="75" alt="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/17/ed-jones-set-for-road-courses-indianapolis-500-in-2019-with-ed-carpenter-racing/" title="Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing">Ed Jones Set for Road Courses, Indianapolis 500 in 2019 With Ed Carpenter Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 17, 2018</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/matt-mcmurry-gabriel-aubry-join-pr1-mathiasen-motorsports-for-2019/" title="Matt McMurry, Gabriel Aubry Join PR1 Mathiasen Motorsports for 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2018/12/2018-Road-Atlanta-IWSC-Sebastian-Saavedra-Car-Phil-Allaway-660x425.jpg" width="660" height="330" alt="Matt McMurry, Gabriel Aubry Join PR1 Mathiasen Motorsports for 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/20/matt-mcmurry-gabriel-aubry-join-pr1-mathiasen-motorsports-for-2019/" title="Matt McMurry, Gabriel Aubry Join PR1 Mathiasen Motorsports for 2019">Matt McMurry, Gabriel Aubry Join PR1 Mathiasen Motorsports for 2019</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>December 20, 2018</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/precision-performance-motorsports-launches-weathertech-championship-effort/" title="Precision Performance Motorsports Launches WeatherTech Championship Effort"><img src="https://www.frontstretch.com/wp-content/uploads/2018/01/Quin-Houff-Iowa-XFINITY-110x75.jpg" width="110" height="75" alt="Precision Performance Motorsports Launches WeatherTech Championship Effort" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/19/precision-performance-motorsports-launches-weathertech-championship-effort/" title="Precision Performance Motorsports Launches WeatherTech Championship Effort">Precision Performance Motorsports Launches WeatherTech Championship Effort</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 19, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/14/montaplast-by-land-motorsport-reveals-rolex-24-at-daytona-lineup/" title="MONTAPLAST by Land-Motorsport Reveals Rolex 24 at Daytona Lineup"><img src="https://www.frontstretch.com/wp-content/uploads/2018/03/2018-Daytona-IWSC-Kelvin-van-der-Linde-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="MONTAPLAST by Land-Motorsport Reveals Rolex 24 at Daytona Lineup" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/14/montaplast-by-land-motorsport-reveals-rolex-24-at-daytona-lineup/" title="MONTAPLAST by Land-Motorsport Reveals Rolex 24 at Daytona Lineup">MONTAPLAST by Land-Motorsport Reveals Rolex 24 at Daytona Lineup</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 14, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/14/turner-motorsport-announces-double-duty-for-rolex-24-weekend/" title="Turner Motorsport Announces Double-Duty for Rolex 24 Weekend"><img src="https://www.frontstretch.com/wp-content/uploads/2018/12/2018-Daytona-IWSC-Mark-Kvamme-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Turner Motorsport Announces Double-Duty for Rolex 24 Weekend" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/12/14/turner-motorsport-announces-double-duty-for-rolex-24-weekend/" title="Turner Motorsport Announces Double-Duty for Rolex 24 Weekend">Turner Motorsport Announces Double-Duty for Rolex 24 Weekend</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 14, 2018</span></li></ul></div></div></div></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="http://fanduel.com/frontstretch" title="FanDuel - Play Now!" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/04/fd-nascar-generic-728x90.jpg" alt="FanDuel - Play Now!" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Best of 2018</span></div><article class="post-listing post-176649 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-dustin-albino category-featured-content category-mike-neff category-podcast category-zach-catanzareti tag-aric-almirola tag-chase-elliott tag-joey-logano tag-kevin-harvick tag-kyle-busch tag-martin-truex-jr tag-ross-chastain" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2018/11/logano-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Zach Catanzareti)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Best of 2018</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/mike-neff/" rel="category tag">Mike Neff</a>, <a href="https://www.frontstretch.com/category/podcast/" rel="category tag">Podcast</a>, <a href="https://www.frontstretch.com/category/zach-catanzareti/" rel="category tag">Zach Catanzareti</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2018/12/27/frontstretch-podcast-best-of-2018/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In a special offseason episode of the <em>Frontstretch Podcast</em>, <a href="https://twitter.com/DustinAlbino">Dustin Albino</a>, <a href="https://twitter.com/MNeffShortTrack">Mike Neff</a> and <a href="https://twitter.com/ZachRacing">Zach Catanzareti</a> discuss the best of 2018.</p><p>The gang kicks it off by discussing their favorite paint scheme of the year, excluding the Darlington throwback paint schemes. Next, we talk about our favorite quotes and finishes of 2018, some of which go hand-in-hand (Chicagoland Speedway and <a href="/tag/kyle-busch">Kyle Busch</a>).</p><p>The trio follows it up with the best race of the year and favorite Victory Lane celebration, which really boils down to <a href="/tag/joey-logano">Joey Logano</a> winning the championship and <a href="/tag/kevin-harvick">Kevin Harvick</a>&#8216;s quest of bringing youth into NASCAR.</p><p>Next, we talk our biggest surprises of 2018 and best breakout driver &#8212; <a href="/tag/aric-almirola">Aric Almirola</a> fits into both of these, as does <a href="/tag/ross-chastain">Ross Chastain</a>, among other drivers.</p><p>Finally, we discuss the best team of the year, which was divvied up between Busch&#8217;s No. 18 team and <a href="/tag/martin-truex-jr">Martin Truex Jr.</a>&#8216;s No. 78 Furniture Row Racing squad. We end it with the best driver, also a split between Busch and Harvick.</p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-176649-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2018/12/BEST-OF-FS-PODCAST.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2018/12/BEST-OF-FS-PODCAST.mp3">https://www.frontstretch.com/wp-content/uploads/2018/12/BEST-OF-FS-PODCAST.mp3</a></audio><p><em>Make sure to leave us a rating, review and subscribe to the Frontstretch Podcast: <a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p><p><i>Music. Thanks to Big Rock Kevin MacLeod (<a href="http://incompetech.com/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://incompetech.com&amp;source=gmail&amp;ust=1529623483308000&amp;usg=AFQjCNEYiPAsxhsXiokRatbNZRGiEs_xxA">incompetech.com</a>)</i></p></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=176649" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Best+of+2018&url=https://www.frontstretch.com/?p=176649" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=176649&amp;name=Frontstretch+Podcast%3A+Best+of+2018" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=176649&title=Frontstretch+Podcast%3A+Best+of+2018" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=176649&title=Frontstretch+Podcast%3A+Best+of+2018" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=176649&amp;description=Frontstretch+Podcast%3A+Best+of+2018&amp;media=https://www.frontstretch.com/wp-content/uploads/2018/11/logano-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2018-12-27T11:56:36+00:00","datePublished":"2018-12-27T11:56:36+00:00","dateModified":"2018-12-27T11:56:36+00:00","headline":"Frontstretch Podcast: Best of 2018","name":"Frontstretch Podcast: Best of 2018","keywords":"Aric Almirola,Chase Elliott,Joey Logano,Kevin Harvick,Kyle Busch,Martin Truex Jr.,Ross Chastain","url":"https:\/\/www.frontstretch.com\/2018\/12\/27\/frontstretch-podcast-best-of-2018\/","description":"In a special offseason episode of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino,\u00a0Mike Neff\u00a0and\u00a0Zach Catanzareti\u00a0discuss the best of 2018. The gang kicks it off by discussing their favorite paint scheme of t","copyrightYear":"2018","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2018\/12\/27\/frontstretch-podcast-best-of-2018\/"},"author":{"@type":"Person","name":"Dustin Albino","url":"https:\/\/www.frontstretch.com\/author\/dustin-albino\/"},"articleSection":"Cup Series,Dustin Albino,Featured Content,Mike Neff,Podcast,Zach Catanzareti","articleBody":"In a special offseason episode of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino,\u00a0Mike Neff\u00a0and\u00a0Zach Catanzareti\u00a0discuss the best of 2018.\r\n\r\nThe gang kicks it off by discussing their favorite paint scheme of the year, excluding the Darlington throwback paint schemes. Next, we talk about our favorite quotes and finishes of 2018, some of which go hand-in-hand (Chicagoland Speedway and Kyle Busch).\r\n\r\nThe trio follows it up with the best race of the year and favorite Victory Lane celebration, which really boils down to Joey Logano winning the championship and Kevin Harvick's quest of bringing youth into NASCAR.\r\n\r\nNext, we talk our biggest surprises of 2018 and best breakout driver -- Aric Almirola fits into both of these, as does Ross Chastain, among other drivers.\r\n\r\nFinally, we discuss the best team of the year, which was divvied up between Busch's No. 18 team and Martin Truex Jr.'s No. 78 Furniture Row Racing squad. We end it with the best driver, also a split between Busch and Harvick.\r\n\r\n\r\n\r\nMake sure to leave us a rating, review and subscribe to the Frontstretch Podcast:\u00a0iTunes\r\n\r\nMusic. Thanks to\u00a0Big Rock Kevin MacLeod (incompetech.com)","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2018\/11\/logano.jpg","width":974,"height":658}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/aric-almirola/" rel="tag">Aric Almirola</a> <a href="https://www.frontstretch.com/tag/chase-elliott/" rel="tag">Chase Elliott</a> <a href="https://www.frontstretch.com/tag/joey-logano/" rel="tag">Joey Logano</a> <a href="https://www.frontstretch.com/tag/kevin-harvick/" rel="tag">Kevin Harvick</a> <a href="https://www.frontstretch.com/tag/kyle-busch/" rel="tag">Kyle Busch</a> <a href="https://www.frontstretch.com/tag/martin-truex-jr/" rel="tag">Martin Truex Jr.</a> <a href="https://www.frontstretch.com/tag/ross-chastain/" rel="tag">Ross Chastain</a></p><div class="e3lan e3lan-post"> <a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon" /> </a></div><section id="author-box"><div class="block-head"><h3>About Dustin Albino</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361-150x138.jpg" width="90" height="83" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.</div><div class="author-social flat-social"> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a> <a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2018/12/27/2018-nascar-driver-reviews-david-ragan/" rel="prev"><span>Previous</span> 2018 NASCAR Driver Reviews: David Ragan</a></div><div class="post-next"></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/12/27/2018-nascar-driver-reviews-david-ragan/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/09/David-Ragan-38-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/12/27/2018-nascar-driver-reviews-david-ragan/" rel="bookmark">2018 NASCAR Driver Reviews: David Ragan</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/12/27/2018-xfinity-series-review-best-of-the-rest/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/11/Race_FE300-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/12/27/2018-xfinity-series-review-best-of-the-rest/" rel="bookmark">2018 Xfinity Series Review: Best of the Rest</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>December 27, 2018</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/12/21/2018-nascar-driver-reviews-jamie-mcmurray/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2017/03/2017-Fontana-CUP-Jamie-McMurray-Nigel-Kinrade-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2018/12/21/2018-nascar-driver-reviews-jamie-mcmurray/" rel="bookmark">2018 NASCAR Driver Reviews: Jamie McMurray</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>December 21, 2018</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2018/12/20/2018-xfinity-series-review-midpack-teams/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/06/clemnt-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2018/12/20/2018-xfinity-series-review-midpack-teams/" rel="bookmark">2018 Xfinity Series Review: Midpack Teams</a></h2><p>While all eyes were focused on teams in the playoffs, some of the best racing &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/12/27/frontstretch-podcast-best-of-2018/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='176649' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="dd7a3a4321" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="210"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="https://www.americanmuscle.com/2015-ford-mustang-parts.html"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/18-8594_am-2018-mustang-seo-banners_250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-10" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.fanduel.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/04/fd-nascar-generic-300x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="http://www.racingelectronics.com/"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/02/300x250-re-2018.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-2" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><p align="center"><a href="http://starcoachracetours.com/"><img src="https://frontstretch.com/wp-content/uploads/2015/02/starcoach_logo_fullcolor-2-1-e1424317191919.jpg"></a></p><p align="center"><a href="https://frontstretch.com/star-coach-race-tours-provides-the-epitome-of-nascar-luxury/">Star Coach Race Tours Provides the Epitome of NASCAR Luxury</a></p></div></div></div><div id="ads300_250-widget-12" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://www.patreon.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2018, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_82d449cd3c3ffce5056c7326747f00d0.js"></script></body></html>