<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_f3b91d2d676756a77bcd9dc4ba741792.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_6689916540184aa4d1d0baa34b7a1716.css" rel="stylesheet" /><title>Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</title> <script type="text/javascript">var ajaxurl = 'https://www.frontstretch.com/wp-admin/admin-ajax.php';</script> <meta property="og:title" content="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In this week's edition of the Frontstretch Podcast, Dustin Albino, Mike Neff and Aric Almirola discu"/><meta property="og:url" content="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-660x425.jpg" /><meta name="description" content="In this week&#039;s edition of the Frontstretch Podcast, Dustin Albino, Mike Neff and Aric Almirola discuss the new aerodynamic package that was displayed at"/><link rel="canonical" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts" /><meta property="og:description" content="In this week&#039;s edition of the Frontstretch Podcast, Dustin Albino, Mike Neff and Aric Almirola discuss the new aerodynamic package that was displayed at" /><meta property="og:url" content="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" /><meta property="article:tag" content="Aric Almirola" /><meta property="article:tag" content="Austin Dillon" /><meta property="article:tag" content="Joey Logano" /><meta property="article:tag" content="Kurt Busch" /><meta property="article:tag" content="Kyle Busch" /><meta property="article:tag" content="Ricky Stenhouse Jr." /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2019-03-07T01:41:25+00:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP.jpg" /><meta property="og:image:width" content="800" /><meta property="og:image:height" content="531" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In this week&#039;s edition of the Frontstretch Podcast, Dustin Albino, Mike Neff and Aric Almirola discuss the new aerodynamic package that was displayed at" /><meta name="twitter:title" content="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP.jpg" /><meta name="twitter:creator" content="@DustinAlbino" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts Comments Feed" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.4.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto', {'allowAnchor':true,'allowLinker':true});
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview', location.pathname + location.search + location.hash);
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.frontstretch.com","hash_tracking":"true"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.1" /><meta name="generator" content="Seriously Simple Podcasting 1.19.16" /><link rel='shortlink' href='https://www.frontstretch.com/?p=186313' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F03%2F06%2Ffrontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F03%2F06%2Ffrontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.0"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /></head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-186313 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-183833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183833"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-184021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184021"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-183834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183834"><a href="https://www.frontstretch.com/category/cup-series/cup-series-news/">Cup Series News</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/2-headed-monster-is-the-new-package-good/" title="2-Headed Monster: Is the New Package Good?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Las-Vegas-I-CUP-Joey-Logano-pack-racing-NKP-660x425.jpg" width="660" height="330" alt="2-Headed Monster: Is the New Package Good?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/2-headed-monster-is-the-new-package-good/" title="2-Headed Monster: Is the New Package Good?">2-Headed Monster: Is the New Package Good?</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts">Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/odds-ends-around-the-track-ticketguardian-500/" title="Odds &#038; Ends Around the Track: TicketGuardian 500"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/Aric-Almirola-Rodney-Childers-Kevin-HArvick-NKP-110x75.jpg" width="110" height="75" alt="Odds &#038; Ends Around the Track: TicketGuardian 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/odds-ends-around-the-track-ticketguardian-500/" title="Odds &#038; Ends Around the Track: TicketGuardian 500">Odds &#038; Ends Around the Track: TicketGuardian 500</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/bayley-currey-making-cup-series-debut-at-ism/" title="Bayley Currey Making Cup Debut at ISM"><img src="https://www.frontstretch.com/wp-content/uploads/2018/04/Bayley-Currey-110x75.jpg" width="110" height="75" alt="Bayley Currey Making Cup Debut at ISM" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/bayley-currey-making-cup-series-debut-at-ism/" title="Bayley Currey Making Cup Debut at ISM">Bayley Currey Making Cup Debut at ISM</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">Xfinity</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-184022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184022"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on Xfinity</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">Xfinity Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-660x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts">Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/eyes-on-xfinity-brandon-jones-regaining-confidence-with-joe-gibbs-racing/" title="Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/Brandon-Jones-Atlanta-2019-110x75.jpg" width="110" height="75" alt="Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/eyes-on-xfinity-brandon-jones-regaining-confidence-with-joe-gibbs-racing/" title="Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing">Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/nascar-mailbox-who-could-be-the-next-first-time-winner-in-the-xfinity-series/" title="NASCAR Mailbox: Who Could be the Next First-Time Winner in the Xfinity Series?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Las-Vegas-I-NXS-Jeremy-Clements-Ryan-Sieg-racing-NKP-110x75.jpg" width="110" height="75" alt="NASCAR Mailbox: Who Could be the Next First-Time Winner in the Xfinity Series?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/nascar-mailbox-who-could-be-the-next-first-time-winner-in-the-xfinity-series/" title="NASCAR Mailbox: Who Could be the Next First-Time Winner in the Xfinity Series?">NASCAR Mailbox: Who Could be the Next First-Time Winner in the Xfinity Series?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/05/couch-potato-tuesday-las-vegas-features-the-package-headscratching-decision-making/" title="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Las-Vegas-I-CUP-Kyle-Busch-pack-racing-NKP-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/05/couch-potato-tuesday-las-vegas-features-the-package-headscratching-decision-making/" title="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making">Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 5, 2019</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-183832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183832"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184020"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/truckin-thursdays-6-overlooked-things-from-the-first-3-races-of-2019/" title="Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/IMG_7768-660x425.jpg" width="660" height="330" alt="Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/truckin-thursdays-6-overlooked-things-from-the-first-3-races-of-2019/" title="Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019">Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/" title="Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts">Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/05/couch-potato-tuesday-las-vegas-features-the-package-headscratching-decision-making/" title="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Las-Vegas-I-CUP-Kyle-Busch-pack-racing-NKP-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/05/couch-potato-tuesday-las-vegas-features-the-package-headscratching-decision-making/" title="Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making">Couch Potato Tuesday: Las Vegas Features the Package, Headscratching Decision Making</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 5, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/04/tanner-thorson-injured-in-highway-accident/" title="Tanner Thorson Injured in Highway Accident"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2018-Talladega-CWTS-Tanner-Thorson-Nigel-Kinrade-Photography-110x75.jpg" width="110" height="75" alt="Tanner Thorson Injured in Highway Accident" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/04/tanner-thorson-injured-in-highway-accident/" title="Tanner Thorson Injured in Highway Accident">Tanner Thorson Injured in Highway Accident</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 4, 2019</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/02/27/clauson-marshall-racing-pippa-mann-entering-2019-indianapolis-500/" title="Clauson-Marshall Racing, Pippa Mann Entering 2019 Indianapolis 500"><img src="https://www.frontstretch.com/wp-content/uploads/2015/04/Pippa-Mann-Pink-Indy-500-660x439.jpg" width="660" height="330" alt="Clauson-Marshall Racing, Pippa Mann Entering 2019 Indianapolis 500" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/02/27/clauson-marshall-racing-pippa-mann-entering-2019-indianapolis-500/" title="Clauson-Marshall Racing, Pippa Mann Entering 2019 Indianapolis 500">Clauson-Marshall Racing, Pippa Mann Entering 2019 Indianapolis 500</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>February 27, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/01/22/max-chilton-returning-to-carlin-charlie-kimball-running-part-time/" title="Max Chilton Returning to Carlin, Charlie Kimball Running Part-Time"><img src="https://www.frontstretch.com/wp-content/uploads/2019/01/Max_Chilrton_2018-110x75.jpg" width="110" height="75" alt="Max Chilton Returning to Carlin, Charlie Kimball Running Part-Time" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/01/22/max-chilton-returning-to-carlin-charlie-kimball-running-part-time/" title="Max Chilton Returning to Carlin, Charlie Kimball Running Part-Time">Max Chilton Returning to Carlin, Charlie Kimball Running Part-Time</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 22, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/01/15/indycar-lands-ntt-data-as-new-title-sponsor/" title="IndyCar Lands NTT Data As New Title Sponsor"><img src="https://www.frontstretch.com/wp-content/uploads/2018/08/04CJ8939-110x75.jpg" width="110" height="75" alt="IndyCar Lands NTT Data As New Title Sponsor" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/01/15/indycar-lands-ntt-data-as-new-title-sponsor/" title="IndyCar Lands NTT Data As New Title Sponsor">IndyCar Lands NTT Data As New Title Sponsor</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 15, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/10/fernando-alonso-to-race-in-the-103rd-indianapolis-500-with-mclaren/" title="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2588-1-110x75.jpg" width="110" height="75" alt="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/10/fernando-alonso-to-race-in-the-103rd-indianapolis-500-with-mclaren/" title="Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren">Fernando Alonso to Race in the 103rd Indianapolis 500 with McLaren</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 10, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/log2-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Can Joey Logano Steal a Championship?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/11/01/4-burning-questions-can-joey-logano-steal-a-championship/" title="4 Burning Questions: Can Joey Logano Steal a Championship?">4 Burning Questions: Can Joey Logano Steal a Championship?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 1, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/BATTLE-110x75.jpg" width="110" height="75" alt="The Frontstretch 5: Closest Finishes Ever" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/31/the-frontstretch-5-closest-finishes-ever/" title="The Frontstretch 5: Closest Finishes Ever">The Frontstretch 5: Closest Finishes Ever</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2018</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign"><img src="https://www.frontstretch.com/wp-content/uploads/2018/10/16C_2042-1-110x75.jpg" width="110" height="75" alt="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2018/10/30/schmidt-peterson-motorsports-tabs-marcus-ericsson-for-2019-indycar-campaign/" title="Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign">Schmidt Peterson Motorsports Tabs Marcus Ericsson for 2019 IndyCar Campaign</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 30, 2018</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/alan-brynjolfsson-trent-hindman-win-cota-pirelli-gt4-america-race-no-2/" title="Alan Brynjolfsson, Trent Hindman Win COTA Pirelli GT4 America Race No. 2"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Daytona-IMPC-Trent-Hindman-Car-Phil-Allaway-660x425.jpg" width="660" height="330" alt="Alan Brynjolfsson, Trent Hindman Win COTA Pirelli GT4 America Race No. 2" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/alan-brynjolfsson-trent-hindman-win-cota-pirelli-gt4-america-race-no-2/" title="Alan Brynjolfsson, Trent Hindman Win COTA Pirelli GT4 America Race No. 2">Alan Brynjolfsson, Trent Hindman Win COTA Pirelli GT4 America Race No. 2</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>March 3, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/pace-laps-penskes-power-the-kyle-busch-show-in-las-vegas/" title="Pace Laps: Penske&#8217;s Power &#038; The Kyle Busch Show In Las Vegas"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/a727f05e9a96152187d38e322f07fab2-11-110x75.jpg" width="110" height="75" alt="Pace Laps: Penske&#8217;s Power &#038; The Kyle Busch Show In Las Vegas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/pace-laps-penskes-power-the-kyle-busch-show-in-las-vegas/" title="Pace Laps: Penske&#8217;s Power &#038; The Kyle Busch Show In Las Vegas">Pace Laps: Penske&#8217;s Power &#038; The Kyle Busch Show In Las Vegas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 3, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/r-ferri-motorsports-claims-cota-blancpain-gt-world-challenge-america-race-no-2/" title="R. Ferri Motorsports Claims COTA Blancpain GT World Challenge America Race No. 2"><img src="https://www.frontstretch.com/wp-content/uploads/2018/03/2018-COTA-PWC-Toni-Vilander-Miguel-Molina-Podium-WC-Vision-110x75.jpg" width="110" height="75" alt="R. Ferri Motorsports Claims COTA Blancpain GT World Challenge America Race No. 2" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/03/r-ferri-motorsports-claims-cota-blancpain-gt-world-challenge-america-race-no-2/" title="R. Ferri Motorsports Claims COTA Blancpain GT World Challenge America Race No. 2">R. Ferri Motorsports Claims COTA Blancpain GT World Challenge America Race No. 2</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 3, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/02/nolasports-matt-travis-jason-hart-dominate-cota-gt4-america-race-no-1/" title="NOLAsport&#8217;s Matt Travis, Jason Hart Dominate COTA GT4 America Race No. 1"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2018-Lime-Rock-PWC-Jason-Hart-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="NOLAsport&#8217;s Matt Travis, Jason Hart Dominate COTA GT4 America Race No. 1" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/03/02/nolasports-matt-travis-jason-hart-dominate-cota-gt4-america-race-no-1/" title="NOLAsport&#8217;s Matt Travis, Jason Hart Dominate COTA GT4 America Race No. 1">NOLAsport&#8217;s Matt Travis, Jason Hart Dominate COTA GT4 America Race No. 1</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 2, 2019</span></li></ul></div></div></div></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li><li id="menu-item-183998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-183998"><a>Race / Team Info</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184023"><a href="https://frontstretch.com">2019 Schedules</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184024"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184025"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">Xfinity Series</a></li><li id="menu-item-184026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184026"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-183999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183999"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-177919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-177919"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/">Paint Schemes</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184000"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/cup-series/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184001"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/xfinity-series/">Xfinity Series</a></li><li id="menu-item-184002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184002"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/truck-series/">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-184004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184004"><a>Team Charts</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184003"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">Gander Outdoors Truck Series</a></li></ul></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.americanmuscle.com/2008-dodge-challenger-accessories-parts.html" title="American Muscle - Challenger Parts are here!" > <img src="https://www.frontstretch.com/wp-content/uploads/2019/01/american-muscle-banner-728x90.jpg" alt="American Muscle - Challenger Parts are here!" /> </a></div><div id="main-content" class="container"><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</span></div><article class="post-listing post-186313 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-dustin-albino category-featured-content category-mike-neff category-podcast category-truck-series category-xfinity tag-aric-almirola tag-austin-dillon tag-joey-logano tag-kurt-busch tag-kyle-busch tag-ricky-stenhouse-jr" id="the-post"><div class="single-post-thumb"> <img width="660" height="425" src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-660x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" /></div><div class="single-post-caption">(Photo: Nigel Kinrade Photography)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/mike-neff/" rel="category tag">Mike Neff</a>, <a href="https://www.frontstretch.com/category/podcast/" rel="category tag">Podcast</a>, <a href="https://www.frontstretch.com/category/truck-series/" rel="category tag">Truck Series</a>, <a href="https://www.frontstretch.com/category/xfinity/" rel="category tag">Xfinity</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In this week&#8217;s edition of the <em>Frontstretch Podcast</em>, <a href="https://twitter.com/DustinAlbino">Dustin Albino</a>, <a href="https://twitter.com/MNeffShortTrack">Mike Neff</a> and <a href="/tag/aric-almirola">Aric Almirola</a> discuss the new aerodynamic package that was displayed at Las Vegas Motor Speedway and how it led to wild restarts and a peculiar qualifying session last Friday (March 1).</p><p>Almirola states the race was exciting, and that&#8217;s what he enjoys as a race car driver, though there may need to be some tweaks moving forward. One of those adjustments includes modification to qualifying, as he believes NASCAR may need to step in and alter the group qualifying format.</p><p>Albino and Neff discuss Team Penske currently being the best team in the sport, as <a href="/tag/joey-logano">Joey Logano</a> went to Victory Lane with <a href="/tag/brad-keselowski">Brad Keselowski</a> in close pursuit.</p><p>Next, they discuss <a href="/tag/kyle-busch">Kyle Busch</a> and his impressive comeback after a pit road speeding penalty. Speaking of penalties, <a href="/tag/austin-dillon">Austin Dillon</a> could never rebound from his odd pit road penalty, nor could <a href="/tag/kyle-larson">Kyle Larson</a>.</p><p>Finally, the duo discuss strong performances from <a href="/tag/kurt-busch">Kurt Busch</a> and <a href="/tag/ricky-stenhouse-jr">Ricky Stenhouse Jr.</a> Could this be the turning point for the No. 17 team and Roush Fenway Racing? Listen in to find out.</p><p><em>Make sure to leave us a rating, review and subscribe to the Frontstretch Podcast: <a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-186313-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2019/03/Phoenix-I-FS-PODCAST.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2019/03/Phoenix-I-FS-PODCAST.mp3">https://www.frontstretch.com/wp-content/uploads/2019/03/Phoenix-I-FS-PODCAST.mp3</a></audio></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=186313" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Aric+Almirola+Talks+New+Aero+Package%2C+Group+Qualifying%2C+Chaotic+Restarts&url=https://www.frontstretch.com/?p=186313" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=186313&amp;name=Frontstretch+Podcast%3A+Aric+Almirola+Talks+New+Aero+Package%2C+Group+Qualifying%2C+Chaotic+Restarts" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=186313&title=Frontstretch+Podcast%3A+Aric+Almirola+Talks+New+Aero+Package%2C+Group+Qualifying%2C+Chaotic+Restarts" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=186313&title=Frontstretch+Podcast%3A+Aric+Almirola+Talks+New+Aero+Package%2C+Group+Qualifying%2C+Chaotic+Restarts" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=186313&amp;description=Frontstretch+Podcast%3A+Aric+Almirola+Talks+New+Aero+Package%2C+Group+Qualifying%2C+Chaotic+Restarts&amp;media=https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Aric-Almirola-NKP-660x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2019-03-06T20:41:25-05:00","datePublished":"2019-03-06T20:41:25-05:00","dateModified":"2019-03-06T20:41:25-05:00","headline":"Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts","name":"Frontstretch Podcast: Aric Almirola Talks New Aero Package, Group Qualifying, Chaotic Restarts","keywords":"Aric Almirola,Austin Dillon,Joey Logano,Kurt Busch,Kyle Busch,Ricky Stenhouse Jr.","url":"https:\/\/www.frontstretch.com\/2019\/03\/06\/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts\/","description":"In this week's edition of the Frontstretch Podcast,\u00a0Dustin Albino,\u00a0Mike Neff and Aric Almirola discuss the new aerodynamic package that was displayed at Las Vegas Motor Speedway and how it led to wild","copyrightYear":"2019","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2019\/03\/06\/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts\/"},"author":{"@type":"Person","name":"Dustin Albino","url":"https:\/\/www.frontstretch.com\/author\/dustin-albino\/"},"articleSection":"Cup Series,Dustin Albino,Featured Content,Mike Neff,Podcast,Truck Series,Xfinity","articleBody":"In this week's edition of the Frontstretch Podcast,\u00a0Dustin Albino,\u00a0Mike Neff and Aric Almirola discuss the new aerodynamic package that was displayed at Las Vegas Motor Speedway and how it led to wild restarts and a peculiar qualifying session last Friday (March 1).\r\n\r\nAlmirola states the race was exciting, and that's what he enjoys as a race car driver, though there may need to be some tweaks moving forward. One of those adjustments includes modification to qualifying, as he believes NASCAR may need to step in and alter the group qualifying format.\r\n\r\nAlbino and Neff discuss Team Penske currently being the best team in the sport, as Joey Logano went to Victory Lane with Brad Keselowski in close pursuit.\r\n\r\nNext, they discuss Kyle Busch and his impressive comeback after a pit road speeding penalty. Speaking of penalties, Austin Dillon could never rebound from his odd pit road penalty, nor could Kyle Larson.\r\n\r\nFinally, the duo discuss strong performances from Kurt Busch and Ricky Stenhouse Jr. Could this be the turning point for the No. 17 team and Roush Fenway Racing? Listen in to find out.\r\n\r\nMake sure to leave us a rating, review and subscribe to the Frontstretch Podcast:\u00a0iTunes\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2019\/02\/2019-Atlanta-CUP-Aric-Almirola-NKP.jpg","width":800,"height":531}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/aric-almirola/" rel="tag">Aric Almirola</a> <a href="https://www.frontstretch.com/tag/austin-dillon/" rel="tag">Austin Dillon</a> <a href="https://www.frontstretch.com/tag/joey-logano/" rel="tag">Joey Logano</a> <a href="https://www.frontstretch.com/tag/kurt-busch/" rel="tag">Kurt Busch</a> <a href="https://www.frontstretch.com/tag/kyle-busch/" rel="tag">Kyle Busch</a> <a href="https://www.frontstretch.com/tag/ricky-stenhouse-jr/" rel="tag">Ricky Stenhouse Jr.</a></p><div class="e3lan e3lan-post"> <a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon" /> </a></div><section id="author-box"><div class="block-head"><h3>About Dustin Albino</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361-150x138.jpg" width="90" height="83" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.</div><div class="author-social flat-social"> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a> <a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2019/03/06/eyes-on-xfinity-brandon-jones-regaining-confidence-with-joe-gibbs-racing/" rel="prev"><span>Previous</span> Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing</a></div><div class="post-next"><a href="https://www.frontstretch.com/2019/03/06/truckin-thursdays-6-overlooked-things-from-the-first-3-races-of-2019/" rel="next"><span>Next</span> Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/03/06/2-headed-monster-is-the-new-package-good/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Las-Vegas-I-CUP-Joey-Logano-pack-racing-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/03/06/2-headed-monster-is-the-new-package-good/" rel="bookmark">2-Headed Monster: Is the New Package Good?</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/03/06/truckin-thursdays-6-overlooked-things-from-the-first-3-races-of-2019/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/02/IMG_7768-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/03/06/truckin-thursdays-6-overlooked-things-from-the-first-3-races-of-2019/" rel="bookmark">Truckin&#8217; Thursdays: 6 Overlooked Things from the First 3 Races of 2019</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/03/06/eyes-on-xfinity-brandon-jones-regaining-confidence-with-joe-gibbs-racing/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/03/Brandon-Jones-Atlanta-2019-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/03/06/eyes-on-xfinity-brandon-jones-regaining-confidence-with-joe-gibbs-racing/" rel="bookmark">Eyes on Xfinity: Brandon Jones Regaining Confidence with Joe Gibbs Racing</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 6, 2019</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/03/06/odds-ends-around-the-track-ticketguardian-500/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/02/Aric-Almirola-Rodney-Childers-Kevin-HArvick-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2019/03/06/odds-ends-around-the-track-ticketguardian-500/" rel="bookmark">Odds &#038; Ends Around the Track: TicketGuardian 500</a></h2><p>The biggest debate among NASCAR fans and media was typical: Was Las Vegas a good &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/03/06/frontstretch-podcast-aric-almirola-talks-new-aero-package-group-qualifying-chaotic-restarts/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='186313' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c954cbe89f" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="115"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="https://www.americanmuscle.com/2015-ford-mustang-parts.html"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/18-8594_am-2018-mustang-seo-banners_250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://racingelectronics.com/collections/legend-fanvision/products/legend-gray"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019_re_310x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-12" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://www.patreon.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2019, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_6bddc7e03448259b7fc30dad528db34c.js"></script></body></html>