<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_745e873cad7e203ddc757572c30530f0.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_6689916540184aa4d1d0baa34b7a1716.css" rel="stylesheet" /><title>Frontstretch Podcast: Bobby Labonte Examines Career, Highs &amp; Lows</title><meta property="og:title" content="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss the Monday m"/><meta property="og:url" content="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-640x425.jpg" /><meta name="description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway"/><link rel="canonical" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &amp; Lows" /><meta property="og:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway" /><meta property="og:url" content="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Frontstretch" /><meta property="article:tag" content="Austin Dillon" /><meta property="article:tag" content="Bobby Labonte" /><meta property="article:tag" content="Clint Bowyer" /><meta property="article:tag" content="derek kraus" /><meta property="article:tag" content="Greg Biffle" /><meta property="article:tag" content="Hailie Deegan" /><meta property="article:tag" content="Joey Logano" /><meta property="article:tag" content="Kevin Harvick" /><meta property="article:tag" content="Tyler Reddick" /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2019-06-12T23:17:53+00:00" /><meta property="article:modified_time" content="2019-06-13T01:52:35+00:00" /><meta property="og:updated_time" content="2019-06-13T01:52:35+00:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas.jpg" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="425" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway" /><meta name="twitter:title" content="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &amp; Lows" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas.jpg" /><meta name="twitter:creator" content="@Frontstretch" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.frontstretch.com/#organization","name":"","url":"https://www.frontstretch.com/","sameAs":["https://www.facebook.com/Frontstretch","https://instagram.com/frontstretchdotcom/","https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw","https://twitter.com/Frontstretch"]},{"@type":"WebSite","@id":"https://www.frontstretch.com/#website","url":"https://www.frontstretch.com/","name":"Frontstretch","publisher":{"@id":"https://www.frontstretch.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.frontstretch.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#webpage","url":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/","inLanguage":"en","name":"Frontstretch Podcast: Bobby Labonte Examines Career, Highs &amp; Lows","isPartOf":{"@id":"https://www.frontstretch.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#primaryimage","url":"https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas.jpg","width":640,"height":425},"primaryImageOfPage":{"@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#primaryimage"},"datePublished":"2019-06-12T23:17:53+00:00","dateModified":"2019-06-13T01:52:35+00:00","description":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway"},{"@type":"Article","@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#article","isPartOf":{"@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#webpage"},"author":{"@id":"https://www.frontstretch.com/author/staff/#author"},"headline":"Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows","datePublished":"2019-06-12T23:17:53+00:00","dateModified":"2019-06-13T01:52:35+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#webpage"},"publisher":{"@id":"https://www.frontstretch.com/#organization"},"image":{"@id":"https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#primaryimage"},"keywords":"Austin Dillon,Bobby Labonte,Clint Bowyer,derek kraus,Greg Biffle,Hailie Deegan,Joey Logano,Kevin Harvick,Tyler Reddick","articleSection":"Cup Series,Dustin Albino,Featured Content,Mike Neff,Podcast,Truck Series,Xfinity"},{"@type":["Person"],"@id":"https://www.frontstretch.com/author/staff/#author","name":"Frontstretch Staff","image":{"@type":"ImageObject","@id":"https://www.frontstretch.com/#authorlogo","url":"https://www.frontstretch.com/wp-content/uploads/2015/06/frontstretch-sq-logo.png","caption":"Frontstretch Staff"},"description":"The Frontstretch Staff is made up of a group of talented men and women spread out all over the United States and Canada. Residing in 15 states throughout the country, plus Ontario, and widely ranging in age, the staff showcases a wide variety of diverse opinions that will keep you coming back for more week in and week out.","sameAs":["https://www.facebook.com/Frontstretch","https://www.instagram.com/frontstretchdotcom/","https://www.pinterest.com/frontstretch/","https://twitter.com/Frontstretch","https://www.youtube.com/user/Frontstretch"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows Comments Feed" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.6.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto', {'allowAnchor':true});
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview', location.pathname + location.search + location.hash);
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.frontstretch.com","hash_tracking":"true"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.1" /><meta name="generator" content="Seriously Simple Podcasting 1.20.2" /><link rel='shortlink' href='https://www.frontstretch.com/?p=197859' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F06%2F12%2Ffrontstretch-podcast-bobby-labonte-examines-career-highs-lows%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F06%2F12%2Ffrontstretch-podcast-bobby-labonte-examines-career-highs-lows%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.1"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="application/javascript" src="//ced.sascdn.com/tag/3265/smart.js" async></script> <script type="application/javascript">var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "//www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 293194,
            pageId: 1078178,
            formats: [
                 { id: 71430 }
                ,{ id: 71427 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3515913239267445",
          enable_page_level_ads: true
     });</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-197859 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" rel="noopener noreferrer" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-183833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183833"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-189006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189006"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184021"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-183834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183834"><a href="https://www.frontstretch.com/category/cup-series/cup-series-news/">Cup Series News</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/odds-and-ends-around-the-track-trouble-in-paradise-edition/" title="Odds &#038; Ends Around the Track: Trouble in Paradise Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Michigan-I-CUP-Ryan-Blaney-Corey-LaJoie-Bubba-Wallace-football-NKP-660x425.jpg" width="660" height="330" alt="Odds &#038; Ends Around the Track: Trouble in Paradise Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/odds-and-ends-around-the-track-trouble-in-paradise-edition/" title="Odds &#038; Ends Around the Track: Trouble in Paradise Edition">Odds &#038; Ends Around the Track: Trouble in Paradise Edition</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/2-headed-monster-should-stewart-haas-racing-keep-clint-bowyer/" title="2-Headed Monster: Should Stewart-Haas Racing Keep Clint Bowyer?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Michigan-I-CUP-Clint-Bowyer-helmet-NKP-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Should Stewart-Haas Racing Keep Clint Bowyer?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/2-headed-monster-should-stewart-haas-racing-keep-clint-bowyer/" title="2-Headed Monster: Should Stewart-Haas Racing Keep Clint Bowyer?">2-Headed Monster: Should Stewart-Haas Racing Keep Clint Bowyer?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows">Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/nationwide-leaving-hendrick-after-2019/" title="Nationwide Leaving Hendrick After 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Michigan-I-CUP-Alex-Bowman-car-NKP-110x75.jpg" width="110" height="75" alt="Nationwide Leaving Hendrick After 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/nationwide-leaving-hendrick-after-2019/" title="Nationwide Leaving Hendrick After 2019">Nationwide Leaving Hendrick After 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">Xfinity</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-191283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191283"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184022"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on Xfinity</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">Xfinity Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/eyes-on-xfinity-michael-annett-feeling-rejuvenated-in-2019/" title="Eyes on Xfinity: Michael Annett Feeling Rejuvenated In 2019"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/Michael-Annett-Richmond-I-2019-640x425.jpg" width="660" height="330" alt="Eyes on Xfinity: Michael Annett Feeling Rejuvenated In 2019" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/eyes-on-xfinity-michael-annett-feeling-rejuvenated-in-2019/" title="Eyes on Xfinity: Michael Annett Feeling Rejuvenated In 2019">Eyes on Xfinity: Michael Annett Feeling Rejuvenated In 2019</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows">Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/11/jeff-green-to-miss-remainder-of-2019-season-after-kentucky/" title="Jeff Green to Miss Remainder of 2019 Season After Kentucky"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/2019-Phoenix-I-NXS-Jeff-Green-NKP-110x75.jpg" width="110" height="75" alt="Jeff Green to Miss Remainder of 2019 Season After Kentucky" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/11/jeff-green-to-miss-remainder-of-2019-season-after-kentucky/" title="Jeff Green to Miss Remainder of 2019 Season After Kentucky">Jeff Green to Miss Remainder of 2019 Season After Kentucky</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 11, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/entry-list-circuitcity-com-250/" title="Entry List: CircuitCity.com 250"><img src="https://www.frontstretch.com/wp-content/uploads/2018/06/Restart-Turn3-110x75.jpg" width="110" height="75" alt="Entry List: CircuitCity.com 250" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/entry-list-circuitcity-com-250/" title="Entry List: CircuitCity.com 250">Entry List: CircuitCity.com 250</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 10, 2019</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-183832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183832"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184020"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/truckin-thursdays-josh-reaume-building-his-team-business-one-race-at-a-time/" title="Truckin&#8217; Thursdays: Josh Reaume Building His Team &#038; Business One Race at a Time"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-GOTS-Texas-Josh-Reaume-On-Track-Rick-Lunkenheimer-660x425.jpg" width="660" height="330" alt="Truckin&#8217; Thursdays: Josh Reaume Building His Team &#038; Business One Race at a Time" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/truckin-thursdays-josh-reaume-building-his-team-business-one-race-at-a-time/" title="Truckin&#8217; Thursdays: Josh Reaume Building His Team &#038; Business One Race at a Time">Truckin&#8217; Thursdays: Josh Reaume Building His Team &#038; Business One Race at a Time</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/" title="Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows">Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/tyler-ankrum-to-run-partial-schedule-for-rest-of-2019-due-to-lack-of-sponsorship/" title="Tyler Ankrum to Run Partial Schedule for Rest of 2019 Due to Lack of Sponsorship"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Texas-GOTS-Tyler-Ankrum-NKP-110x75.jpg" width="110" height="75" alt="Tyler Ankrum to Run Partial Schedule for Rest of 2019 Due to Lack of Sponsorship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/tyler-ankrum-to-run-partial-schedule-for-rest-of-2019-due-to-lack-of-sponsorship/" title="Tyler Ankrum to Run Partial Schedule for Rest of 2019 Due to Lack of Sponsorship">Tyler Ankrum to Run Partial Schedule for Rest of 2019 Due to Lack of Sponsorship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/entry-list-mms-200/" title="Entry List: M&#038;M&#8217;s 200"><img src="https://www.frontstretch.com/wp-content/uploads/2018/06/Brett_Moffitt_MMs2002-110x75.jpg" width="110" height="75" alt="Entry List: M&#038;M&#8217;s 200" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/entry-list-mms-200/" title="Entry List: M&#038;M&#8217;s 200">Entry List: M&#038;M&#8217;s 200</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 10, 2019</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/josef-newgarden-wins-saturday-night-shootout-in-texas/" title="Josef Newgarden Wins Saturday Night Shootout in Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2018/08/newg-660x425.jpg" width="660" height="330" alt="Josef Newgarden Wins Saturday Night Shootout in Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/josef-newgarden-wins-saturday-night-shootout-in-texas/" title="Josef Newgarden Wins Saturday Night Shootout in Texas">Josef Newgarden Wins Saturday Night Shootout in Texas</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>June 8, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/ntt-indycar-series-hits-the-high-banks-of-texas-motor-speedway/" title="NTT IndyCar Series Hits the High Banks of Texas Motor Speedway"><img src="https://www.frontstretch.com/wp-content/uploads/2016/06/16C_3190-1-110x75.jpg" width="110" height="75" alt="NTT IndyCar Series Hits the High Banks of Texas Motor Speedway" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/ntt-indycar-series-hits-the-high-banks-of-texas-motor-speedway/" title="NTT IndyCar Series Hits the High Banks of Texas Motor Speedway">NTT IndyCar Series Hits the High Banks of Texas Motor Speedway</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 8, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/06/4-burning-questions-is-christopher-bell-about-to-replace-clint-bowyer/" title="4 Burning Questions: Is Christopher Bell About To Replace Clint Bowyer?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/b06e9b34bd0350b0dfb735107940c54f-11-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Is Christopher Bell About To Replace Clint Bowyer?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/06/4-burning-questions-is-christopher-bell-about-to-replace-clint-bowyer/" title="4 Burning Questions: Is Christopher Bell About To Replace Clint Bowyer?">4 Burning Questions: Is Christopher Bell About To Replace Clint Bowyer?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/05/frontstretch-podcast-poc-oh-no-chase-briscoe-chats-season-best-run/" title="Frontstretch Podcast: Poc-oh-no, Chase Briscoe Chats Season-Best Run"><img src="https://www.frontstretch.com/wp-content/uploads/2019/04/Chase-Briscoe-Fontana-110x75.jpg" width="110" height="75" alt="Frontstretch Podcast: Poc-oh-no, Chase Briscoe Chats Season-Best Run" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/05/frontstretch-podcast-poc-oh-no-chase-briscoe-chats-season-best-run/" title="Frontstretch Podcast: Poc-oh-no, Chase Briscoe Chats Season-Best Run">Frontstretch Podcast: Poc-oh-no, Chase Briscoe Chats Season-Best Run</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 5, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/04/conor-daly-to-drive-for-carlin-at-texas/" title="Conor Daly to Drive for Carlin at Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/16C1572-EDIT-1-110x75.jpg" width="110" height="75" alt="Conor Daly to Drive for Carlin at Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/04/conor-daly-to-drive-for-carlin-at-texas/" title="Conor Daly to Drive for Carlin at Texas">Conor Daly to Drive for Carlin at Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 4, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/02/kyle-busch-dominates-pocono-cole-custer-wins-big-indycar-tackles-detroit/" title="Pace Laps: Kyle Busch Dominates Pocono, Cole Custer Wins Big and IndyCar Tackles Detroit"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/b756cb6b33f3120c4eae97d3ba82205f-11-110x75.jpg" width="110" height="75" alt="Pace Laps: Kyle Busch Dominates Pocono, Cole Custer Wins Big and IndyCar Tackles Detroit" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/02/kyle-busch-dominates-pocono-cole-custer-wins-big-indycar-tackles-detroit/" title="Pace Laps: Kyle Busch Dominates Pocono, Cole Custer Wins Big and IndyCar Tackles Detroit">Pace Laps: Kyle Busch Dominates Pocono, Cole Custer Wins Big and IndyCar Tackles Detroit</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 2, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/02/indycar-detroit-grand-prix-dual-2-recap-results-scott-dixon-wins/" title="A Day After Crashing, Scott Dixon Wins Wild Detroit Grand Prix Dual 2"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/Scott_Dixon_JB-110x75.jpg" width="110" height="75" alt="A Day After Crashing, Scott Dixon Wins Wild Detroit Grand Prix Dual 2" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/02/indycar-detroit-grand-prix-dual-2-recap-results-scott-dixon-wins/" title="A Day After Crashing, Scott Dixon Wins Wild Detroit Grand Prix Dual 2">A Day After Crashing, Scott Dixon Wins Wild Detroit Grand Prix Dual 2</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 2, 2019</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/kamui-kobayashi-earns-le-mans-provisional-pole/" title="Kamui Kobayashi Earns Le Mans Provisional Pole"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Le-Mans-WEC-Kamui-Kobayashi-Car-Joao-Filipe-Alves-Beato-Adrenal-Media-660x425.jpg" width="660" height="330" alt="Kamui Kobayashi Earns Le Mans Provisional Pole" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/12/kamui-kobayashi-earns-le-mans-provisional-pole/" title="Kamui Kobayashi Earns Le Mans Provisional Pole">Kamui Kobayashi Earns Le Mans Provisional Pole</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/scott-hargrove-patrick-long-win-sonoma-blancpain-gt-race-no-2/" title="Scott Hargrove, Patrick Long Win Sonoma Blancpain GT Race No. 2"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2018-Lime-Rock-IWSC-Christina-Nielsen-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Scott Hargrove, Patrick Long Win Sonoma Blancpain GT Race No. 2" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/10/scott-hargrove-patrick-long-win-sonoma-blancpain-gt-race-no-2/" title="Scott Hargrove, Patrick Long Win Sonoma Blancpain GT Race No. 2">Scott Hargrove, Patrick Long Win Sonoma Blancpain GT Race No. 2</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 10, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/09/murillo-racing-wins-pirelli-gt4-sprintx-race-no-2-at-sonoma/" title="Murillo Racing Wins Pirelli GT4 SprintX Race No. 2 at Sonoma"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2018-Lime-Rock-PWC-Christian-Szymczak-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Murillo Racing Wins Pirelli GT4 SprintX Race No. 2 at Sonoma" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/09/murillo-racing-wins-pirelli-gt4-sprintx-race-no-2-at-sonoma/" title="Murillo Racing Wins Pirelli GT4 SprintX Race No. 2 at Sonoma">Murillo Racing Wins Pirelli GT4 SprintX Race No. 2 at Sonoma</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 9, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/09/pace-laps-michigan-monsoon-makes-for-monday-nascar-racing/" title="Pace Laps: Michigan Monsoon Makes For Monday NASCAR Racing"><img src="https://www.frontstretch.com/wp-content/uploads/2018/09/rainme-110x75.jpg" width="110" height="75" alt="Pace Laps: Michigan Monsoon Makes For Monday NASCAR Racing" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/09/pace-laps-michigan-monsoon-makes-for-monday-nascar-racing/" title="Pace Laps: Michigan Monsoon Makes For Monday NASCAR Racing">Pace Laps: Michigan Monsoon Makes For Monday NASCAR Racing</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 9, 2019</span></li></ul></div></div></div></li><li id="menu-item-186592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-186592"><a href="https://www.frontstretch.com/category/arca/">ARCA</a></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li><li id="menu-item-183998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-183998"><a>Race / Team Info</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184023"><a href="https://frontstretch.com">2019 Schedules</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184024"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184025"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">Xfinity Series</a></li><li id="menu-item-184026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184026"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-183999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183999"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-177919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-177919"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/">Paint Schemes</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184000"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/cup-series/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184001"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/xfinity-series/">Xfinity Series</a></li><li id="menu-item-184002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184002"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/truck-series/">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-184004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184004"><a>Team Charts</a><ul class="sub-menu menu-sub-content"><li id="menu-item-189005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189005"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-191282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191282"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">Xfinity Series</a></li><li id="menu-item-184003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184003"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">Gander Outdoors Truck Series</a></li></ul></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.americanmuscle.com/2008-dodge-challenger-accessories-parts.html" title="American Muscle - Challenger Parts are here!" > <img src="https://www.frontstretch.com/wp-content/uploads/2019/01/american-muscle-banner-728x90.jpg" alt="American Muscle - Challenger Parts are here!" /> </a></div><div id="main-content" class="container"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div id="sas_71428"></div> <script type="application/javascript">sas.cmd.push(function() {
        sas.render("71428");  // Format : 728x90_RON 728x90
    });</script></div><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows</span></div><article class="post-listing post-197859 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-dustin-albino category-featured-content category-mike-neff category-podcast category-truck-series category-xfinity tag-austin-dillon tag-bobby-labonte tag-clint-bowyer tag-derek-kraus tag-greg-biffle tag-hailie-deegan tag-joey-logano tag-kevin-harvick tag-tyler-reddick" id="the-post"><div class="single-post-thumb"> <img width="640" height="425" src="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-640x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas.jpg 640w, https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-150x100.jpg 150w, https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-300x199.jpg 300w, https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-310x205.jpg 310w" sizes="(max-width: 640px) 100vw, 640px" /></div><div class="single-post-caption">(Photo: Nigel Kinrade Photography)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/staff/" title="">Frontstretch Staff </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/mike-neff/" rel="category tag">Mike Neff</a>, <a href="https://www.frontstretch.com/category/podcast/" rel="category tag">Podcast</a>, <a href="https://www.frontstretch.com/category/truck-series/" rel="category tag">Truck Series</a>, <a href="https://www.frontstretch.com/category/xfinity/" rel="category tag">Xfinity</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In this week’s edition of the <em>Frontstretch Podcast</em>, <a href="https://www.frontstretch.com/twitter.com/dustinalbino">Dustin Albino</a> and <a href="https://twitter.com/MNeffShortTrack">Mike Neff</a> discuss the Monday matinee (June 10) at Michigan International Speedway where <a href="/tag/joey-logano">Joey Logano</a> put a whippin&#8217; on the field en route to his second victory of 2019.</p><p>Spoiler alert, we didn&#8217;t like the action we saw, and neither did <a href="/tag/kevin-harvick">Kevin Harvick</a>, who once again overcame pit road woes just to have a fighter&#8217;s chance at the win. Ultimately, Rodney Childers called for four tires late and lost valuable track position.</p><p>It wasn&#8217;t a good day for <a href="/tag/clint-bowyer">Clint Bowyer</a> either, who said after a mid-race wreck, &#8220;This isn&#8217;t racing.&#8221; We give our take on his comments. Another fast car was thrown out the window for <a href="/tag/austin-dillon">Austin Dillon</a> with a late wreck, despite winning the second stage.</p><p><a href="/tag/tyler-reddick">Tyler Reddick</a> stretched his fuel in the NASCAR Xfinity Series race to win his third event of the season. Is he the championship favorite? <a href="/tag/greg-biffle">Greg Biffle</a> returned to the Gander Outdoors Truck Series with a triumph for Kyle Busch Motorsports. It was his first NASCAR start in nearly three years. Was the last lap of the K&amp;N Pro Series West race, which saw teammates <a href="/tag/hailie-deegan">Hailie Deegan</a> and <a href="/tag/derek-kraus">Derek Kraus</a> make contact, fair or foul? We share our thoughts.</p><p>Finally, 2020 NASCAR Hall of Fame inductee <a href="/tag/bobby-labonte">Bobby Labonte</a> joins the show to discuss some of his career highs at Joe Gibbs Racing, career lows after leaving Petty Enterprises in 2008, what it means to be selected into the HOF, the best advice Coach Gibbs ever gave him and much more.</p><p><em>Make sure to leave us a rating, review and subscribe to the Frontstretch Podcast: <a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-197859-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-HOF.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-HOF.mp3">https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-HOF.mp3</a></audio></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=197859" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Bobby+Labonte+Examines+Career%2C+Highs+%26+Lows&url=https://www.frontstretch.com/?p=197859" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=197859&amp;name=Frontstretch+Podcast%3A+Bobby+Labonte+Examines+Career%2C+Highs+%26+Lows" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=197859&title=Frontstretch+Podcast%3A+Bobby+Labonte+Examines+Career%2C+Highs+%26+Lows" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=197859&title=Frontstretch+Podcast%3A+Bobby+Labonte+Examines+Career%2C+Highs+%26+Lows" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=197859&amp;description=Frontstretch+Podcast%3A+Bobby+Labonte+Examines+Career%2C+Highs+%26+Lows&amp;media=https://www.frontstretch.com/wp-content/uploads/2019/06/Bobby-Labonte-2004-Kansas-640x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2019-06-12T19:17:53-04:00","datePublished":"2019-06-12T19:17:53-04:00","dateModified":"2019-06-12T21:52:35-04:00","headline":"Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows","name":"Frontstretch Podcast: Bobby Labonte Examines Career, Highs &#038; Lows","keywords":"Austin Dillon,Bobby Labonte,Clint Bowyer,derek kraus,Greg Biffle,Hailie Deegan,Joey Logano,Kevin Harvick,Tyler Reddick","url":"https:\/\/www.frontstretch.com\/2019\/06\/12\/frontstretch-podcast-bobby-labonte-examines-career-highs-lows\/","description":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway where Joey Logano put a whippin' on the field en","copyrightYear":"2019","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2019\/06\/12\/frontstretch-podcast-bobby-labonte-examines-career-highs-lows\/"},"author":{"@type":"Person","name":"Frontstretch Staff","url":"https:\/\/www.frontstretch.com\/author\/staff\/"},"articleSection":"Cup Series,Dustin Albino,Featured Content,Mike Neff,Podcast,Truck Series,Xfinity","articleBody":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss the Monday matinee (June 10) at Michigan International Speedway where Joey Logano put a whippin' on the field en route to his second victory of 2019.\r\n\r\nSpoiler alert, we didn't like the action we saw, and neither did Kevin Harvick, who once again overcame pit road woes just to have a fighter's chance at the win. Ultimately, Rodney Childers called for four tires late and lost valuable track position.\r\n\r\nIt wasn't a good day for Clint Bowyer either, who said after a mid-race wreck, \"This isn't racing.\" We give our take on his comments. Another fast car was thrown out the window for Austin Dillon with a late wreck, despite winning the second stage.\r\n\r\nTyler Reddick stretched his fuel in the NASCAR Xfinity Series race to win his third event of the season. Is he the championship favorite? Greg Biffle returned to the Gander Outdoors Truck Series with a triumph for Kyle Busch Motorsports. It was his first NASCAR start in nearly three years. Was the last lap of the K&amp;N Pro Series West race, which saw teammates Hailie Deegan and Derek Kraus make contact, fair or foul? We share our thoughts.\r\n\r\nFinally, 2020 NASCAR Hall of Fame inductee Bobby Labonte joins the show to discuss some of his career highs at Joe Gibbs Racing, career lows after leaving Petty Enterprises in 2008, what it means to be selected into the HOF, the best advice Coach Gibbs ever gave him and much more.\r\n\r\nMake sure to leave us a rating, review and subscribe to the Frontstretch Podcast:\u00a0iTunes\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2019\/06\/Bobby-Labonte-2004-Kansas.jpg","width":696,"height":425}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/austin-dillon/" rel="tag">Austin Dillon</a> <a href="https://www.frontstretch.com/tag/bobby-labonte/" rel="tag">Bobby Labonte</a> <a href="https://www.frontstretch.com/tag/clint-bowyer/" rel="tag">Clint Bowyer</a> <a href="https://www.frontstretch.com/tag/derek-kraus/" rel="tag">derek kraus</a> <a href="https://www.frontstretch.com/tag/greg-biffle/" rel="tag">Greg Biffle</a> <a href="https://www.frontstretch.com/tag/hailie-deegan/" rel="tag">Hailie Deegan</a> <a href="https://www.frontstretch.com/tag/joey-logano/" rel="tag">Joey Logano</a> <a href="https://www.frontstretch.com/tag/kevin-harvick/" rel="tag">Kevin Harvick</a> <a href="https://www.frontstretch.com/tag/tyler-reddick/" rel="tag">Tyler Reddick</a></p><div class="e3lan e3lan-post"> <a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon" /> </a></div><section id="author-box"><div class="block-head"><h3>About Frontstretch Staff</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2015/06/frontstretch-sq-logo-150x150.png" width="90" height="90" alt="Frontstretch Staff" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> The Frontstretch Staff is made up of a group of talented men and women spread out all over the United States and Canada. Residing in 15 states throughout the country, plus Ontario, and widely ranging in age, the staff showcases a wide variety of diverse opinions that will keep you coming back for more week in and week out.</div><div class="author-social flat-social"> <a class="social-site" target="_blank" href="https://frontstretch.com"><i class="fa fa-home"></i></a> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Frontstretch"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/Frontstretch"><i class="fa fa-twitter"></i><span> @Frontstretch</span></a> <a class="social-youtube" target="_blank" href="https://www.youtube.com/user/Frontstretch"><i class="fa fa-youtube"></i></a> <a class="social-pinterest" target="_blank" href="https://www.pinterest.com/frontstretch/"><i class="fa fa-pinterest"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/frontstretchdotcom/"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2019/06/12/tyler-ankrum-to-run-partial-schedule-for-rest-of-2019-due-to-lack-of-sponsorship/" rel="prev"><span>Previous</span> Tyler Ankrum to Run Partial Schedule for Rest of 2019 Due to Lack of Sponsorship</a></div><div class="post-next"><a href="https://www.frontstretch.com/2019/06/12/kamui-kobayashi-earns-le-mans-provisional-pole/" rel="next"><span>Next</span> Kamui Kobayashi Earns Le Mans Provisional Pole</a></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/06/12/arca-preview-2019-shore-lunch-200-at-madison-international-speedway/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/06/xlarge-310x165.jpeg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/06/12/arca-preview-2019-shore-lunch-200-at-madison-international-speedway/" rel="bookmark">ARCA Preview: 2019 Shore Lunch 200 at Madison International Speedway</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/06/12/odds-and-ends-around-the-track-trouble-in-paradise-edition/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Michigan-I-CUP-Ryan-Blaney-Corey-LaJoie-Bubba-Wallace-football-NKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/06/12/odds-and-ends-around-the-track-trouble-in-paradise-edition/" rel="bookmark">Odds &#038; Ends Around the Track: Trouble in Paradise Edition</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/06/12/eyes-on-xfinity-michael-annett-feeling-rejuvenated-in-2019/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/06/Michael-Annett-Richmond-I-2019-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/06/12/eyes-on-xfinity-michael-annett-feeling-rejuvenated-in-2019/" rel="bookmark">Eyes on Xfinity: Michael Annett Feeling Rejuvenated In 2019</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>June 12, 2019</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/06/12/truckin-thursdays-josh-reaume-building-his-team-business-one-race-at-a-time/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-GOTS-Texas-Josh-Reaume-On-Track-Rick-Lunkenheimer-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2019/06/12/truckin-thursdays-josh-reaume-building-his-team-business-one-race-at-a-time/" rel="bookmark">Truckin&#8217; Thursdays: Josh Reaume Building His Team &#038; Business One Race at a Time</a></h2><p>Frontstretch’s Truck Series content is presented by American Trucks Josh Reaume, Josh Bilicki, Daniel Sasnett, &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/06/12/frontstretch-podcast-bobby-labonte-examines-career-highs-lows/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='197859' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9518d22a7d" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="40"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="https://www.americanmuscle.com/2015-ford-mustang-parts.html"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/18-8594_am-2018-mustang-seo-banners_250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://racingelectronics.com/collections/legend-fanvision/products/legend-gray"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019_re_310x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-12" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://www.patreon.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2019, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div>  <script type="text/javascript">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</script>  <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_b326dfd8430e5fd1e9d64f9355ed686d.js"></script></body></html>