<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_745e873cad7e203ddc757572c30530f0.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_6689916540184aa4d1d0baa34b7a1716.css" rel="stylesheet" /><title>Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</title><meta property="og:title" content="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss a long, hot"/><meta property="og:url" content="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" /><meta name="description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt"/><link rel="canonical" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky" /><meta property="og:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt" /><meta property="og:url" content="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" /><meta property="article:tag" content="Ben Rhodes" /><meta property="article:tag" content="Brennan Poole" /><meta property="article:tag" content="Christopher Bell" /><meta property="article:tag" content="Clint Bowyer" /><meta property="article:tag" content="Cole Custer" /><meta property="article:tag" content="Kurt Busch" /><meta property="article:tag" content="Kyle Busch" /><meta property="article:tag" content="Natalie Decker" /><meta property="article:tag" content="Ryan Newman" /><meta property="article:tag" content="Spencer Boyd" /><meta property="article:tag" content="Stewart Friesen" /><meta property="article:tag" content="Tyler Ankrum" /><meta property="article:tag" content="William Byron" /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2019-07-18T01:57:19+00:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019.jpg" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="426" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In this week’s edition of the Frontstretch Podcast, Dustin Albino and Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt" /><meta name="twitter:title" content="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019.jpg" /><meta name="twitter:creator" content="@DustinAlbino" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.frontstretch.com/#website","url":"https://www.frontstretch.com/","name":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https://www.frontstretch.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/#primaryimage","url":"https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019.jpg","width":640,"height":426},{"@type":"WebPage","@id":"https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/#webpage","url":"https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/","inLanguage":"en","name":"Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky","isPartOf":{"@id":"https://www.frontstretch.com/#website"},"primaryImageOfPage":{"@id":"https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/#primaryimage"},"datePublished":"2019-07-18T01:57:19+00:00","dateModified":"2019-07-18T01:57:19+00:00","author":{"@id":"https://www.frontstretch.com/#/schema/person/2db9fddeca7c316f33856f3fb1c1d434"},"description":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt"},{"@type":["Person"],"@id":"https://www.frontstretch.com/#/schema/person/2db9fddeca7c316f33856f3fb1c1d434","name":"Dustin Albino","image":{"@type":"ImageObject","@id":"https://www.frontstretch.com/#authorlogo","url":"https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361.jpg","caption":"Dustin Albino"},"description":"Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.","sameAs":["https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel","https://www.instagram.com/dustin_albino/?hl=en","https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile","https://twitter.com/@DustinAlbino"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky Comments Feed" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.7.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto', {'allowAnchor':true});
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview', location.pathname + location.search + location.hash);
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.frontstretch.com","hash_tracking":"true"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><meta name="generator" content="Seriously Simple Podcasting 1.20.5" /><link rel='shortlink' href='https://www.frontstretch.com/?p=202779' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F07%2F17%2Ffrontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F07%2F17%2Ffrontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.1"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="application/javascript" src="//ced.sascdn.com/tag/3265/smart.js" async></script> <script type="application/javascript">var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "//www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 293194,
            pageId: 1078178,
            formats: [
                 { id: 71430 }
                ,{ id: 71427 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3515913239267445",
          enable_page_level_ads: true
     });</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-202779 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" rel="noopener noreferrer" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-183833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183833"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-189006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189006"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184021"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-183834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183834"><a href="https://www.frontstretch.com/category/cup-series/cup-series-news/">Cup Series News</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky">Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/odds-ends-around-the-track-magic-mile-edition/" title="Odds &#038; Ends Around the Track: Magic Mile Edition"><img src="https://www.frontstretch.com/wp-content/uploads/2018/07/laimroa-110x75.jpg" width="110" height="75" alt="Odds &#038; Ends Around the Track: Magic Mile Edition" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/odds-ends-around-the-track-magic-mile-edition/" title="Odds &#038; Ends Around the Track: Magic Mile Edition">Odds &#038; Ends Around the Track: Magic Mile Edition</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/" title="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNGOTSTylerAnkrumVictoryLaneNKP-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/" title="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?">2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/clint-bowyer-not-worried-about-making-playoffs/" title="Clint Bowyer Not Worried About Making Playoffs"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Michigan-I-CUP-Clint-Bowyer-helmet-NKP-110x75.jpg" width="110" height="75" alt="Clint Bowyer Not Worried About Making Playoffs" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/clint-bowyer-not-worried-about-making-playoffs/" title="Clint Bowyer Not Worried About Making Playoffs">Clint Bowyer Not Worried About Making Playoffs</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 16, 2019</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">Xfinity</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-191283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191283"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184022"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on Xfinity</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">Xfinity Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky">Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/eyes-on-xfinity-ryan-truex-making-most-of-limited-opportunities-at-jr-motorsports/" title="Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Truex-Kentucky-110x75.jpg" width="110" height="75" alt="Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/eyes-on-xfinity-ryan-truex-making-most-of-limited-opportunities-at-jr-motorsports/" title="Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports">Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/ryan-vargas-making-xfinity-debut-at-iowa-with-jd-motorsports/" title="Ryan Vargas Making Xfinity Debut at Iowa With JD Motorsports"><img src="https://www.frontstretch.com/wp-content/uploads/2017/10/varg-110x75.jpg" width="110" height="75" alt="Ryan Vargas Making Xfinity Debut at Iowa With JD Motorsports" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/ryan-vargas-making-xfinity-debut-at-iowa-with-jd-motorsports/" title="Ryan Vargas Making Xfinity Debut at Iowa With JD Motorsports">Ryan Vargas Making Xfinity Debut at Iowa With JD Motorsports</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/" title="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNGOTSTylerAnkrumVictoryLaneNKP-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/" title="2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?">2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-183832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183832"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184020"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" width="660" height="330" alt="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/" title="Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky">Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/truckin-thursdays-no-further-penalties-for-stewart-friesen-after-kentucky/" title="Truckin&#8217; Thursdays: No Further Penalties for Stewart Friesen After Kentucky"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNGOTSStewartFriesenTruckNKP-110x75.jpg" width="110" height="75" alt="Truckin&#8217; Thursdays: No Further Penalties for Stewart Friesen After Kentucky" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/truckin-thursdays-no-further-penalties-for-stewart-friesen-after-kentucky/" title="Truckin&#8217; Thursdays: No Further Penalties for Stewart Friesen After Kentucky">Truckin&#8217; Thursdays: No Further Penalties for Stewart Friesen After Kentucky</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/couch-potato-tuesday-does-gwc-alone-make-broadcast-great/" title="Couch Potato Tuesday: Does a GWC Alone Make a Broadcast Great?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyMENCSKurtBuschKyleBuschRacingNKP-110x75.jpg" width="110" height="75" alt="Couch Potato Tuesday: Does a GWC Alone Make a Broadcast Great?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/couch-potato-tuesday-does-gwc-alone-make-broadcast-great/" title="Couch Potato Tuesday: Does a GWC Alone Make a Broadcast Great?">Couch Potato Tuesday: Does a GWC Alone Make a Broadcast Great?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/beside-the-rising-tide-feels-like-the-first-time/" title="Beside the Rising Tide: Feels Like the First Time "><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/39ba2ee7dae6810afc4ab75c6b08ad82-1-110x75.jpg" width="110" height="75" alt="Beside the Rising Tide: Feels Like the First Time " /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/16/beside-the-rising-tide-feels-like-the-first-time/" title="Beside the Rising Tide: Feels Like the First Time ">Beside the Rising Tide: Feels Like the First Time </a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 16, 2019</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/14/pace-laps-kentucky-speedway-shakes-up-each-of-nascars-top-3-series/" title="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNXSColeCusterVictoryLaneNKP-640x425.jpg" width="660" height="330" alt="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/14/pace-laps-kentucky-speedway-shakes-up-each-of-nascars-top-3-series/" title="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series">Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 14, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/13/ntt-indycar-series-returns-to-action-in-toronto/" title="NTT IndyCar Series Returns to Action in Toronto"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019TorontoIndyFelixRosenqvistCarIndyCarMedia-110x75.jpg" width="110" height="75" alt="NTT IndyCar Series Returns to Action in Toronto" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/13/ntt-indycar-series-returns-to-action-in-toronto/" title="NTT IndyCar Series Returns to Action in Toronto">NTT IndyCar Series Returns to Action in Toronto</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 13, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/02/sage-karam-adds-smartstop-sponsorship-will-drive-toronto-for-carlin/" title="Sage Karam Adds Smartstop Sponsorship, Will Drive Toronto for Carlin"><img src="https://www.frontstretch.com/wp-content/uploads/2018/03/2017-Indianapolis-IndyCar-Sage-Karam-Dreyer-Reinbold-Racing-110x75.jpg" width="110" height="75" alt="Sage Karam Adds Smartstop Sponsorship, Will Drive Toronto for Carlin" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/02/sage-karam-adds-smartstop-sponsorship-will-drive-toronto-for-carlin/" title="Sage Karam Adds Smartstop Sponsorship, Will Drive Toronto for Carlin">Sage Karam Adds Smartstop Sponsorship, Will Drive Toronto for Carlin</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 2, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/sonoma-snoozer-ross-chastain-takes-nascar-storm/" title="Pace Laps: A Sonoma Snoozer, While Ross Chastain Takes NASCAR by Storm"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/44dc7c9d3da607861defe670e084bfcc-1-110x75.jpg" width="110" height="75" alt="Pace Laps: A Sonoma Snoozer, While Ross Chastain Takes NASCAR by Storm" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/sonoma-snoozer-ross-chastain-takes-nascar-storm/" title="Pace Laps: A Sonoma Snoozer, While Ross Chastain Takes NASCAR by Storm">Pace Laps: A Sonoma Snoozer, While Ross Chastain Takes NASCAR by Storm</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 23, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/alexander-rossi-dominates-at-road-america/" title="Alexander Rossi Dominates At Road America"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/JDC-ROADAM_0709-A-110x75.jpg" width="110" height="75" alt="Alexander Rossi Dominates At Road America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/alexander-rossi-dominates-at-road-america/" title="Alexander Rossi Dominates At Road America">Alexander Rossi Dominates At Road America</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 23, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/alexander-rossi-josef-newgarden-continue-title-fight-at-road-america/" title="Alexander Rossi, Josef Newgarden Continue Title Fight at Road America"><img src="https://www.frontstretch.com/wp-content/uploads/2019/03/Alexander_Rossi_CO2-110x75.jpg" width="110" height="75" alt="Alexander Rossi, Josef Newgarden Continue Title Fight at Road America" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/23/alexander-rossi-josef-newgarden-continue-title-fight-at-road-america/" title="Alexander Rossi, Josef Newgarden Continue Title Fight at Road America">Alexander Rossi, Josef Newgarden Continue Title Fight at Road America</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 23, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/josef-newgarden-wins-saturday-night-shootout-in-texas/" title="Josef Newgarden Wins Saturday Night Shootout in Texas"><img src="https://www.frontstretch.com/wp-content/uploads/2018/08/newg-110x75.jpg" width="110" height="75" alt="Josef Newgarden Wins Saturday Night Shootout in Texas" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/06/08/josef-newgarden-wins-saturday-night-shootout-in-texas/" title="Josef Newgarden Wins Saturday Night Shootout in Texas">Josef Newgarden Wins Saturday Night Shootout in Texas</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 8, 2019</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/entry-list-lime-rock-park-120-3/" title="Entry List: Lime Rock Park 120"><img src="https://www.frontstretch.com/wp-content/uploads/2018/07/2018-Lime-Rock-CTSC-Owen-Trinkler-Car-Phil-Allaway-660x425.jpeg" width="660" height="330" alt="Entry List: Lime Rock Park 120" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/entry-list-lime-rock-park-120-3/" title="Entry List: Lime Rock Park 120">Entry List: Lime Rock Park 120</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/entry-list-northeast-grand-prix-3/" title="Entry List: Northeast Grand Prix"><img src="https://www.frontstretch.com/wp-content/uploads/2017/08/2017-Lime-Rock-IWSC-Tommy-Milner-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Entry List: Northeast Grand Prix" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/17/entry-list-northeast-grand-prix-3/" title="Entry List: Northeast Grand Prix">Entry List: Northeast Grand Prix</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/14/pace-laps-kentucky-speedway-shakes-up-each-of-nascars-top-3-series/" title="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNXSColeCusterVictoryLaneNKP-110x75.jpg" width="110" height="75" alt="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/14/pace-laps-kentucky-speedway-shakes-up-each-of-nascars-top-3-series/" title="Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series">Pace Laps: Kentucky Speedway Shakes Up Each of NASCAR&#8217;s Top-3 Series</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 14, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/07/daytona-provides-pair-of-surprise-winners/" title="Pace Laps: Daytona Provides Pair of Surprise Winners"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ross-Chastain-Daytona-watermeln-110x75.jpg" width="110" height="75" alt="Pace Laps: Daytona Provides Pair of Surprise Winners" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/07/07/daytona-provides-pair-of-surprise-winners/" title="Pace Laps: Daytona Provides Pair of Surprise Winners">Pace Laps: Daytona Provides Pair of Surprise Winners</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 7, 2019</span></li></ul></div></div></div></li><li id="menu-item-186592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-186592"><a href="https://www.frontstretch.com/category/arca/">ARCA</a></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li><li id="menu-item-183998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-183998"><a>Race / Team Info</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184023"><a href="https://frontstretch.com">2019 Schedules</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184024"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184025"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">Xfinity Series</a></li><li id="menu-item-184026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184026"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-183999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183999"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-177919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-177919"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/">Paint Schemes</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184000"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/cup-series/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184001"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/xfinity-series/">Xfinity Series</a></li><li id="menu-item-184002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184002"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/truck-series/">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-184004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184004"><a>Team Charts</a><ul class="sub-menu menu-sub-content"><li id="menu-item-189005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189005"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-191282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191282"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">Xfinity Series</a></li><li id="menu-item-184003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184003"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">Gander Outdoors Truck Series</a></li></ul></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"> <a href="https://www.americanmuscle.com/2008-dodge-challenger-accessories-parts.html" title="American Muscle - Challenger Parts are here!" > <img src="https://www.frontstretch.com/wp-content/uploads/2019/01/american-muscle-banner-728x90.jpg" alt="American Muscle - Challenger Parts are here!" /> </a></div><div id="main-content" class="container"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div id="sas_71428"></div> <script type="application/javascript">sas.cmd.push(function() {
        sas.render("71428");  // Format : 728x90_RON 728x90
    });</script></div><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</span></div><article class="post-listing post-202779 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-dustin-albino category-featured-content category-mike-neff category-podcast category-truck-series category-xfinity tag-ben-rhodes tag-brennan-poole tag-christopher-bell tag-clint-bowyer tag-cole-custer tag-kurt-busch tag-kyle-busch tag-natalie-decker tag-ryan-newman tag-spencer-boyd tag-stewart-friesen tag-tyler-ankrum tag-william-byron" id="the-post"><div class="single-post-thumb"> <img width="640" height="425" src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019.jpg 640w, https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-150x100.jpg 150w, https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-300x200.jpg 300w, https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-310x205.jpg 310w" sizes="(max-width: 640px) 100vw, 640px" /></div><div class="single-post-caption">(Photo: Nigel Kinrade Photography)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/mike-neff/" rel="category tag">Mike Neff</a>, <a href="https://www.frontstretch.com/category/podcast/" rel="category tag">Podcast</a>, <a href="https://www.frontstretch.com/category/truck-series/" rel="category tag">Truck Series</a>, <a href="https://www.frontstretch.com/category/xfinity/" rel="category tag">Xfinity</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In this week’s edition of the <em>Frontstretch Podcast</em>, <a href="https://www.frontstretch.com/twitter.com/dustinalbino">Dustin Albino</a> and <a href="https://twitter.com/MNeffShortTrack">Mike Neff</a> discuss a long, hot weekend of racing at Kentucky Speedway, which saw <a href="/tag/kurt-busch">Kurt Busch</a> oust his brother <a href="/tag/kyle-busch">Kyle Busch</a> for his first victory with Chip Ganassi Racing.</p><p>What did we think of the Kentucky race? The finish was spectacular, as was <a href="/tag/clint-bowyer">Clint Bowyer</a>&#8216;s sixth-place run, which the No. 14 team desperately needed. Also, get our takes on <a href="/tag/william-byron">William Byron</a>&#8216;s restart violation, which cost him a shot at the victory.</p><p>In NASCAR Xfinity Series competition, <a href="/tag/cole-custer">Cole Custer</a> and <a href="/tag/christopher-bell">Christopher Bell</a> stunk up the show in one of the least thrilling races of the year — one which left some drivers outspoken about the product.</p><p>The Gander Outdoors Truck Series race was thrilling, seeing <a href="/tag/tyler-ankrum">Tyler Ankrum</a> pick up his first career victory. There was a mid-race scrum between <a href="/tag/natalie-decker">Natalie Decker</a> and <a href="/tag/spencer-boyd">Spencer Boyd</a>, as Boyd turned into Decker and caused a big wreck. Post-race, it was <a href="/tag/ben-rhodes">Ben Rhodes</a> chasing down <a href="/tag/brennan-poole">Brennan Poole</a> for what he believed to be dirty racing on the track. In addition, we go in depth on <a href="/tag/stewart-friesen">Stewart Friesen</a>&#8216;s day, as NASCAR confiscated his No. 52 truck prior to practice.</p><p>Finally, <a href="/tag/ryan-newman">Ryan Newman</a> calls into the show to discuss his first year with Roush Fenway Racing, meshing with crew chief Scott Graves, grading the 2019 aero package a &#8220;C&#8221; and racing modifieds this weekend at New Hampshire Motor Speedway.</p><p><em>Make sure to</em><em> leave us a rating, review and subscribe to the Frontstretch Podcast: <a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-202779-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-New-Hampshire.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-New-Hampshire.mp3">https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-New-Hampshire.mp3</a></audio></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=202779" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Ryan+Newman+Relives+Top+10+Run+at+Kentucky&url=https://www.frontstretch.com/?p=202779" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.frontstretch.com/?p=202779&amp;name=Frontstretch+Podcast%3A+Ryan+Newman+Relives+Top+10+Run+at+Kentucky" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=202779&title=Frontstretch+Podcast%3A+Ryan+Newman+Relives+Top+10+Run+at+Kentucky" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=202779&title=Frontstretch+Podcast%3A+Ryan+Newman+Relives+Top+10+Run+at+Kentucky" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=202779&amp;description=Frontstretch+Podcast%3A+Ryan+Newman+Relives+Top+10+Run+at+Kentucky&amp;media=https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Newman-Martinsville-2019-640x425.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2019-07-17T21:57:19-04:00","datePublished":"2019-07-17T21:57:19-04:00","dateModified":"2019-07-17T21:57:19-04:00","headline":"Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky","name":"Frontstretch Podcast: Ryan Newman Relives Top 10 Run at Kentucky","keywords":"Ben Rhodes,Brennan Poole,Christopher Bell,Clint Bowyer,Cole Custer,Kurt Busch,Kyle Busch,Natalie Decker,Ryan Newman,Spencer Boyd,Stewart Friesen,Tyler Ankrum,William Byron","url":"https:\/\/www.frontstretch.com\/2019\/07\/17\/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky\/","description":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt Busch oust his brother Kyle Busch for his fir","copyrightYear":"2019","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2019\/07\/17\/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky\/"},"author":{"@type":"Person","name":"Dustin Albino","url":"https:\/\/www.frontstretch.com\/author\/dustin-albino\/"},"articleSection":"Cup Series,Dustin Albino,Featured Content,Mike Neff,Podcast,Truck Series,Xfinity","articleBody":"In this week\u2019s edition of the\u00a0Frontstretch Podcast,\u00a0Dustin Albino\u00a0and\u00a0Mike Neff discuss a long, hot weekend of racing at Kentucky Speedway, which saw Kurt Busch oust his brother Kyle Busch for his first victory with Chip Ganassi Racing.\r\n\r\nWhat did we think of the Kentucky race? The finish was spectacular, as was Clint Bowyer's sixth-place run, which the No. 14 team desperately needed. Also, get our takes on William Byron's restart violation, which cost him a shot at the victory.\r\n\r\nIn NASCAR Xfinity Series competition, Cole Custer and Christopher Bell stunk up the show in one of the least thrilling races of the year \u2014 one which left some drivers outspoken about the product.\r\n\r\nThe Gander Outdoors Truck Series race was thrilling, seeing Tyler Ankrum pick up his first career victory. There was a mid-race scrum between Natalie Decker and Spencer Boyd, as Boyd turned into Decker and caused a big wreck. Post-race, it was Ben Rhodes chasing down Brennan Poole\u00a0for what he believed to be dirty racing on the track. In addition, we go in depth on Stewart Friesen's day, as NASCAR confiscated his No. 52 truck prior to practice.\r\n\r\nFinally, Ryan Newman calls into the show to discuss his first year with Roush Fenway Racing, meshing with crew chief Scott Graves, grading the 2019 aero package a \"C\" and racing modifieds this weekend at New Hampshire Motor Speedway.\r\n\r\nMake sure to leave us a rating, review and subscribe to the Frontstretch Podcast:\u00a0iTunes\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2019\/07\/Ryan-Newman-Martinsville-2019.jpg","width":696,"height":426}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/ben-rhodes/" rel="tag">Ben Rhodes</a> <a href="https://www.frontstretch.com/tag/brennan-poole/" rel="tag">Brennan Poole</a> <a href="https://www.frontstretch.com/tag/christopher-bell/" rel="tag">Christopher Bell</a> <a href="https://www.frontstretch.com/tag/clint-bowyer/" rel="tag">Clint Bowyer</a> <a href="https://www.frontstretch.com/tag/cole-custer/" rel="tag">Cole Custer</a> <a href="https://www.frontstretch.com/tag/kurt-busch/" rel="tag">Kurt Busch</a> <a href="https://www.frontstretch.com/tag/kyle-busch/" rel="tag">Kyle Busch</a> <a href="https://www.frontstretch.com/tag/natalie-decker/" rel="tag">Natalie Decker</a> <a href="https://www.frontstretch.com/tag/ryan-newman/" rel="tag">Ryan Newman</a> <a href="https://www.frontstretch.com/tag/spencer-boyd/" rel="tag">Spencer Boyd</a> <a href="https://www.frontstretch.com/tag/stewart-friesen/" rel="tag">Stewart Friesen</a> <a href="https://www.frontstretch.com/tag/tyler-ankrum/" rel="tag">Tyler Ankrum</a> <a href="https://www.frontstretch.com/tag/william-byron/" rel="tag">William Byron</a></p><div class="e3lan e3lan-post"> <a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon" /> </a></div><section id="author-box"><div class="block-head"><h3>About Dustin Albino</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361-150x138.jpg" width="90" height="83" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.</div><div class="author-social flat-social"> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a> <a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2019/07/17/eyes-on-xfinity-ryan-truex-making-most-of-limited-opportunities-at-jr-motorsports/" rel="prev"><span>Previous</span> Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports</a></div><div class="post-next"></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/07/17/eyes-on-xfinity-ryan-truex-making-most-of-limited-opportunities-at-jr-motorsports/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/07/Ryan-Truex-Kentucky-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/07/17/eyes-on-xfinity-ryan-truex-making-most-of-limited-opportunities-at-jr-motorsports/" rel="bookmark">Eyes on Xfinity: Ryan Truex Making Most of Limited Opportunities at JR Motorsports</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/07/17/truckin-thursdays-no-further-penalties-for-stewart-friesen-after-kentucky/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNGOTSStewartFriesenTruckNKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/07/17/truckin-thursdays-no-further-penalties-for-stewart-friesen-after-kentucky/" rel="bookmark">Truckin&#8217; Thursdays: No Further Penalties for Stewart Friesen After Kentucky</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/07/17/odds-ends-around-the-track-magic-mile-edition/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2018/07/laimroa-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/07/17/odds-ends-around-the-track-magic-mile-edition/" rel="bookmark">Odds &#038; Ends Around the Track: Magic Mile Edition</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>July 17, 2019</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019KentuckyNGOTSTylerAnkrumVictoryLaneNKP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2019/07/17/2-headed-monster-does-nascar-need-to-eliminate-playoff-waivers/" rel="bookmark">2-Headed Monster: Does NASCAR Need To Eliminate Playoff Waivers?</a></h2><p>Tyler Ankrum won the 2019 Buckle Up In Your Truck 225 at Kentucky Speedway. For &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/07/17/frontstretch-podcast-ryan-newman-relives-top-10-run-at-kentucky/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='202779' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="686b0e3f64" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="120"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="https://www.americanmuscle.com/2015-ford-mustang-parts.html"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/18-8594_am-2018-mustang-seo-banners_250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://racingelectronics.com/collections/legend-fanvision/products/legend-gray"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019_re_310x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-12" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://www.patreon.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2019, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div>  <script type="text/javascript">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</script>  <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_b326dfd8430e5fd1e9d64f9355ed686d.js"></script></body></html>