<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.frontstretch.com/xmlrpc.php" /><link type="text/css" media="all" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_984c25165e6c1df0cc5a6986cd1ba067.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.frontstretch.com/wp-content/cache/autoptimize/css/autoptimize_5b5364deffa1b71f58385d9239aa07f8.css" rel="stylesheet" /><title>Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian</title><meta property="og:title" content="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian - Frontstretch"/><meta property="og:type" content="article"/><meta property="og:description" content="In a live episode of the Frontstretch Podcast at Homestead-Miami Speedway, Dustin Albino, Michael Ma"/><meta property="og:url" content="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/"/><meta property="og:site_name" content="Frontstretch"/><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" /><meta name="description" content="In a live episode of the Frontstretch Podcast at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday&#039;s Cup Series"/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian" /><meta property="og:description" content="In a live episode of the Frontstretch Podcast at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday&#039;s Cup Series" /><meta property="og:url" content="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" /><meta property="og:site_name" content="Frontstretch" /><meta property="article:publisher" content="https://www.facebook.com/Frontstretch" /><meta property="article:author" content="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel" /><meta property="article:tag" content="Christopher Bell" /><meta property="article:tag" content="Cole Custer" /><meta property="article:tag" content="Denny Hamlin" /><meta property="article:tag" content="Kevin Harvick" /><meta property="article:tag" content="Kyle Busch" /><meta property="article:tag" content="Martin Truex Jr." /><meta property="article:tag" content="Tyler Reddick" /><meta property="article:section" content="Cup Series" /><meta property="article:published_time" content="2019-11-17T05:12:37-05:00" /><meta property="og:image" content="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" /><meta property="og:image:secure_url" content="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="426" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In a live episode of the Frontstretch Podcast at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday&#039;s Cup Series" /><meta name="twitter:title" content="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian" /><meta name="twitter:site" content="@Frontstretch" /><meta name="twitter:image" content="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" /><meta name="twitter:creator" content="@DustinAlbino" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.frontstretch.com/#website","url":"https://www.frontstretch.com/","name":"Frontstretch","potentialAction":{"@type":"SearchAction","target":"https://www.frontstretch.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/#primaryimage","url":"https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg","width":640,"height":426},{"@type":"WebPage","@id":"https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/#webpage","url":"https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/","inLanguage":"en","name":"Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian","isPartOf":{"@id":"https://www.frontstretch.com/#website"},"primaryImageOfPage":{"@id":"https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/#primaryimage"},"datePublished":"2019-11-17T05:12:37-05:00","dateModified":"2019-11-17T05:12:37-05:00","author":{"@id":"https://www.frontstretch.com/#/schema/person/2db9fddeca7c316f33856f3fb1c1d434"},"description":"In a live episode of the\u00a0Frontstretch Podcast\u00a0at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday's Cup Series"},{"@type":["Person"],"@id":"https://www.frontstretch.com/#/schema/person/2db9fddeca7c316f33856f3fb1c1d434","name":"Dustin Albino","image":{"@type":"ImageObject","@id":"https://www.frontstretch.com/#authorlogo","url":"https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361.jpg","caption":"Dustin Albino"},"description":"Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.","sameAs":["https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel","https://www.instagram.com/dustin_albino/?hl=en","https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile","https://twitter.com/@DustinAlbino"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Feed" href="https://www.frontstretch.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Comments Feed" href="https://www.frontstretch.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Frontstretch &raquo; Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian Comments Feed" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-34668381-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-34668381-1', 'auto', {'allowAnchor':true});
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview', location.pathname + location.search + location.hash);
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">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</script> <link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.frontstretch.com","hash_tracking":"true"};</script> <script type='text/javascript'>var tie_insta = {"ajaxurl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.frontstretch.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var ai_front = {"wp_ai":"5.3+2.5.8","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};</script> <script type='text/javascript'>function ai_insert(a,e,h){var f=-1!=e.indexOf(":eq")?jQuery(e):document.querySelectorAll(e);Array.prototype.forEach.call(f,function(b,f){selector_string=b.hasAttribute("id")?"#"+b.getAttribute("id"):b.hasAttribute("class")?"."+b.getAttribute("class").replace(RegExp(" ","g"),"."):"";var d=document.createElement("div");d.innerHTML=h;var c=d.getElementsByClassName("ai-selector-counter")[0];null!=c&&(c.innerText=f+1);c=d.getElementsByClassName("ai-debug-name ai-main")[0];if(null!=c){var g="";"before"==
a?g=ai_front.insertion_before:"after"==a?g=ai_front.insertion_after:"prepend"==a?g=ai_front.insertion_prepend:"append"==a?g=ai_front.insertion_append:"replace-content"==a?g=ai_front.insertion_replace_content:"replace-element"==a&&(g=ai_front.insertion_replace_element);c.innerText=g+" "+e+" ("+b.tagName.toLowerCase()+selector_string+")"}c=document.createRange().createContextualFragment(d.innerHTML);"before"==a?b.parentNode.insertBefore(c,b):"after"==a?b.parentNode.insertBefore(c,b.nextSibling):"prepend"==
a?b.insertBefore(c,b.firstChild):"append"==a?b.insertBefore(c,null):"replace-content"==a?b.innerHTML=d.innerHTML:"replace-element"==a&&(b.parentNode.insertBefore(c,b),b.parentNode.removeChild(b))})}
function ai_insert_code(a){function e(a,b){return null==a?!1:a.classList?a.classList.contains(b):-1<(" "+a.className+" ").indexOf(" "+b+" ")}function h(a,b){null!=a&&(a.classList?a.classList.add(b):a.className+=" "+b)}function f(a,b){null!=a&&(a.classList?a.classList.remove(b):a.className=a.className.replace(new RegExp("(^|\\b)"+b.split(" ").join("|")+"(\\b|$)","gi")," "))}var b=e(a,"no-visibility-check")?!0:!!(a.offsetWidth||a.offsetHeight||a.getClientRects().length);a.getAttribute("data-block");
if(b){b=a.getAttribute("data-code");var k=a.getAttribute("data-insertion"),d=a.getAttribute("data-selector");null!=b&&(null!=k&&null!=d?document.querySelectorAll(d).length&&(ai_insert(k,d,b64d(b)),f(a,"ai-viewports")):(b=document.createRange().createContextualFragment(b64d(b)),a.parentNode.insertBefore(b,a.nextSibling),f(a,"ai-viewports")));a=a.getElementsByClassName("ai-check-block");"undefined"!=typeof a[0]&&a[0].parentNode.removeChild(a[0])}else b=a.previousElementSibling,e(b,"ai-debug-bar")&&
e(b,"ai-debug-script")&&(f(b,"ai-debug-script"),h(b,"ai-debug-viewport-invisible")),f(a,"ai-viewports")}function b64e(a){return btoa(encodeURIComponent(a).replace(/%([0-9A-F]{2})/g,function(a,h){return String.fromCharCode("0x"+h)}))}function b64d(a){return decodeURIComponent(atob(a).split("").map(function(a){return"%"+("00"+a.charCodeAt(0).toString(16)).slice(-2)}).join(""))};</script> <script type='text/javascript'>var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};</script> <script type='text/javascript'>var WEF = {"local":"en_US","version":"v2.9","fb_id":""};</script> <link rel='https://api.w.org/' href='https://www.frontstretch.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.frontstretch.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.frontstretch.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3" /><meta name="generator" content="Seriously Simple Podcasting 1.20.10" /><link rel='shortlink' href='https://www.frontstretch.com/?p=216636' /><link rel="alternate" type="application/json+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F11%2F17%2Ffrontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.frontstretch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.frontstretch.com%2F2019%2F11%2F17%2Ffrontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" /> <script type="text/javascript">if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"DomReady",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:false,enableByQuery:false,commentsEnabled:true,version:"1.6.1"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};</script><link rel="shortcut icon" href="https://frontstretch.com/wp-content/uploads/2016/04/favicon-16x16.png" title="Favicon" /> <!--[if IE]> <script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]--> <!--[if lt IE 9]> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/html5.js"></script> <script src="https://www.frontstretch.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script> <![endif]--> <!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie9.css" /> <![endif]--> <!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie8.css" /> <![endif]--> <!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.frontstretch.com/wp-content/themes/sahifa/css/ie7.css" /> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1.0" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-144x144.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon-precomposed" href="https://frontstretch.com/wp-content/uploads/2016/04/apple-touch-icon-57x57.png" /> <script type="application/javascript" src="//ced.sascdn.com/tag/3265/smart.js" async></script> <script type="application/javascript">var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "//www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 293194,
            pageId: 1078178,
            formats: [
                 { id: 71430 }
                ,{ id: 71427 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3515913239267445",
          enable_page_level_ads: true
     });</script> </head><body data-rsssl=1 id="top" class="post-template-default single single-post postid-216636 single-format-standard lazy-enabled"><div class="wrapper-outer"><div class="background-cover"></div><aside id="slide-out"><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div id="mobile-menu" ></div></aside><div id="wrapper" class="boxed"><div class="inner-wrapper"><header id="theme-header" class="theme-header"><div id="top-nav" class="top-nav"><div class="container"><div class="top-menu"><ul id="menu-fs-top" class="menu"><li id="menu-item-76742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76742"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li><li id="menu-item-78979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78979"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li><li id="menu-item-78724" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-78724"><a target="_blank" rel="noopener noreferrer" href="https://www.frontstretch.com/newsletter/">Newsletter</a></li><li id="menu-item-117474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117474"><a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421">Podcast</a></li><li id="menu-item-170194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170194"><a href="https://www.patreon.com/frontstretch">Patreon</a></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157945"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Fantasy Forecast</a></li><li id="menu-item-78725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78725"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-78723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78723"><a href="https://www.frontstretch.com/jobs/">Jobs</a></li><li id="menu-item-76740" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76740"><a href="https://www.frontstretch.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div></div></div><div class="header-content"> <a id="slide-out-open" class="slide-out-open" href="#"><span></span></a><div class="logo"><h2> <a title="Frontstretch" href="https://www.frontstretch.com/"> <img src="https://frontstretch.com/wp-content/uploads/2016/03/FS-Logo.png" alt=""  /><strong></strong> </a></h2></div><div class="clear"></div></div><nav id="main-nav" class="fixed-enabled"><div class="container"><div class="main-menu"><ul id="menu-fs-mega" class="menu"><li id="menu-item-114497" class="main-nav ul limenu-item-home a menu-item menu-item-type-custom menu-item-object-custom menu-item-114497"><a href="https://frontstretch.com">Home</a></li><li id="menu-item-114537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114537 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/cup-series/">Cup Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-183833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183833"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-189006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189006"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184021"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-183834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183834"><a href="https://www.frontstretch.com/category/cup-series/cup-series-news/">Cup Series News</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" title="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" width="660" height="330" alt="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" title="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian">Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/kyle-busch-leads-lone-homestead-practice-joe-gibbs-racing-1-2-3/" title="Kyle Busch Leads Lone Homestead Practice, Joe Gibbs Racing 1-2-3"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019-Homestead-Cup-Kyle-Busch-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Kyle Busch Leads Lone Homestead Practice, Joe Gibbs Racing 1-2-3" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/kyle-busch-leads-lone-homestead-practice-joe-gibbs-racing-1-2-3/" title="Kyle Busch Leads Lone Homestead Practice, Joe Gibbs Racing 1-2-3">Kyle Busch Leads Lone Homestead Practice, Joe Gibbs Racing 1-2-3</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/daily-fantasy-nascar-fanduel-forecast-ford-ecoboost-400-2/" title="Daily Fantasy NASCAR FanDuel Forecast: Ford EcoBoost 400"><img src="https://www.frontstretch.com/wp-content/uploads/2019/07/2019LoudonMENCSKurtBuschFaceNKP-110x75.jpg" width="110" height="75" alt="Daily Fantasy NASCAR FanDuel Forecast: Ford EcoBoost 400" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/daily-fantasy-nascar-fanduel-forecast-ford-ecoboost-400-2/" title="Daily Fantasy NASCAR FanDuel Forecast: Ford EcoBoost 400">Daily Fantasy NASCAR FanDuel Forecast: Ford EcoBoost 400</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/15/daily-fantasy-nascar-draftkings-forecast-ford-ecoboost-400/" title="Daily Fantasy NASCAR DraftKings Forecast: Ford EcoBoost 400"><img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Atlanta-CUP-Kyle-Larson-NKP-110x75.jpg" width="110" height="75" alt="Daily Fantasy NASCAR DraftKings Forecast: Ford EcoBoost 400" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/15/daily-fantasy-nascar-draftkings-forecast-ford-ecoboost-400/" title="Daily Fantasy NASCAR DraftKings Forecast: Ford EcoBoost 400">Daily Fantasy NASCAR DraftKings Forecast: Ford EcoBoost 400</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 15, 2019</span></li></ul></div></div></div></li><li id="menu-item-114540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-114540 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/xfinity/">Xfinity</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-151080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151080"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-191283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191283"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184022"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-151084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151084"><a href="https://www.frontstretch.com/category/xfinity/xfinity-news/">News</a></li><li id="menu-item-151082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151082"><a href="https://www.frontstretch.com/category/xfinity/eyes-on-xfinity/">Eyes on Xfinity</a></li><li id="menu-item-151081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151081"><a href="https://www.frontstretch.com/category/xfinity/xfinity-breakdown/">Xfinity Breakdown</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" title="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" width="660" height="330" alt="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/" title="Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian">Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 17, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/xfinity-breakdown-tyler-reddick-proves-biggest-of-big-3/" title="Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019HomesteadNXSTylerReddickTrophyCCK-110x75.jpg" width="110" height="75" alt="Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/xfinity-breakdown-tyler-reddick-proves-biggest-of-big-3/" title="Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3">Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/justin-allgaier-just-didnt-have-the-speed-at-homestead-finishes-fourth-in-championship/" title="Justin Allgaier &#8216;Just Didn&#8217;t Have The Speed&#8217; At Homestead, Finishes 4th In Championship"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019HomesteadNXSJustinAllgaierCarCCK-110x75.jpg" width="110" height="75" alt="Justin Allgaier &#8216;Just Didn&#8217;t Have The Speed&#8217; At Homestead, Finishes 4th In Championship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/justin-allgaier-just-didnt-have-the-speed-at-homestead-finishes-fourth-in-championship/" title="Justin Allgaier &#8216;Just Didn&#8217;t Have The Speed&#8217; At Homestead, Finishes 4th In Championship">Justin Allgaier &#8216;Just Didn&#8217;t Have The Speed&#8217; At Homestead, Finishes 4th In Championship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/austin-cindric-has-up-and-down-run-to-7th-finishes-6th-in-points/" title="Austin Cindric Has Up-and-Down Run To 7th, Finishes 6th In Points"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019-Homestead-NXS-Austin-Cindric-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Austin Cindric Has Up-and-Down Run To 7th, Finishes 6th In Points" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/austin-cindric-has-up-and-down-run-to-7th-finishes-6th-in-points/" title="Austin Cindric Has Up-and-Down Run To 7th, Finishes 6th In Points">Austin Cindric Has Up-and-Down Run To 7th, Finishes 6th In Points</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li></ul></div></div></div></li><li id="menu-item-114542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-114542 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/truck-series/">Truck Series</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150588"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">2019 Schedule</a></li><li id="menu-item-183832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-183832"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">2019 Team Chart</a></li><li id="menu-item-184020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184020"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-114645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114645"><a href="https://www.frontstretch.com/category/truck-series/truck-series-news/">News</a></li><li id="menu-item-114648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114648"><a href="https://www.frontstretch.com/category/truck-series/truckin-thursdays/">Truckin&#8217; Thursdays</a></li><li id="menu-item-114646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114646"><a href="https://www.frontstretch.com/category/truck-series/tracking-the-trucks-race-report/">Tracking the Trucks</a></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/tracking-the-trucks-inside-winless-wonder-matt-craftons-championship-season/" title="Tracking The Trucks: Inside Winless Wonder Matt Crafton&#8217;s Championship Season"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019PhoenixNGOTSMattCraftonTruckNKP-640x425.jpg" width="660" height="330" alt="Tracking The Trucks: Inside Winless Wonder Matt Crafton&#8217;s Championship Season" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/tracking-the-trucks-inside-winless-wonder-matt-craftons-championship-season/" title="Tracking The Trucks: Inside Winless Wonder Matt Crafton&#8217;s Championship Season">Tracking The Trucks: Inside Winless Wonder Matt Crafton&#8217;s Championship Season</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/ross-chastain-comes-up-short-of-1st-nascar-championship/" title="Ross Chastain Comes Up Short of 1st NASCAR Championship"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/Ross-Chastain-Martinsville-2019-110x75.jpg" width="110" height="75" alt="Ross Chastain Comes Up Short of 1st NASCAR Championship" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/ross-chastain-comes-up-short-of-1st-nascar-championship/" title="Ross Chastain Comes Up Short of 1st NASCAR Championship">Ross Chastain Comes Up Short of 1st NASCAR Championship</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/brett-moffitt-dejected-after-failing-to-defend-truck-title/" title="Brett Moffitt Dejected After Failing to Defend NASCAR Truck Series Title"><img src="https://www.frontstretch.com/wp-content/uploads/2019/06/2019-Kansas-GOTS-Brett-Moffitt-helmet-NKP-110x75.jpg" width="110" height="75" alt="Brett Moffitt Dejected After Failing to Defend NASCAR Truck Series Title" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/brett-moffitt-dejected-after-failing-to-defend-truck-title/" title="Brett Moffitt Dejected After Failing to Defend NASCAR Truck Series Title">Brett Moffitt Dejected After Failing to Defend NASCAR Truck Series Title</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/stewart-friesen-comes-up-short-at-homestead-we-just-didnt-have-a-chance/" title="Stewart Friesen Comes Up Short at Homestead: &#8216;We Just Didn&#8217;t Have A Chance&#8217;"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/IMG_8455-110x75.jpeg" width="110" height="75" alt="Stewart Friesen Comes Up Short at Homestead: &#8216;We Just Didn&#8217;t Have A Chance&#8217;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/16/stewart-friesen-comes-up-short-at-homestead-we-just-didnt-have-a-chance/" title="Stewart Friesen Comes Up Short at Homestead: &#8216;We Just Didn&#8217;t Have A Chance&#8217;">Stewart Friesen Comes Up Short at Homestead: &#8216;We Just Didn&#8217;t Have A Chance&#8217;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></li></ul></div></div></div></li><li id="menu-item-114548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114548 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/indycar/">IndyCar</a><div class="mega-menu-block menu-sub-content"><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/08/meyer-shank-racing-jack-harvey-going-full-time-in-2020-with-andretti-technologies/" title="Meyer Shank Racing, Jack Harvey Going Full-Time in 2020 with Andretti Technologies"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/Jack_Harvey_CJ-640x425.jpg" width="660" height="330" alt="Meyer Shank Racing, Jack Harvey Going Full-Time in 2020 with Andretti Technologies" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/08/meyer-shank-racing-jack-harvey-going-full-time-in-2020-with-andretti-technologies/" title="Meyer Shank Racing, Jack Harvey Going Full-Time in 2020 with Andretti Technologies">Meyer Shank Racing, Jack Harvey Going Full-Time in 2020 with Andretti Technologies</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 8, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/06/2-headed-monster-will-penskes-ownership-be-good-or-bad-for-indycar-indianapolis-motor-speedway/" title="2-Headed Monster: Will Penske&#8217;s Ownership Be Good or Bad for IndyCar &#038; Indianapolis Motor Speedway?"><img src="https://www.frontstretch.com/wp-content/uploads/2019/10/IMG_2155-110x75.jpg" width="110" height="75" alt="2-Headed Monster: Will Penske&#8217;s Ownership Be Good or Bad for IndyCar &#038; Indianapolis Motor Speedway?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/06/2-headed-monster-will-penskes-ownership-be-good-or-bad-for-indycar-indianapolis-motor-speedway/" title="2-Headed Monster: Will Penske&#8217;s Ownership Be Good or Bad for IndyCar &#038; Indianapolis Motor Speedway?">2-Headed Monster: Will Penske&#8217;s Ownership Be Good or Bad for IndyCar &#038; Indianapolis Motor Speedway?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 6, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/05/beside-the-rising-tide-4790-w-16th-street-indianapolis-in/" title="Beside the Rising Tide: 4790 W 16th Street, Indianapolis IN"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/17MH20180527_3753-110x75.jpg" width="110" height="75" alt="Beside the Rising Tide: 4790 W 16th Street, Indianapolis IN" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/05/beside-the-rising-tide-4790-w-16th-street-indianapolis-in/" title="Beside the Rising Tide: 4790 W 16th Street, Indianapolis IN">Beside the Rising Tide: 4790 W 16th Street, Indianapolis IN</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 5, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/04/penske-entertainment-corp-purchases-indianapolis-motor-speedway-indycar-series/" title="Penske Entertainment Corp Purchases Indianapolis Motor Speedway, IndyCar Series"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/FelixRosenqvist-110x75.jpg" width="110" height="75" alt="Penske Entertainment Corp Purchases Indianapolis Motor Speedway, IndyCar Series" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/04/penske-entertainment-corp-purchases-indianapolis-motor-speedway-indycar-series/" title="Penske Entertainment Corp Purchases Indianapolis Motor Speedway, IndyCar Series">Penske Entertainment Corp Purchases Indianapolis Motor Speedway, IndyCar Series</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/31/4-burning-questions-showdown-at-the-formula-1-corral/" title="4 Burning Questions: Showdown at the Formula 1 Corral"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/James_Hinchcliffe_JS-110x75.jpg" width="110" height="75" alt="4 Burning Questions: Showdown at the Formula 1 Corral" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/31/4-burning-questions-showdown-at-the-formula-1-corral/" title="4 Burning Questions: Showdown at the Formula 1 Corral">4 Burning Questions: Showdown at the Formula 1 Corral</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 31, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/30/oliver-askew-pato-oward-to-drive-for-arrow-mclaren-in-2020/" title="Oliver Askew, Pato O&#8217;Ward to Drive for Arrow McLaren in 2020"><img src="https://www.frontstretch.com/wp-content/uploads/2017/04/2017-Long-Beach-IndyCar-James-Hinchcliffe-Car-Phil-Allaway-110x75.jpg" width="110" height="75" alt="Oliver Askew, Pato O&#8217;Ward to Drive for Arrow McLaren in 2020" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/30/oliver-askew-pato-oward-to-drive-for-arrow-mclaren-in-2020/" title="Oliver Askew, Pato O&#8217;Ward to Drive for Arrow McLaren in 2020">Oliver Askew, Pato O&#8217;Ward to Drive for Arrow McLaren in 2020</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 30, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/22/scott-dixon-on-the-ford-gt-the-2019-season-indycar/" title="Scott Dixon on the Ford GT, the 2019 Season &#038; INDYCAR"><img src="https://www.frontstretch.com/wp-content/uploads/2019/05/Scott_Dixon_JC-110x75.jpg" width="110" height="75" alt="Scott Dixon on the Ford GT, the 2019 Season &#038; INDYCAR" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/10/22/scott-dixon-on-the-ford-gt-the-2019-season-indycar/" title="Scott Dixon on the Ford GT, the 2019 Season &#038; INDYCAR">Scott Dixon on the Ford GT, the 2019 Season &#038; INDYCAR</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 22, 2019</span></li></ul></div></div></div></li><li id="menu-item-114559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114559"><a href="https://www.frontstretch.com/category/formula-one/">Formula One</a></li><li id="menu-item-150949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150949 mega-menu mega-recent-featured "><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a><div class="mega-menu-block menu-sub-content"><ul class="mega-recent-featured-list sub-list"><li id="menu-item-150958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150958"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/">Michelin Pilot Challenge</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150959"><a href="https://www.frontstretch.com/category/sports-cars/imsa/michelin-pilot-challenge/michelin-pilot-challenge-news/">Michelin Pilot Challenge News</a></li></ul></li><li id="menu-item-150956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150956"><a href="https://www.frontstretch.com/category/sports-cars/elms/">ELMS</a></li><li id="menu-item-150957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150957"><a href="https://www.frontstretch.com/category/sports-cars/imsa/">IMSA</a></li><li id="menu-item-150954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150954"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/">Blancpain GT World Challenge America</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150955"><a href="https://www.frontstretch.com/category/sports-cars/sro/blancpain-gt-world-challenge-america/blancpain-gt-world-challenge-america-news/">Blancpain GT World Challenge America News</a></li></ul></li><li id="menu-item-150950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150950"><a href="https://www.frontstretch.com/category/sports-cars/imsa/tusc/">TUSC</a></li><li id="menu-item-150952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150952"><a href="https://www.frontstretch.com/category/sports-cars/wec/">WEC</a></li><li id="menu-item-150953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150953"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/">WSC</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150951"><a href="https://www.frontstretch.com/category/sports-cars/imsa/wsc/wsc-news/">WSC News</a></li></ul></li></ul><div class="mega-menu-content"><div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/forty-7-motosports-wins-imsa-michelin-encore-tim-george-dies/" title="Forty 7 Motosports Wins IMSA Michelin Encore; Tim George Dies"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019-Road-Atlanta-PC-Austin-McCusker-Car-Phil-Allaway-660x425.jpg" width="660" height="330" alt="Forty 7 Motosports Wins IMSA Michelin Encore; Tim George Dies" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/forty-7-motosports-wins-imsa-michelin-encore-tim-george-dies/" title="Forty 7 Motosports Wins IMSA Michelin Encore; Tim George Dies">Forty 7 Motosports Wins IMSA Michelin Encore; Tim George Dies</a></h3> <span class="tie-date"><i class="fa fa-clock-o"></i>November 10, 2019</span></div><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/weekend-racing-roundup-denny-hamlin-justin-allgaier-stewart-friesen-conquer-ism-raceway/" title="Weekend Racing Roundup: Denny Hamlin, Justin Allgaier &#038; Stewart Friesen Conquer ISM Raceway"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019PhoenixNXSJustinAllgaierVictoryLaneNKP-110x75.jpg" width="110" height="75" alt="Weekend Racing Roundup: Denny Hamlin, Justin Allgaier &#038; Stewart Friesen Conquer ISM Raceway" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/weekend-racing-roundup-denny-hamlin-justin-allgaier-stewart-friesen-conquer-ism-raceway/" title="Weekend Racing Roundup: Denny Hamlin, Justin Allgaier &#038; Stewart Friesen Conquer ISM Raceway">Weekend Racing Roundup: Denny Hamlin, Justin Allgaier &#038; Stewart Friesen Conquer ISM Raceway</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 10, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/rebellion-racing-wins-4-hours-of-shanghai/" title="Rebellion Racing Wins 4 Hours of Shanghai"><img src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019-Shanghai-WEC-Gustavo-Menezes-Car-Joao-Filipe-Alves-Beato-Adrenal-Media-110x75.jpg" width="110" height="75" alt="Rebellion Racing Wins 4 Hours of Shanghai" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/10/rebellion-racing-wins-4-hours-of-shanghai/" title="Rebellion Racing Wins 4 Hours of Shanghai">Rebellion Racing Wins 4 Hours of Shanghai</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 10, 2019</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/04/kyle-busch-to-race-in-2020-rolex-24-at-daytona/" title="Kyle Busch To Race In 2020 Rolex 24 at Daytona"><img src="https://www.frontstretch.com/wp-content/uploads/2019/08/2019MichiganMENCSKyleBuschFaceNKP-110x75.jpg" width="110" height="75" alt="Kyle Busch To Race In 2020 Rolex 24 at Daytona" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.frontstretch.com/2019/11/04/kyle-busch-to-race-in-2020-rolex-24-at-daytona/" title="Kyle Busch To Race In 2020 Rolex 24 at Daytona">Kyle Busch To Race In 2020 Rolex 24 at Daytona</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 4, 2019</span></li></ul></div></div></div></li><li id="menu-item-186592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-186592"><a href="https://www.frontstretch.com/category/arca/">ARCA</a></li><li id="menu-item-150964" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-150964"><a>Television</a><ul class="sub-menu menu-sub-content"><li id="menu-item-150965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150965"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li><li id="menu-item-152299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152299"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li><li id="menu-item-114550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114550"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li></ul></li><li id="menu-item-183998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-183998"><a>Race / Team Info</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184023" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184023"><a href="https://frontstretch.com">2019 Schedules</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184024"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Monster-Energy-NASCAR-Cup-Series-Schedule.pdf">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184025"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Xfinity-Series-Schedule.pdf">Xfinity Series</a></li><li id="menu-item-184026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184026"><a href="https://www.frontstretch.com/wp-content/uploads/2019/02/2019-Gander-Outdoors-Truck-Series-Schedule.pdf">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-183999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183999"><a href="https://www.frontstretch.com/nascar-race-weekend-central/">NASCAR Race Weekend Central</a></li><li id="menu-item-177919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-177919"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/">Paint Schemes</a><ul class="sub-menu menu-sub-content"><li id="menu-item-184000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184000"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/cup-series/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-184001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184001"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/xfinity-series/">Xfinity Series</a></li><li id="menu-item-184002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184002"><a href="https://www.frontstretch.com/team-information-and-paint-schemes/truck-series/">Gander Outdoors Truck Series</a></li></ul></li><li id="menu-item-184004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-184004"><a>Team Charts</a><ul class="sub-menu menu-sub-content"><li id="menu-item-189005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189005"><a href="https://www.frontstretch.com/2019-monster-energy-nascar-cup-series-team-driver-chart/">Monster Energy NASCAR Cup Series</a></li><li id="menu-item-191282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191282"><a href="https://www.frontstretch.com/2019-xfinity-series-team-driver-chart/">Xfinity Series</a></li><li id="menu-item-184003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-184003"><a href="https://www.frontstretch.com/2019-gander-outdoors-truck-series-team-driver-chart/">Gander Outdoors Truck Series</a></li></ul></li></ul></li></ul></div> <a href="https://www.frontstretch.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a></div></nav></header><div class="e3lan e3lan-below_header"></div><div id="main-content" class="container"><div class='code-block code-block-center code-block-3'><div id="sas_71428"></div> <script type="application/javascript">sas.cmd.push(function() {
        sas.render("71428");  // Format : 728x90_RON 728x90
    });</script></div><div class="content"><div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.frontstretch.com">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.frontstretch.com/category/cup-series/">Cup Series</a></span> <span class="delimiter">/</span> <span class="current">Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian</span></div><article class="post-listing post-216636 post type-post status-publish format-standard has-post-thumbnail  category-cup-series category-dustin-albino category-featured-content category-michael-massie category-tom-bowles category-xfinity tag-christopher-bell tag-cole-custer tag-denny-hamlin tag-kevin-harvick tag-kyle-busch tag-martin-truex-jr tag-tyler-reddick" id="the-post"><div class="single-post-thumb"> <img width="638" height="425" src="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg 640w, https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019-300x200.jpg 300w, https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019-150x100.jpg 150w" sizes="(max-width: 638px) 100vw, 638px" /></div><div class="single-post-caption">(Photo: Nigel Kinrade Photography)</div><div class="post-inner"><h1 class="name post-title entry-title"><span itemprop="name">Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian</span></h1><p class="post-meta"> <span class="post-meta-author"><i class="fa fa-user"></i><a href="https://www.frontstretch.com/author/dustin-albino/" title="">Dustin Albino </a></span> <span class="tie-date"><i class="fa fa-clock-o"></i>November 17, 2019</span> <span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/dustin-albino/" rel="category tag">Dustin Albino</a>, <a href="https://www.frontstretch.com/category/featured-content/" rel="category tag">Featured Content</a>, <a href="https://www.frontstretch.com/category/michael-massie/" rel="category tag">Michael Massie</a>, <a href="https://www.frontstretch.com/category/tom-bowles/" rel="category tag">Tom Bowles</a>, <a href="https://www.frontstretch.com/category/xfinity/" rel="category tag">Xfinity</a></span> <span class="post-comments"><i class="fa fa-comments"></i><a href="https://www.frontstretch.com/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/#respond">Leave a comment</a></span></p><div class="clear"></div><div class="entry"><div id="fb-root"></div><p>In a live episode of the <em>Frontstretch Podcast </em>at Homestead-Miami Speedway, <a href="https://twitter.com/DustinAlbino">Dustin Albino</a>, <a href="https://twitter.com/m_massie22">Michael Massie</a> and <a href="https://twitter.com/NASCARBowles">Tom Bowles</a> preview Sunday&#8217;s Cup Series championship race.</p><p>The trio go through why each <a href="/tag/denny-hamlin">Denny Hamlin</a>, <a href="/tag/maartin-truex-jr">Martin Truex Jr.</a>, <a href="/tag/kyle-busch">Kyle Busch</a> and <a href="/tag/kevin-harvick">Kevin Harvick</a> can win the championship.</p><p><a href="/tag/tyler-reddick">Tyler Reddick</a> was victorious in Saturday&#8217;s Xfinity Series race, winning consecutive championships for two different organizations. He bested <a href="/tag/cole-custer">Cole Custer</a> and <a href="/tag/christopher-bell">Christopher Bell</a> in a heavyweight title bout.</p><p>Finally, Albino chatted with Comcast Community Champion of the Year winner, Mike Tatoian, advisory council of USO Delaware. Tatoian is also the President of Dover International Speedway.</p><p><em>Make sure to</em><em> leave us a rating, review and subscribe to the Frontstretch P</em><em>odcast: <a href="https://itunes.apple.com/gh/podcast/frontstretch/id1023154421?mt=2">iTunes</a></em></p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-216636-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.frontstretch.com/wp-content/uploads/2019/11/Homestead-Live.mp3?_=1" /><a href="https://www.frontstretch.com/wp-content/uploads/2019/11/Homestead-Live.mp3">https://www.frontstretch.com/wp-content/uploads/2019/11/Homestead-Live.mp3</a></audio></div><div class="share-post"> <span class="share-text">Share</span><ul class="flat-social"><li><a href="http://www.facebook.com/sharer.php?u=https://www.frontstretch.com/?p=216636" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li><a href="https://twitter.com/intent/tweet?text=Frontstretch+Podcast%3A+Live+at+Homestead%2C+Comcast+Community+Award+Winner+Mike+Tatoian&url=https://www.frontstretch.com/?p=216636" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li><a href="http://www.stumbleupon.com/submit?url=https://www.frontstretch.com/?p=216636&title=Frontstretch+Podcast%3A+Live+at+Homestead%2C+Comcast+Community+Award+Winner+Mike+Tatoian" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.frontstretch.com/?p=216636&title=Frontstretch+Podcast%3A+Live+at+Homestead%2C+Comcast+Community+Award+Winner+Mike+Tatoian" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.frontstretch.com/?p=216636&amp;description=Frontstretch+Podcast%3A+Live+at+Homestead%2C+Comcast+Community+Award+Winner+Mike+Tatoian&amp;media=https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Homestead-2019.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li></ul><div class="clear"></div></div><div class="clear"></div></div> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2019-11-17T00:12:37-05:00","datePublished":"2019-11-17T00:12:37-05:00","dateModified":"2019-11-17T00:12:37-05:00","headline":"Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian","name":"Frontstretch Podcast: Live at Homestead, Comcast Community Award Winner Mike Tatoian","keywords":"Christopher Bell,Cole Custer,Denny Hamlin,Kevin Harvick,Kyle Busch,Martin Truex Jr.,Tyler Reddick","url":"https:\/\/www.frontstretch.com\/2019\/11\/17\/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian\/","description":"In a live episode of the\u00a0Frontstretch Podcast\u00a0at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday's Cup Series championship race. The trio go through why each Denn","copyrightYear":"2019","publisher":{"@id":"#Publisher","@type":"Organization","name":"Frontstretch","logo":{"@type":"ImageObject","url":"https:\/\/frontstretch.com\/wp-content\/uploads\/2016\/03\/FS-Logo.png"},"sameAs":["http:\/\/www.facebook.com\/frontstretch","http:\/\/www.twitter.com\/frontstretch","https:\/\/www.youtube.com\/channel\/UCdyxs72fFqy2fUgah2-_BGw","https:\/\/itunes.apple.com\/us\/podcast\/frontstretch\/id1023154421","https:\/\/www.instagram.com\/frontstretchdotcom"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.frontstretch.com\/2019\/11\/17\/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian\/"},"author":{"@type":"Person","name":"Dustin Albino","url":"https:\/\/www.frontstretch.com\/author\/dustin-albino\/"},"articleSection":"Cup Series,Dustin Albino,Featured Content,Michael Massie,Tom Bowles,Xfinity","articleBody":"In a live episode of the\u00a0Frontstretch Podcast\u00a0at Homestead-Miami Speedway, Dustin Albino, Michael Massie and Tom Bowles preview Sunday's Cup Series championship race.\r\n\r\nThe trio go through why each Denny Hamlin, Martin Truex Jr., Kyle Busch and Kevin Harvick can win the championship.\r\n\r\nTyler Reddick was victorious in Saturday's Xfinity Series race, winning consecutive championships for two different organizations. He bested Cole Custer and Christopher Bell in a heavyweight title bout.\r\n\r\nFinally, Albino chatted with Comcast Community Champion of the Year winner, Mike Tatoian, advisory council of USO Delaware. Tatoian is also the President of Dover International Speedway.\r\n\r\nMake sure to\u00a0leave us a rating, review and subscribe to the Frontstretch Podcast:\u00a0iTunes\r\n\r\n","image":{"@type":"ImageObject","url":"https:\/\/www.frontstretch.com\/wp-content\/uploads\/2019\/11\/Tyler-Reddick-Homestead-2019.jpg","width":696,"height":426}}</script> </article><p class="post-tag">Tags <a href="https://www.frontstretch.com/tag/christopher-bell/" rel="tag">Christopher Bell</a> <a href="https://www.frontstretch.com/tag/cole-custer/" rel="tag">Cole Custer</a> <a href="https://www.frontstretch.com/tag/denny-hamlin/" rel="tag">Denny Hamlin</a> <a href="https://www.frontstretch.com/tag/kevin-harvick/" rel="tag">Kevin Harvick</a> <a href="https://www.frontstretch.com/tag/kyle-busch/" rel="tag">Kyle Busch</a> <a href="https://www.frontstretch.com/tag/martin-truex-jr/" rel="tag">Martin Truex Jr.</a> <a href="https://www.frontstretch.com/tag/tyler-reddick/" rel="tag">Tyler Reddick</a></p><div class="e3lan e3lan-post"> <a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon" > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon" /> </a></div><section id="author-box"><div class="block-head"><h3>About Dustin Albino</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="author-bio"><div class="author-avatar"> <img src="https://www.frontstretch.com/wp-content/uploads/2016/07/Dustin-and-Dale-e1518119312361-150x138.jpg" width="90" height="83" alt="Dustin Albino" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 alignnone photo" /></div><div class="author-description"> Dustin joined the Frontstretch team at the beginning of the 2016 season. 2018 marks his fourth full-time season covering the sport that he grew up loving. His dream was to one day be a NASCAR journalist, thus why he attended Ithaca College (Class of 2018) to earn a journalism degree. Since the ripe age of four, he knew he wanted to be in the sport in some fashion. It's safe to say Dustin is living the dream.</div><div class="author-social flat-social"> <a class="social-facebook" target="_blank" href="https://www.facebook.com/Dustin-Albino-1649260695340254/?ref=aymt_homepage_panel"><i class="fa fa-facebook"></i></a> <a class="social-twitter" target="_blank" href="http://twitter.com/@DustinAlbino"><i class="fa fa-twitter"></i><span> @@DustinAlbino</span></a> <a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/dustin-albino-4bb934105?trk=nav_responsive_tab_profile"><i class="fa fa-linkedin"></i></a> <a class="social-instagram" target="_blank" href="https://www.instagram.com/dustin_albino/?hl=en"><i class="fa fa-instagram"></i></a></div><div class="clear"></div></div></div></section><div class="post-navigation"><div class="post-previous"><a href="https://www.frontstretch.com/2019/11/16/xfinity-breakdown-tyler-reddick-proves-biggest-of-big-3/" rel="prev"><span>Previous</span> Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3</a></div><div class="post-next"></div></div><section id="related_posts"><div class="block-head"><h3>Related Articles</h3><div class="stripe-line"></div></div><div class="post-listing"><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/11/16/xfinity-breakdown-tyler-reddick-proves-biggest-of-big-3/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019HomesteadNXSTylerReddickTrophyCCK-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/11/16/xfinity-breakdown-tyler-reddick-proves-biggest-of-big-3/" rel="bookmark">Xfinity Breakdown: Tyler Reddick Proves Biggest of Big 3</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/11/16/justin-allgaier-just-didnt-have-the-speed-at-homestead-finishes-fourth-in-championship/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/11/2019HomesteadNXSJustinAllgaierCarCCK-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/11/16/justin-allgaier-just-didnt-have-the-speed-at-homestead-finishes-fourth-in-championship/" rel="bookmark">Justin Allgaier &#8216;Just Didn&#8217;t Have The Speed&#8217; At Homestead, Finishes 4th In Championship</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></p></div><div class="related-item"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/11/16/christopher-bell-leaves-xfinity-series-without-championship/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/11/Christopher-Bell-Homestead-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h3><a href="https://www.frontstretch.com/2019/11/16/christopher-bell-leaves-xfinity-series-without-championship/" rel="bookmark">Christopher Bell Leaves NASCAR Xfinity Series Without Championship</a></h3><p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>November 16, 2019</span></p></div><div class="clear"></div></div></section><section id="check-also-box" class="post-listing check-also-right"> <a href="#" id="check-also-close"><i class="fa fa-close"></i></a><div class="block-head"><h3>Check Also</h3></div><div class="check-also-post"><div class="post-thumbnail"> <a href="https://www.frontstretch.com/2019/11/16/cole-custer-finishes-runner-up-in-xfinity-championship-for-2nd-straight-season/"> <img width="310" height="165" src="https://www.frontstretch.com/wp-content/uploads/2019/11/Tyler-Reddick-Cole-Custer-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" /> <span class="fa overlay-icon"></span> </a></div><h2 class="post-title"><a href="https://www.frontstretch.com/2019/11/16/cole-custer-finishes-runner-up-in-xfinity-championship-for-2nd-straight-season/" rel="bookmark">Cole Custer Finishes Runner-Up in Xfinity Championship for 2nd Straight Season</a></h2><p>Entering the NASCAR Xfinity Series championship race at Homestead-Miami Speedway, Cole Custer, Tyler Reddick and &hellip;</p></div></section><div id="comments"><div class="clear"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/11/17/frontstretch-podcast-live-at-homestead-comcast-community-award-winner-mike-tatoian/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='216636' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="40e9dc97ef" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="204"/></p></form></div></div></div><aside id="sidebar"><div class="theiaStickySidebar"><div id="ads300_250-widget-8" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:250px"
 data-ad-client="ca-pub-1931074544731095"
 data-ad-slot="2498160170"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="text-42" class="widget widget_text"><div class="widget-top"><h4>Connect with Frontstretch</h4><div class="stripe-line"></div></div><div class="widget-container"><div class="textwidget"><center> <a href="https://twitter.com/frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Twitter-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://www.facebook.com/Frontstretch"><img src="https://frontstretch.com/wp-content/uploads/2014/12/Facebook_Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://instagram.com/frontstretchdotcom/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Instagram-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.com/wp-content/uploads/2015/07/YouTube-Logo.png" style="width:60px;height:60px;border:0;"></a> <br /><br /> <a href="https://frontstretch.com/podcast/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/Podcast-Logo.png" style="width:60px;height:60px;border:0;"></a> <a href="https://frontstretch.com/feed/"><img src="https://frontstretch.com/wp-content/uploads/2015/07/RSS-Logo.jpg" style="width:60px;height:60px;border:0;"></a> <a href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.com/wp-content/uploads/2015/07/iTunes-Logo.png" style="width:60px;height:60px;border:0;"></a></center></div></div></div><div id="ads250_250-widget-7" class="e3lan-widget-content e3lan250-250"><div class="e3lan-cell"> <a href="https://www.extremeterrain.com/jeep-accessories-parts.html"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2019/09/xt-AZoffroading-banner_250x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-2" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://racingelectronics.com/collections/legend-fanvision/products/legend-gray"  target="_blank"  > <img src="https://www.frontstretch.com/wp-content/uploads/2019/02/2019_re_310x250.jpg" alt="" /> </a></div></div><div id="ads300_250-widget-12" class="e3lan-widget-content e3lan300-250"><div class="e3lan-cell"> <a href="https://www.patreon.com/frontstretch"  > <img src="https://www.frontstretch.com/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="" /> </a></div></div><div id="enhancedtextwidget-3" class="widget widget_text enhanced-text-widget"><div class="textwidget widget-text"><a href="http://thepitlane.org/"><img src="https://frontstretch.com/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg"></a></div></div></div></div></aside><div class="clear"></div></div><div class="clear"></div><div class="footer-bottom"><div class="container"><div class="alignright"> © Copyright 2019, All Rights Reserved</div><div class="social-icons"> <a class="ttip-none" title="Rss" href="https://www.frontstretch.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="http://www.facebook.com/frontstretch" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://www.twitter.com/frontstretch" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/frontstretch/id1023154421" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/frontstretchdotcom" target="_blank"><i class="fa fa-instagram"></i></a> <a class="ttip-none"  title="Patreon" href="https://www.patreon.com/frontstretch" target="_blank"><i class="fa f3d9"></i></a></div><div class="alignleft"> All images are the property of their respective photographers. These images may not be reproduced, copied or transmitted without the written consent of the photographer.</div><div class="clear"></div></div></div></div></div></div><div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div><div id="fb-root"></div> <script>var ai_insert_6 = function(){
    ai_insert ('prepend', '.e3lan-below_header', b64d ('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'));
  };
  if (document.readyState === 'complete' || (document.readyState !== 'loading' && !document.documentElement.doScroll)) ai_insert_6 (); else document.addEventListener ('DOMContentLoaded', ai_insert_6);</script> <script>setTimeout (function() {Array.prototype.forEach.call (document.querySelectorAll (".ai-viewports"), function (element, index) {ai_insert_code (element);});}, 10);</script> <script type="text/javascript">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</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.frontstretch.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var pollsL10n = {"ajax_url":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script type='text/javascript'>var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};</script> <script type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script type='text/javascript'>var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};</script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script type="text/javascript" defer src="https://www.frontstretch.com/wp-content/cache/autoptimize/js/autoptimize_8059c99422172ebc0bf183871e1bd4c3.js"></script></body></html>