<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel='dns-prefetch' href='//frontstretch.b-cdn.net' />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="NASCAR Mailbox: Is Kaz Grala an Underrated Young Prospect?" />
<meta property="og:description" content="What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. - Doug K., Charlottesville, Va. If I&#039;m" />
<meta property="og:url" content="https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/" />
<meta property="og:site_name" content="Frontstretch" />
<meta property="og:updated_time" content="2021-05-25T22:02:56+00:00" />
<meta property="article:published_time" content="2021-05-25T22:02:56+00:00" />
<meta property="article:modified_time" content="2021-05-25T22:02:56+00:00" />
<meta property="og:image" content="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="426" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="NASCAR Mailbox: Is Kaz Grala an Underrated Young Prospect?" />
<meta name="twitter:description" content="What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. - Doug K., Charlottesville, Va. If I&#039;m" />
<meta name="twitter:image" content="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg" />


<title>NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?</title>
<meta name="description" content="What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. -" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?">
<meta property="og:description" content="What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. -">
<meta property="og:url" content="https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/">
<meta property="og:site_name" content="Frontstretch">
<meta property="article:publisher" content="https://www.facebook.com/Frontstretch">
<meta property="article:tag" content="Joey Logano">
<meta property="article:tag" content="Kaz Grala">
<meta property="article:section" content="Cup Series">
<meta property="og:image" content="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg">
<meta property="og:image:secure_url" content="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg">
<meta property="og:image:width" content="640">
<meta property="og:image:height" content="426">
<meta property="og:image:alt" content="#16: Kaz Grala, Kaulig Racing, Chevrolet Camaro Hyperice">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?">
<meta name="twitter:description" content="What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. -">
<meta name="twitter:site" content="@Frontstretch">
<meta name="twitter:creator" content="@Frontstretch">
<meta name="twitter:image" content="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg">
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["NewsMediaOrganization","Organization"],"@id":"https://www.frontstretch.com/#organization","name":"Frontstretch","url":"https://www.frontstretch.com","logo":{"@type":"ImageObject","@id":"https://www.frontstretch.com/#logo","url":"https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/FSHeaderClear.png","caption":"Frontstretch","inLanguage":"en-US","width":"1200","height":"226"}},{"@type":"WebSite","@id":"https://www.frontstretch.com/#website","url":"https://www.frontstretch.com","name":"Frontstretch","publisher":{"@id":"https://www.frontstretch.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg","url":"https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg","width":"640","height":"426","caption":"#16: Kaz Grala, Kaulig Racing, Chevrolet Camaro Hyperice","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.frontstretch.com/author/dsegal/","name":"Davey Segal","url":"https://www.frontstretch.com/author/dsegal/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/24dda09574ef94c821eff9b84c15a7b7?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/24dda09574ef94c821eff9b84c15a7b7?s=96&amp;d=mm&amp;r=g","caption":"Davey Segal","inLanguage":"en-US"},"sameAs":["http://www.daveysegal.com"],"worksFor":{"@id":"https://www.frontstretch.com/#organization"}},{"@type":"WebPage","@id":"https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/#webpage","url":"https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/","name":"NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?","datePublished":"2021-05-25T22:02:56-04:00","dateModified":"2021-05-25T22:02:56-04:00","author":{"@id":"https://www.frontstretch.com/author/dsegal/"},"isPartOf":{"@id":"https://www.frontstretch.com/#website"},"primaryImageOfPage":{"@id":"https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?","keywords":"kaz grala","datePublished":"2021-05-25T22:02:56-04:00","dateModified":"2021-05-25T22:02:56-04:00","author":{"@type":"Person","name":"Davey Segal"},"publisher":{"@id":"https://www.frontstretch.com/#organization"},"description":"What does the future look like for Kaz Grala? He&#039;s consistently performed in whatever equipment he&#039;s put in and seems to have a bright future ahead of him. -","copyrightYear":"2021","copyrightHolder":{"@id":"https://www.frontstretch.com/#organization"},"name":"NASCAR Mailbox: Is Kaz Grala An Underrated Young Prospect?","@id":"https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/#richSnippet","isPartOf":{"@id":"https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/#webpage"},"image":{"@id":"https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//resources.infolinks.com' />
<link rel='dns-prefetch' href='//adservice.google.com' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//stats.g.doubleclick.net' />
<link rel='dns-prefetch' href='//cm.g.doubleclick.net' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel='stylesheet' id='sby_styles-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/feeds-for-youtube/css/sb-youtube.min.css?ver=1.4' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://frontstretch.b-cdn.net/wp-includes/css/dist/block-library/style.css?ver=5.7.2' media='all' />
<link rel='stylesheet' id='ssp-recent-episodes-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/seriously-simple-podcasting/assets/css/recent-episodes.css?ver=2.7.0' media='all' />
<link rel='stylesheet' id='dpsp-frontend-style-pro-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/social-pug/assets/dist/style-frontend-pro.1.18.2.css?ver=1.18.2' media='all' />
<link rel='stylesheet' id='generate-comments-css' href='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/css/components/comments.css?ver=3.0.3' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css' href='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/css/components/widget-areas.css?ver=3.0.3' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/css/main.css?ver=3.0.3' media='all' />
<style id='generate-style-inline-css'>
.is-right-sidebar{width:30%;}.is-left-sidebar{width:30%;}.site-content .content-area{width:70%;}@media (max-width: 780px){.main-navigation .menu-toggle,.sidebar-nav-mobile:not(#sticky-placeholder){display:block;}.main-navigation ul,.gen-sidebar-nav,.main-navigation:not(.slideout-navigation):not(.toggled) .main-nav > ul,.has-inline-mobile-toggle #site-navigation .inside-navigation > *:not(.navigation-search):not(.main-nav){display:none;}.nav-align-right .inside-navigation,.nav-align-center .inside-navigation{justify-content:space-between;}}
.dynamic-author-image-rounded{border-radius:100%;}.dynamic-featured-image, .dynamic-author-image{vertical-align:middle;}.one-container.blog .dynamic-content-template:not(:last-child), .one-container.archive .dynamic-content-template:not(:last-child){padding-bottom:0px;}.dynamic-entry-excerpt > p:last-child{margin-bottom:0px;}
</style>
<link rel='stylesheet' id='cff-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/custom-facebook-feed/assets/css/cff-style.css?ver=2.19.1' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.7.2' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/tablepress/css/default.css?ver=1.13' media='all' />
<link rel='stylesheet' id='tablepress-custom-css' href='https://frontstretch.b-cdn.net/wp-content/tablepress-custom.css?ver=44' media='all' />
<link rel='stylesheet' id='generatepress-dynamic-css' href='https://frontstretch.b-cdn.net/wp-content/uploads/generatepress/style.min.css?ver=1620735913' media='all' />
<link rel='stylesheet' id='generate-child-css' href='https://frontstretch.b-cdn.net/wp-content/themes/generatepress_fs_child/style.css?ver=1618234757' media='all' />
<link rel='stylesheet' id='generate-blog-images-css' href='https://frontstretch.b-cdn.net/wp-content/plugins/gp-premium/blog/functions/css/featured-images.css?ver=2.0.2' media='all' />
<style id='rocket-lazyload-inline-css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://frontstretch.b-cdn.net/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}.wp-has-aspect-ratio .rll-youtube-player{position:absolute;padding-bottom:0;width:100%;height:100%;top:0;bottom:0;left:0;right:0}
</style>
<script src='https://frontstretch.b-cdn.net/wp-includes/js/jquery/jquery.js?ver=3.5.1' id='jquery-core-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-includes/js/jquery/jquery-migrate.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.frontstretch.com/feed/podcast" />
<style type="text/css" data-source="Grow Social by Mediavine">
					@media screen and ( max-width : 720px ) {
						#dpsp-floating-sidebar.dpsp-hide-on-mobile { display: none !important; }
					}
				
					@media screen and ( max-width : 720px ) {
						.dpsp-share-text.dpsp-hide-on-mobile { display: none !important; }
					}
				</style><script type="text/javascript">/* <![CDATA[ */if (!window["WPAC"]) var WPAC = {};WPAC._Options = {debug:false,selectorCommentForm:"#commentform",selectorCommentsContainer:"#comments,.comments-wrapper",selectorCommentPagingLinks:"#comments [class^='nav-'] a",selectorCommentLinks:"#comments a[href*=\"/comment-page-\"]",selectorRespondContainer:"#respond",selectorErrorContainer:"p:parent",popupCornerRadius:5,popupMarginTop:10,popupWidth:30,popupPadding:5,popupFadeIn:400,popupFadeOut:400,popupTimeout:3000,popupBackgroundColorLoading:"#000",popupTextColorLoading:"#fff",popupBackgroundColorSuccess:"#008000",popupTextColorSuccess:"#fff",popupBackgroundColorError:"#f00",popupTextColorError:"#fff",popupOpacity:70,popupTextAlign:"center",popupTextFontSize:"Default font size",popupZindex:1000,scrollSpeed:500,autoUpdateIdleTime:0,textPosted:"Your comment has been posted. Thank you!",textPostedUnapproved:"Your comment has been posted and is awaiting moderation. Thank you!",textReloadPage:"Reloading page. Please wait&hellip;",textPostComment:"Posting your comment. Please wait&hellip;",textRefreshComments:"Loading comments. Please wait&hellip;",textUnknownError:"Something went wrong, your comment has not been posted.",selectorPostContainer:"",commentPagesUrlRegex:"",asyncLoadTrigger:"Viewport",disableUrlUpdate:false,disableScrollToAnchor:false,disableCache:true,enableByQuery:false,commentsEnabled:true,version:"1.7.3"};WPAC._Callbacks = {"beforeSelectElements": function(dom) {},"beforeUpdateComments": function(newDom, commentUrl) {},"afterUpdateComments": function(newDom, commentUrl) {},"beforeSubmitComment": function() {},"afterPostComment": function(commentUrl, unapproved) {}};/* ]]> */</script><meta name="viewport" content="width=device-width, initial-scale=1"><style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><script id="google_gtagjs" src="https://www.frontstretch.com/?local_ga_js=ce01e5c8574acc77e0fc3ad8a58954c9" async></script>
<script id="google_gtagjs-inline">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());gtag('config', 'UA-34668381-1', {} );
</script>
<link rel="icon" href="https://frontstretch.b-cdn.net/wp-content/uploads/2015/06/frontstretch-sq-logo-55x55.png" sizes="32x32" />
<link rel="icon" href="https://frontstretch.b-cdn.net/wp-content/uploads/2015/06/frontstretch-sq-logo.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://frontstretch.b-cdn.net/wp-content/uploads/2015/06/frontstretch-sq-logo.png" />
<meta name="msapplication-TileImage" content="https://frontstretch.b-cdn.net/wp-content/uploads/2015/06/frontstretch-sq-logo.png" />
<style>
.code-block-center {margin: 8px auto; text-align: center; display: block; clear: both;}
.code-block- {}
.code-block-default {margin: 8px 0; clear: both;}
</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-1078134 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade has-grow-sidebar right-sidebar nav-below-header separate-containers header-aligned-center dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <header id="masthead" class="site-header" itemtype="https://schema.org/WPHeader" itemscope>
<div class="inside-header">
<div class="site-logo">
<a href="https://www.frontstretch.com/" title="Frontstretch" rel="home">
<img class="header-image is-logo-image" alt="Frontstretch" src="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/FSHeaderClear.png" title="Frontstretch" width="1200" height="226" />
</a>
</div> </div>
</header>
<nav id="site-navigation" class="main-navigation grid-container sub-menu-right" itemtype="https://schema.org/SiteNavigationElement" itemscope>
<div class="inside-navigation grid-container">
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" />
</svg><svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" />
</svg></span><span class="mobile-menu">Menu</span> </button>
<div id="primary-menu" class="main-nav"><ul id="menu-fs-menu-2021" class=" menu sf-menu"><li id="menu-item-1070541" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1070541"><a href="https://www.frontstretch.com/">Home</a></li>
<li id="menu-item-1070542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1070542"><a>NASCAR<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" fill-rule="nonzero" />
</svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-1072288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1072288"><a href="https://www.frontstretch.com/category/daily-fantasy-forecast/">Daily Fantasy Forecast</a></li>
<li id="menu-item-1070571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070571"><a href="https://www.frontstretch.com/2021-nascar-race-weekend-central/">Race Weekend Central</a></li>
<li id="menu-item-1070544" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1070544"><a href="https://www.frontstretch.com/category/cup-series/">NASCAR Cup Series</a></li>
<li id="menu-item-1070545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070545"><a href="https://www.frontstretch.com/category/xfinity/">Xfinity Series</a></li>
<li id="menu-item-1070546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070546"><a href="https://www.frontstretch.com/category/truck-series/">Camping World Truck Series</a></li>
<li id="menu-item-1070556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070556"><a href="https://www.frontstretch.com/category/arca/">ARCA</a></li>
<li id="menu-item-1070543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070543"><a href="https://www.frontstretch.com/category/enascar/iracing/">iRacing</a></li>
</ul>
</li>
<li id="menu-item-1070552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1070552"><a>Other Racing<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" fill-rule="nonzero" />
</svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-1070554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070554"><a href="https://www.frontstretch.com/category/indycar/">NTT IndyCar Series</a></li>
<li id="menu-item-1070555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070555"><a href="https://www.frontstretch.com/category/f1/">Formula 1 Racing</a></li>
<li id="menu-item-1070557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070557"><a href="https://www.frontstretch.com/category/sports-cars/">Sports Cars</a></li>
<li id="menu-item-1076003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1076003"><a href="https://www.frontstretch.com/category/srx/">SRX</a></li>
<li id="menu-item-1070553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070553"><a href="https://www.frontstretch.com/category/dirt-racing/">Dirt Racing</a></li>
</ul>
</li>
<li id="menu-item-1070559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-1070559"><a href="https://www.frontstretch.com/">Television<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" fill-rule="nonzero" />
</svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-1070551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070551"><a href="https://www.frontstretch.com/category/couch-potato-tuesday/">TV Critique</a></li>
<li id="menu-item-1070562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070562"><a href="https://www.frontstretch.com/tv-ratings/">TV Ratings</a></li>
<li id="menu-item-1070564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070564"><a href="https://www.frontstretch.com/tv-schedule/">TV Schedule</a></li>
</ul>
</li>
<li id="menu-item-1070560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-1070560"><a href="https://www.frontstretch.com/">Multimedia<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" fill-rule="nonzero" />
</svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-1070565" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070565"><a href="https://www.frontstretch.com/category/podcast/">Frontstretch Podcast</a></li>
<li id="menu-item-1070568" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1070568"><a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw">Frontstretch YouTube</a></li>
<li id="menu-item-1070561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070561"><a href="https://www.frontstretch.com/category/reel-racing/">Reel Racing</a></li>
<li id="menu-item-1070566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1070566"><a href="https://www.frontstretch.com/category/stock-car-scoop/">Stock Car Scoop</a></li>
</ul>
</li>
<li id="menu-item-1070569" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1070569"><a>About<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" fill-rule="nonzero" />
</svg></span></span></a>
<ul class="sub-menu">
<li id="menu-item-1070572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070572"><a href="https://www.frontstretch.com/advertise-with-us/">Advertise with Us</a></li>
<li id="menu-item-1070574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070574"><a href="https://www.frontstretch.com/contact-us/">Contact Us</a></li>
<li id="menu-item-1072287" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1072287"><a href="https://www.frontstretch.com/jobs/">Frontstretch Jobs</a></li>
<li id="menu-item-1070576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1070576"><a href="https://www.patreon.com/frontstretch">Patreon</a></li>
<li id="menu-item-1072289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1072289"><a href="https://www.frontstretch.com/our-staff/">Staff</a></li>
<li id="menu-item-1072291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1072291"><a href="https://www.frontstretch.com/newsletter/">Subscribe to the Newsletter</a></li>
<li id="menu-item-1072290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1072290"><a href="https://www.frontstretch.com/about-us/">Welcome to Frontstretch</a></li>
</ul>
</li>
</ul></div> </div>
</nav><div class='code-block code-block-center code-block-10 ai-track' data-ai='WzEwLDAsIkVudGVycHJpc2UgSGVhZGVyIEJhbm5lciIsIiIsMV0='>
<div class="header-banner">
<a href="//elink.enterprise.com/en/20/09/frontstretchcom-llc.html">
<img src="https://frontstretch.b-cdn.net/wp-content/uploads/2021/05/enterprise-banner-2021-970.jpg" alt="Enterprise: Race in and get the same deals drivers and teams use">
</a></div></div>
<div id="page" class="site grid-container container hfeed">
<div class='code-block code-block-center code-block-14'>
<div class="header-banner"><a href="/2021-nascar-race-weekend-central/"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-race-weekend-central-banner.png" alt="NASCAR Race Weekend Central" width="970" height="90" /></a></div></div>
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main">
<span class="ai-content"></span>
<article id="post-1078134" class="post-1078134 post type-post status-publish format-standard has-post-thumbnail hentry category-cup-series category-davey-segal category-nascar-mailbox tag-joey-logano tag-kaz-grala" itemtype="https://schema.org/CreativeWork" itemscope>
<div class="inside-article">
<div class="featured-image  page-header-image-single ">
<div class="wp-caption thumb-caption"><img width="640" height="426" src="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg" class="attachment-full size-full" alt="#16: Kaz Grala, Kaulig Racing, Chevrolet Camaro Hyperice" itemprop="image" srcset="https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP.jpg 640w, https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP-300x200.jpg 300w, https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP-150x100.jpg 150w, https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP-310x205.jpg 310w" sizes="(max-width: 640px) 100vw, 640px" title="NASCAR Mailbox: Is Kaz Grala an Underrated Young Prospect? 1"><p class="wp-caption-text thumb-caption-text">(Photo: Nigel Kinrade Photography)</p></div>
</div> <header class="entry-header">
<h1 class="entry-title" itemprop="headline">NASCAR Mailbox: Is Kaz Grala an Underrated Young Prospect?</h1> <div class="entry-meta">
<span class="posted-on"><time class="entry-date published" datetime="2021-05-25T22:02:56-04:00" itemprop="datePublished">May 25, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.frontstretch.com/author/dsegal/" title="View all posts by Davey Segal" rel="author" itemprop="url"><span class="author-name" itemprop="name">Davey Segal</span></a></span></span> </div>
</header>
<div class="entry-content" itemprop="text">
<p><strong>What does the future look like for <a href="/tag/kaz-grala">Kaz Grala</a>? He&#8217;s consistently performed in whatever equipment he&#8217;s put in and seems to have a bright future ahead of him. &#8211; Doug K., Charlottesville, Va.</strong></p>
<p>If I&#8217;m a NASCAR Cup Series owner (I&#8217;m not, just for clarity here), Grala would be on my short list of candidates to put in a vacant seat. He&#8217;s a young driver who has made the most of his limited opportunities, represents his sponsors well and can flat out race.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.frontstretch.com/2021/04/20/part-timer-kaz-grala-talks-racing-talladega-future-nascar-goals/" target="_self" rel="nofollow" class="IRPP_kangoo"><style> .IRPP_kangoo , .IRPP_kangoo .postImageUrl , .IRPP_kangoo .imgUrl , .IRPP_kangoo .centered-text-area { min-height: 100px; position: relative; } .IRPP_kangoo , .IRPP_kangoo:hover , .IRPP_kangoo:visited , .IRPP_kangoo:active { border:0!important; } .IRPP_kangoo { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #eaeaea; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_kangoo:active , .IRPP_kangoo:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #FFFFFF; } .IRPP_kangoo .postImageUrl , .IRPP_kangoo .imgUrl { background-position: center; background-size: cover; float: left; margin: 0; padding: 0; } .IRPP_kangoo .postImageUrl { width: 30%; } .IRPP_kangoo .imgUrl { width: 100%; } .IRPP_kangoo .centered-text-area { float: right; width: 70%; padding:0; margin:0; } .IRPP_kangoo .centered-text { display: table; height: 100px; left: 0; top: 0; padding:0; margin:0; } .IRPP_kangoo .IRPP_kangoo-content { display: table-cell; margin: 0; padding: 0 10px 0 10px; position: relative; vertical-align: middle; width: 100%; } .IRPP_kangoo .ctaText { border-bottom: 0 solid #fff; color: #34495E; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; text-decoration: underline; } .IRPP_kangoo .postTitle { color: #000000; font-size: 16px; font-weight: 600; margin: 0; padding: 0; } .IRPP_kangoo .ctaButton { background-color: #FFFFFF; margin-left: 10px; position: absolute; right: 0; top: 0; } .IRPP_kangoo:hover .imgUrl { -webkit-transform: scale(1.2); -moz-transform: scale(1.2); -o-transform: scale(1.2); -ms-transform: scale(1.2); transform: scale(1.2); } .IRPP_kangoo .imgUrl { -webkit-transition: -webkit-transform 0.4s ease-in-out; -moz-transition: -moz-transform 0.4s ease-in-out; -o-transition: -o-transform 0.4s ease-in-out; -ms-transition: -ms-transform 0.4s ease-in-out; transition: transform 0.4s ease-in-out; } .IRPP_kangoo:after { content: ""; display: block; clear: both; } </style><div class="postImageUrl" style="overflow:hidden; z-index: 10; max-width: 100%;"><div class="imgUrl" style="background-image:url(https://frontstretch.b-cdn.net/wp-content/uploads/2021/02/2021-Daytona-I-Cup-Kaz-Grala-NKP-300x200.jpg);"></div></div><div class="centered-text-area"><div class="centered-text"><div class="IRPP_kangoo-content"><div class="ctaText" style="float:left;">READ</div><div class="clear:both;"></div><div class="postTitle" style="float:left;">Part-Time Pains: Kaz Grala Talks Racing Cup at Talladega, Future NASCAR Goals</div></div></div></div></a></div>
<p>He&#8217;s only made three Cup starts, but has finished inside the top 10 twice. Limited sample size and two of the three have come on superspeedways, but stats are stats no matter how you slice them. He finished top 10 in three of his five NASCAR Xfinity Series starts for Richard Childress Racing last year and recently impressed at Circuit of the Americas in a Young&#8217;s Motorsports truck, finishing second after leading 11 of the 41 laps.</p>
<p>It&#8217;s no secret Grala wants to be in Cup too. He was slated to have a full-time opportunity at the premier level this season, only for lack of sponsorship to curtail his efforts.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">We can still close these deals, but I need a little help from you guys 👊🏻 <a href="https://t.co/M8SZRpt2m3">pic.twitter.com/M8SZRpt2m3</a></p>
<p>&mdash; Kaz Grala (@KazGrala) <a href="https://twitter.com/KazGrala/status/1320756572767793154?ref_src=twsrc%5Etfw" rel="noopener">October 26, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>He still was able to land a limited schedule with Kaulig Racing (who are going full-time in Cup next year) and has remained close with team president Chris Rice, as well as owner Matt Kaulig. With Grala being a young, marketable driver at age 22, he would be a great candidate to fill Kaulig&#8217;s vacant car for 2022, if not <a href="/tag/justin-haley">Justin Haley</a> or <a href="/tag/aj-allmendinger">AJ Allmendinger</a>.</p>
<p>There lies the issue, though. Two drivers (one a proven Cup winner, one also a Cup winner with multiple years of Xfinity experience under his belt) are also in the mix (theoretically) for that ride, which may leave Grala out of a competitive Cup ride.</p>
<p>Or so we think. Silly Season works in mysterious ways, and who knows what team(s) may expand, which new teams may enter the sport with the introduction of the NextGen car or if a departure of Allmendinger or Haley leaves a vacant Xfinity ride with Kaulig open.</p>
<p>Would Grala be open to running full-time in Xfinity despite already theoretically having proven himself at the top level? Only he knows the answer. But one thing is for sure: the NASCAR world is taking notice of the youngster, as he&#8217;ll be around for years and years to come.</p>
<p><strong>Even though the visibility was an issue, the Goodyear rain tires held up well. Could we see rain racing on ovals since we know the tires work? Amelia Y., Omaha, Neb.</strong></p>
<p>There&#8217;s been a wet weather test at Martinsville Speedway, and <a href="/tag/joey-logano">Joey Logano</a> revealed that he&#8217;d be participating in one this week at Richmond Raceway. But in terms of racing in the rain (or even damp) at bigger tracks like, say, Atlanta Motor Speedway, Texas Motor Speedway, Darlington Raceway or Daytona International Speedway, that won&#8217;t be happening.</p>
<p>It&#8217;s just too unsafe. You see what happened in the rain this past weekend at COTA, last year at the Charlotte Motor Speedway ROVAL and in various other rain races across all three national series over the years. And that&#8217;s when cars are relatively slow and camber/loads on the vehicles aren&#8217;t what they are on ovals.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.frontstretch.com/2021/05/24/zachs-turn-why-did-nascar-allow-dangerous-conditions-at-cota/" target="_self" rel="nofollow" class="IRPP_kangoo"><style> .IRPP_kangoo , .IRPP_kangoo .postImageUrl , .IRPP_kangoo .imgUrl , .IRPP_kangoo .centered-text-area { min-height: 100px; position: relative; } .IRPP_kangoo , .IRPP_kangoo:hover , .IRPP_kangoo:visited , .IRPP_kangoo:active { border:0!important; } .IRPP_kangoo { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #eaeaea; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_kangoo:active , .IRPP_kangoo:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #FFFFFF; } .IRPP_kangoo .postImageUrl , .IRPP_kangoo .imgUrl { background-position: center; background-size: cover; float: left; margin: 0; padding: 0; } .IRPP_kangoo .postImageUrl { width: 30%; } .IRPP_kangoo .imgUrl { width: 100%; } .IRPP_kangoo .centered-text-area { float: right; width: 70%; padding:0; margin:0; } .IRPP_kangoo .centered-text { display: table; height: 100px; left: 0; top: 0; padding:0; margin:0; } .IRPP_kangoo .IRPP_kangoo-content { display: table-cell; margin: 0; padding: 0 10px 0 10px; position: relative; vertical-align: middle; width: 100%; } .IRPP_kangoo .ctaText { border-bottom: 0 solid #fff; color: #34495E; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; text-decoration: underline; } .IRPP_kangoo .postTitle { color: #000000; font-size: 16px; font-weight: 600; margin: 0; padding: 0; } .IRPP_kangoo .ctaButton { background-color: #FFFFFF; margin-left: 10px; position: absolute; right: 0; top: 0; } .IRPP_kangoo:hover .imgUrl { -webkit-transform: scale(1.2); -moz-transform: scale(1.2); -o-transform: scale(1.2); -ms-transform: scale(1.2); transform: scale(1.2); } .IRPP_kangoo .imgUrl { -webkit-transition: -webkit-transform 0.4s ease-in-out; -moz-transition: -moz-transform 0.4s ease-in-out; -o-transition: -o-transform 0.4s ease-in-out; -ms-transition: -ms-transform 0.4s ease-in-out; transition: transform 0.4s ease-in-out; } .IRPP_kangoo:after { content: ""; display: block; clear: both; } </style><div class="postImageUrl" style="overflow:hidden; z-index: 10; max-width: 100%;"><div class="imgUrl" style="background-image:url(https://frontstretch.b-cdn.net/wp-content/uploads/2021/05/2021-COTA-Cup-Corey-LaJoie-racing-NKP-300x199.jpg);"></div></div><div class="centered-text-area"><div class="centered-text"><div class="IRPP_kangoo-content"><div class="ctaText" style="float:left;">READ</div><div class="clear:both;"></div><div class="postTitle" style="float:left;">Zach's Turn: Why Did NASCAR Allow Such Dangerous Conditions at COTA?</div></div></div></div></a></div>
<p>Simply put, the speeds are too high, loads are too great and risks are too catastrophic to race in the rain on bigger tracks. But that doesn&#8217;t mean they can&#8217;t do so on short tracks. In fact, that&#8217;s the plan.</p>
<p>The wet weather test at Martinsville was  implemented in the hopes of potentially debuting race-ready rain tires for ovals like &#8220;the Paperclip,&#8221; New Hampshire Motor Speedway, Richmond and others.</p>
<p>&#8220;It’s certainly ambitious,” NASCAR’s Senior Vice President of Racing Innovation John Probst <a href="https://www.nascar.com/news-media/2021/04/01/nascar-short-track-rain-tire-test-martinsville-speedway/" rel="noopener">told NASCAR.com earlier this year</a> regarding the possibility of using the rain tires on ovals this year. “I’m not going to say it’s impossible, but there’s a lot of data we need to go through. We need to not only look at can it be done, but what tracks lie ahead, and there’s a whole lot of different variables that get brought into the mix, including the weather. … I wouldn’t say no, but I certainly wouldn’t sign us up for it either — just yet.”</p>
<p>But getting back to COTA this weekend: that certainly was a bright spot. Even with all the standing water, all the slipping and sliding, all the scary crashes, the Goodyear tires did their job and did so <em>extremely</em> well.</p>
<p>Offensive lineman in football (and <a href="/tag/corey-lajoie">Corey LaJoie</a>, actually) have a rule: if TV doesn&#8217;t talk about you, it means you&#8217;re doing your job. The same can apply to Goodyear. Take the small victories when you get &#8217;em, work on developing for the future, but stay realistic through it all.</p>
<p class="dpsp-share-text ">Share this article</p><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-size-medium dpsp-has-spacing dpsp-show-on-mobile dpsp-button-style-3"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-share dpsp-networks-btns-content dpsp-column-auto dpsp-has-button-icon-animation">
<li>
<a rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&t=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F" class="dpsp-network-btn dpsp-facebook dpsp-first dpsp-has-label" target="_blank" aria-label="Share on Facebook" title="Share on Facebook">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span>
</span>
<span class="dpsp-network-label">Facebook</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="https://twitter.com/intent/tweet?text=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F&url=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&via=Frontstretch" class="dpsp-network-btn dpsp-twitter dpsp-has-label" target="_blank" aria-label="Share on Twitter" title="Share on Twitter">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span>
</span>
<span class="dpsp-network-label">Twitter</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&title=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F&summary=What%20does%20the%20future%20look%20like%20for%20Kaz%20Grala%3F%20He%27s%20consistently%20performed%20in%20whatever%20equipment%20he%27s%20put%20in%20and%20seems%20to%20have%20a%20bright%20future%20ahead%20of%20him.%20-%20Doug%20K.%2C%20Charlottesville%2C%20Va.%20If%20I%27m&mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-has-label" target="_blank" aria-label="Share on LinkedIn" title="Share on LinkedIn">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="32" viewBox="0 0 27 32"><path d="M6.24 11.168v17.696h-5.888v-17.696h5.888zM6.624 5.696q0 1.312-0.928 2.176t-2.4 0.864h-0.032q-1.472 0-2.368-0.864t-0.896-2.176 0.928-2.176 2.4-0.864 2.368 0.864 0.928 2.176zM27.424 18.72v10.144h-5.856v-9.472q0-1.888-0.736-2.944t-2.272-1.056q-1.12 0-1.856 0.608t-1.152 1.536q-0.192 0.544-0.192 1.44v9.888h-5.888q0.032-7.136 0.032-11.552t0-5.28l-0.032-0.864h5.888v2.56h-0.032q0.352-0.576 0.736-0.992t0.992-0.928 1.568-0.768 2.048-0.288q3.040 0 4.896 2.016t1.856 5.952z"></path></svg></span>
</span>
<span class="dpsp-network-label">LinkedIn</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="/cdn-cgi/l/email-protection#edd29e988f87888e99d0a3acbeaeacbfc8dfdda08c84818f8295c8deacc8dfdda49ec8dfdda68c97c8dfddaa9f8c818cc8dfdd8c83c8dfddb88389889f9f8c998889c8dfddb48298838ac8dfddbd9f829e9d888e99c8deabcb8c809dd68f828994d08599999d9ec8deacc8dfabc8dfab9a9a9ac38b9f8283999e999f88998e85c38e8280c8dfabdfdddfdcc8dfabddd8c8dfabdfd8c8dfab838c9e8e8c9fc0808c84818f8295c0849ec0868c97c08a9f8c818cc08c83c0988389889f9f8c998889c0948298838ac09d9f829e9d888e99c8dfab" class="dpsp-network-btn dpsp-email dpsp-last dpsp-has-label" target="_blank" aria-label="Send over email" title="Send over email">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span>
</span>
<span class="dpsp-network-label">Email</span>
</a>
</li>
</ul></div>
</div>
<footer class="entry-meta">
<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
 <path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0 1 43.592 27.907l12.349 26.791A16 16 0 0 0 228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" fill-rule="nonzero" />
</svg></span><span class="screen-reader-text">Categories </span><a href="https://www.frontstretch.com/category/cup-series/" rel="category tag">Cup Series</a>, <a href="https://www.frontstretch.com/category/davey-segal/" rel="category tag">Davey Segal</a>, <a href="https://www.frontstretch.com/category/nascar-mailbox/" rel="category tag">NASCAR Mailbox</a></span> <span class="tags-links"><span class="gp-icon icon-tags"><svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path d="M20 39.5c-8.836 0-16 7.163-16 16v176c0 4.243 1.686 8.313 4.687 11.314l224 224c6.248 6.248 16.378 6.248 22.626 0l176-176c6.244-6.244 6.25-16.364.013-22.615l-223.5-224A15.999 15.999 0 0 0 196.5 39.5H20zm56 96c0-13.255 10.745-24 24-24s24 10.745 24 24-10.745 24-24 24-24-10.745-24-24z" />
<path d="M259.515 43.015c4.686-4.687 12.284-4.687 16.97 0l228 228c4.686 4.686 4.686 12.284 0 16.97l-180 180c-4.686 4.687-12.284 4.687-16.97 0-4.686-4.686-4.686-12.284 0-16.97L479.029 279.5 259.515 59.985c-4.686-4.686-4.686-12.284 0-16.97z" fill-rule="nonzero" />
</svg></span><span class="screen-reader-text">Tags </span><a href="https://www.frontstretch.com/tag/joey-logano/" rel="tag">Joey Logano</a>, <a href="https://www.frontstretch.com/tag/kaz-grala/" rel="tag">Kaz Grala</a></span> <nav id="nav-below" class="post-navigation">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414">
<path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" />
</svg></span><span class="prev" title="Previous"><a href="https://www.frontstretch.com/2021/05/25/waids-world-charlotte-motor-speedway-is-product-of-a-visionary-and-the-pt-barnum-of-racing/" rel="prev">Waid&#8217;s World: Charlotte Motor Speedway Is Product of a Visionary &#038; ‘The P.T. Barnum of Racing’</a></span></div> </nav>
</footer>
</div><div class='code-block code-block-center code-block-13 ai-track' data-ai='WzEzLDAsIlBhdHJlb24gQmFubmVyIEFkIGFuZCBOZXdzbGV0dGVyIEh1c3RsZSBQcm8gZW1iZWQgYWZ0ZXIgYXJ0aWNsZXMiLCIiLDFd'>
<div class="header-banner"><a href="https://www.patreon.com/frontstretch" title="Support Frontstretch on Patreon">
<img src="https://frontstretch.b-cdn.net/wp-content/uploads/2018/11/fs-patreon-banner-728x90.jpg" alt="Support Frontstretch on Patreon">
</a>
</div></div>
</article>
<div class="comments-area">
<p class='comment-policy'>Thanks for choosing to comment on this article. A name and email address are required to post a comment.
The email address is not publicly visible or shared. Please keep in mind that comments are moderated according to our <a href='https://www.frontstretch.com/comment-policy/'>comment policy</a>.</p><div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Comment on this article <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.frontstretch.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1078134' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2eeed89634" /></p><input type="hidden" id="ak_js" name="ak_js" value="106" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
</div>
</div>
<span class="ai-content"></span>
</main>
</div>
<span class="ai-content"></span>
<div id="right-sidebar" class="widget-area sidebar is-right-sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
<div class="inside-right-sidebar">
<aside id="youtube-feeds-widget-2" class="widget inner-padding widget_youtube-feeds-widget">
<div id="sb_youtube_sbyUCdyxs72fFqy2fUgah2BGw1" class="sb_youtube sby_layout_grid sby_col_1 sby_mob_col_1  sby_width_resp" data-feedid="sby_UCdyxs72fFqy2fUgah2-_BGw#1" data-shortcode-atts="{}" data-cols="1" data-colsmobile="1" data-num="1" data-nummobile="1" data-sby-flags="resizeDisable" data-postid="1078134" data-sby-supports-lightbox="1" style="width: 100%;">
<div class="sb_youtube_header ">
<a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw/" target="_blank" rel="noopener" title="@Frontstretch" class="sby_header_link">
<div class="sby_header_text sby_no_bio">
<h3>Frontstretch</h3>
</div>
<div class="sby_header_img" data-avatar-url="https://yt3.ggpht.com/ytc/AAUvwniyY9DSfRbJhAwmZnxJnD4fdQ8RhyCVufpWoD5F=s88-c-k-c0x00ffffff-no-rj">
<div class="sby_header_img_hover"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="youtube" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" class="sby_new_logo svg-inline--fa fa-youtube fa-w-18"><path fill="currentColor" d="M549.655 124.083c-6.281-23.65-24.787-42.276-48.284-48.597C458.781 64 288 64 288 64S117.22 64 74.629 75.486c-23.497 6.322-42.003 24.947-48.284 48.597-11.412 42.867-11.412 132.305-11.412 132.305s0 89.438 11.412 132.305c6.281 23.65 24.787 41.5 48.284 47.821C117.22 448 288 448 288 448s170.78 0 213.371-11.486c23.497-6.321 42.003-24.171 48.284-47.821 11.412-42.867 11.412-132.305 11.412-132.305s0-89.438-11.412-132.305zm-317.51 213.508V175.185l142.739 81.205-142.739 81.201z" class=""></path></svg></div>
<img src="https://yt3.ggpht.com/ytc/AAUvwniyY9DSfRbJhAwmZnxJnD4fdQ8RhyCVufpWoD5F=s88-c-k-c0x00ffffff-no-rj" alt="Frontstretch" width="50" height="50">
</div>
</a>
</div> <div class="sby_items_wrap" style="padding: 5px;">
<div class="sby_item  sby_new sby_transition sby_no_margin" id="sby_VVVkeXhzNzJmRnF5MmZVZ2FoMi1fQkd3LmQ1dTJ4SVdMeGlZ" data-date="1621946383" data-video-id="d5u2xIWLxiY">
<div class="sby_video_thumbnail_wrap">
<a class="sby_video_thumbnail sby_item_video_thumbnail" href="https://www.youtube.com/watch?v=d5u2xIWLxiY" target="_blank" rel="noopener" data-full-res="https://i.ytimg.com/vi/d5u2xIWLxiY/maxresdefault.jpg" data-img-src-set="{&quot;120&quot;:&quot;https:\/\/i.ytimg.com\/vi\/d5u2xIWLxiY\/default.jpg&quot;,&quot;320&quot;:&quot;https:\/\/i.ytimg.com\/vi\/d5u2xIWLxiY\/mqdefault.jpg&quot;,&quot;480&quot;:&quot;https:\/\/i.ytimg.com\/vi\/d5u2xIWLxiY\/hqdefault.jpg&quot;,&quot;640&quot;:&quot;https:\/\/i.ytimg.com\/vi\/d5u2xIWLxiY\/sddefault.jpg&quot;}" data-video-id="d5u2xIWLxiY" data-video-title="Justin Melillo, Michael Massie Turn Season Around with Strong MNR Indiana 500k Finishes">
<img src="https://frontstretch.b-cdn.net/wp-content/plugins/feeds-for-youtube/img/placeholder.png" alt="After a dismal start to season 3 of Monday Night Racing, Frontstretch&#039;s Justin Melillo and Michael Massie finally had a good night in the Indiana 500k at Indianapolis Motor Speedway.

Melillo recaps his fifth-place outing, which involved leading laps and a varrying strategy. Massie talks about how he overcame using his quick repairs up in the first 45 laps of the race to come back and finish 11th.">
<div class="sby_thumbnail_hover">
<span class="sby_video_title">Justin Melillo, Michael Massie Turn Season Around with Strong MNR Indiana 500k Finishes</span>
</div>
<span class="sby-screenreader">YouTube Video VVVkeXhzNzJmRnF5MmZVZ2FoMi1fQkd3LmQ1dTJ4SVdMeGlZ</span>
<div class="sby_play_btn">
<span class="sby_play_btn_bg"></span>
<svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="youtube" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" class="svg-inline--fa fa-youtube fa-w-18"><path fill="currentColor" d="M549.655 124.083c-6.281-23.65-24.787-42.276-48.284-48.597C458.781 64 288 64 288 64S117.22 64 74.629 75.486c-23.497 6.322-42.003 24.947-48.284 48.597-11.412 42.867-11.412 132.305-11.412 132.305s0 89.438 11.412 132.305c6.281 23.65 24.787 41.5 48.284 47.821C117.22 448 288 448 288 448s170.78 0 213.371-11.486c23.497-6.321 42.003-24.171 48.284-47.821 11.412-42.867 11.412-132.305 11.412-132.305s0-89.438-11.412-132.305zm-317.51 213.508V175.185l142.739 81.205-142.739 81.201z" class=""></path></svg> </div>
<span class="sby_loader sby_hidden" style="background-color: rgb(255, 255, 255);"></span>
</a>
</div>
</div> </div>
<div class="sby_footer">
<a class="sby_load_btn" href="javascript:void(0);">
<span class="sby_btn_text">Load More...</span>
<span class="sby_loader sby_hidden" style="background-color: rgb(255, 255, 255);"></span>
</a>
<span class="sby_follow_btn sby_custom">
<a href="https://www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw/" style="background: rgb(182,47,28);" target="_blank" rel="noopener"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="youtube" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" class="svg-inline--fa fa-youtube fa-w-18"><path fill="currentColor" d="M549.655 124.083c-6.281-23.65-24.787-42.276-48.284-48.597C458.781 64 288 64 288 64S117.22 64 74.629 75.486c-23.497 6.322-42.003 24.947-48.284 48.597-11.412 42.867-11.412 132.305-11.412 132.305s0 89.438 11.412 132.305c6.281 23.65 24.787 41.5 48.284 47.821C117.22 448 288 448 288 448s170.78 0 213.371-11.486c23.497-6.321 42.003-24.171 48.284-47.821 11.412-42.867 11.412-132.305 11.412-132.305s0-89.438-11.412-132.305zm-317.51 213.508V175.185l142.739 81.205-142.739 81.201z" class=""></path></svg>Subscribe</a>
</span>
</div>
</div></aside><aside id="ai_widget-17" class="widget inner-padding ai_widget"><a href="https://www.raceweather.net/">
<img src="https://frontstretch.b-cdn.net/wp-content/uploads/2021/05/RaceWeatherForecastUpcomingLogo.png" alt="Weather forecast provided by raceweather.net/">
</a></aside><aside id="ai_widget-12" class="widget inner-padding ai_widget"><div class='code-block code-block-center code-block-12 ai-track' data-ai='WzEyLDAsIkdvb2dsZSBBZHNlbnNlIFNpZGViYXIgQWQgV2lkZ2V0IiwiIiwxXQ=='>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1931074544731095" data-ad-slot="2498160170" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</aside><aside id="custom_html-11" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Connect with Frontstretch</h2><div class="textwidget custom-html-widget"><div align="center">
<a href="//twitter.com/Frontstretch"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/Twitter_Social_Icon_Rounded_Square_Color.svg" alt="Follow Frontstretch on Twitter" title="Follow Frontstretch on Twitter" height="60" width="60" /></a>
<a href="//www.facebook.com/Frontstretch"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/facebook-icon-rounded-square.svg" alt="Like Frontstretch on Facebook" title="Like Frontstretch on Facebook" height="60" width="60" /></a>
<a href="//www.instagram.com/frontstretchdotcom"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/Instagram_simple_icon.svg" alt="Follow Frontstretch on Instagram" title="Follow Frontstretch on Instagram" height="60" width="60" /></a>
<a href="//www.youtube.com/channel/UCdyxs72fFqy2fUgah2-_BGw"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/youtube-social-red-squircle.svg" alt="Watch and Subscribe to Frontstretch on YouTube" title="Watch and Subscribe to Frontstretch on YouTube" height="60" width="60" /></a>
<br /><br />
<a href="//www.frontstretch.com/feed/"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/rss-feed-icon.svg" alt="Subscribe to the Frontstretch RSS feed" title="Subscribe to the Frontstretch RSS feed" height="60" width="60" /></a>
<a href="//podcasts.apple.com/us/podcast/frontstretch/id1023154421"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/podcast-icon.svg" alt="Listen to the Frontstretch podcast at Apple Podcasts" title="Listen to the Frontstretch podcast at Apple Podcasts" height="60" width="60" /></a>
<a href="//www.frontstretch.com/podcast/"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/podcast-headphones.svg" alt="Listen to Frontstretch's Podcasts" title="Listen to Frontstretch's Podcasts" height="60" width="60" /></a>
<a href="//www.patreon.com/frontstretch"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/07/patreon-tile.svg" alt="Support Frontstretch on Patreon" title="Support Frontstretch on Patreon" height="60" width="60" /></a>
</div>
</div></aside><aside id="search-2" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.frontstretch.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
</label>
<button class="search-submit" aria-label="Search"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" role="img" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="1em" height="1em">
<path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" />
</svg></span></button></form>
</aside><aside id="ai_widget-13" class="widget inner-padding ai_widget"><div class='code-block code-block-center code-block-3 ai-track' data-ai='WzMsMCwiQW1lcmljYW4gVHJ1Y2tzIC0gR2VuZXJhbCBTaWRlYmFyIEFkIiwiIiwxXQ=='>

<a href="//www.extremeterrain.com" target="_blank"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/04/AT-SEO-Ads300x250.jpg" alt="American Trucks / Extreme Terrian" /></a>

</div>
</aside><aside id="ai_widget-14" class="widget inner-padding ai_widget"><div class='code-block code-block-default code-block-15 ai-track' data-ai='WzE1LDAsIlJhY2luZyBFbGVjdHJvbmljcyAtICBTaWRlYmFyIEFkIFdpZGdldCIsIiIsMV0='>
<a href="//racingelectronics.com" target="_blank"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2020/11/racing-electronics-2020.jpg" alt="Racing Electronics - Be Ready" width="310" height="250" /></a></div>
</aside><aside id="ai_widget-15" class="widget inner-padding ai_widget"><div class='code-block code-block-center code-block-16'>
<a href="//www.patreon.com/frontstretch" target="_blank"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2018/11/fs-patreon-banner-350x250.jpg" alt="Exclusive Content from Frontstretch on Patreon" width="300" height="250" /></a></div>
</aside><aside id="ai_widget-16" class="widget inner-padding ai_widget"><div class='code-block code-block-center code-block-9 ai-track' data-ai='WzksMCwiVGhlIFBpdCBMYW5lIFNpZGViYXIgV2lkZ2V0IiwiIiwxXQ=='>
<a href="http://thepitlane.org" target="_blank"><img src="https://frontstretch.b-cdn.net/wp-content/uploads/2013/02/The-Pit-Lane-Formatted.jpg" alt="The Pit Lane"></a></div>
</aside>
<aside id="recent-posts-2" class="widget inner-padding widget_recent_entries">
<h2 class="widget-title">Latest Articles</h2>
<ul>
<li>
<a href="https://www.frontstretch.com/2021/05/25/nascar-mailbox-is-kaz-grala-an-underrated-young-prospect/" aria-current="page">NASCAR Mailbox: Is Kaz Grala an Underrated Young Prospect?</a>
</li>
<li>
<a href="https://www.frontstretch.com/2021/05/25/waids-world-charlotte-motor-speedway-is-product-of-a-visionary-and-the-pt-barnum-of-racing/">Waid&#8217;s World: Charlotte Motor Speedway Is Product of a Visionary &#038; ‘The P.T. Barnum of Racing’</a>
</li>
<li>
<a href="https://www.frontstretch.com/2021/05/25/mosport-truck-race-moved-darlington/">Mosport Truck Race Moved to Darlington</a>
</li>
<li>
<a href="https://www.frontstretch.com/2021/05/25/indycar-techbench-tuesday-sage-karams-indianapolis-500-qualifying-run/">Techbench Tuesday: Sage Karam&#8217;s Indianapolis 500 Qualifying Run</a>
</li>
<li>
<a href="https://www.frontstretch.com/2021/05/25/entry-list-2021-general-tire-150-2/">Entry List: 2021 General Tire 150</a>
</li>
</ul>
</aside><aside id="recent-comments-2" class="widget inner-padding widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">wildcatsfan2016</span> on <a href="https://www.frontstretch.com/2021/05/24/5-points-to-ponder-do-you-need-to-see-where-youre-going-to-race-in-nascar/comment-page-1/#comment-71104">5 Points to Ponder: Do You Need to See Where You&#8217;re Going to Race in NASCAR?</a></li><li class="recentcomments"><span class="comment-author-link">Rain rain go away</span> on <a href="https://www.frontstretch.com/2021/05/24/zachs-turn-why-did-nascar-allow-dangerous-conditions-at-cota/comment-page-1/#comment-71103">Zach&#8217;s Turn: Why Did NASCAR Allow Such Dangerous Conditions at COTA?</a></li><li class="recentcomments"><span class="comment-author-link">Jo</span> on <a href="https://www.frontstretch.com/2021/05/24/thinkin-out-loud-2021-echopark-texas-grand-prix-at-cota/comment-page-1/#comment-71102">Thinkin&#8217; Out Loud: 2021 Echopark Texas Grand Prix at COTA</a></li><li class="recentcomments"><span class="comment-author-link">Echo</span> on <a href="https://www.frontstretch.com/2021/05/24/couch-potato-tuesday-fox-sports-1-handles-texas-rain-andy-lally-shines/comment-page-1/#comment-71101">Couch Potato Tuesday: FOX Sports 1 Handles the Texas Rain While Andy Lally Shines</a></li><li class="recentcomments"><span class="comment-author-link">Jo</span> on <a href="https://www.frontstretch.com/2021/05/24/nascar-stat-sheet-chase-elliott-slip-slides-away-with-another-victory/comment-page-1/#comment-71100">NASCAR Stat Sheet: Chase Elliott Slip Slides Away With Another Victory</a></li></ul></aside> </div>
</div>
</div>
</div>
<div class="site-footer footer-bar-active footer-bar-align-left">
<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
<div class="inside-site-info grid-container">
<div class="footer-bar">
<aside id="nav_menu-3" class="widget inner-padding widget_nav_menu"><div class="menu-footer-policies-container"><ul id="menu-footer-policies" class="menu"><li id="menu-item-230087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-230087"><a href="https://www.frontstretch.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-1070374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1070374"><a href="https://www.frontstretch.com/comment-policy/">Comment Policy</a></li>
</ul></div></aside> </div>
<div class="copyright-bar">
&copy; 2021 Frontstretch.com LLC </div>
</div>
</footer>
</div>
<a title="Scroll back to top" aria-label="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<span class="gp-icon icon-arrow-up"><svg viewBox="0 0 330 512" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414">
<path d="M305.863 314.916c0 2.266-1.133 4.815-2.832 6.514l-14.157 14.163c-1.699 1.7-3.964 2.832-6.513 2.832-2.265 0-4.813-1.133-6.512-2.832L164.572 224.276 53.295 335.593c-1.699 1.7-4.247 2.832-6.512 2.832-2.265 0-4.814-1.133-6.513-2.832L26.113 321.43c-1.699-1.7-2.831-4.248-2.831-6.514s1.132-4.816 2.831-6.515L158.06 176.408c1.699-1.7 4.247-2.833 6.512-2.833 2.265 0 4.814 1.133 6.513 2.833L303.03 308.4c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" />
</svg></span>
</a><script type="text/javascript"> var infolinks_pid = 3269291; var infolinks_wsid = 0; </script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script><a rel="nofollow" style="display:none" href="https://www.frontstretch.com/?blackhole=5435c8dd85" title="Do NOT follow this link or you will be banned from the site!">Frontstretch</a>

<script type="text/javascript">var cffajaxurl = "https://www.frontstretch.com/wp-admin/admin-ajax.php";
var cfflinkhashtags = "true";
</script>
<div id="mv-grow-data" data-settings='{&quot;general&quot;:{&quot;contentSelector&quot;:false},&quot;shareCounts&quot;:[],&quot;shouldRun&quot;:true,&quot;buttonSVG&quot;:{&quot;facebook&quot;:{&quot;path&quot;:&quot;M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z&quot;,&quot;width&quot;:18,&quot;height&quot;:32},&quot;twitter&quot;:{&quot;path&quot;:&quot;M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z&quot;,&quot;width&quot;:30,&quot;height&quot;:32},&quot;linkedin&quot;:{&quot;path&quot;:&quot;M6.24 11.168v17.696h-5.888v-17.696h5.888zM6.624 5.696q0 1.312-0.928 2.176t-2.4 0.864h-0.032q-1.472 0-2.368-0.864t-0.896-2.176 0.928-2.176 2.4-0.864 2.368 0.864 0.928 2.176zM27.424 18.72v10.144h-5.856v-9.472q0-1.888-0.736-2.944t-2.272-1.056q-1.12 0-1.856 0.608t-1.152 1.536q-0.192 0.544-0.192 1.44v9.888h-5.888q0.032-7.136 0.032-11.552t0-5.28l-0.032-0.864h5.888v2.56h-0.032q0.352-0.576 0.736-0.992t0.992-0.928 1.568-0.768 2.048-0.288q3.040 0 4.896 2.016t1.856 5.952z&quot;,&quot;width&quot;:27,&quot;height&quot;:32},&quot;email&quot;:{&quot;path&quot;:&quot;M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z&quot;,&quot;width&quot;:28,&quot;height&quot;:32}}}'></div><div id="dpsp-floating-sidebar" class=" dpsp-position-left dpsp-shape-rectangular dpsp-size-medium  dpsp-hide-on-mobile dpsp-button-style-1 dpsp-no-animation" data-trigger-scroll="false"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-share dpsp-networks-btns-sidebar  dpsp-has-button-icon-animation">
<li>
<a rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&t=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F" class="dpsp-network-btn dpsp-facebook dpsp-no-label dpsp-first" target="_blank" aria-label="Share on Facebook" title="Share on Facebook">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span>
</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="https://twitter.com/intent/tweet?text=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F&url=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&via=Frontstretch" class="dpsp-network-btn dpsp-twitter dpsp-no-label" target="_blank" aria-label="Share on Twitter" title="Share on Twitter">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span>
</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.frontstretch.com%2F2021%2F05%2F25%2Fnascar-mailbox-is-kaz-grala-an-underrated-young-prospect%2F&title=NASCAR%20Mailbox%3A%20Is%20Kaz%20Grala%20an%20Underrated%20Young%20Prospect%3F&summary=What%20does%20the%20future%20look%20like%20for%20Kaz%20Grala%3F%20He%27s%20consistently%20performed%20in%20whatever%20equipment%20he%27s%20put%20in%20and%20seems%20to%20have%20a%20bright%20future%20ahead%20of%20him.%20-%20Doug%20K.%2C%20Charlottesville%2C%20Va.%20If%20I%27m&mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-no-label" target="_blank" aria-label="Share on LinkedIn" title="Share on LinkedIn">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="32" viewBox="0 0 27 32"><path d="M6.24 11.168v17.696h-5.888v-17.696h5.888zM6.624 5.696q0 1.312-0.928 2.176t-2.4 0.864h-0.032q-1.472 0-2.368-0.864t-0.896-2.176 0.928-2.176 2.4-0.864 2.368 0.864 0.928 2.176zM27.424 18.72v10.144h-5.856v-9.472q0-1.888-0.736-2.944t-2.272-1.056q-1.12 0-1.856 0.608t-1.152 1.536q-0.192 0.544-0.192 1.44v9.888h-5.888q0.032-7.136 0.032-11.552t0-5.28l-0.032-0.864h5.888v2.56h-0.032q0.352-0.576 0.736-0.992t0.992-0.928 1.568-0.768 2.048-0.288q3.040 0 4.896 2.016t1.856 5.952z"></path></svg></span>
</span>
</a>
</li>
<li>
<a rel="nofollow noopener" href="/cdn-cgi/l/email-protection#d6e9a5a3b4bcb3b5a2eb989785959784f3e4e69bb7bfbab4b9aef3e597f3e4e69fa5f3e4e69db7acf3e4e691a4b7bab7f3e4e6b7b8f3e4e683b8b2b3a4a4b7a2b3b2f3e4e68fb9a3b8b1f3e4e686a4b9a5a6b3b5a2f3e590f0b7bba6edb4b9b2afebbea2a2a6a5f3e597f3e490f3e490a1a1a1f8b0a4b9b8a2a5a2a4b3a2b5bef8b5b9bbf3e490e4e6e4e7f3e490e6e3f3e490e4e3f3e490b8b7a5b5b7a4fbbbb7bfbab4b9aefbbfa5fbbdb7acfbb1a4b7bab7fbb7b8fba3b8b2b3a4a4b7a2b3b2fbafb9a3b8b1fba6a4b9a5a6b3b5a2f3e490" class="dpsp-network-btn dpsp-email dpsp-no-label dpsp-last" target="_blank" aria-label="Send over email" title="Send over email">
<span class="dpsp-network-icon">
<span class="dpsp-network-icon-inner"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span>
</span>
</a>
</li>
</ul></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":945,"name":"Davey Segal","avatar":"24dda09574ef94c821eff9b84c15a7b7"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '35984']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>

<script type="text/javascript">

</script>
<script async data-noptimize src='https://frontstretch.b-cdn.net/wp-content/plugins/social-pug/assets/dist/front-end-free.1.18.2.js?ver=1.18.2' id='dpsp-frontend-js-pro-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-content/plugins/wp-ajaxify-comments/js/wp-ajaxify-comments.min.js?ver=1.7.3' id='wpAjaxifyComments-js'></script>
<script id='rocket-browser-checker-js-after'>
class RocketBrowserCompatibilityChecker {

	constructor( options ) {
		this.passiveSupported = false;

		this._checkPassiveOption( this );
		this.options = this.passiveSupported ? options : false;
	}

	/**
	 * Initializes browser check for addEventListener passive option.
	 *
	 * @link https://developer.mozilla.org/en-US/docs/Web/API/EventTarget/addEventListener#Safely_detecting_option_support
	 * @private
	 *
	 * @param self Instance of this object.
	 * @returns {boolean}
	 */
	_checkPassiveOption( self ) {
		try {
			const options = {
				// This function will be called when the browser attempts to access the passive property.
				get passive() {
					self.passiveSupported = true;
					return false;
				}
			};

			window.addEventListener( 'test', null, options );
			window.removeEventListener( 'test', null, options );
		} catch ( err ) {
			self.passiveSupported = false;
		}
	}

	/**
	 * Checks if the browser supports requestIdleCallback and cancelIdleCallback. If no, shims its behavior with a polyfills.
	 *
	 * @link @link https://developers.google.com/web/updates/2015/08/using-requestidlecallback
	 */
	initRequestIdleCallback() {
		if ( ! 'requestIdleCallback' in window ) {
			window.requestIdleCallback = ( cb ) => {
				const start = Date.now();
				return setTimeout( () => {
					cb( {
						didTimeout: false,
						timeRemaining: function timeRemaining() {
							return Math.max( 0, 50 - ( Date.now() - start ) );
						}
					} );
				}, 1 );
			};
		}

		if ( ! 'cancelIdleCallback' in window ) {
			window.cancelIdleCallback = ( id ) => clearTimeout( id );
		}
	}

	/**
	 * Detects if data saver mode is on.
	 *
	 * @link https://developers.google.com/web/fundamentals/performance/optimizing-content-efficiency/save-data/#detecting_the_save-data_setting
	 *
	 * @returns {boolean|boolean}
	 */
	isDataSaverModeOn() {
		return (
			'connection' in navigator
			&&
			true === navigator.connection.saveData
		);
	}

	/**
	 * Checks if the browser supports link prefetch.
	 *
	 * @returns {boolean|boolean}
	 */
	supportsLinkPrefetch() {
		const elem = document.createElement( 'link' );
		return (
			elem.relList
			&&
			elem.relList.supports
			&&
			elem.relList.supports( 'prefetch' )
			&&
			window.IntersectionObserver
			&&
			'isIntersecting' in IntersectionObserverEntry.prototype
		);
	}

	isSlowConnection() {
		return (
			'connection' in navigator
			&&
			'effectiveType' in navigator.connection
			&&
			(
				'2g' === navigator.connection.effectiveType
				||
				'slow-2g' === navigator.connection.effectiveType
			)
		)
	}
}
</script>
<script id='rocket-delay-js-js-after'>
class RocketLazyLoadScripts {

	constructor( triggerEvents, browser ) {
		this.attrName = 'data-rocketlazyloadscript';
		this.browser = browser;
		this.options = this.browser.options;
		this.triggerEvents = triggerEvents;
		this.userEventListener = this.triggerListener.bind( this );
	}

	/**
	 * Initializes the LazyLoad Scripts handler.
	 */
	init() {
		this._addEventListener( this );
	}

	/**
	 * Resets the handler.
	 */
	reset() {
		this._removeEventListener( this );
	}

	/**
	 * Adds a listener for each of the configured user interactivity event type. When an even is triggered, it invokes
	 * the triggerListener() method.
	 *
	 * @private
	 *
	 * @param self Instance of this object.
	 */
	_addEventListener( self ) {
		this.triggerEvents.forEach(
			eventName => window.addEventListener( eventName, self.userEventListener, self.options )
		);
	}

	/**
	 * Removes the listener for each of the configured user interactivity event type.
	 *
	 * @private
	 *
	 * @param self Instance of this object.
	 */
	_removeEventListener( self ) {
		this.triggerEvents.forEach(
			eventName => window.removeEventListener( eventName, self.userEventListener, self.options )
		);
	}

	/**
	 * Loads the script's src from the data attribute, which will then trigger the browser to request and
	 * load the script.
	 */
	_loadScriptSrc() {
		const scripts = document.querySelectorAll( `script[${ this.attrName }]` );

		if ( 0 === scripts.length ) {
			this.reset();
			return;
		}

		Array.prototype.slice.call( scripts ).forEach( elem => {
			const scriptSrc = elem.getAttribute( this.attrName );

			elem.setAttribute( 'src', scriptSrc );
			elem.removeAttribute( this.attrName );
		} );

		this.reset();
	}

	/**
	 * Window event listener - when triggered, invokes the load script src handler and then resets.
	 */
	triggerListener() {
		this._loadScriptSrc();
		this._removeEventListener( this );
	}

	/**
	 * Named static constructor to encapsulate how to create the object.
	 */
	static run() {
		// Bail out if the browser checker does not exist.
		if ( ! RocketBrowserCompatibilityChecker ) {
			return;
		}

		const options = {
			passive: true
		};
		const browser = new RocketBrowserCompatibilityChecker( options );
		const instance = new RocketLazyLoadScripts(
			[
				'keydown',
				'mouseover',
				'touchmove',
				'touchstart',
				'wheel'
			],
			browser
		);
		instance.init();
	}
}

RocketLazyLoadScripts.run();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/garage-hot-pass|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/garage-hot-pass\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.frontstretch.com","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script id='rocket-preload-links-js-after'>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</script>
<!--[if lte IE 11]>
<script src='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/js/classList.js?ver=3.0.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/js/menu.js?ver=3.0.3' id='generate-menu-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/js/a11y.js?ver=3.0.3' id='generate-a11y-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-content/themes/generatepress/assets/js/back-to-top.js?ver=3.0.3' id='generate-back-to-top-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-includes/js/comment-reply.js?ver=5.7.2' id='comment-reply-js'></script>
<script src='https://frontstretch.b-cdn.net/wp-content/plugins/custom-facebook-feed/assets/js/cff-scripts.js?ver=2.19.1' id='cffscripts-js'></script>
<script async="async" src='https://frontstretch.b-cdn.net/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script id='sby_scripts-js-extra'>
var sbyOptions = {"adminAjaxUrl":"https:\/\/www.frontstretch.com\/wp-admin\/admin-ajax.php","placeholder":"https:\/\/www.frontstretch.com\/wp-content\/plugins\/feeds-for-youtube\/img\/placeholder.png","placeholderNarrow":"https:\/\/www.frontstretch.com\/wp-content\/plugins\/feeds-for-youtube\/img\/placeholder-narrow.png","lightboxPlaceholder":"https:\/\/www.frontstretch.com\/wp-content\/plugins\/feeds-for-youtube\/img\/lightbox-placeholder.png","lightboxPlaceholderNarrow":"https:\/\/www.frontstretch.com\/wp-content\/plugins\/feeds-for-youtube\/img\/lightbox-placeholder-narrow.png","autoplay":"1","semiEagerload":"","eagerload":""};
</script>
<script src='https://frontstretch.b-cdn.net/wp-content/plugins/feeds-for-youtube/js/sb-youtube.min.js?ver=1.4' id='sby_scripts-js'></script>
<script>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</script>
<script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                continue;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                continue;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://frontstretch.b-cdn.net/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6557684299bb5c9a","token":"84847544b67743019483ddcffa87738a","version":"2021.5.1","si":10}'></script>
</body>
</html>
